Jump to content
Whiley

Prestashop 1.6.1.24 Demoshop

Recommended Posts

PRESTASHOP 1.6.1.24 stable wurde freigegeben!

Modul "Europäische Rechtssicherheit"  Vers. 2.02 (eleazar Modifikation) aktiviert.

Wer testen will:

Demoshop

Zugang zum Backoffice:

Backoffice

email:  demo@demo.com

passw: demo16124

Grüsse
Whiley

  • Like 2

Share this post


Link to post
Share on other sites

Hast du "zuzüglich Versandkosten" manuell übersetzt oder war das out of the box nach Modulinstallation?

Bei mir steht dort englisch "Shipping excluded" und ich bekomme es einfach nicht übersetzt. stelle mich gerade irgendwie doof an. Im Backoffice kann ich es nicht übersetzten weil mein Server wohl nur 1000 Anfragen zulässt und für die Modulübersetzungen brauche ich mindestens 2200 :-(

jetzt habe ich manuell in den de.php Dateien gesucht und finde es einfach nicht :-O In der Moduldatei ist die Übersetzung korrekt, in der Hauptsprachdatei meines Themes finde ich den String nicht. Hab auch nochmal die Übersetzung aus dem aktuellen Bootstrap Theme 1.6.1.1 in mein Theme kopiert.

Share this post


Link to post
Share on other sites

Hallo schinulski.

 

ich habs im BO übersetzt, wie du den Wert 1000 hochsetzen kannst findest du hier im Forum (Suche)

 

Die Übersetzungsdatei müsstest du in deinem theme-Ordner finden, dort gibt es nochmal einen modul-Ordner also z.B.:

/themes/default-bootstrap/modules/advancedeucompliance/translations/de.php

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Update:

Shop neu installiert, im aktuellen Paket ist das Modul "Europäische Rechtssicherheit" vorhanden,

Die Geschwindigkeit des FE ist gegenüber 1.1.0.14 deutlich besser, wobei das BO langsamer zu sein scheint.

Probleme gibt es mit "Cache löschen"

Share this post


Link to post
Share on other sites

Wie mach ich denn das Update auf 1.6.1.1 ?

 

Irgendwie funktioniert das nicht...

Share this post


Link to post
Share on other sites

Falls du eine Version älter als 1.6.1 hast, solltest du erst auf 1.6.1 upgraden. Sonst kann es Probleme geben, denn 1.6.1.1 scheint hinsichtlich der Datenbank, die jetzt noch einmal erweitert wird, nur bis zu 1.6.1 abwärtskompatibel zu sein.

Edited by eleazar 

Share this post


Link to post
Share on other sites

 

wie sieht es in der Final Version mit der Rechtssicherheit EU aus. Kann man damit an den markt?

 

Hallo Bernd,

 

Wenn du mit "Final Version" die 1.6.1.1 meinst kannst du dir ja im Demoshop anschauen ob die Anforderungen die du in deiner Branche an die "Rechtssicherheit" stellst, erfüllt werden.

Im Moment dürften ja einige Probleme bzgl Rechtssicherheit in deinem Shop bestehen (inkl MwSt inkl MwSt - Preisklarheit / Lieferzeiten etc)

 

Es gibt in der neuen Version einige Fehler (Grundpreisanzeige in der Übersicht etc) die dich nicht betreffen dürften und es gibt nachwievor "gefähliche Einstellmöglichkeiten" (Streichpreise , Warenkorbtext 2 etc) die man halt nicht - oder eben nur dann wenn man sehr genau weiß was diese Einstellungen bewirken - benutzen sollte.

 

Grüsse

Whiley

  • Like 1

Share this post


Link to post
Share on other sites

Hi

 

da es mir den gesamten shop verknallt hat ist das mit doppelten inkl. MwSt. meine kleinste Sorge.

 

Ich kann noch nicht einmal das 1-Klick-Update machen, da dieses Modul meint dass mein cache ausgeschaltet ist, was nicht stimmt.

 

lg

Bernd

Share this post


Link to post
Share on other sites

 

Ich kann noch nicht einmal das 1-Klick-Update machen, da dieses Modul meint dass mein cache ausgeschaltet ist, was nicht stimmt.

Servervoraussetzungen stimmen?

 

Mach eine Sicherung (insbesondere Datenbank und Bilder), dann mach den Shop platt und zieh ihn neu auf - aber wichtig, die Servereinstellungen müssen halt stimmen (kleiner V-server langt i.d.R.)

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Prinzipiell scheinst Du sehr viel verschiedene Probleme mit dem Shop zu haben, daher würde ich von der 1.6.1.1 sowieso abraten, und das ganze von Grund auf neu aufsetzen

mit einer 1.6.0.14 und Eu-legal

 

am besten mit der letzten funktionieren Datensicherung.

 

Dann würde ich lokal den Shop auf 1.6.1.0 bringen, und erst wenn alles reibungslos funktioniert damit live gehen.

Share this post


Link to post
Share on other sites

@kulli,

 

wo gibts Nachteile vom 16.1.1 gegenüber 1.6.0.14?

Ich halte den 1.6.1.1 für stabiler und auf jeden Fall für weitaus schneller!

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Ich steige gerade auf einen eigenen Server um.

 

Wenn es klappt werden wir am WE die jetzige prestainstallation platt machen und die 1.6.1.1 aufspielen

 

Was ich in der Demo sehe sieht alles ganz gut aus.

 

Nur wie ich die ganzen Indexe in der Datenbank erneuere weiß ich noch immer nicht

 

lg

Bernd

Share this post


Link to post
Share on other sites

Habe immer noch das Problem, dass ich nicht weiß wie ich von 1.6.1 auf 1.6.1.1 komme...

 

One-klick upgrade funktioniert irgendwie nicht, da zeigt er mir zwar an, dass es die neu Version gibt aber ich kann niergends updaten.

 

Vielleicht seh ich auch wieder mal den Wald vor lauter Bäumen nicht...

Share this post


Link to post
Share on other sites

Habe immer noch das Problem, dass ich nicht weiß wie ich von 1.6.1 auf 1.6.1.1 komme...

 

One-klick upgrade funktioniert irgendwie nicht, da zeigt er mir zwar an, dass es die neu Version gibt aber ich kann niergends updaten.

 

Vielleicht seh ich auch wieder mal den Wald vor lauter Bäumen nicht...

 

Okay, Prestashop war nicht im Wartungsmodus... Oh Man.

Share this post


Link to post
Share on other sites

Na toll, jetzt habe ich das update gemacht und habe auch die Mekdung bekommen, dass alles succesful war.

Und jetzt komm ich nicht mehr ins BO rein.

 

Zeigt mir nicht mal die Anmeldemaske. Nur eine weiße Seite...

 

Jemand ne Idee?

Share this post


Link to post
Share on other sites

Hallo Regnidor,

 

erstmal  in der Datei: config/defines.inc.php

 

set  define('_PS_MODE_DEV_', false);

ändern in

define('_PS_MODE_DEV_', true);

Dann die Adminseite erneut aufrufen , es müssten dann Fehlermeldungen sichtbar werden.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Okay danke, jetzt konnte ich mich einloggen und habe folgende Fehler bekommen:

 

Unknown error in Zeile 58 der Datei /modules/advancedeucompliance/advancedeucompliance.php
[4096] Argument 1 passed to Advancedeucompliance::__construct() must be an instance of Core_Foundation_Database_EntityManager, none given, called in //override/classes/module/Module.php on line 164 and defined

Unknown error in Zeile 59 der Datei /modules/advancedeucompliance/advancedeucompliance.php
[4096] Argument 2 passed to Advancedeucompliance::__construct() must be an instance of Core_Foundation_FileSystem_FileSystem, none given, called in /override/classes/module/Module.php on line 164 and defined

Unknown error in Zeile 60 der Datei /modules/advancedeucompliance/advancedeucompliance.php
[4096] Argument 3 passed to Advancedeucompliance::__construct() must be an instance of Core_Business_Email_EmailLister, none given, called in /override/classes/module/Module.php on line 164 and defined

Notice in Zeile 73 der Datei /modules/advancedeucompliance/advancedeucompliance.php
[8] Undefined variable: entity_manager

Notice in Zeile 74 der Datei //modules/advancedeucompliance/advancedeucompliance.php
[8] Undefined variable: fs

Notice in Zeile 75 der Datei //modules/advancedeucompliance/advancedeucompliance.php
[8] Undefined variable: email

Edited by Regnidor

Share this post


Link to post
Share on other sites

whiley:

Nachteile gegenüber 0.14 sehe ich keine

1.6.1.1 macht probleme gegenüber 1.6.1.0 (paypal und andere module; schau Dir mal den Bugtracker an)

generell rate ich von 1.6.1 für "Normalkunden" eben wegen diverser Problemchen immer noch ab

Edited by kulli

Share this post


Link to post
Share on other sites

regnidor

Erste Hilfe:

 

benenne mal den ordner overrides per ftp um in z.B. dummerrides; so hast Du ihn als datensicherung

und spiele den overrides ordner des Installationspaketes (von presta runterladen) per ftp auf Deinen Shop

 

Vorsicht: so können auch andere Overrides deaktiviert sein, die andere Module brauchen

  • Like 1

Share this post


Link to post
Share on other sites

Okay danke kulli jetzt bekomme ich keine Fehlermeldung mehr.

 

Scheint jetzt wieder alles zu funktionieren. Kann ich das jetzt so lassen und woher weiß ich, ob jetzt nicht irgendwelche Ovverrides weg sind, die auch andere Module brauchen?

 

Danke

Share this post


Link to post
Share on other sites

Am besten Du vergleichst die beiden Ordner mal

und hoffst dass es nur Reste vom eucompliance waren;

 

ansonsten musst Du den kompletten Shop "durchprobieren"; also schauen ob alle Module laufen: Bestellungen/Zahlarten vorallem Fremdmodule etc. etc.

Share this post


Link to post
Share on other sites

Hmm die Ordner sehen eigentlich gleich aus. Die Dateien kann ich jetzt ja nicht alle vergleichen oder gibts irgendwas bestimmtes auf was ich achten sollte?

Share this post


Link to post
Share on other sites

doch, Du sollst sie alle vergleichen, mit tools wie winmerge geht das ganz schnell

 

für den Anfang reicht es darauf zu achten ob im alten ordner zusätzliche Dateien drin waren, die im Namen auf ein Modul hinweisen

Share this post


Link to post
Share on other sites

whiley:

Nachteile gegenüber 0.14 sehe ich keine

1.6.1.1 macht probleme gegenüber 1.6.1.0 (paypal und andere module; schau Dir mal den Bugtracker an)

generell rate ich von 1.6.1 für "Normalkunden" eben wegen diverser Problemchen immer noch ab

Und das ist noch beileibe nicht alles!

Die Anpassung an Tablets (zumindest unter Android) ist mehr als bescheiden, weil die Menüführung im Back Office nur in Ausnahmefällen gelingt. Oft lässt sich nur der oberste Menüpunkt aktivieren. Unter Chrome braucht man fast eine Lupe, weil das Back Office alles andere als responsive zu sein scheint, im Firefox wird nur ein Teil des Menüs (zumindest bei horizontaler Darstellung) angezeigt.

Auf dem ipad habe ich es noch nicht getestet. Auf einem iPhone sieht es zwar auch grauenhaft aus, aber wenigstens funktioniert die Menüführung.

Edited by eleazar 

Share this post


Link to post
Share on other sites

Hallo, ich bin Lea, bin neu in diesem Forum;  habe Presta Shop (neueste Version) vor etwa 10 Tagen installiert und nun einige Produkte eingesetzt. Leider klappt das mit der Preisanzeige nicht. Obwohl ich die Steuer eingegeben habe zeigt die Bestellseite und der Warenkorb immer den Preis excl. Tax an. Was mache ich denn falsch? Danke für Eure Hilfe!

Share this post


Link to post
Share on other sites

Hallo Lea,

Bitte immer für neue Fragen einen gesonderten Topic aufmachen!

 

Lösung für dein Problem:

Unter Lokalisierung --> Länder für Deutschland die MwSt aktivieren

Share this post


Link to post
Share on other sites

@Lea: Wenn im Frontend zzgl. MwSt. angezeigt wird, kann es auch daran liegen, dass unter Kunden -> Gruppen bei den jeweiligen Gruppen das Feld Preisanzeige falsch gesetzt ist. Hier "inkl. MwSt." auswählen.

Share this post


Link to post
Share on other sites

Zumindest diese Demo-Version erlaubt auch die Eingabe individueller Lieferzeiten je Artikel - mit den hier beschriebenen Einschränkungen: https://www.prestashop.com/forums/topic/475154-lieferzeiten-und-template-schwierigkeiten/?do=findComment&comment=2167773

 

:ph34r: (Sei mir bitte nicht böse, Jörg. Ich konnte nicht widerstehen und habe deinen Demoshop etwas "erweitert". ) :ph34r:

Share this post


Link to post
Share on other sites

 

 

:ph34r: (Sei mir bitte nicht böse, Jörg. Ich konnte nicht widerstehen und habe deinen Demoshop etwas "erweitert". ) :ph34r:

 

Rainer, dafür ist der Demoshop ja gedacht :)

Share this post


Link to post
Share on other sites

Whiley: kannst meinen beitrag löschen

der Beitrag von heute früh ist noch da:

https://www.prestashop.com/forums/topic/475154-lieferzeiten-und-template-schwierigkeiten/page-2?do=findComment&comment=2168459

 

so ein mist, alles von gestern und heute früh umsonst geschrieben: (Prestashops Server  wieder mal komplett abgestürzt ?)

 

vielleicht liegts ja daran dass ich wieder einen issue aufgemacht habe :-))

aber der ist sicher auch weg

 

eleazar:

vielen dank nochmal für die Aufklärungen

 

es geht um den unit_price

der wird nur in der direkten Artikelansicht angezeigt;

weder in der kategorieansicht (liste und kachel)

noch in den modulen der Startseite (neue Produkte, etc. etc.wie bei eu_legal 1.6.0.14)

eben wie beim testartikel

 

Edit der issue ist noch da:

http://forge.prestashop.com/browse/PSCSX-7073

hopffe auf rege beteiligung, damit das mal endlich rechtsicher wird....

(kurz danach ist der ganze Kram bei denen abgeschmiert - ein Schelm wer böses dabei denkt;-))

Edited by kulli

Share this post


Link to post
Share on other sites

Hallo,
habe den Shop gerade erst installiert. Alles etwas verwirrend am Anfang. Dieses Modul Rechtssicherheit ist nicht in der Modulliste zu finden.
Shopversion schein 1.6.1.1 zu sein. Wo findet man das Modul?

Share this post


Link to post
Share on other sites

Willkommen

advanced_eu_compliance

wenns noch auf englisch dort steht

(deutsch : Europäische Rechtsicherheit)

ansonsten musst Du warten bis der Shop die Modulliste nachgeladen hat,

aber die Server waren heute in Frankreich faul, das kann dauern

Edited by kulli

Share this post


Link to post
Share on other sites

Hallo Manica und willkommen im Forum!

 

Das Modul heißt vor der Installation unübersetzt "advancedeucompliance". Erst nach Installation ändert sich der Name in "Europäische Rechtssicherheit". Das gilt im Übrigen für alle Module: Vor Installation haben Sie alle den englischen Originalnamen, sofern eine Übersetzung vorhanden ist sieht man diese erst nach der Installation. Das war glaube ich mal anders und ist in der Tat etwas verwirrend, aber nach ner Zeit kommt man rein :-)

 

Edit: Mist, ne Sekunde zu spät Kulli. Du "Ninja Forist"! :-D

Edited by schibulski

Share this post


Link to post
Share on other sites

Gefunden, installiert aber es zeigt nicht überall zzgl. Versandkosten mit Link an. Ist bei Einstellungen aktiviert. Dann kann man da anscheindend noch ein Formular ändern, einbauen etc. aber wo?
Bin ja noch ganz am Anfang. Mal sehen wie es später im Bestellverlauf ist. Da müssen ja alle wichtigen Merkmale plus artikel bild angezeigt werden.

Share this post


Link to post
Share on other sites

 

Mal sehen wie es später im Bestellverlauf ist. Da müssen ja alle wichtigen Merkmale plus artikel bild angezeigt werden.

 

Du solltest auf jeden Fall im Modul "Europäische Rechtssicherheit" "One Page Checkout" einstellen (heißt in den den neueren Versionen jetzt "Bestellübersicht" und hat nichts mit dem eigentlichen One-Page-Checkout bei Voreinstellungen-->Bestellungen zutun).

 

Artikelbild ist in der Bestellzusammenfassung vorhanden (wenn du dir den Gesetzestext durchliest aber eigentlich nicht erforderlich)

 

Grüsse

Whiley

Edited by Whiley

Share this post


Link to post
Share on other sites

Der Demoshop ist jetzt 1.6.1.2 final!

 

Mit den Übersetzungen (Module) siehts nicht gut aus!

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Du solltest du doch mittlerweile wissen, Jörg, dass PrestaShop standardmäßig mit veralteten Übersetzungen ausgeliefert wird. :D
Ich habe es mittlerweile aufgegeben, mich darüber zu ärgern. Also, zur Abhilfe einmal unter

Lokalisierung --> Übersetzungen

die deutsche Sprache importieren. Danach sieht es viel freundlicher aus. :rolleyes:


EDIT: Leider zu früh gefreut. Habe gerade festgestellt, dass die lieben Kollegen aus Paris es irgendwie geschafft haben, etliche Übersetzungs-Hashcodes zu ändern, so dass die Übersetzungen zwar vorhanden sind, aber nicht mehr greifen.

EDIT 2: Ich habe sie auf Crowdin vorhin wieder ergänzt. Dürften dann ab Montag im Download sein.



Der One-Page-Checkout ist nicht zwingend erforderlich, wenn man in den Einstellungen des Moduls Europäische Rechtssicherheit unter Zusatzoptionen die Option
Bestellübersicht aktivieren

auf JA stellt.

Edited by eleazar 

Share this post


Link to post
Share on other sites

 

Der One-Page-Checkout ist nicht zwingend erforderlich, ...

 

Ja klar Rainer, die obige Bemerkung war auch auf die frühere Übersetzung bezogen, als die "Bestellübersicht" noch "One-Page-Checkout" hieß, ich habe das im obigen Post ergänzt.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Die Ausgabe der Steuer auf die Versandkosten auf der Rechnung scheint immer noch nicht zu funktionieren.

 

Frage mich langsam echt was das soll...

Share this post


Link to post
Share on other sites

Die Ausgabe der Steuer auf die Versandkosten auf der Rechnung scheint immer noch nicht zu funktionieren.

 

Frage mich langsam echt was das soll...

 

:wacko: Bei mir schon. Und im Demoshop auch. Dürfte daher kein PrestaShop-Problem sein.

Share this post


Link to post
Share on other sites

Tatsächlich, im Demoshop funktioniert es...

 

Das kann doch nicht sein. Ich habe den Shop neu aufgesetzt. Kann dann ja nur eine Einstellungssache sein, oder?

 

@ elezar: Kann ich Dir mal die Zugangsdaten zum Shop schicken und Du schaust mal drüber woran es liegt?

 

Weiß echt nicht weiter...

Share this post


Link to post
Share on other sites

:wacko: Bei mir schon. Und im Demoshop auch. Dürfte daher kein PrestaShop-Problem sein.

 

So ich habe jetzt mal ein wenig rumprobiert. Im Demoshop funktioniert es nicht und bei dir wahrscheinlich auch nicht!

 

Es passiert folgendes:

 

Wenn Du einen Versanddienst anlegst bevor Du eu compliance installiert hast, bzw. diesen anlegst wenn die "Anteiliger Steuersatz auf Versand und Verpackung" deaktiviert ist.

Dann kannst du einen Steuersatz für den Versanddienst auswählen. Wenn du jetzt 19% auswählst so wie es auch beim schon vorhandenen "My Carrier" der Fall ist, dann wird später auch in der Rechnung die Steuer auf Versandkosten ausgewiesen und zwar mit 19%.

 

Wenn man einen Versanddienst anlegt nachdem "Anteiliger Steuersatz auf Versand und Verpackung" aktiviert wurde, dann kann man hier auch keinen Steuersatz für den Versanddienst auswählen (macht ja auch keinen Sinn) jetzt wird dann aber auch kein Steuersatz für diesen Versanddienst in der Rechnung ausgewiesen, weil kein Steuersatz hinterlegt wurde.

 

Wenn ich jetzt eine Bestellung mit dem schon angelegten "My Carrier" mache. Werden wieder 19% in der Rechnung ausgewiesen. Aber leider nur die 19% auch wenn ich einen gemischten Warenkorb habe, weil eben nur die 19% hinterlegt sind. Also nichts mit Anteiliger Steuersatz auf Versand und Verpackung. Zumindest nicht bei den Steuersetails in der Rechnung.

 

@ eleazar: Ich denke das ist auch der Grund dafür, was Du hier festgestellt hast:

 

Auf jeden Fall ist in der Tabelle prstshp_order_invoice_tax den Bestellungen überhaupt kein MwSt-Betrag für shipping zugeordnet. Da ist nur das wrapping gespeichert.

 

Ergo kann auch nichts ausgegeben werden.

Oder was meinst Du? Ist auf jeden Fall ein Bug und liegt nicht an meinem Shop...

Eine Idee wie man das fixen kann?

  • Like 1

Share this post


Link to post
Share on other sites

Was Regnidor hier herausgefunden hat, kann ich nach ein paar Tests auch bestätigen. Wird ein Versanddienst nach Aktivierung von Advancedeucompliance angelegt (in diesem Fall kann keine Versanddienststeuer mehr erfasst werden, weil das Eingabefeld dann nicht mehr angezeigt wird), wird überhaupt keine Steuer auf Versand in der Rechnung mehr angezeigt.

Dazu passt auch folgende Beobachtung: in 1.6.1.2 ist auch an anderen Stellen wieder Einiges geändert worden. Unter anderen funktioniert jetzt auch die anteilige Steuer auf die Versandkosten nicht mehr. Es wird starr immer der Steuersatz 19% ausgegeben, egal wie der Satz auf die Artikel aussieht.

Im Moment scheint es mit dem Modul Advancedeucompliance weniger voran als vielmehr zurück zu gehen ... :(

 

Nachtrag: Ich habe vorhin versuchsweise mal eine alte Version des Moduls vom August dieses Jahres eingespielt. Die weist zwar nun "0% MwSt" beim Versand aus, weil die Variable sich wohl geändert hat - aber dafür stimmt wenigstens der Betrag (in diesem Fall 7% auf die Versandkosten). Es sind also eindeutig neue Fehler eingebaut worden.

Edited by eleazar 

Share this post


Link to post
Share on other sites

trifft es auf den Punkt

 

irgendwie wird das modul nicht rechtzeitig an die neuen versionen angepasst, was ja für uns sehr wichtig ist, aber die Franzosen doch weniger interessiert als gedachtpost-434580-0-50272400-1446613832.gif

Share this post


Link to post
Share on other sites

Der Ansicht bin ich nicht, kulli.

Es handelt sich schon um eine Weiterentwicklung des Moduls, aber m.E. In die falsche Richtung. Es entwickelt sich zurück.

Share this post


Link to post
Share on other sites

also eine Rückentwicklung

eigentlich meinen wir ja alle das Gleiche;  oder dasselbe ?  :) 

Share this post


Link to post
Share on other sites

Update des Demoshops auf 1.6.1.3

 

Grüsse

Whiley

 

Wollte mal einen Artikel anlegen, läßt sich aber nix abspeichern...

Share this post


Link to post
Share on other sites

 

Wollte mal einen Artikel anlegen, läßt sich aber nix abspeichern...

 

Hm... ich hab es gerade mal probiert, es gab keine Probleme.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Ich kann das nur bestätigen. Die Speicher-Buttons drehen und drehen sich - es nimmt kein Ende. Die Performance ist unterirdisch! Als ich gestern zum ersten Mal versucht habe, einen Artikel zu duplizieren oder zu ändern, hatte ich das auf meine schwache DSL-Verbindung im Büro (max.6000) zurückgeführt. Zuhause habe ich VDSL, abe auch von dort aus gelingt es mir nicht. Die Buttons drehen sich inzwischen schon über 10 Minuten. Ich breche jetzt ab.

 

Es liegt aber definitiv nicht an Version 1.6.1.3, denn die habe ich auch im Testbetrieb laufen. Es ist zwar nicht gerade elegant, dass bei jedem Speichervorgang beim Artikel ein komplett neuer Seitenaufbau erfolgt, aber die Speicherbuttons brauchen im Gegensatz zu früheren Versionen nur ein paar Sekunden, um wieder funktionsfähig zu sein.

Share this post


Link to post
Share on other sites

Kann ich nicht nachvollziehen. weder beim Duplizieren noch beim Abspeichern :mellow:

 

Gerade nochmal probiert!

Share this post


Link to post
Share on other sites

Das passiert scheinbar auch nur gelegentlich. Vorhin hatte ich die Probleme nur einmal ganz kurz; nach einem Neustart des Shops waren sie weg.

 

Ich habe übrigens den Demoshop gerade mal ein bisschen erweitert:

  • alternatives Rechnungsformular (einstellbar in Bestellungen --> Rechnungen)
  • Zusätzliche Eingabefelder für individuelle Lieferzeiten bei jedem Artikel (Anzeige auf Produktdetailseite im Shop)

Share this post


Link to post
Share on other sites

Update Modul "Europäische Rechtssicherheit"   auf Version 2.0

Share this post


Link to post
Share on other sites

Spinning Save-Button (PS 1.6.1.3)

 

Es gab ja schon mehrere Hinweise auf auf die sich endlos drehenden Speicher-Buttons beim Artikel-Bearbeiten.

 

Ich hatte diesen Zustand gerade auch.

 

In den diversen Log-Dateien des Servers finden sich keine Hinweise auf einen möglichen Fehler, aber ..

 

...es gibt einen unmittelbaren und reproduzierbaren Zusammenhang zwischen der Einstellung im Leistungstab "Smarty kompilieren/Smarty nicht kompilieren" und dem Fehler.

 

Sobald "Kompilierung erzwingen" aktiviert ist kann man einen Artikel  einmal neu speichern, danach drehen sich die Buttons endlos, ein weiteres Abspeichern ist nicht möglich!

Aktiviert man "Template-Dateien nie neu kompilieren" lassen sich die Artikel normal speichern.

 

 

Grüsse

Whiley

  • Like 1

Share this post


Link to post
Share on other sites

Hi, ist zwar eine blöde Frage, habe schon bei Prestashop Module geguckt, die Google Suche genutzt, woooo findet man das Modul Europäische Rechtssicherheit zum download ???

Share this post


Link to post
Share on other sites

danke  hatte es auch danach gefunden. Wenn man halt das Modul mit Rechtsicherheit sucht, dann findet man nichts, musste erst heruasfinden, das es advancedeucompliance heisst. 

Share this post


Link to post
Share on other sites

danke hatte es auch danach gefunden. Wenn man halt das Modul mit Rechtsicherheit sucht, dann findet man nichts, musste erst heruasfinden, das es advancedeucompliance heisst.

Nein, es heißt wirklich so, nur wird Prestashops Installationsversion leider meist mit z.T. veralteten oder unvollständigen deutschen Sprachdateien ausgeliefert, vor allem wird die sog. config_de.xml nicht mitgeliefert, die dafür sorgt, dass das Modul im Back Office in der Landessprache erscheint. Das gilt vor allem für solche sog. Partnermodule. Deshalb solltest du anschließend immer als erstes die deutsche Sprache aktualisieren.

Share this post


Link to post
Share on other sites

Funktioniert eigentlich mittlerweile bei irgend jemandem die Steueraufschlüsslung getrennt nach Artikel UND Versandkosten?

 

Habe gerade auf einem neuen Server 1.6.1.4 installiert und zwei Testartikel angelegt und siehe da: geht nicht. Bei mir zumindest...

Share this post


Link to post
Share on other sites

Nein, aktuell leider nicht. :(

Es sei denn, du hast nur 19%-Artikel. Dann reicht es

  • die Option zur Steueraufschlüsselung in AdvancedEUCompliance zu deaktivieren
  • Bei jedem Versanddienst im nun sichtbaren Feld MwSt 19% einzugeben
  • anschließend die Option wieder zu aktivieren

Ab der nächsten Rechnung wird dann der Versanddienst zumindet mit 19% angezeigt. Aber hattest du nicht diesen Tipp selbst gegeben?

 

Ich habe das und andere Probleme aber vor zwei Wochen mit dem zuständigen Projektmanager in Paris besprochen und er will sich drum kümmern.

Share this post


Link to post
Share on other sites

Nein, aktuell leider nicht. :(

Es sei denn, du hast nur 19%-Artikel. Dann reicht es

  • die Option zur Steueraufschlüsselung in AdvancedEUCompliance zu deaktivieren
  • Bei jedem Versanddienst im nun sichtbaren Feld MwSt 19% einzugeben
  • anschließend die Option wieder zu aktivieren

Ab der nächsten Rechnung wird dann der Versanddienst zumindet mit 19% angezeigt. Aber hattest du nicht diesen Tipp selbst gegeben?

 

Ich habe das und andere Probleme aber vor zwei Wochen mit dem zuständigen Projektmanager in Paris besprochen und er will sich drum kümmern.

 

Ja hatte den Tipp selbst gegeben. Wollte nur wissen, ob es mittlerweile bei 1.6.1.4 bei gemischten Steuersätzen bei irgendjemqand läuft...

 

Aber leider, wohl nicht. Aber schön das Du das Problem besprochen hast, vielleicht tut sich ja was...

Share this post


Link to post
Share on other sites

Halloo :-) EIne Frage. Woher bekomme ich dieses Modul? Bei Presta finde ich das nicht? "Europäische Rechtssicherheit"  Vers. 2.0

Share this post


Link to post
Share on other sites

Im Normalfall ist es nach der Installation im Backoffice -->Module-->Module bereits vorhanden. Dort advancedeucompilance bei der Suche eingeben.

 

Ansonsten kannst du dir die neuste Version auch hier herunterladen:

https://github.com/PrestaShop/advancedeucompliance

 

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Kann man den eig. mit php7 laufen lassen? Da war ja eigentlich Support angedacht für 1.6.1.4, oder?

Share this post


Link to post
Share on other sites

Mit php7 gibts schon noch kleinere Probleme (BO, csv-Import ...) FE läuft bei mir zumindest stabil. Leichter Performande-Gewinn ist erkennbar.

 

Hier gibts einen thread:

https://www.prestashop.com/forums/topic/494424-prestashop-16-with-php-70-experience-problems-solutions/

 

Einen laufenden Shop würde ich im Moment nicht umstellen!

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Der Upgrade auf 1.6.1.5 hat wunderbar funktioniert, alles bestens!

Nur Europäische Rechtssicherheit funktioniert nicht. Da habe ich wieder eine alte Version eingesetzt. Gibt es da wieder irgendeinen Trick, um das Modul einzusetzen? Ich habe bei einer früheren Version auch schon mal basteln müssen

Edited by itknitter

Share this post


Link to post
Share on other sites

Ich habe ein Problem bei der Anzeige der Preisübersicht Artikel im Backend...

 

Wie kann ich dies umschalten?

 

Brauche dringend Hilfe... 

 

Vielen Dank!

 

PS: 1.6.1.5.

 

 

Problem gelöst! Falsche Lokalisierungseinstellung!

post-1252783-0-36862400-1463053676_thumb.png

post-1252783-0-00521100-1463053764_thumb.png

Edited by eniani

Share this post


Link to post
Share on other sites

Benutze noch 1.6.1.3 kann man auf 1.6.1.5 updaten oder gibt es noch irgendwelche Bugs?

 

Danke

Share this post


Link to post
Share on other sites

Update Demoshop auf 1.6.1.6

Europäische Rechtssicherheit 2.02

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo,

im Demoshop erscheint der Lieferzeitraum doppelt. Woran liegt das?

Gruß,

Franz

Share this post


Link to post
Share on other sites

Zwischenzeitlich war das Problem der Spinning Buttons ja erträglich geworden, aber zumindest in diesem Demoshop bin ich ja nicht mal in der Lage, auch nur einen Artikel anzulegen.

Kann es mit den eingeschränkten Nutzerrechten zu tun haben im BO?

Oder sind hier wieder alte Fehler drin wie ja z.B. auch die doppelte Lieferzeitanzeige, wobei letzteres natürlich einer der wieder auferstandenen Bugs der aktuellen AEUC-Version ist.

Ein weiterer gravierender Fehler ist mir gerade zufällig aufgefallen. Wenn man ein Modul anklickt und über die Bulk-Option deinstalliert, verschwindet es automatisch von der Modulliste, wird also vermutlich auch gleich gelöscht ohne Sicherheitsabfrage. (Tut mir leid, aber auf diese Weise habe ich Advancedeucompliance aus der Demo geworfen. Da die Modulinstallation gesperrt ist, kann nur Whiley neu installier, sonst hätte ich das schon selbst erledigt.)

Share this post


Link to post
Share on other sites

Wann u. wodurch die doppelte Lieferzeitanzeige auftritt habe ich noch nicht herausgefunden, durch Löschen des Cache ist regelmäßig für eine Weile alles ok.

 

Spinning Buttons verschwinden imo wenn smarty auf nicht kompillieren (Leistung) eingestellt ist.

 

Benutzerrechte hatte ich eingeschränkt nachdem irgendwelche Scherzkekse den Shop täglich lahngelegt hatten, ich habe soeben wieder alle Rechte freigegeben.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Guten Tag, Grüsse aus der Schweiz. Bin an meinem Shop erstellen, somit führte mein weg auf dieses Forum. Mein erstes Grosses problem, habe keinerlein Icons auf meiner Seite. wie krieg ich sie sichtbar. Habe mehrmals den Shop runtergeladen entzipt, nach den Dateien gesucht z.B icon-user aber nichts gefunden. Kann mir da jemand helfen? Besten Dank im voraus. Jürg

 

shop.textildrucker.li

Share this post


Link to post
Share on other sites

Hallo Jürg,

 

suche mal nach dem Begriff "Font Awesome"

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Danke für das schnelle reagieren. Habe bei mir auf der HD und auf dem Server danach gesucht: admin/themes/default/fonts und modules/themenconfigurator/views/css/font div. vorhanden. was mir aufgefallen ist, wenn ich Hilfe klicke sind bis auf wenige icons sichtbar. habe ich ev. ein Problem mit der darstellung? Nachtrag, ich babe die neuste Version 1.6.1.6

Share this post


Link to post
Share on other sites

Der Font muss auch noch im Ordner:

themes/default-bootstrap/fonts

vorhanden sein.

 

Wenn dann trotzdem nicht alle Icons angezeigt werden könnte das ein Cache Problem sein. Lösche mal die Inhalte der Ordner (ausser index.php)

 

 /cache/purifier/CSS/

 /cache/purifier/HTML/

 /cache/purifier/URI/

 /cache/smarty/cache/

 /cache/smarty/compile/

 

Danm mit ctrl F5 im Browser nochmal probieren.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Der Font muss auch noch im Ordner:

themes/default-bootstrap/fonts

vorhanden sein.

das hab ich übersehen, aber dort sind auch fonts

 

 

/cache/purifier/CSS/          css Ordner existiert nicht

 /cache/purifier/HTML/       html ebenfals nicht

 /cache/purifier/URI/           auch uri nicht

 /cache/smarty/cache/        alle unterordner auch löschen?

 /cache/smarty/compile/     alle unterordner auch löschen?

Share this post


Link to post
Share on other sites

ja auch die Unterordner löschen.

 

die anderen existieren nur falls du CCC eingeschaltet hättest.

Share this post


Link to post
Share on other sites

also alles gelöscht. auch Browsercache. Nichts verändert. Habe ich eventuell beim ersten Install etwas mit der Monitor auflösen verkackt. Kann man es neu Installieren ohne die Einstellung vom Server nochmals einzugeben,

Ich habe ja am Shop noch nichts verändert.

 

 

OK. Habe alles auf dem Server gelöscht, und nachträglich den Shop neu installiert. Jetzt alles wie es sein soll. Danke

Edited by jubara

Share this post


Link to post
Share on other sites

Hallo

 

Ich habe auch update gemacht dachte das sich mein Problem mit dem mailversand endlich ändert aber ich bekomme immernoch die fehler meldung

Beim Senden der E-Mail an den Kunden ist ein Fehler aufgetreten.

 

kann mir bitte einer helfen

 

Ich verzweifel noch,testmail geht aber es wird einfach keine mail an den kunden gesendet

 

vieleicht muss ich bei strato was einstellen weiß einer was ich tun kann

 

Danke 

 

Ralf

Share this post


Link to post
Share on other sites

Ich verzweifel noch,testmail geht aber es wird einfach keine mail an den kunden gesendet

Ich habe gerade mal ein wenig gegoogelt, die Frage kommt öfters, meist aber ohne Antwort, ist halt aus der Ferne kaum zu lösen. Bei einem lag's daran, daß bei dem die Mail auslösenden Bestell-Status keine E-Mail hinterlegt war ...

 

Hast du denn mal alles ausprobiert, was Mails versendet (also Bestellung mit verschiedenen Zahlungsarten, Kontaktformular, Mail an Kunden aus dem Backoffice)? Was hast du auf der E-Mail-Seite eingestellt, werden versandte E-Mails angezeigt? Was für Module hast du installiert, die evtl. damit zu tun haben könnten (ggf. mal Fremdmodule und Overrides deaktivieren)? Hatte der E-Mail-Versand schon mal funktioniert oder noch nie?

 

Einfach Input, Input, Input, auch damit potentielle Helfer merken, daß du dich selbst bemühst ...

Share this post


Link to post
Share on other sites

PRESTASHOP 1.6.1.7 stable wurde freigegeben!

Modul "Europäische Rechtssicherheit"  Vers. 2.01 aktiviert.

 

 

Wer testen will:

 

Demoshop

 

Zugang zum Backoffice:

Backoffice

 

email:  demo@demo.com

passw: demo1617

 

Grüsse

Whiley

Hallo Whiley, hallo alle anderen :-)

 

sorry daß ich diese "alte Antwort" mal zitiere, aber so kann ich es evtl am besten erklären :)

 

ich habe eine Frage zu einer ganz bestimmten Einstellung - bzw finde ich etwas bei mir nicht vor, was es aber in deinem Demoshop gibt :(

 

und zwar im Backoffice,  Modul eucompliance, bei den Einstellungen... ganz unten, die "Zusätzlichen E-Mail-Inhalte"

 

ich hab zwar diesen Bereich auch, sehe aber nur die oberste Reihe oberhalb des blauen Striches...

 

sichtbar ist folgendes bei mir:

 

 

Alle E-Mail-Vorlagen Allgemeine Geschäftsbedingungen (AGB) Rechtliche Hinweise Datenschutz Widerrufsrecht Versand und Zahlung

 

aber alles was darunter kommt (die ganzen verschiedenen Bereiche) werden nicht angezeigt... also sprich, wo ich anhaken kann, wenn AGB, Widerrufsrecht ... mitgesendet werden sollen.

 

vorhanden sind die ganzen Vorlagen zwar nicht alle bei mir so wie bei dir, aber die meisten habe ich auch

 

was genau ist falsch bei mir? kann mir eventuell jmd einen Rat geben? :(

 

liebe Grüße

 

post-1058825-0-78683400-1478193365_thumb.jpg

Share this post


Link to post
Share on other sites

Ich habe mir mal erlaubt, die deutsche Übersetzung des Demoshops manuell zu aktualisieren, da 1.6.1.8 mit einer völlig veralteten Übersetzung ausgeliefert wird und offenbar auch auf der Übersetzungseite von Prestashop geschludert wird, da die automatische Aktualisierung genausowenig funktioniert, weil auch hier eine Übersetzung aus der Mottenkiste hinterlegt wurde.

Wer seine eigene Version aktualisieren möchte, sollte sich von der Downloadseite als Notbehelf die deutsche Sprache zur Version 1.6.1.5 laden.

Share this post


Link to post
Share on other sites

Wohin soll das alles nur führen. Mich gruselt es schon, wenn ich 1.7 sehe :/

Share this post


Link to post
Share on other sites

Ach, weißt du, ich mache das mit der deutschen Übersetzung jetzt sei fast 4 Jahren, war also schon lange vor Crowdin aktiv beteiligt. Aber diese Geschichte mit den veralteten Übersetzungen zieht sich wie ein roter Faden durch. Das kenne ich gar nicht anders. :D

Aber ich werde mich jetzt mal drum kümmern, dass die von der Downloadseite verschwindet, damit man die aktuelle Übersetzung wenigstens nachladen kann. Nur, am Wochenende wird in Paris eh nicht gearbeitet. So was machen höchstens die Shopbetreiber ... :)

Share this post


Link to post
Share on other sites

Demoshop ist aktualisiert auf Vers. 1.6.1.10

 

Grüsse

Whiley

  • Like 1

Share this post


Link to post
Share on other sites

Ich habe mir mal erlaubt, die Prestools Suite hochzuladen und direkt auf der Bestellseite mit einem zusätzlichen Button einzubauen, der bei Prestashop bisher immer gefehlt hat: Bestellung ändern. :)

 

Benutzername: demo@demo.com

PW: demo16110

  • Like 1

Share this post


Link to post
Share on other sites

Habe bei der Gelegenheit auch den Schnellzugriff mithilfe der Prestools Suite um ein paar nützliche Funktionen erweitert:

  • Artikel bearbeiten (auch Massenänderungen möglich)
  • Kategorien bearbeiten (auch Massenänderungen möglich)
  • Artikel sortieren (inner halb Kategorie oder Startseite, direkt per Mausklick auf dem Bildschirm)

Share this post


Link to post
Share on other sites

Na, das Update auf 1.6.1.10 war vielleicht doch nicht die beste Idee, Whiley. Die Spinning Buttons sind nämlich zurück! :angry: Artikel speichern wird zum Geduldsspiel, wenn es denn überhaupt funktioniert!

Egal welche Version von 1.6.1x man nimmt, überall findet man neue Bugs. Die letzte stabile Version war wirklich 1.6.0.9 bzw. 1.6.0.14! Danach ging es bergab mit PrestaShop!

Share this post


Link to post
Share on other sites