Jump to content
Pepozzo

[PS 1.5.2.0] Customer can't login in Front-End

Recommended Posts

Hello!

 

I've several problem with my configuration to sign in as customer.

 

My notebook is part of my business LAN and the whole LAN is under a PC with Kerio Firewall and cache enabled.

 

Sometime happens that another PC that visit my site is already logged in, and sometimes happens that i cannot log out or login into my site, because when i go to http://www.mydomain.tld/en/authetication?back=my-account and i fill the form with my username and password and click to "log in", the page simply refresh without logging me in.

 

Maybe is a Kerio cache problem, but my prestashop site is the only one where i have this kind of problem. No problem with: gmail, youtube, facebook and also phpbb forums or other no-professional website.

 

I think this is an "interesting" problem and it really need to be fixed soon.

 

What do you think?

 

Thanks

Share this post


Link to post
Share on other sites

I don't know how you can locally reproduce this problem, because i've this firewall PC with Kerio Control (this is not a free firewall) that filters all the web traffic and has an internal cache to store web pages, images etc etc.

 

You can try to login at www.computerparma.it with these credentials, but i don't think will be problems:

User: test@testcomputerparma.it

Pass: pass123

 

And i forgot to say in the first post, that at the moment i've enabled "force compile".

Edited by Pepozzo (see edit history)

Share this post


Link to post
Share on other sites

Hi,

I created an account, then re-enter several times to reproduce the error, but everything seems to work well for me

Share this post


Link to post
Share on other sites

Hi,

I created an account, then re-enter several times to reproduce the error, but everything seems to work well for me

Yes, I start thinking it can be only my problem or a problem for who has Kerio Control Firewall with cache enabled. Uhm...

 

Can i ask you another test? Could you try to see in "your address" page if you see the "VAT Number" field (with Chrome or Firefox) and if the "State" select (maybe selecting "Italy" or "USA" as Country) is working well with Internet Explorer?

 

It's the problem that i've reporter here: http://www.prestashop.com/forums/topic/196937-ps-1520-doesnt-display-vat-number-field-in-registration-with-chromeff/

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

I have also the problem whit the login (when i go to www.mydomain/authentification?back=my-account and i fill the form with my username and password and click to "log in", the page simply refresh without logging me in) but only with Firefox, it works good with Internet Explorer 8 ...

My theme is not prestashop theme (I've bought one on http://www.crea-templates.fr/).

Is someone has got an idea ?

Thanks.

 

Version de PrestaShop: 1.5.2.0

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

Edited by Tess (see edit history)

Share this post


Link to post
Share on other sites

Hello!

 

I've several problem with my configuration to sign in as customer.

 

My notebook is part of my business LAN and the whole LAN is under a PC with Kerio Firewall and cache enabled.

 

Sometime happens that another PC that visit my site is already logged in, and sometimes happens that i cannot log out or login into my site, because when i go to http://www.mydomain.tld/en/authetication?back=my-account and i fill the form with my username and password and click to "log in", the page simply refresh without logging me in.

 

Maybe is a Kerio cache problem, but my prestashop site is the only one where i have this kind of problem. No problem with: gmail, youtube, facebook and also phpbb forums or other no-professional website.

 

I think this is an "interesting" problem and it really need to be fixed soon.

 

What do you think?

 

Thanks

Hi, Pepozzo!

My PS, www.lovingprize.com, have a similar problem as yours, when I try to log in at my front-office of PS 1.5.2.0, the page just reload and nothing happens. I have try login to http://www.mydomain.tld/en/authetication?back=my-account with test email and the its password "pass123" It looks OK. Can you tell me how to solve this problem?

Edited by yusufzulkarnain (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

have you find a solution to this issue? Im having the same problem. Some customers can login but some cannot. For example now I'm not able to login with Google Chrome but with Firefox it works. The same issue on testing shop and also on clean installation of 1.5.2 prestashop.

I have found a similar problem in following post but it didn't help to me :(http://www.prestashop.com/forums/topic/161377-solved-customers-cant-log-in-at-front-office-new-installps-1462/

Share this post


Link to post
Share on other sites

Hi

put in a ticket with prestashop forge. Just let them know as much detail as possible.

 

I heard an upgrade is coming in a few days. Hopefully it will help but more detail is the forge site is better for prestashop developers.

Share this post


Link to post
Share on other sites

There is a solution posted in other similar threads, it has worked for me and several other people

 

In our case the steps to solve were:

  • In URLs and SEO put the "www." before your shop url
  • Enable url rewrite (optional)
  • In the .htaccess file add the the lines
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
     
    right after the line
     
    RewriteEngine on
  • Clear your cookies and restart the browser

Hope this helps, cheers!

Edited by perino (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi guys, I have created a ticket in a meantime so detailed description can be found there

http://forge.prestashop.com/browse/PSCFV-6210

 

perino thanks for your post but I cant force my customers to clear their cache and cookies while shopping. It needs to be somehow automatic without doing this. And also I would rather change php which is generating htaccess instead of htaccess itself because when shop will generate a new one that problem may occur again :(

Can you please add a link to the thread so I can see it in more detail?

Share this post


Link to post
Share on other sites

Hi jimmyc, could you please post the Bug Report in this thread. I can take a look at it.

 

 

Hi Benjamin,

Can I pm you with a full report of our issues.

some are across more than one site.

 

At the moment we are under a lot of stress just keeping customers at bay.

Edited by jimmyc (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

I have the same problem, login is impossible at front office. And i found what is the problem for me.

My prestashop is hosted on 1&1 servers, and i got an url like sXXXXXXX.onlinehome.fr.

When i link my domain in "SEO & URL" to mywebsite.com, my shop works correctly but login in front office seems to be broken. If i get back to sXXXXXXX.onlinehome.fr it works.

 

Don't have any issue, someone got an idea ?

Have a nice day !

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I have the same problem, client can not log in with PC IE9 and Samsung tablet and phone (Android). Chrome and Safari (iPhone) do log. This is a big issue, Prestashop team should give priority to this.

  • Like 1

Share this post


Link to post
Share on other sites

hi everybody,

 

for the bug : customers can't login at the front office, maybe you can try this, it works for me. i'm using prestashop 1.5.2 custom theme

 

i solved the problem, first change address in SEO URL from www.domainname.com to domainname.com (delete the www.) and after change it... set the friendly URL to "NO" and then try to go to your website, if it works, it should be http://domainname.com/index.php in the address bar, without any error or "page not found" and then try to login again... it quite bit slow when you're not using "friendly URL", but just try to login first... if it works normally, then you can use "friendly URL" again... hope this works for you :) ... if something wrong ... just change the settings like you used before,

 

NOTE: i'm not responsible for this method, and i'm not guarantee this method works 100%... i'm just try to help you fixed this problem... (it works for me without clearing any browsing data/cookies) if you affraid of the risk, please don't do it... :)

do it with your own risk :)

 

best regards,

sandy sasmita

Edited by sandysasmita (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

hi everybody,

 

for the bug : customers can't login at the front office, maybe you can try this, it works for me. i'm using prestashop 1.5.2 custom theme

 

i solved the problem, first change address in SEO URL from www.domainname.com to domainname.com (delete the www.) and after change it... set the friendly URL to "NO" and then try to go to your website, if it works, it should be http://domainname.com/index.php in the address bar, without any error or "page not found" and then try to login again... it quite bit slow when you're not using "friendly URL", but just try to login first... if it works normally, then you can use "friendly URL" again... hope this works for you :) ... if something wrong ... just change the settings like you used before,

 

NOTE: i'm not responsible for this method, and i'm not guarantee this method works 100%... i'm just try to help you fixed this problem... (it works for me without clearing any browsing data/cookies) if you affraid of the risk, please don't do it... :)

do it with your own risk :)

 

best regards,

sandy sasmita

Thanks Sandy Sasmita.. I tested your suggestion and found that without "www" everything goes well, but it happens again when change to www.yourdomain.com. Is it possible to contact the server and ask for add "www" for us? Or just do something to the .htaccess file? I hope my site address is www.yourdomain.com this way....

Share this post


Link to post
Share on other sites

Thanks Sandy Sasmita.. I tested your suggestion and found that without "www" everything goes well, but it happens again when change to www.yourdomain.com. Is it possible to contact the server and ask for add "www" for us? Or just do something to the .htaccess file? I hope my site address is www.yourdomain.com this way....

 

hello yafay,

 

i think if you want to use www.yourdomain.com instead of yourdomain.com, you should choose "NO" at the friendly URL option. well, i'm not sure if that would be a problem to you... but, you can try it :) and if something wrong happens again, you know what to do :) change into yourdomain.com (without www.) about changing .htaccess i definitely have no idea what to do, maybe you can read this article http://serverfault.com/questions/272606/what-is-the-difference-between-www-domain-name-com-and-domain-name-com-how-to and remember ... do it with your own risk... good luck Yafay :)

Edited by sandysasmita (see edit history)

Share this post


Link to post
Share on other sites

Somewhere else someone suggested the just released version 1.5.3 (not for production) correct this problem. I have not tried it yet.

Share this post


Link to post
Share on other sites

Updated to 1.5.3.1 is still not solve the issues! Now my users can't log in and it is not work even they clean the cookies. :( There is only one way which is to remove "www" then issues gone! I don't what to do ... Prestashop team please help up..

Share this post


Link to post
Share on other sites

in my case, not only login problem... but, costumers can't add more than one item to the shopping cart if i using "www"... when they add two items, the previous item that they put on shopping cart is gone... so, i think i would prefer to use http://myweb.com than losing all my costumers satisfaction. i don't want to upgrade to 1.5.3 because of my theme is not compatible with the new version of prestashop (they're still have a lot of bugs) even my hosting server that have auto installer for prestashop, they still using 1.5.2, not 1.5.3 ... bugs everywhere...

Share this post


Link to post
Share on other sites

in my case, not only login problem... but, costumers can't add more than one item to the shopping cart if i using "www"... when they add two items, the previous item that they put on shopping cart is gone... so, i think i would prefer to use http://myweb.com than losing all my costumers satisfaction. i don't want to upgrade to 1.5.3 because of my theme is not compatible with the new version of prestashop (they're still have a lot of bugs) even my hosting server that have auto installer for prestashop, they still using 1.5.2, not 1.5.3 ... bugs everywhere...

 

:wub: Hi sandysasmita, They solve this bug here: http://forge.prestashop.com/browse/PSCFV-5717

You need to delete the three lines below in your file classes/shop/Shop.php

  // Optimization - don't redirect and allow WS and other script to work
  if (!$id_shop)
   $id_shop = Configuration::get('PS_SHOP_DEFAULT');

 

For mine is line 330-332. And then clear your browser cookies. I am so Happy now!! Have a nice day!

  • Like 2

Share this post


Link to post
Share on other sites

There is a solution posted in other similar threads, it has worked for me and several other people

 

In our case the steps to solve were:

  • In URLs and SEO put the "www." before your shop url
  • Enable url rewrite (optional)
  • In the .htaccess file add the the lines
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
     
    right after the line
     
    RewriteEngine on
  • Clear your cookies and restart the browser

Hope this helps, cheers!

 

 

@perino:

Hi,

In my 1.5.3.1 htaccess I have

RewriteCond %{HTTP_HOST} ^www.domain.com$
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

Do you mean I should replace them with

RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

?

Regards,

Share this post


Link to post
Share on other sites

:wub: Hi sandysasmita, They solve this bug here: http://forge.prestas...owse/PSCFV-5717

You need to delete the three lines below in your file classes/shop/Shop.php

  // Optimization - don't redirect and allow WS and other script to work
  if (!$id_shop)
$id_shop = Configuration::get('PS_SHOP_DEFAULT');

 

For mine is line 330-332. And then clear your browser cookies. I am so Happy now!! Have a nice day!

 

hi, Yafay,

 

i already tested your trick... yes it works... :):D thank you for posting it here, but somehow my web is running a little bit slow after i edit the shop.php... BO and FO.. did you realize that Yafay?

or maybe you are very excited so you don't even mind that :rolleyes::P:D

  • Like 1

Share this post


Link to post
Share on other sites

:wub: Hi sandysasmita, They solve this bug here: http://forge.prestas...owse/PSCFV-5717

You need to delete the three lines below in your file classes/shop/Shop.php

  // Optimization - don't redirect and allow WS and other script to work
  if (!$id_shop)
$id_shop = Configuration::get('PS_SHOP_DEFAULT');

 

For mine is line 330-332. And then clear your browser cookies. I am so Happy now!! Have a nice day!

 

Hi Yafay,

 

thanks for your post. I'm going to try it right now. :)

Share this post


Link to post
Share on other sites

There is a solution posted in other similar threads, it has worked for me and several other people

 

In our case the steps to solve were:

  • In URLs and SEO put the "www." before your shop url
  • Enable url rewrite (optional)
  • In the .htaccess file add the the lines
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
     
    right after the line
     
    RewriteEngine on
  • Clear your cookies and restart the browser

Hope this helps, cheers!

 

Hello

 

I had the same issue with Prestashop 1.5.3.1

I did the above and it worked..

My .htaccess now looks like this:

 

RewriteEngine on

RewriteCond %{HTTP_HOST} !^www\.

RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^www.techballoon365.com$

RewriteRule . - [E=REWRITEBASE:/]

RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

 

Can you please confirm if this is correct?

 

Thanks

Share this post


Link to post
Share on other sites

i have tried all the solutions that i found on the forum, but none works for me

when i click login or checkout as guest nothing happens

when i create account i see it in bo but in fo happens nothing, just the same login page with empty fields

i tried on local host and all works fine, but live (1and1 server germany) doesnt work

dunno what to do, if any1 wants to give it a try just pm with ip and i will give the shop link and add the ip

Share this post


Link to post
Share on other sites

:wub: Hi sandysasmita, They solve this bug here: http://forge.prestas...owse/PSCFV-5717

You need to delete the three lines below in your file classes/shop/Shop.php

  // Optimization - don't redirect and allow WS and other script to work
  if (!$id_shop)
$id_shop = Configuration::get('PS_SHOP_DEFAULT');

 

For mine is line 330-332. And then clear your browser cookies. I am so Happy now!! Have a nice day!

It's very helpful,thank you very much!

  • Like 1

Share this post


Link to post
Share on other sites

i am creating a wholesale site and installed the Customerregistration module

http://www.prestashop.com/forums/topic/10305-module-customerregistration-management/

 

Which 'tried' to work but probably needed a tweak

I uninstalled but now when I try to login I get sent back to the 'create  an account/ register' page

'www.my domain//authentication?back=my-account'

 

Can anyone help?

Share this post


Link to post
Share on other sites

i am creating a wholesale site and installed the Customerregistration module

http://www.prestashop.com/forums/topic/10305-module-customerregistration-management/

 

Which 'tried' to work but probably needed a tweak

I uninstalled but now when I try to login I get sent back to the 'create  an account/ register' page

'www.my domain//authentication?back=my-account'

 

Can anyone help?

 

This is a little off topic. Did you have a backup from before you installed the module? It may have changed some files even after you uninstalled. 

Share this post


Link to post
Share on other sites

hi everybody,

 

for the bug : customers can't login at the front office, maybe you can try this, it works for me. i'm using prestashop 1.5.2 custom theme

 

i solved the problem, first change address in SEO URL from www.domainname.com to domainname.com (delete the www.) and after change it... set the friendly URL to "NO" and then try to go to your website, if it works, it should be http://domainname.com/index.php in the address bar, without any error or "page not found" and then try to login again... it quite bit slow when you're not using "friendly URL", but just try to login first... if it works normally, then you can use "friendly URL" again... hope this works for you :) ... if something wrong ... just change the settings like you used before,

 

NOTE: i'm not responsible for this method, and i'm not guarantee this method works 100%... i'm just try to help you fixed this problem... (it works for me without clearing any browsing data/cookies) if you affraid of the risk, please don't do it... :)

do it with your own risk :)

 

best regards,

sandy sasmita

Hi everyone,

 

The solution provided by sandy (quoted above) worked for me temporarily but I am not able to use the permanent solution provided in this forum which talks about editing shop.php file since I am using 1.6.0.9. Anyone has any idea. 

 

any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

I found same problem

and after I clear browser cache and cookie.

It's work!!!.

 

Version : 1.5.2

Browser : Chrome v.43

OS : Mac 10.10.3

Share this post


Link to post
Share on other sites

Same problem with 1.6.09. The only temporary solution i have found is clearing cookies. That is not a solution for my customers. Any news?

Share this post


Link to post
Share on other sites

Hi

 

I found the solution. 

 

Basically copy these lines from the old settings file and paste in the new one. Don't forget to import your ps_employee table from your old site to the new one.

 

root/config/settings.inc.php

 

 

define('_COOKIE_KEY_', '#########nnnnnnnnn[spam-filter][spam-filter]@&&&&&&&');
define('_COOKIE_IV_', '%%&/NN');
 
 
define('_RIJNDAEL_KEY_', '$$$%%&""nnnnnnn[spam-filter][spam-filter][spam-filter]@%%%%');
define('_RIJNDAEL_IV_', '%%NN//[spam-filter]');

Share this post


Link to post
Share on other sites

same problem to my shop, some customer can login in but some can't login in just simply refresh...i can see them create account in BO but nothing happen in FO and they can't login... my shop ver. 1.6.13, any 1 can help me???

Share this post


Link to post
Share on other sites

Hello

 

Iam French and i have the same problem, you have find a solution please ? 

 

Thank you so much :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More