Jump to content
Xavier  du Tertre

Next release - 1.6.0.12

Recommended Posts

Hi!

 

PrestaShop 1.6.0.12 has been released!

 

Regards

MacRoy

  • Like 1

Share this post


Link to post
Share on other sites

I tried importing CSV and does not work correctly in Prestashop 1.6.0.12

Articles with stock 0 not upgraded.

Is there any solution?

Share this post


Link to post
Share on other sites

Hi!

 

Has made a new clean install of the PrestaShop 1.6.0.12 Not Beta released today!

 

Can not create products or CMS pages with 1.6.0.12!

 

What is this?

 

 

Regards

MacRoy

Edited by MacRoy (see edit history)

Share this post


Link to post
Share on other sites

Hi. 

I Use Advanced Stock Management and i have a problem with packs. 
 

If i create product pack module shows 0 quantity. 
Shop creates new products in stock instead shows quantity sum of product in pack. 

i checked in Presta 1.6.0.12 not beta released and still not work. 

Sorry for my english language ;-)

Share this post


Link to post
Share on other sites

Hi!

 

Has made a new clean install of the PrestaShop 1.6.0.12 Not Beta released today!

 

Can not create products or CMS pages with 1.6.0.12!

 

What is this?

 

 

Regards

MacRoy

 

This is buggy software...i cannot edit products. Did not even look further. 

Share this post


Link to post
Share on other sites

Hi!

 

Has made a new clean install of the PrestaShop 1.6.0.12 Not Beta released today!

 

Can not create products or CMS pages with 1.6.0.12!

 

What is this?

 

 

Regards

MacRoy

 

This is buggy software...i cannot edit products. Did not even look further. 

 

 

Hi,

 

Thank you for your feebacks!

 

We can't reproduce your issues about the creation and edition of products and CMS.

 

On witch environnement are you testing?

 

 

Best regards,

Share this post


Link to post
Share on other sites

Once again I downloaded the github version of PS aprx 40 minutes ago (16.30) and installed it. When going to products (and then"Edit") it takes insanely long time before saving changes is possible. The prestahand at the left top corner and the "Save and stay" & "Save" buttons at the bottom right now spins for about 45 seconds (20 seconds more than last time i tried. 02.02-15) before they're ready.


 


This happens in both Chrome (Version 40.0.2214.115 (64-bit) and FF (35.0). Currently running OpenSuse 13.2 (64).


Installed with demo products and English language and no modificaions is done to any ps files on the server.


Server is running PHP 5.6.


 


I thought this issue was solved?


 


(I know I DL the GH-version, and that it's not the official 1.6.0.12 version, but something tells me it will be just the same in the official release? =)


 


Now the version says 1.6.1.0 btw


 


Regards


Elvis


Edited by Izraelviz (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

 

Once again I downloaded the github version of PS aprx 40 minutes ago (16.30) and installed it. When going to products (and then"Edit") it takes insanely long time before saving changes is possible. The prestahand at the left top corner and the "Save and stay" & "Save" buttons at the bottom right now spins for about 45 seconds (20 seconds more than last time i tried. 02.02-15) before they're ready.

 

This happens in both Chrome (Version 40.0.2214.115 (64-bit) and FF (35.0). Currently running OpenSuse 13.2 (64).

Installed with demo products and English language and no modificaions is done to any ps files on the server.

Server is running PHP 5.6.

 

I thought this issue was solved?

 

(I know I DL the GH-version, and that it's not the official 1.6.0.12 version, but something tells me it will be just the same in the official release? =)

 

Now the version says 1.6.1.0 btw

 

Regards

Elvis

 

 

Ok good news then it take less time to download/install a Prestashop that create a product entry... :-D

 

Appart from the joke, normally if I understand correctly the next .12 is what you can pull from the release branch

Share this post


Link to post
Share on other sites

 

Once again I downloaded the github version of PS aprx 40 minutes ago (16.30) and installed it. When going to products (and then"Edit") it takes insanely long time before saving changes is possible. The prestahand at the left top corner and the "Save and stay" & "Save" buttons at the bottom right now spins for about 45 seconds (20 seconds more than last time i tried. 02.02-15) before they're ready.

 

This happens in both Chrome (Version 40.0.2214.115 (64-bit) and FF (35.0). Currently running OpenSuse 13.2 (64).

Installed with demo products and English language and no modificaions is done to any ps files on the server.

Server is running PHP 5.6.

 

I thought this issue was solved?

 

 

You should see with your hosting provider, you must have "Evasive mode" activated: https://www.prestashop.com/forums/topic/393218-16011-problem-with-saving-products/page-5?do=findComment&comment=1960762

Share this post


Link to post
Share on other sites

The hosting company just forwarded me to their docs and told me the settings are locked: http://www.one-docs.com/php5

 

Don't know if you can make anything out of it

 

But still; If "evasie mode" is enabled, shouldn't it "just" take 12 seconds? What's eating the other 30 seconds?

Edited by Izraelviz (see edit history)

Share this post


Link to post
Share on other sites

The hosting company just forwarded me to their docs and told me the settings is locked: http://www.one-docs.com/php5

 

Don't know if you can make anything out of it

 

But still; If "evasie mode" is enabled, shouldn't it "just" take 12 seconds? What's eating the other 30 seconds?

 

Try this commit; it solved my problems on Safari..

 

https://github.com/PrestaShop/PrestaShop/commit/46a42825b28c393529f700fa0ccffd1c219ecd8f

Share this post


Link to post
Share on other sites

The "Skip Tutorial" is not working, I can´t reach the whole menu.

 

Go on the page of the modules and disable it, I did it with the version 11, with thema modified

  • Like 1

Share this post


Link to post
Share on other sites

Still a bit confused here... There are several community members willing to pre-test a release, but presta just release it with several issues (not working on FF and Safari is MAJOR i think)

 

Why not use the help available here a bit better??

 

my two cents..

  • Like 1

Share this post


Link to post
Share on other sites

Delete this "usefull" module on your ftp^^

  • Like 1

Share this post


Link to post
Share on other sites

I am unable to do a fresh install of todays .12 release, I 500 error out after saying next on the terms and conditions.... ;(

Share this post


Link to post
Share on other sites

1. Installer still has old translations, not reflecting current ones from Crowdin

2. I think, the new client registartion form should be slightly changed - need to add 2-nd field for password confirmation.

3. Fresh install on clean database (From GIT) -> no homepage at frontoffice. Just a logo and 2 gray ribbons across the page.

 

UPD

4. When trying to translate Front-office translations -> Core (no theme selected) the got error message [invalid theme "%s"]

Edited by DaoKakao (see edit history)

Share this post


Link to post
Share on other sites

Still a bit confused here... There are several community members willing to pre-test a release, but presta just release it with several issues (not working on FF and Safari is MAJOR i think)

 

Why not use the help available here a bit better??

 

my two cents..

 

Apparently since the last 2 tries they did at proposing us to test, ended-up in people testing and escalating major issues they have decided that probably if they release it to the public as-is the bugs will magically hide themselves ...

 

It could not be qualified "epic fail" again, since it is on intent. It is pure contempt for the community.

  • Like 1

Share this post


Link to post
Share on other sites

Hi All,

 

We currently have a web shop running on 1.5 and we are looking to upgrade to 1.6 for at least 6 months now. We have put a lot of effort to restyle and configure our theme into the new 1.6 style. However every time when we think we can upgrade using the 'next' release serious bugs arise which will be solved in the next release or need a .tpl or .php from git to fix (cache problems, save slow, categories could not editted, mail templates resize incorrectly, final step at checkout is not correct etc.). We are worried we have chosen the wrong platform for our web shop. 

 

Could the Prestashop team please work on a 1.6 release on which they would 'bet their mother' that it is usable for a production webshop ?

 

Kind regards

Edited by pipo1000 (see edit history)
  • Like 4

Share this post


Link to post
Share on other sites

Hi All,

 

We currently have a web shop running on 1.5 and we are looking to upgrade to 1.6 for at least 6 months now. We have put a lot of effort to restyle and configure our theme into the new 1.6 style. However every time when we think we can upgrade using the 'next' release serious bugs arise which will be solved in the next release or need a .tpl or .php from git to fix (cache problems, save slow, categories could not editted, mail templates resize incorrectly, final step at checkout is not correct etc.). We are worried we have chosen the wrong platform for our web shop. 

 

Could the Prestashop team please work on a 1.6 release on which they would 'bet their mother' that it is usable for a production webshop ?

 

Kind regards

 

I'd like that too! The newer versions all have been more problematic (and slower!) that the ones before. I am seriously looking for alternatives for my 3 shops, but conversion will be a hell of a job too (the export function in prestashop has bugs ;))

 

Earlier i have reacted on the effort the presto team has put in imho useless modules (the e-commerce badges..merchant expertise) and leave a critical module as google sitemap with large errors for more than half a year.

 

So please Prestateam, listen to your users and create a usable version for us. The community is a great place to get input and test results, so do something with it! I think that is the real strength of Open Source...

 

So...what will 1.6.1 bring us??

  • Like 3

Share this post


Link to post
Share on other sites

I saw this news version on prestashop's website yesterday but it was remplaced with the previous one. Is it normal ? When will this version be released ? I used PS1.6.0.11 for another projet and it contains a lot of bugs. If I can avoid to use it... Thank you.

 

Edit : I didn't dream. It's available on sourceforge as stable : http://sourceforge.net/projects/prestashop/files/prestashop%20v1/1.6.0.12%20stable/

 

Is this version OK to a production use ?

Edited by makinero (see edit history)

Share this post


Link to post
Share on other sites

The manual translation export/import does not work properly. It exports file, but not imports same file. Inside the gzipped' langpack there are few extra LF's in some lines, the hyhpen symbol cloacking sometimes also finctioning incorrectly (have to manually edit .php files and change the "\' " substrings to "\'' " (with two hyphens, not quotes)

Edited by DaoKakao (see edit history)

Share this post


Link to post
Share on other sites
then after passing agony with version 11, and started a new agony with 12, and perhaps better return to version 1.6.0.9, which was fine with me.

  who made me do ... as they say in Italy

what the criteria is written to "Stable"

well with pages cms there are problems, and woe to change thema, otherwise the problems multiply

mhaa

  • Like 1

Share this post


Link to post
Share on other sites

I've a problem too upgrading to *.13:
 

Todos los archivos actualizados. Actualización de bases de datos en curso...
Error durante la actualización de la base de datos. Puede que tenga que restaurar la base de datos.
Restaurando archivos ...

Restoring *.12

Share this post


Link to post
Share on other sites
Hi!
 
Same problem as with PrestaShop 1.6.0.12! As with 1.6.0.13. What is this for anything, it just gets worse and worse ...
 

Nothing of what I wrote about regarding 1.6.0.12 has been fixed!

 

Regards

MacRoy

 

 

Share this post


Link to post
Share on other sites

 

then after passing agony with version 11, and started a new agony with 12, and perhaps better return to version 1.6.0.9, which was fine with me.
  who made me do ... as they say in Italy
what the criteria is written to "Stable"
well with pages cms there are problems, and woe to change thema, otherwise the problems multiply
mhaa

 

 

Yep, 1.6.0.9 is the way to go for now for performance and stability.

  • Like 1

Share this post


Link to post
Share on other sites

Guys one advice, never use the latest version of PS, wait at least 1-2 months to see if the version is kinda stable... 2 days 2 versions, this is ridicules. 

  • Like 1

Share this post


Link to post
Share on other sites

Hi!

 

Of course not!

 
This forum is about the beta version of PrestaShop 1.6.0.12 and 13!
 
Therefore, it never used live.
 
But one can expect that the bugs reported since several months fared back in time would be fixed by now. But it is definitely not!
 
And how on earth had prestashop imagined that we would run this version 1.6.0.13 Live?!?!?
 
Best regards
MacRoy
  • Like 1

Share this post


Link to post
Share on other sites

From the presta point of view, a stable release does not mean stable at all, you should take it for granteed once for all.

 

Prestashop has his own rules for releasing system, if you want an inner view of the process, once they have released a new version it looks like this :

 

24s.jpg

 

but for the tests, even they pretend to do some , it seems difficult to talk about, it looks like it's the most sacred area for prestashop.

 

Best Regards for all :)

Edited by ZenGraph (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

For those who are already on 1.6.0.12 , you can download latest 0.13 version and only pick these files and replaced them in 0.12 installation:

 

  • /classes/Pack.php
  • /docs/CHANGELOG.txt
  • /install/install_version.php
  • /js/admin/products.js

Or do the whole update again.

Share this post


Link to post
Share on other sites

For those who are already on 1.6.0.12 , you can download latest 0.13 version and only pick these files and replaced them in 0.12 installation:

 

  • /classes/Pack.php
  • /docs/CHANGELOG.txt
  • /install/install_version.php
  • /js/admin/products.js

Or do the whole update again.

 

unfortunately but pack + advanced stock still not work. 

Share this post


Link to post
Share on other sites

I see several issues with multistore and CMS pages (on forge and in my testenvironment), so looks like 1.6.0.9 is the way to go. In .09 it looks like the shop does not have severe issues (besides the wrong tax calculations off course) I'd leave the .13 for now.

 

Looks like Prestateam has a lot of work to do before an acceptable upgrade is available

  • Like 1

Share this post


Link to post
Share on other sites

All we want is a stable version \ reply's to our support calls \ decent help on the forum :(

Disapointed again and back to 1.6.0.9...

  • Like 2

Share this post


Link to post
Share on other sites

hello, 2 released versions and contain errors in it, I think it should launch a new prestashop 1.6.1 already very stable to use. I think for now I'll stick with my prestashop 1.4.10.
is getting harder to version 1.6 to be very stable to use.
best regards

Share this post


Link to post
Share on other sites

The things I read here sounds horrible. At the moment I am working with 1.6.0.11. Why are you "all" talking bad about the new version? Are there even more bugs than before?

 

My impression would be that as long as there are no or only a few new features, the number of bugs should be reduced from version to version. 

  • Like 1

Share this post


Link to post
Share on other sites

The IE fix was not included because they want a fix for IE only. Your solution works the same for all browsers. In my opinion, they should include you solution until they come up with something better...Anyway, I download and install your mod and it works fine :)

 

On the positive side, i see some of my issues solved in the forge, so we all should keep posting our issues there, and vote for the most important issues. Lets hope the next version will be a much improved one!

Share this post


Link to post
Share on other sites

The IE fix was not included because they want a fix for IE only. Your solution works the same for all browsers. In my opinion, they should include you solution until they come up with something better...Anyway, I download and install your mod and it works fine :)

 

On the positive side, i see some of my issues solved in the forge, so we all should keep posting our issues there, and vote for the most important issues. Lets hope the next version will be a much improved one!

 

It is only possible way to fix the IE issue. It maybe only posible to exted this mod to genereate 3 css files(2 splitet for IE, and one not splited for others), but in summary it will be less optimal solution

  • Like 1

Share this post


Link to post
Share on other sites

Hello, I was a "victim" of 0.12... I just updated with the 1-click update module and after completed update the Front Office works fine but the BackOffice is completely gone! when I try to enter BO after logging in just appears a blank page with only 1 line:

 

 
With debug mode on, when I check the source code on the browser, it shows 
 
<a href="http://www.prestashop.com/en/contact_us?utm_source=back-office&utm_medium=footer&utm_campaign=back-office-<br />
<b>Fatal error</b>: Call to undefined function mb_strtoupper() in <b>/home/tomatico/public_html/cache/smarty/compile/71/93/94/7193946579aa01860cf892eea7fc366c6786d0d0.file.footer.tpl.php</b> on line <b>67</b><br />

What can I do now to rollover to 1.6.0.11 or update to 1.6.0.13 ??? Unfortunately I only have the backup of the 1-click upgrade module    :( ... Please help!!!

Share this post


Link to post
Share on other sites

Remove physically the directory modules/dashboard this should allow you to enter your backoffice

Either your PHP is not having mb_strtoupper ( odd since most php install have it )

Some memcache or xcache or php-pfm or mod_php memory corruption.

 

You may try to afterward to re-install dashboard but I suspect it won't do good.

 

Be sure also that you have reset your cache (cache/class_index.php delete it, smarty/compile/* delete them)

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

one more thing, the Front Office is working at pieces... if I try to enter to home page, only got a blank page but if I go to a direct link of a product it works fine...

 

Doekia i'll try that and see what happens.... 

Share this post


Link to post
Share on other sites

.....

Be sure also that you have reset your cache (cache/class_index.php delete it, smarty/compile/* delete them)

 

Well that last advice works!   delete both things and voila! now the store works.... 

 

One last question, should I update to 1.6.0.14 ??? it is now safe to do it??

 

Thanks again Doekia! ^_^

Share this post


Link to post
Share on other sites

Well that last advice works!   delete both things and voila! now the store works.... 

 

One last question, should I update to 1.6.0.14 ??? it is now safe to do it??

 

Thanks again Doekia! ^_^

 

Doekia can not answer you, he has no right to post on this forum...

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More