Jump to content

[UPDATED] 1.5.4 FINAL Available [UPDATED]


Recommended Posts

03-26-2013 [uPDATED] PrestaShop v1.5.4 Final is available now.

 

Here is the 1.5.4 Final version changelog: http://www.prestasho...angelog/1.5.4.0

 

to download: http://www.prestashop.com/en/download

 

 

[uPDATED]

 

 

 

----------------------------------------------------------

[TESTING ONLY] This is for Testing purposes only, do NOT upgrade or use this RC for Production/Live Mode.

 

Dear PrestaShop Community,

 

We have listened to your suggestions and we have prepared the first package for 1.5.4 RC.

 

If you would like to Test out v1.5.4 RC, Please send me a PM with the subject "Community Tester 1.5.4 [Your Username]"

 

-I will then send you the file for testing and it can be discussed on this thread.

 

We appreciate all your support and feedback in testing this version. For a short time we will use your feedback and suggestions to make corrections on the release branch to Github:

 

https://github.com/P...commits/release

 

We have no problem making several RC packages if necessary. Let us work together to make this release the best ever.

 

B) B)

 

Regards,

 

Benjamin

 

[TESTING ONLY] This is for Testing purposes only, do NOT upgrade or use this RC for Production/Live Mode.

  • Like 1

Share this post


Link to post
Share on other sites

Installing it clean now to play with it for few days to see if any bugs will come out.

 

Just a question about it:

 

- is there work with PayPal module bug of "unsupported currency"

- any advice of GENUINLY WORKING manual upgrade - procedures and advices. We need something that will confidently work? File replace and SQL import on updates or what?

Share this post


Link to post
Share on other sites

2 tests for a manual upgrade 1.4.9. to 1.5.4 failed.

PHP Parse error:  syntax error, unexpected 'public' (T_PUBLIC) in /var/www/xxxxx/install/upgrade/php/update_customer_default_group.php on line 27

So far I had no probs with manual upgrade in test environment so I guess this is a critical issue?! Shall I post that on the bug tracker? Anyway, smart move to roll out rc's.. and yes, we are working on making it the best release ever ;)

All the best, trip

Share this post


Link to post
Share on other sites

Hi CD 2500, check if you can access the backend. Maybe you have the wrong template in your config?!.. Anyway it seems

public function update_customer_default_group()

in /install/upgrade/php/update_customer_default_group.php should be not public. I will test that..... fixed that but new errors occur.

 

So atm manual upgade is not working

Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'upgrade_cms_15' not found or invalid function name in /var/www/xxxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:03 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'remove_tab' not found or invalid function name in /var/www/xxxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:03 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'update_feature_detachable_cache' not found or invalid function name in /var/wwwxxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:08 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'set_product_suppliers' not found or invalid function name in /var/www/xxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:09 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'update_stock_mvt_reason' not found or invalid function name in /var/www/xxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:25 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'update_modules_multishop' not found or invalid function name in /var/www/xxxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:26 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'generate_root_category_for_multishop' not found or invalid function name in /var/www/xxxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:27 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'fix_unique_specific_price' not found or invalid function name in /var/www/xxx/install/upgrade/upgrade.php on line 328
[Tue Mar 05 23:17:27 2013] [error] [client 127.0.0.1] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'migrate_tabs_15' not found or invalid function name in /var/www/xxxxx/install/upgrade/upgrade.php on line 328

Is someone of PS team reading this or should I repost it on the bug tracker. All the best, trip

Edited by Trip (see edit history)

Share this post


Link to post
Share on other sites

When I try to import 1.5.3.1 language (Bulgarian) it gives me:

 

Validation failed for: mails/bg/lang.php

 

and doesn't import it. How can I edit the language file and delete the email translations for Bulgarian and then when I have it on 1.5.4 I'll translate them again.

Share this post


Link to post
Share on other sites

@ Trip - Not possible to access...

 

.ps_tab_module_preference' doesn't exist
  SELECT module
  FROM ps_tab_module_preference
  WHERE `id_tab` = 122
  AND `id_employee` = 0

at line 607 in file classes/db/Db.php
601.	WebserviceRequest::getInstance()->setError(500, '[sql Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
602.   }
603.   else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))
604.   {
605.	if ($sql)
606.	 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
607.	throw new PrestaShopDatabaseException($this->getMsgError());
608.   }
609.  }
610.
611.  /**
DbCore->displayError - [line 307 - classes/db/Db.php] - [1 Arguments]
DbCore->query - [line 482 - classes/db/Db.php] - [1 Arguments]
DbCore->executeS - [line 518 - classes/Tab.php] - [1 Arguments]
TabCore::getTabModulesList - [line 1463 - classes/controller/AdminController.php] - [1 Arguments]
AdminControllerCore->initTabModuleList - [line 1423 - classes/controller/AdminController.php] - [0 Argument]
AdminControllerCore->initContent - [line 104 - controllers/admin/AdminLoginController.php] - [0 Argument]
AdminLoginControllerCore->initContent - [line 167 - classes/controller/Controller.php] - [0 Argument]
ControllerCore->run - [line 348 - classes/Dispatcher.php] - [0 Argument]
DispatcherCore->dispatch - [line 50 - admin9520/index.php] - [0 Argument]

Share this post


Link to post
Share on other sites

No problem Gregory... I was really honest when I say smart move so this way we can at least iron out the biggest stoppers. Maybe you can check my next bug too? I changed

public function update_customer_default_group() to function update_customer_default_group() before I

started the upgrade.

All the best, Trip

Share this post


Link to post
Share on other sites

Is someone of PS team reading this or should I repost it on the bug tracker.

 

Hi again,

 

This is really weird, this is from 1.5.0.0. Are you sure you have all files from the zip in install/upgrade/php, specifically upgrade_cms_15.php for instance ?

Share this post


Link to post
Share on other sites

OK guys... This is getting annoying!

 

[b]PayPal response:[/b]
TIMESTAMP -> 2013-03-05T21:47:53Z
L_ERRORCODE0 -> 10605
L_SHORTMESSAGE0 -> Transaction refused because of an invalid argument. See additional error messages for details.
L_LONGMESSAGE0 -> Currency is not supported
L_SEVERITYCODE0 -> Error 

 

How to build online shop if I have to checkout only in USD or EURO but not in other 'unsupported' currencies?

 

 

Can't you make a function to convert the used currency to USD or EURO if it's unsupported by PayPal API and then send it to them? I have to disable PayPal for my main currency.

Edited by the.rampage.rado (see edit history)

Share this post


Link to post
Share on other sites

Have an issue with the installer, can not get past the License agreements page.

I check, I agree to the above terms and conditions., next button turns green, I click next and the check disappears and the page goes no where. (just remains on License page)

Share this post


Link to post
Share on other sites

Question to the developers -

 

1) I have a PS 1.4.5.1. which I upgraded to PS 1.4.10. Then after to 1.5.3.1. I noticed here that the folder orverrides contained only the subfolders, but no files in there. Is there a bug on installer ? I'm sure that the files where loaded to FTP before manual upgrade to 1.4.1.0. When shop was upgraded to 1.5.3.1. they where all deleted.

 

2) On the package of the 1.5.4 RC I have no override files (only folders), just the same pattern as for the failed upgrade tried under 1). BUT this shop I've tried to upgrade is not the same as I tried to upgrade to 1.5.4.RC. Is a complete other clone based on PS 1.5.2. which was working well, but with only one bug on the cart.

 

Are overides been stripping in the future ?

Share this post


Link to post
Share on other sites

Hi Todd, I did get the message and I will copy it here because it may be helpful to others.

 

"Have an issue with the installer, can not get past the License agreements page.

I check I agree to the above terms and conditions., next button turns green, I click next and the check disappears and the page goes no where. (just remains on License page)"

 

Was this on a local host?

 

 

Where should we submit bugs for 1.5.4.0?

 

Hi Dreamtheme, you can submit bugs on the forge in the same way. You can also post the bugs on this thread with a forge link as well. This will help facilitate possible resolutions.

Share this post


Link to post
Share on other sites

No its in the same location I had my 1.5.3 test site, I deleted the 1.5.3 test and created a new DB for the 1.5.4 test but as I posted can't get paste the license page.

It is on the same host Ipage that I have three other working sites.

Share this post


Link to post
Share on other sites

Issue Solved!

 

Turns out this was the same issue as others had in the paste with Prestashop installs, you need to edit the PHP.ini file and insert a sessions.save_path.

I have a sessions.save_path in php 5.2 but have upgraded to 5.3 and did not change the sessions path, seems this is required for installing Prestashop.

I went back to 5.2 and the install went right through, the sessions.save.path should be similar to below or call your proivider and have them change it for you if you are unsure.

 

(this is for Ipage others may vary)

session.save_path = /home/users/web/b1447/ipg.shepherd/cgi-bin/tmp

  • Like 2

Share this post


Link to post
Share on other sites

1. This bug http://forge.prestas...owse/PSCFV-7861 is old (from the start of 1.5.x) and it is still not fixed in 1.5.4, see also this threat http://www.prestasho...-prestashop-15/

 

2. Theme installer module still says that newest version is 2.2, but install 2.1, and update button appear, no matter how much you press it, it is not updating it.

Edited by Dreamtheme (see edit history)

Share this post


Link to post
Share on other sites

I don't think so. We had to take the link down for security purposes. Last thing we want is a link going around the internet with people updating live stores. cd2500 , I can Email you the file to the email you used at forum registration.

 

Yes please. Only replace the files, or should I make a new clone from live shop ? By the way I NEVER TEST ON LIVE-SHOP, I have several clones with different versions. I don't touch my shops if a testrun is not positive, so I reduce my risks to nearly 0% ;-)

Share this post


Link to post
Share on other sites

Great! The 1.5.4 version seems to be much better then the current version 1.5.3 i had an problem with empty cart in some browsers, after installing and testing 1.5.4 it seems work fine.

 

Live edit works for me as well.

I tested on different computers and this is my reaction on some computers the customer don't recieve mails.

 

Also the payment module for (ideal - dutch payments) gives an error?? So it dont work i can make a short video to show this issue...

 

1.5.4 loads many times faster and no issues with importing images like in. 1.5.3 version. So i go further with checking this version..

 

Regards Jack

 

Share this post


Link to post
Share on other sites

Hi Conny, yes I have sent you the file to the E-mail that we usually use to correspond. Thank you for all the reports!

 

Thank you. Just override the old files from first package I presume ?

 

**************

Edit: question answered by my self. No, I can trash the first try and must begin with a new clone. OK I will give a try in the late evening.

Share this post


Link to post
Share on other sites

@Benjamin Utterback - is there gonna be sollution for the "problem" I mentioned above with PayPal?

 

Hi Rampage, PayPal, as any other partner module, is updated through the module webservice. There isn't any link between the release and the module update (the module is not even in the ZIP).

Share this post


Link to post
Share on other sites

I would need to get more information about this. I'm not sure but take a look at this post, http://www.prestashop.com/forums/topic/189293-currency-is-not-supported-for-paypal-312-prestashop-15017/page__st__20

 

This seems to have fixed the problem for some. However, PayPal is not packaged into this release so if you could please refrain from further commenting about PayPal.

 

That said, it is obvious that it really is concerning and I will do my best to help solve the issue. I just really want to keep this thread from being off topic.

Share this post


Link to post
Share on other sites

1. This bug http://forge.prestas...owse/PSCFV-7861 is old (from the start of 1.5.x) and it is still not fixed in 1.5.4, see also this threat http://www.prestasho...-prestashop-15/

 

Hi Dreamtheme, the information I received about this was that we did remove the empty override files, but we kept the feature available. You can still override whatever you want, but PrestaShop will run faster without those empty files which we removed.

Share this post


Link to post
Share on other sites

Testing 1.5.4

 

First issue - Live edit does not function, can not move modules.

Second Issue - this one is not a real issue just strange, when clicking on add new product this message is displayed.

The product name is empty. You will at least need to enter a name for the default language before you can save the product.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Dreamtheme, the information I received about this was that we did remove the empty override files, but we kept the feature available. You can still override whatever you want, but PrestaShop will run faster without those empty files which we removed.

 

Benjamin,

What empty files do you refer to? as far as i can see there is no empty files. This bad writing of the code is not changed for the last 4 months in the github.

 

"$this->display_column_left = false;" this line should be set to "true" for all payment modules by default in PS, (best to remove it at all), and left column hide to be controlled only by CSS like in 1.4.x and everything else. Layout should not be controlled by hard-coded code in the core modules. You can see that 100% of all 1.5.x themes on the market, has this problem.

 

So PS need to change this or should provide us a way to override it WITHOUT changing core files, so override can be included in theme packages and be in effect with theme installer.

Share this post


Link to post
Share on other sites

Hi Dreamtheme, the information I received about this was that we did remove the empty override files, but we kept the feature available. You can still override whatever you want, but PrestaShop will run faster without those empty files which we removed.

Benjamin - I assume you mean the override files coded like this

<?php
class XYZController extends XYZControllerCore
{
}

 

Does that mean if we delete those files from existing 1.5.3.1 installations, Prestashop will run faster?

Share this post


Link to post
Share on other sites

How long will we wait for linking payment with shipping as standard? This functionality is important for sellers.

 

Why being on GitHub you take just a small patch, not a big, robust changes such as the implementation of rich-snippets and html5 template?

 

You want to support the old template? This is ridiculous. Serious developers will not send you changes on GitHub if you have the attitude that someone will do something good, and you're going to have it in the ass.

 

Currently GitHub is a place where you corrected the errors are ridiculous as those in the mechanism of CMS, a major, major changes are completely rejected by you.

 

Example of bankwire module is another thing completely ignored by you. Another ridiculous approach to disable the left column in the module, probably time to think about that programmers know that creating such software tends to completely separate the view of other things!

Edited by Krystian Podemski (see edit history)

Share this post


Link to post
Share on other sites

Testing 1.5.4 - Fresh Install

 

First issue - Live edit does not function, can not move modules.

Second Issue - this one is not a real issue just strange, when clicking on add new product this message is displayed.

The product name is empty. You will at least need to enter a name for the default language before you can save the product.

 

1.5.4 test - Upgrade 1.4.7 used local archive under more options (expert mode)

same result after upgrading to 1.4.10.0 using same method

 

Can not upgrade from 1.4.7 to 1.5.4 receive error below, tried twice.

 

[Ajax / Server Error] textStatus: "error" errorThrown:"Internal Server Error" jqXHR: ""

Edited by tdr170 (see edit history)

Share this post


Link to post
Share on other sites

I am not sure if those are the files that have been removed. That was the information I received, I would have to gather more info and let you guys know the details later.

 

those files are actually removed, comment from git : "Delete empty override files - use IO/s for nothing [rGaillard]"

 

So if my module override certain class, e.g, AuthController.php the file will be generated automatically.

Share this post


Link to post
Share on other sites

Testing PS 1.4.10 running shop (clone) -> manual upgrade to 1.5.4.RC - manual install=no errors, but ends into a blanc page, instead to show XML-file.

 

Log-in BO possible.

 

********

Front-office available (but wrong template...). Unable to switch templates. After manual upgrade from PS 1.4.5.1 to 1.4.10 I deleted all modules I know that there are not working with PS 1.5. I also deactivated(deleted) my own Template used with PS 1.4.5.1 and set the standard "Prestashop". The shop was running well under PS 1.4.10 with the standard theme. Now after manual upgrade to 1.5.4.0RC my old theme is showing, instead of "prestashop" ?! but this old theme isn't available in the theme list (it was deleted and set to another before upgrade). On BO I have prestashop set, I changed now to "default", cleared all cache (browser and /cache/smarty/compile and /cache/smarty/cache and /themes/prestashop/cache), cleared all cookies and old theme which was deleted before upgrade is still showing. Also all links are redirected to my "real" shop with ending on 404-Site although this is impossible, because the shop under 1.4.10 was working well with the new shoplink (clone).

EDIT after 10 minutes:

I don't know if it is a cache issue due to the high memory_limit or while I've activated debug-modus - Now front-office is showing with theme "default". I've never had such problems on an upgrade and also the switch of a theme takes immediate effect...

 

Front-office very, very slow.... WORST-CASE ever = 18-20 seconds per click on a product.

Category pictures all blurred...

Product pictures on modules all missing..

 

Cannot add products to cart =

Impossible to add the product to the cart.
textStatus: 'error'
errorThrown: 'Internal Server Error'
responseText:

 

********

 

Tab "modules" = blanc page, so I'm unable to select any module. The new feature on "Theme" - "modul list" loads and loads and loads (never ending request)

(After debug-modus activated) :

[PrestaShopDatabaseException]
Table 'clone15.ps_tab_module_preference' doesn't exist
SELECT * FROM `ps_tab_module_preference` WHERE `id_employee` = 1

at line 607 in file classes/db/Db.php
601.	WebserviceRequest::getInstance()->setError(500, '[sql Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
602.   }
603.   else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))
604.   {
605.	if ($sql)
606.	 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
607.	throw new PrestaShopDatabaseException($this->getMsgError());
608.   }
609.  }
610.
611.  /**
DbCore->displayError - [line 307 - classes/db/Db.php] - [1 Arguments]
DbCore->query - [line 482 - classes/db/Db.php] - [1 Arguments]
DbCore->executeS - [line 974 - controllers/admin/AdminModulesController.php] - [1 Arguments]
AdminModulesControllerCore->initContent - [line 167 - classes/controller/Controller.php] - [0 Argument]
ControllerCore->run - [line 348 - classes/Dispatcher.php] - [0 Argument]
DispatcherCore->dispatch - [line 50 - cdadmin/index.php] - [0 Argument]

 

 

More testing in the late evening...

 

 

Hi Dreamtheme, the information I received about this was that we did remove the empty override files, but we kept the feature available. You can still override whatever you want, but PrestaShop will run faster without those empty files which we removed.

 

Exact here I'm having a problem on the last upgrades I've tried with my cloned onlineshop. For the last upgrade done with 1-click-upgrader there were all override files missing, and the two added manually with extend core do not take any effect. That's why I was explicit asking for this...

Share this post


Link to post
Share on other sites

At cd2500. Which version did you test? Ben send me 2 RC's which I think were the same. Did you get the usual XML output after the manual upgrade that everythink worked "ok" or not? If there just was a blank page the upgrade was not successful and therefore you get these errors missing tabs blah blah .... the last change in

install-dev / upgrade / php / update_customer_default_group.php

https://github.com/PrestaShop/PrestaShop/commits/release/install-dev/upgrade/php/update_customer_default_group.php was yesterday. You have to look if you have the up2date update_customer_default_group.php or your manual upgrades will fail.

All the best, trip

Share this post


Link to post
Share on other sites

@ Trip - The one Benjamin sent me by mail on 06th March- Install no problem, but than the ones told on post #52. I'm now testing more options..

 

For the github-Link there is no fix related to my errors ?!

As I said; no, XML-Site was not showing, just a blank site, that's why I posted it here. I'm not missing any tab. I cannot access to the tab modules, which is a blank page.

 

In this package is also no folder install-dev/ available. So, sorry, I don't know what are you talking about.

Share this post


Link to post
Share on other sites

Sorry, but I cannot procceed with tests. After I activated debug-modus I cannot access anymore to the back-office. The site is now instead to show error message, completly blanc (FO + BO). I've cleared all cache possibilities. By each try to access to the page log-alert is written. I'm now going to disable this feature direct into DB, because it is spamming my mail-account.

Share this post


Link to post
Share on other sites

Hi cd2500,

Gregory fixed some errors at least in update_customer_default_group.php .Before that I could not upgrade manually. So look if the file looks like here https://github.com/PrestaShop/PrestaShop/blob/d4bf96b387691449343dcd565c5795eb86135e2e/install-dev/upgrade/php/update_customer_default_group.php or overwrite the content with the code on gitHub. That is how I could proceed with the manual upgrade. Only error was thrown in my case I reported to the bug tracker already http://forge.prestashop.com/browse/PSCFV-8167

I hope that helps. At least I could do the manual upgrade with this procedure.

Best regrads, trip

Share this post


Link to post
Share on other sites

I also was able to upgrade manually without this ?! but now I'm having other troubles... And no, I will not repeat the install/upgrade process again. I have to clone shop, upgrade manually to 1.4.10 and than again upgrade manually to 1.5.4. This take a half day preparation...

Share this post


Link to post
Share on other sites

Tested 1.5.4, most of the bugs on 1.5.3 seems to be solved. Installation was perfect.

 

I got one problem right now, I do not know if it is an issue of the new version....

 

After extensively testing CSV import with good result (much better, solved category ISSUE ecc..), I've tried to change the category association manually in BO, but unfortunately after clicking on SAVE buttons, I got a redirection out on FO (home page), and no save is made...

I'm sorry for my terrible english, I hope you understand what I mean

Anyone has the same problem?

 

Thanks!

Francesco

Share this post


Link to post
Share on other sites

@cd2500 Maybe we misunderstood ... my testsetup is copy(clone)old shop db via phpmyadmin 1 minute. Extract prestashop and copy settings.inc.php from old shop to config folder. Change db settings in settings.inc.php and start the manual upgrade. As I am doing this on my local server the whole procedure takes about 10 minutes. When I read betweeen the lines you are doing it on your live server and this can be time extensive. For a quick check my approach is relatively fast. When I am happy with the result I can copy images/modules etc to the test installation to make further tests. Also I have access to error.log etc.pp that help me find errors.

All the best, trip

Share this post


Link to post
Share on other sites

Hi, yes it is a misunderstood. My clone have 20.000 products, so I need also to export the pictures to my local machine and than upload them again to the clone on FTP to have an exact copy. The download and upload takes a half day...

 

The software does not take more than 3 minutes...

 

I'm no letting parked in a folder somewhere on FTP the pictures to can use them.

Share this post


Link to post
Share on other sites

Testing 1.5.4 - Fresh Install

 

First issue - Live edit does not function, can not move modules.

Second Issue - this one is not a real issue just strange, when clicking on add new product this message is displayed.

The product name is empty. You will at least need to enter a name for the default language before you can save the product.

 

1.5.4 test - Upgrade 1.4.7 used local archive under more options (expert mode)

same result after upgrading to 1.4.10.0 using same method

 

Can not upgrade from 1.4.7 to 1.5.4 receive error below, tried twice.

 

[Ajax / Server Error] textStatus: "error" errorThrown:"Internal Server Error" jqXHR: ""

 

 

Has anyone successfully upgraded from 1.4.9.or 10, has any one else tried the local archive under more options rather then updating manually.

Share this post


Link to post
Share on other sites

PROBLEM 1:

I've switched in debug mode, but everytime I try to change a single things of a product, and then click on save the changes i got the message:

 

[Debug] This page has moved

Please use the following URL instead....

 

Have you got the same problem? Could it be a configuration problem? I've tried a new installation but the problem seems to be the same.

 

Any idea?

Thanks

Share this post


Link to post
Share on other sites

Test on fresh 1.5.4RC with new products

VAT 21%

 

product 1 - price with VAT - 0.06Ls

product 2 - price with VAT - 0.07ls

product 3 - price with VAT - 2.70ls

 

 

 

Same bug as it was in 1.5.3.1

 

-_-

 

not going to test further before this isn't solved.

post-293204-0-20706000-1363108642_thumb.png

post-293204-0-27011700-1363108655_thumb.png

Share this post


Link to post
Share on other sites

Test on fresh 1.5.4RC with new products

VAT 21%

 

product 1 - price with VAT - 0.06Ls

product 2 - price with VAT - 0.07ls

product 3 - price with VAT - 2.70ls

 

 

 

Same bug as it was in 1.5.3.1

 

-_-

 

not going to test further before this isn't solved.

 

 

 

Yes, i have same problem. VAT is incorrect like in 1.5.3.1

Share this post


Link to post
Share on other sites

Another bug in 1.5.4

 

If you have cart block enabled in both places columns and header drop down, if you add item to the cart, the cart block in columns don't update the name until refresh.

 

the problem is in ajax-cart.js, this is old bug from 1.5.2, 1.5.3.1

Edited by Dreamtheme (see edit history)

Share this post


Link to post
Share on other sites

Hopefully when it fixed?

 

I'd also say, the latter, the better ;)

 

Was the "2 discounts get the same amount, even if different" bug fixed? haven't had the chance to test this. Basically, in 1.5.3.1 if I add 2 different discounts to the cart, they get the same amount of the first I added

Share this post


Link to post
Share on other sites

Hello all, I will be sending each of you who requested 1.5.4 RC a new package. We still do not want to distribute the file or link publicly .

 

 

UPDATED: Okay, I went through the E-mail list and sent the file through E-mail. Make sure you use the correct one, they look very similar (sorry). the zip file is named " prestashop_1.5.4.0(1).zip "

If by any chance I missed you, feel free to let me know and I apologize in advance.

Share this post


Link to post
Share on other sites

i got two emails from you with attached file named "prestashop_1.5.4.0 (1).zip"

 

I believe, we need to use one in latest email? :D

 

So, no big improvements on tax calculation, if price for customer group is with VAT

 

FO price excl vat still have problems as well

post-293204-0-72928300-1363273876_thumb.png

post-293204-0-99125800-1363273885_thumb.png

post-293204-0-52135800-1363273894_thumb.png

post-293204-0-07373700-1363274356_thumb.png

post-293204-0-36171700-1363277820_thumb.png

Edited by Benjamin Utterback (see edit history)

Share this post


Link to post
Share on other sites

There's some bug with 1.5.4 RC version regarding translations:

 

I noticed there's change in the installed module translations page - now you can only translate FO visible fields and obviously everything else is going in BO translation but I removed every string there (I want my BO in English no matter what) and there's few pieces of code (like for example live edit) where the strings are still applied (those moved strings are removed from Installed modules translations but are missing now from BO translations page)

 

I even tried removing Bulgarian language, then making it again, not importing it from your server but uploading it myself from package I made earlier and happens exactly the same thing.

 

Latest 1.5.4. RC "2" from today, clearly installed and no mods done.

 

Screens:

post-358365-0-87440700-1363286362_thumb.jpg

post-358365-0-67471000-1363286363_thumb.jpg

Share this post


Link to post
Share on other sites

Fresh Install:

No change here either with newest 1.5.4.0 (1), live edit still does not function and strange message still apears on product entry page.

The product name is empty. You will at least need to enter a name for the default language before you can save the product.

 

 

Upgrade 1.4.10 - 1.5.4.0.(1):

With the new file the upgrade does not fail and does a full upgrade.

However the second I tried to enable force compile the page failed to HTTP 500 error and the test site was lost.

Going to try uploading the some files to see if I can gain access again, I had this error one time before and after loading Admin, Classes and Controllers I was able to access the BO but anytime I tried to enable force compile the same issue appeared.

 

This only happens on the upgrade I also have a fresh install and that is fine.

 

 

 

If I try to enter the BO through the saved link I get this message.

 

 

Share this post


Link to post
Share on other sites