Jump to content
DevelHope

Module "Product Question"

Recommended Posts

Hello everyone,

 

where can I find a PRODUCT QUESTION module that works with version 1.4.8.2?

 

A form with a button from within the product send me an email with a link to the product, the customer's email and text application.

 

And if I could edit that module by adding other fields (eg telephone), would be the top.

 

I lost a lot of time to download and try, if anyone can give me a straight thank him right now.

Share this post


Link to post
Share on other sites

Thank you Mike.

 

I had already seen these moduli, but it takes me is different.

 

I need a module, to be exact, QUESTION ABOUT PRODUCT, or a form where the customer from within the product, pressing the "Request Information" sends me a mail with the link to the product and customer demand.

 

I found some modules, free, originated by the modification of the module "send to friend",but on this latest release does not work for me.

 

Can you help?

 

Thank you.

Luigi

Share this post


Link to post
Share on other sites

Are you sure that a 'development' forum is the right place to ask for a free already made module for which you have all technical informations to do it yourself in several working modules really close to your request? <_<

Share this post


Link to post
Share on other sites

Hi Luigi,

Those modules do appear to accomplish what you are looking for, although they may have slightly different wording that the user would see. However, you can very easily change this once the module is installed through the Back Office under Tools > Translations > Translation of Installed Modules.

 

If this is not the case, can you please be a little more clear on exactly what you're looking to do versus what these modules offer?

 

-Mike

Share this post


Link to post
Share on other sites

Ok Mike,

I try.

 

The module in question should do so:

 

1) the customer sees a product

2) the client wants to ask a question about this specific product and select a key product in the "request information"

3) opens a form where you enter your details (name, email, message) and press send

4) I, the site manager, an email arrives with the customer data message and an indication of the product subject of the inquiry

 

On the net I tried these modules and I am often called QUESTION ABOUT PRODUCT.

 

Thanks to all

Share this post


Link to post
Share on other sites

Hi DevelHope,

Those two modules I posted above accomplish exactly that, but with the added benefit of adding them to the Product listing as Frequently Asked Questions, hopefully limiting the number of duplicate messages you would receive asking the same question.

 

Unfortunately, I am not currently aware of a module that will do the same thing without adding it to the FAQs, but you may be able to speak with the developers of these modules to find out what would need to be done to adapt their work for that purpose.

 

-Mike

Share this post


Link to post
Share on other sites

Hello everyone,

 

where can I find a PRODUCT QUESTION module that works with version 1.4.8.2?

 

A form with a button from within the product send me an email with a link to the product, the customer's email and text application.

 

And if I could edit that module by adding other fields (eg telephone), would be the top.

 

I lost a lot of time to download and try, if anyone can give me a straight thank him right now.

 

Have you find out, how to do this product request form? I want to have the same form.

  • Like 1

Share this post


Link to post
Share on other sites

Hello everyone,

 

where can I find a PRODUCT QUESTION module that works with version 1.4.8.2?

 

A form with a button from within the product send me an email with a link to the product, the customer's email and text application.

 

And if I could edit that module by adding other fields (eg telephone), would be the top.

 

I lost a lot of time to download and try, if anyone can give me a straight thank him right now.

 

Hi.

 

Have you solved your problem?

I need something just like you need.

 

Can you help me with this?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi!

 

If i understood you I have this module. I got it from PrestashopBR forum.

 

Have a try.

 

I will try that when I come home.

 

Thank you.

Share this post


Link to post
Share on other sites

It's working

 

Take a look at http://dieletronicos.com.br

 

Thank you

 

Nice! I saw you're from Brazil.. me too!

 

ps: I didnt saw this module working in your store

 

Traduzindo: Eu vi que você é do Brasil. Também sou.

 

ps: Não vi o módulo funcionando no seu site.

Share this post


Link to post
Share on other sites

Nice! I saw you're from Brazil.. me too!

 

ps: I didnt saw this module working in your store

 

Traduzindo: Eu vi que você é do Brasil. Também sou.

 

ps: Não vi o módulo funcionando no seu site.

 

Just click in the "Comprar" link. (you can finish the order if you want... :D)

I've adapted it to work as I need.

 

Try it and than you will figure out how it's working.

 

Thanks a lot for your help.

 

PS: you are right... I'm from Brazil

Edited by douglascrp (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

any chance it works with Prestashop 1.5 ?

 

I try to install it using the Back Office but I don't find it in the module list, and I don't see it in the front office...

 

Any advice is welcome,

 

Thanks

Edited by Acidy (see edit history)

Share this post


Link to post
Share on other sites

Sorry to insist, but you've personally tested in version 1.5.X ?

 

I've tested within my 1.5 version and it works. I had some issues within the sending since I had to create an it folder and correct the php :)

Share this post


Link to post
Share on other sites

Sorry to insist, but you've personally tested in version 1.5.X ?

 

Hi Totti,

 

It works on my prestashop 1.5.2, I tested as customer and I received the product question.

I had nothing to fix.

 

Regards

Share this post


Link to post
Share on other sites

Hi!

 

If i understood you I have this module. I got it from PrestashopBR forum.

 

Have a try.

 

productquestion.zip 11.68K 97 downloads

This one works on 1.5 with the exception of the redirect after the question is submitted. I get a 404 not found. Problem is I'm in a shared space with no access to error/access logs to find out what's up. Anyone have any clues and/or experienced the same issue?

Edited by DBMAN (see edit history)

Share this post


Link to post
Share on other sites

Hello,

the module, on my web site http://www.spazioespositivo.it doesen't work.

 

The screen it's correct but after i send the messa, exit the message

"C'è 1 errore : An error occurred during the process."

 

 

?

Where is the problem?

 

Thx to All

 

I saw that the module works in your site !

How fix error ?

Share this post


Link to post
Share on other sites

Fix error - An error occurred during the process.Create folder in folder (mail) with language you use.

 

But now "This one works on 1.5 with the exception of the redirect after the question is submitted. I get a 404 not found."

Please help !

Share this post


Link to post
Share on other sites

Hi, I'm from Brazil.

 

I installed productquestion module in my prestashop v. 1.5.2, but i don't see any button on my product to send a question.

 

How can i do to it works ?

 

Thanks,

Share this post


Link to post
Share on other sites

Hi guys,

 

fantastic module. works great on 1.5.3.1 with no problems. view working here many thanks guys.

 

Cheers

 

Dean0

 

 

<p>

<label for="phone">{l s='Telephone' mod='productquestion'}:</label>

<input type="text" id="phone" name="phone" style="width: 215px;" value="{if isset($smarty.post.phone)}{$smarty.post.phone|escape:'htmlall'|stripslashes}{/if}" />

</p>

 

P.S Have tried to place phone number field in the form, have placed on the form but cant seem to get the number to show in the received email. any help would be most appreciated. :)

Edited by jonah2494 (see edit history)

Share this post


Link to post
Share on other sites

Hi All

 

Here is the module for product Enquiry / Product Question

 

working well with the Prestashop version 1.5.4.0 tested This modules ads an link similar to send to friend module on click a Enquiry form will open when user fills that form and submit an email goes to

Email specified from back end of this module if email not specified Email will goes to default shop email id

post-89073-0-58760300-1365773044_thumb.jpg

productenquiry.zip

  • Like 9

Share this post


Link to post
Share on other sites

Hi All

 

Here is the module for product Enquiry / Product Question

 

working well with the Prestashop version 1.5.4.0 tested This modules ads an link similar to send to friend module on click a Enquiry form will open when user fills that form and submit an email goes to

Email specified from back end of this module if email not specified Email will goes to default shop email id

 

Hi Vivek!

 

I`ve installed your module, but no mail is send. Im using prestashop 1.5.4.

 

Regards

Share this post


Link to post
Share on other sites

Hi, install the module but does nothing, or prune Sponer the data but not the mails arrive, will that my language is Spanish? or not has nothing to do?

Share this post


Link to post
Share on other sites

Hi, install the module but does nothing, or prune Sponer the data but not the mails arrive, will that my language is Spanish? or not has nothing to do?

 

Hola Polcap.

 

Me paso lo mismo, lo instale aparece el formulario bien, pero no llega nada..... Los mails del hosting salen bien.

 

Saludos.

 

Sergio

 

Hi Polcap.

 

Same for me. I've installed, form appears, but nothing arrives..... Hosting mails works correctly.

 

Regards.

 

Sergio

Edited by 53rg10 (see edit history)

Share this post


Link to post
Share on other sites

Hi, install the module but does nothing, or prune Sponer the data but not the mails arrive, will that my language is Spanish? or not has nothing to do?

 

I confirm.

Share this post


Link to post
Share on other sites

I have also installed and I have the same problem, everything works fine, but does not send emails. I checked the other mails sent in the shop and work.

 

Any idea?

 

The module is great, but if you do not get the emails ...

Share this post


Link to post
Share on other sites

I have also installed and I have the same problem, everything works fine, but does not send emails. I checked the other mails sent in the shop and work.

 

Any idea?

 

The module is great, but if you do not get the emails ...

 

prestashop version 1.5.3.1

 

the config:

config.png

Share this post


Link to post
Share on other sites

Fix error - An error occurred during the process.Create folder in folder (mail) with language you use.

 

But now "This one works on 1.5 with the exception of the redirect after the question is submitted. I get a 404 not found."

Please help !

Change in productquestion.php

 

/* Email sending */

if (!Mail::Send((int)($cookie->id_lang), 'send_question', Mail::l('A customer').' '.Mail::l('send question about').' '.$product->name, $templateVars, Configuration::get('PS_SHOP_EMAIL'), NULL, NULL, NULL, NULL, NULL, dirname(__FILE__).'/mails/'))

$error = $this->l('An error occurred during the process.');

else

Tools::redirect($productLink);

That will redirect the sender to the product submited. <_<

Regards,

  • Like 1

Share this post


Link to post
Share on other sites

Hi All I have checked many times this module even I have checked it for Prestashop version 1.5.2.0 to 1.5.4.0

its working properly and and emails are coming please ad email address at module configure section where you want to send email

 

Please also check your shop email system is working properly by going to admin-> Advance parameter -> email and check by sending test email to same email id where product enquiry emails are going

 

 

One Issue can be arise different language than English If you guys are using different language other than English please make folder of you language in module->productenquiry->mail-> [your language folder name]

for example for french make folder name fr

 

and copy en folder content into them.

 

 

if you are still facing an issue you. I can check it for you if you share admin and ftp details.

Edited by vivek tripathi (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Please also check your shop email system is working properly by going to admin-> Advance parameter -> email and check by sending test email to same email id where product enquiry emails are going

 

I tested and its OK

 

One Issue can be arise different language than English If you guys are using different language other than English please make folder of you language in module->productenquiry->mail-> [your language folder name]

for example for french make folder name fr

 

and copy en folder content into them.

 

I use french language, I made as you said, it works ! Perfect !

 

Thank you very much !

Edited by Fehmi135 (see edit history)

Share this post


Link to post
Share on other sites

Thank you very much

 

I made ​​the switch and it works perfect

 

Now the store I have not published

 

When it is active, I put it in the forum

 

 

producto-enquiry-1.png

producto-enquiry-2.png

 

with your permission, I attach the module with reference to author prestashop forum in Spanish

 

http://www.prestashop.com/forums/topic/245119-modulo-consulta-sobre-producto/page__p__1214520?do=findComment&comment=1214520

Edited by Espigol (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Great Vivek!

 

I've created a folder name es/ (my site is in Spanish) and that fixed the error.

 

Now working perfectly. :)

 

Thank you!!

Share this post


Link to post
Share on other sites

I installed the module (productenquiry) in prestashop 1.5.2 but the module does not appear in the backoffice, is there any solution?

 

thanks!!

Share this post


Link to post
Share on other sites

It works great

 

How I can add a field to the form? eg "Your company" or other? thanks!!!

Share this post


Link to post
Share on other sites

The problem sending the email still has not been resolved ?

Share this post


Link to post
Share on other sites

Anybody knows how to change the font size, color and location of the text displayed at the product page?

if it is possible I would like to change only it without changing parameters of print and view full size. Here is an example: http://bartek.navv.nazwa.pl/index.php?id_product=4&controller=product&id_lang=1

 

Thanks in advance.

Edited by polemnik (see edit history)

Share this post


Link to post
Share on other sites

Hello All ... and thanks for this module....

I translate the module from Backoffice no problem...

 

email was not working and yes... i Copied the folder /modules/productenquiry/mails/en into a new folder /modules/productenquiry/mails/es (es for Spanish) and yes its working now. remember to do this copy files to get the send mail OK

 

.....

 

But i need some help now... i was trying to translate the email that its send but when i make changes succefully in the backoffice changes dont remains and keep like the original email... How can i make this changes works please...

 

THANKS agains for this module

Greetings to all.

http://americas.com.ve

Edited by erikmlb (see edit history)

Share this post


Link to post
Share on other sites
Hi All Here is the module for product Enquiry / Product Question working well with the Prestashop version 1.5.4.0 tested This modules ads an link similar to send to friend module on click a Enquiry form will open when user fills that form and submit an email goes to Email specified from back end of this module if email not specified Email will goes to default shop email id

 

Thanks for your efforts

Can you make this model work on prestashop 1.4

Thanks again

Share this post


Link to post
Share on other sites

I am hoping to use this module. I have an English website. I have installed it and it does send the emails to the configured email address.

 

My issue is, that the emails do not contain any of the 3 user fields that were entered. Name, email, and question/comment are black on my received email

 

So I have no way to know who entered the request or what his question was. Product info and link do show up.

Share this post


Link to post
Share on other sites

I am VERY sorry. The module does work correctly. The fields are way on the left of the email beyond my banner. Module works well.

 

Only question would be, can we copy the customer with an email similar to the one the admin gets?

Share this post


Link to post
Share on other sites

Hi All

 

Here is the module for product Enquiry / Product Question

 

working well with the Prestashop version 1.5.4.0 tested This modules ads an link similar to send to friend module on click a Enquiry form will open when user fills that form and submit an email goes to

Email specified from back end of this module if email not specified Email will goes to default shop email id

 

Hi

can anyone help me get this working...I am using english language but United Kindom...I have copied the content from the folder into a new folder called gb. Still can get this to sent emails...this would be a fantastic module.

 

I would like to change the wording slightly and just leave it as product enquiry and have it aligned with the other text, as you will see from my link that it does not............

 

http://176.32.230.27/andersonkilts.co.uk/semi-dress-sporrans/thistle-semi-dress-sporran.html

 

Any help will be really appreciated as this has got me stumped!!!!

 

Thanks

Edited by Barry1877 (see edit history)

Share this post


Link to post
Share on other sites

No.....no emails get sent....I have tried sending it to various email addresses and checked all spam folders.

 

The email does not send, that is why I am asking for help....please!

Share this post


Link to post
Share on other sites

Yo tampoco puedo enviar los mensajes, trabajo con prestashop 1.5.4, desde ya muchas gracias si logran solucionarlo.

-------------------

I I can not send messages, work with prestashop 1.5.4, of course thank you very much if they can fix it.

Edited by ediaime (see edit history)

Share this post


Link to post
Share on other sites

Hello, see it that still are some problems regarding that product question module, with your permission i attached the autor productenquiry file , but with some changes that i made to work on ps1.5.4.1, for me the module it´s working fine in english & spanish, try it.

Regards,

-----------------------------------------------------------------------------------------------------------------------------

Hola, viendo que todavia hay problemas con el modulo productquestion que no se pueden enviar los correos en español, con vuestro permiso he adjuntado el archivo del autor con el modulo productenquiry con algunas modificaciones que ya permite enviar el correo en ingles & español tambien, para mi el modulo funciona perfectamente en español y en ingles, probarlo.

Un saludo

productenquiry.zip

Edited by corsor (see edit history)
  • Like 4

Share this post


Link to post
Share on other sites

Hello, see it that still are some problems regarding that product question module, with your permission i attached the autor productenquiry file , but with some changes that i made to work on ps1.5.4.1, for me the module it´s working fine in english & spanish, try it.

Regards,

-----------------------------------------------------------------------------------------------------------------------------

Hola, viendo que todavia hay problemas con el modulo productquestion que no se pueden enviar los correos en español, con vuestro permiso he adjuntado el archivo del autor con el modulo productenquiry con algunas modificaciones que ya permite enviar el correo en ingles & español tambien, para mi el modulo funciona perfectamente en español y en ingles, probarlo.

Un saludo

 

Guys many thanks for your input and assistance, this still does not work for me!! I am on prestashop 1.5.4.1. The send to a friend module works fine and sends emails with no problems.

 

is anyone able to help me figure this out???

 

Thank you

 

Chicos muchas gracias por sus comentarios y ayuda, esto todavía no funciona para mí! Estoy en Prestashop 1.5.4.1. El enviar a un amigo módulo funciona bien y envía mensajes de correo electrónico sin problemas.

 

es alguien capaz de ayudar a resolver esto??

 

Gracias

  • Like 1

Share this post


Link to post
Share on other sites

Hola a todos, uso la version 1.5.4.1 y envia y funciona, pero no salen las traducciones, solo sale en ingles.

Alguien sabe como hacer que salgan cada uno en su idioma?

 

Mil gracias y gracias al creador del modulo

 

Hi all, I use the 1.5.4.1 version and send and it works, but do not leave the translations, only comes in English.

Anyone know how to make out everyone in your language?

 

Thank you and thanks to the creator of the module

 

Raul

  • Like 1

Share this post


Link to post
Share on other sites

Hi, the module is great, but need some corrects, for example in file productenquire-extra.tpl I added email validation, so the <script> looks:

 

<script text="javascript">
{literal}
$('document').ready(function(){
$('#enquire_product_button').fancybox({
'hideOnContentClick': false
});

$('#enquireProduct').click(function(){
var datas ='';
var name=$('#your_name').val();
var email=$('#your_email').val();

function validateEmail(email) { 
var re = /^(([^<>()[\]\\.,;:\s@\"]+(\.[^<>()[\]\\.,;:\s@\"]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
return re.test(email);
}  

if(name=='')datas +='Please write your name';
if(email=='' || validateEmail(email)==false)datas +='<br/>Please write your correct email';
               //console.log(datas);
if (datas == '')
{
$.ajax({
{/literal}url: "{$module_dir}productenq_ajax.php",{literal}
post: "POST",
data: $('#penq').serialize(),
dataType: "json",
success: function(result){

}
}); $.fancybox.close();
}
else{ 
$('#product_enq_form_error').html(datas);
                       }
});
});
{/literal}
</script>

Edited by rekram (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi, the module is great, but need some corrects, for example in file productenquire-extra.tpl I added email validation, so the <script> looks:

 

<script text="javascript">
{literal}
$('document').ready(function(){
$('#enquire_product_button').fancybox({
'hideOnContentClick': false
});

$('#enquireProduct').click(function(){
var datas ='';
var name=$('#your_name').val();
var email=$('#your_email').val();

function validateEmail(email) {
var re = /^(([^<>()[\]\\.,;:\s@\"]+(\.[^<>()[\]\\.,;:\s@\"]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
return re.test(email);
}  

if(name=='')datas +='Please write your name';
if(email=='' || validateEmail(email)==false)datas +='<br/>Please write your correct email';
			//console.log(datas);
if (datas == '')
{
$.ajax({
{/literal}url: "{$module_dir}productenq_ajax.php",{literal}
post: "POST",
data: $('#penq').serialize(),
dataType: "json",
success: function(result){

}
}); $.fancybox.close();
}
else{
$('#product_enq_form_error').html(datas);
					}
});
});
{/literal}
</script>

 

You can fill in a zip file?

Share this post


Link to post
Share on other sites

Hi, is it possible to add a confirmation pop up after sending the message?

Or even just a text that says that the message has been sent?

I've been not able to fix this thing. Any help would be appreciated. Than you

Share this post


Link to post
Share on other sites

Hi all and thanks for everyones input into this!

 

Like others who have posted I still cannot get this to send emails.

 

I have tried this on another site which also runs 1.5.4.1 with the default theme and it works perfectly, however on the site that I need it to work it does not send the emails.

 

On the second site which does not work, the send to a friend module works fine and the emails send, so it cannot be an issue with the PHP mail function.

 

If I switch the second site back to the defualt theme it still does not work, I have tried to duplicate everything from the first site

 

does anyone have any ideas??????

 

Much appreciated

Share this post


Link to post
Share on other sites

Can someone help me about this please:

Its not hook properly with "print", confused.

 

s1k7c.jpg

Share this post


Link to post
Share on other sites

Guys....check our store where you will find exactly what you are discussing......check any product at our site www.handcraft.co.in and if you click on Bulk Inquiry or Price On Request, inquiry form will pop up..........

  • Like 1

Share this post


Link to post
Share on other sites

Hola a todos, uso la version 1.5.4.1 y envia y funciona, pero no salen las traducciones, solo sale en ingles.

Alguien sabe como hacer que salgan cada uno en su idioma?

 

Mil gracias y gracias al creador del modulo

 

Hi all, I use the 1.5.4.1 version and send and it works, but do not leave the translations, only comes in English.

Anyone know how to make out everyone in your language?

 

Thank you and thanks to the creator of the module

 

Raul

 

¿Lo conseguiste Raul? me pasa lo mismo.

Solucionado! primero saqué el archivo 'es.php' de la carpeta 'es' dentro de 'translations'.

Y segundo es que fallaban las secuencias md5. Aquí está el enlace para que las podáis traducir manualmente. Copiáis cada frase en inglés y lo traduce a ese código raro que está en todas las traducciones. Lo pegáis en cada línea a traducir, y listo!

http://www.cuwhois.com/herramienta-seo-genera-md5.php 

Versión PS: 1.5.4.1

Genial el módulo!

Edited by Cristrinity (see edit history)

Share this post


Link to post
Share on other sites

Hi all and thanks for everyones input into this!

 

Like others who have posted I still cannot get this to send emails.

 

I have tried this on another site which also runs 1.5.4.1 with the default theme and it works perfectly, however on the site that I need it to work it does not send the emails.

 

On the second site which does not work, the send to a friend module works fine and the emails send, so it cannot be an issue with the PHP mail function.

 

If I switch the second site back to the defualt theme it still does not work, I have tried to duplicate everything from the first site

 

does anyone have any ideas??????

 

Much appreciated

Same problem here.

Any idea how to fix it?

Share this post


Link to post
Share on other sites

Buenas, me gustaría añadir mas campos al formulario, nombre, apellidos, teléfono y correo.

Los campos estos se guardan en la BD o solo se envían por correo, en el caso de querer añadirlos (veo que alguien ha puesto una confirmación del correo, seria parecido? 

 

Por la tarde lo trasteare bien, que ahora estoy en el curro, si consigo añadir los campos subo aquí los archivos.

Saludos

  • Like 1

Share this post


Link to post
Share on other sites

Atenção ao mover este módulo. Caso você mova-o a um hook que esteja dentro de uma tag <form></form>, o e-mail não será enviado. O hook "actionProductOutOfStock" é um exemplo.

Boa sorte.

 

__________________________________________________________________________________________________

 

Attention to move this module. If you move it to a hook that is inside a tag <form></ form>, the email is not sent. The hook "actionProductOutOfStock" is an example.

Good luck
.

  • Like 1

Share this post


Link to post
Share on other sites

No problem, I changed the email template too.

 

Hello I come back to this post because I'm testing the module on a prest V1.5.6.2

 

here www.equipement-de-maison.fr

 

but no email are sent !!!

what about the hook to display ??

 

some boby can help ?

Edited by bretweb (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi, is it possible to add a confirmation pop up after sending the message?

Or even just a text that says that the message has been sent?

I've been not able to fix this thing. Any help would be appreciated. Than you

 

I attach productenquire with confirmation fancybox after succesfully sent email. 

 

If you want to add extra confirmation out of the fancybox, you have to do something like this:

 

file productenquire-extra.tpl  should look like this:

});	$("#email_sent").css("display", "block"); $.fancybox("THANK YOU, YOUR MESSAGE HAS BEEN SENT"); $.fancybox.close(); 

and put this code below in some place on page (for example just after script): 

<li>
<p id="email_sent" style="display: none; color: green;">We have succesfully sent your question</p>
</li>

 

And I have still problems with sending email from Firefox and Opera. Emails from Chrome and IE9 are working. Any ideas?

 

EDIT Ok, I made some changes in productenq-ajax.php and it seems, that module is now sending e-mails from any browser (Opera, Firefox, Chrome, IE9), but let me know if it's working in your webpages. 

productenquiry.zip

Edited by rekram (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

I attach productenquire with confirmation fancybox after succesfully sent email. 

 

If you want to add extra confirmation out of the fancybox, you have to do something like this:

 

file productenquire-extra.tpl  should look like this:

});	$("#email_sent").css("display", "block"); $.fancybox("THANK YOU, YOUR MESSAGE HAS BEEN SENT"); $.fancybox.close(); 

and put this code below in some place on page (for example just after script): 

<li>
<p id="email_sent" style="display: none; color: green;">We have succesfully sent your question</p>
</li>

 

And I have still problems with sending email from Firefox and Opera. Emails from Chrome and IE9 are working. Any ideas?

 

EDIT Ok, I made some changes in productenq-ajax.php and it seems, that module is now sending e-mails from any browser (Opera, Firefox, Chrome, IE9), but let me know if it's working in your webpages. 

 

 

I still get the error when sending email, I don't know why... I'm exhausted and I need to have it operating, Really Tired

  • Like 1

Share this post


Link to post
Share on other sites

Ok je répond ici en français pour ceux qui auraient le même problème que moi ici  : http://www.equipement-de-maison.fr/

 

Le module fonctionne bien sur Prestashop V1.5.6 mais il faut créer un dossier  FR pour la langue française .... ou pour les autres mangues utilisée 

 

Good !!!  The module is working on a Prestashop V1.5.6.2 but you need to create a file FR  for French langage or for each used langage ...

 

Perhaps it could be better to have a confirmation that the email is send ...

Share this post


Link to post
Share on other sites

Oh, it works :). I made all needed files and folders with language 'pl' and it worsk fine. There is no confirmation popup for customer but it works.

Share this post


Link to post
Share on other sites

I attach productenquire with confirmation fancybox after succesfully sent email. 

 

If you want to add extra confirmation out of the fancybox, you have to do something like this:

 

file productenquire-extra.tpl  should look like this:

});	$("#email_sent").css("display", "block"); $.fancybox("THANK YOU, YOUR MESSAGE HAS BEEN SENT"); $.fancybox.close(); 

and put this code below in some place on page (for example just after script): 

<li>
<p id="email_sent" style="display: none; color: green;">We have succesfully sent your question</p>
</li>

 

And I have still problems with sending email from Firefox and Opera. Emails from Chrome and IE9 are working. Any ideas?

 

EDIT Ok, I made some changes in productenq-ajax.php and it seems, that module is now sending e-mails from any browser (Opera, Firefox, Chrome, IE9), but let me know if it's working in your webpages. 

 

It's working perfectly!

 

Just, I'm not getting the fancybox with the confirmation

is it possible that you add the code for the "out of the fancybox" confirmation on the zip? Because i'm not 100% sure of where to put it.

Thanks so much in advance!

Share this post


Link to post
Share on other sites

I attach productenquire with confirmation fancybox after succesfully sent email. 

 

If you want to add extra confirmation out of the fancybox, you have to do something like this:

 

file productenquire-extra.tpl  should look like this:

});	$("#email_sent").css("display", "block"); $.fancybox("THANK YOU, YOUR MESSAGE HAS BEEN SENT"); $.fancybox.close(); 

and put this code below in some place on page (for example just after script): 

<li>
<p id="email_sent" style="display: none; color: green;">We have succesfully sent your question</p>
</li>

 

And I have still problems with sending email from Firefox and Opera. Emails from Chrome and IE9 are working. Any ideas?

 

EDIT Ok, I made some changes in productenq-ajax.php and it seems, that module is now sending e-mails from any browser (Opera, Firefox, Chrome, IE9), but let me know if it's working in your webpages. 

 

 

Hello Sorry but  I don't have sent  email confirmation !

I do all needs but  not working ( the email is working )

 

Best regards

Share this post


Link to post
Share on other sites

Hi All

 

Here is the module for product Enquiry / Product Question

 

working well with the Prestashop version 1.5.4.0 tested This modules ads an link similar to send to friend module on click a Enquiry form will open when user fills that form and submit an email goes to

Email specified from back end of this module if email not specified Email will goes to default shop email id

 

Hi vivek, thank you very much. your module working perfectly on 1.6 too.

Good work ;)

Share this post


Link to post
Share on other sites

It dont display fancybox confirmation after submit, but module is working well on 1.6.0.6. Thank you very much :)

Share this post


Link to post
Share on other sites