Jump to content

Recommended Posts

Hallo ūüôā

 

Ich habe schon seit längerem einen Prestashop, der funktioniert auch eigentlich ganz gut :)

 

Version: 1.6.1.1

 

Nun wollte ich die Mail Adresse ändern in der Rubrik Shopadressen, will ich diese verändern bleibt die Seite weiss (nachdem ich auf speichern geklickt habe) die alte Mail ist nicht mehr in Funktion und sollte ersetzt werden.

 

Was ich bereits getan habe:

 

Ausgelogt, cache geleert

 

 

Vielleicht kennt jemand das Problem? Bin sehr dankbar f√ľr die Hilfe.

Share this post


Link to post
Share on other sites

Hallo Sandra,

du könntest zunächst mal "error-reporting" (si. mein Footer) einschalten, vermutlich werden dann Fehlermeldungen angezeigt mit denen man dann den eigentlichen Fehler suchen kann.

Wenn du jetzt schnell vorab die shop-email Adresse ändern willst kannst du das auch direkt in der Datenbank, in der Tabelle

ps_shop_configuration

bei

PS_SHOP_EMAIL

Gr√ľsse
Whiley

Share this post


Link to post
Share on other sites

Lieber Whiley

 

Danke dir vielmal f√ľr deine Nachricht- konnte es in der Datenbank √§ndern- mal schauen ob sich das Spam Problem l√∂st. Bekome pro Tag sicher 40 Spam Mails, furchbar momentan.

 

 

Das mit dem Error Report muss ich mal noch herausfinden wie das geht.

 

 

tausend dank und gute nacht :)

Share this post


Link to post
Share on other sites

hab jetzt noch grad andere Probleme- nachdem ich die Mail ge√§ndert habe kommt gar keine mail an beim Kontaktformular und als ich eine Testbestellung machen wollte (mache ich so all paar Monate) ¬†bleibt die seite weiss nach der Gastbestellung und geht nicht mehr weiter. Ohje mine, nachdem ich doch nun alle neuen Artikel eingepflegt habe ūüėě

 

url: www.lernpostershop.ch

Share this post


Link to post
Share on other sites

hallo Sandra,

schalte "error reporting" ein und wir sehen weiter.

Gr√ľsse
Whiley

Share this post


Link to post
Share on other sites

So, error reporting ist aktiviert ūüôā¬†

 

 

bei der weissen Seite f√ľr den Wartungsmodus zu aktivieren kommt :

 

Fatal error: Uncaught Error: Access to undeclared static property: Validate::$field in /home/sites/2b/1/157db03259/public_html/shop/classes/controller/AdminController.php:3640 Stack trace: #0 /home/sites/2b/1/157db03259/public_html/shop/classes/controller/AdminController.php(1425): AdminControllerCore->validateField(0, Array) #1 /home/sites/2b/1/157db03259/public_html/shop/classes/controller/AdminController.php(897): AdminControllerCore->processUpdateOptions() #2 /home/sites/2b/1/157db03259/public_html/shop/classes/controller/Controller.php(178): AdminControllerCore->postProcess() #3 /home/sites/2b/1/157db03259/public_html/shop/classes/Dispatcher.php(367): ControllerCore->run() #4 /home/sites/2b/1/157db03259/public_html/shop/admin1137/index.php(58): DispatcherCore->dispatch() #5 {main} thrown in /home/sites/2b/1/157db03259/public_html/shop/classes/controller/AdminController.php on line 3640

 

 

Beim Fehler direkt wenn ich mich einlogge ist der Fehler der im Screenshot kommt.

 

 

Beim Fehler der Gastbestellung kommt folgendes:

 

Fatal error: Uncaught Error: Access to undeclared static property: Validate::$data in /home/sites/2b/1/157db03259/public_html/shop/classes/ObjectModel.php:1149 Stack trace: #0 /home/sites/2b/1/157db03259/public_html/shop/controllers/front/AuthController.php(430): ObjectModelCore->validateController() #1 /home/sites/2b/1/157db03259/public_html/shop/controllers/front/AuthController.php(256): AuthControllerCore->processSubmitAccount() #2 /home/sites/2b/1/157db03259/public_html/shop/classes/controller/Controller.php(178): AuthControllerCore->postProcess() #3 /home/sites/2b/1/157db03259/public_html/shop/classes/Dispatcher.php(367): ControllerCore->run() #4 /home/sites/2b/1/157db03259/public_html/shop/index.php(28): DispatcherCore->dispatch() #5 {main} thrown in /home/sites/2b/1/157db03259/public_html/shop/classes/ObjectModel.php on line 1149

 

 

Liebe Gr√ľsse und Danke

Screenshot 2019-05-17 12.12.50.jpg

Share this post


Link to post
Share on other sites

Whiley, kann es sein das es an der PHP Version liegt? hab von 5.6 auf 7.0 gewechselt, weil ich nebenbei auf dem Hosting den Prestashop auf 1.7 aufbauen wollte. Hab nun zur√ľckgewechselt und die Bestellung geht. ganz schreg.

Share this post


Link to post
Share on other sites

PHP 7.0 ist veraltet und hat Fehler, wenn dann PHP 7.1 oder 7.2 installieren, damit ein PS 1.6  unter PHP 7.2 läuft sind Anpassungen erforderlich aso besser bei 5.6 bleiben

Gr√ľsse
Whiley

Share this post


Link to post
Share on other sites

ok danke f√ľr die info, dann bleib ich bei 5.6

bin so froh hab ich denn fehler gefundenūüôĄ

 

die 1.7 läuft aber nur mit php 1.7 oder?

 

ich hab immer noch tonnenweise spam, trotz neuer mail addy und eicaptcha. ūüôĄ

 

 

37B76458-1311-4FA3-A5DF-E21DCB77B39F.png

Share this post


Link to post
Share on other sites

Das sieht so aus, als ob deine E-Mail-Adresse nicht aktiv ist, das hat nichts mit Prestashop zu tun.

Was den Spam angeht, kommt der denn √ľber das Kontaktformular von Prestashop? Oder wird der halt einfach normal an deine E-Mail-Adresse(n) geschickt?

Share this post


Link to post
Share on other sites

Die ganzen Spamvorkehrungen helfen nur bedingt und eben nur auf der Ebene des eigenen Servers.

Wir hatten neulich mal gesucht, woher eine Spamflut kam, die augenscheinlich von einem Shop kam. Da wurden pl√∂tlzich massenhaft Mails versendet, die auf den ersten Blick vom Shop kamen, aber dann zeigte sich, dass da Leute sich √ľbers Kontaktformular eine Mail schicken lassen, um dann die Absenderadresse zu spoofen und damit zu spammen...

Das kann mittlerweile fast jedes kleine Kind :)

Und wenn das passiert, kannst du dir nat√ľrlich bei dir selbst einen Wolf suchen, da findest du nichts.

 

Share this post


Link to post
Share on other sites

Sory, meine verspätete Antwort.

 

 

Also bei mir scheint es, dass die in meinem mail namen an deren mails versenden. Siehe Bild.

 

Ich weiss echt nicht mehr was tun, hab mail geändert, captcha eingebaut, link zur kontaktseite geändert und nun ist alles wieder wie vorher....ohje mine.

 

Screenshot 2019-05-23 12.52.57.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More