Jump to content
NilsvanDoorn

SSL Aktivierung

Recommended Posts

Ich versuche meinen Shop auf https:// umzustellen. Ich habe das SSL Zertifikat meines Hosting Providers aktiviert und im PrestaShop System SSL aktiviert. Allerdings kann ich danach nicht mehr auf die Seite zugreifen, sie wird nicht mehr angezeigt. Gibt es noch etwas anderes, dass man umstellen muss, dass man auf den Shop unter https:// zugreifen kann?

Share this post


Link to post
Share on other sites

Hallo SnilsvanDoorn,

ich hatte das selbe Problem, wie man das SSL jetzt genau einbindet kann ich Dir noch nicht sagen. Allerdings konnte ich auch nicht mehr auf unseren Shop zugreifen, ich kann dir erstmal sagen, wie Du deine Seite wieder erreichbar machen kannst.

Was Du aber auf jeden Fall machen musst, ist in deinen Einstellungen die Domain deines Shops zu ändern, denn du erreichst deine Seite nach Aktivierung des SSL-Zertifikats nicht mehr über http, sondern https.

Hier der Link: https://www.prestashop.com/forums/topic/900110-gelöst-probleme-mit-ssl-zertifikat/?page=0#comment-2966961

 

 

Share this post


Link to post
Share on other sites

Vielleicht wäre es bei solchen Eingangspostings nützlich, die Shopversion mitzuteilen und auch genauer zu beschreiben, was man alles gemacht hat, bis es dann nicht mehr funktioniert hat. Dann kann einem auch leichter und gezielter geholfen werden.

Dennoch ist es immer eine gute Idee, vor jeder Änderung ein Backup zu machen, um bei Bedarf den entscheidenden Schritt wieder rückgängig machen zu können.

Share this post


Link to post
Share on other sites

Vielen Dank für das Feedback und Entschuldigung für fehlende Angaben zu Hosting und Software.

PrestaShop 1.7.2.1 und Hosting via Strato. Läuft beides problemlos. Als Browser benutze ich Chrome und Safari.

Im Anhang ein paar screen shots: ich habe das SSL Zertifikat zugewiesen und in einem ersten Schritt SSL nur für Kundenanmeldung und Bestellvorgang aktiviert. Im Prinzip würde ich aber gerne den gesamten Shop auf https:// umstellen wollen.

Sobald das SSL Zertifikat aktiviert ist, wird die Website nicht mehr im Browser angezeigt.

Screen Shot 2018-09-11 at 11.18.20 AM.png

Screen Shot 2018-09-11 at 11.18.48 AM.png

Screen Shot 2018-09-11 at 11.19.02 AM.png

Screen Shot 2018-09-11 at 11.20.19 AM.png

Share this post


Link to post
Share on other sites

Browser und Shop Caches geleert? Mal probiert die htaccess vorübergehend u zu benennen?

Share this post


Link to post
Share on other sites

Sieht nett aus, der Shop. Aber .... hast auch daran gedacht, dass es sinnvoll wäre, wenn die Kunden auch etwas kaufen können? :rolleyes: Denn man kann einfach keinen Artikel in den Warenkorb legen.

Und wenn man dann auf die geniale Idee kommt, dass man sich vielleicht erst anmelden muss .... schwupps, und man stellt fest, dass es eine URL zur Anmeldung gar nicht gibt und man aus dem Shop rausfliegt. Finde ich eigentlich nicht so kundenfreundlich ....

Dann noch ein höchst eigenwilliges Impressum, keine Datenschutzhinweise, kein rechtssicheres Newsletter-Modul, und ... und ... und. Also, Spaß beiseite: ich würde den Shop so bestimmt noch nicht online stellen. Für Google ist er das aber.

Übrigens ist die Mobildarstellung auf Smartphones vergleichsweise bescheiden, da viele Responsive Themes mit einer 2. Artikelspalte in der Listenansicht nicht umgehen können - so auch deines. Auch mehrteilige Breadcrumbs oder die Header Beschriftungen überlappen den Hintergrund oder werden abgeschnitten. Aber diese Probleme kennt man ja auch vom Classic Theme in 1.7 oder vom Standard-Template von 1.6.

Share this post


Link to post
Share on other sites

Das SSL-Problem besteht wenn ich den Shop besuche nicht, entweder hast du das zwischenzeitlich gelöst oder es tritt nur auf deinem Computer auf (vgl. erster Screenshot). Ich würde übrigens SSL für die gesamte Site aktivieren.

Und zumindest falls dein Shop in Deutschland ist achte darauf, die Rechtssicherheit herzustellen oder den Shop erst einmal in den Wartungsmodus zu versetzen.

Share this post


Link to post
Share on other sites

Das Problem war - um ehrlich zu sein - recht simpel. Den Shop immer komplett auf https:// umstellen, und nicht nur Anmeldung und Bestellvorgang (wollte das nur im ersten Schritt machen und, wenn das klappt, dann den gesamten Shop). Auf jeden Fall hat das aktivierte Strato SSL Zertifikat und die Teilaktivierung in PrestaShop dazu geführt, dass die Homepage nicht angezeigt wurde. Den Shop dann im PrestaShop back office komplett auf https:// umgestellt, und jetzt wird die gesamte Seite ohne Probleme angezeigt und von etwa Chrome als 'secure' gekennzeichnet.

Share this post


Link to post
Share on other sites
vor 17 Stunden schrieb rictools:

Und zumindest falls dein Shop in Deutschland ist achte darauf, die Rechtssicherheit herzustellen oder den Shop erst einmal in den Wartungsmodus zu versetzen.

 

Solange er eh nicht funktioniert, weil man sich weder anmelden noch etwas bestellen kann, ist das eigentlich egal. Abgemahnt werden kann der User   im Moment ja nur wegen des Newsletter-Moduls. 

Share this post


Link to post
Share on other sites
2 hours ago, eleazar  said:

Solange er eh nicht funktioniert, weil man sich weder anmelden noch etwas bestellen kann, ist das eigentlich egal. Abgemahnt werden kann der User   im Moment ja nur wegen des Newsletter-Moduls. 

Ob der Warenkorb funktioniert, wird einen Abmahner oder ein Gericht kaum interessieren, der Shop ist online und wie du selbst schreibst bei Google auffindbar, außerdem ist er zumindest bei Instagram verlinkt. Besucher können nicht nur einen Newsletter bestellen, es gibt mehrere Social Links sowie konkrete Produktangebote mit Preis, die z. B. über eine formlose E-Mail bestellt werden können. Aber kein korrektes Impressum, keine Datenschutzerklärung ...

Share this post


Link to post
Share on other sites

Danke für den Hinweis. Um die Punkte muss ich mich noch kümmern.

Falls jmd. übrigens ähnliche Probleme hat bzw. Lösungsmöglichkeiten...trotz anti spam Modul hört die Flut an russischen (in kyrillisch) spam Nachrichten noch nicht auf. Und das PrestaShop Forum hat ja ein ähnliches Problem, da muss man nur auf die Forum Seite gehen, um zig spam Nachrichten in Chinesisch, Koreanisch usw. zu sehen. Ich kann mir nicht vorstellen, dass das jmd. händisch eingibt und so die anti spam Module umgeht...

Screen Shot 2018-09-17 at 11.51.19 AM.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More