Jump to content
radek.tuma@seznam.cz

Modules and services are inaccessible

Recommended Posts

Hello, I have a local installation v1.7.0.0 RC3 (XAMPP). Modules and services are inaccessible, I get the message "Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache". In the browser is site PrestaShop Addons accessible. Tested in Firefox 49.0.2, Chrome 54.0.2840.71 and MSIE 11.

Radek Tůma

Share this post


Link to post
Share on other sites

Hi,

Same problems :(

i have tested too the CCC in the Front office ---> Theme broken :(

Regards,

Atch

Share this post


Link to post
Share on other sites
I've encountered the same issue. I fixed it by changing line 117 of app/config/config.yml from:
            verify_ssl: ~ # true by default, declaring "addons.api_client.verify_ssl" parameter overrides its usage

to:

            verify_ssl: false # true by default, declaring "addons.api_client.verify_ssl" parameter overrides its usage
  • Like 1

Share this post


Link to post
Share on other sites

while that gets you past the issue, you should not actually rely on this change.  it is a highly insecure way of fixing the issue.  instead Prestashop should revert to verifying their domain using a certificate as they have done in the previous versions.

Share this post


Link to post
Share on other sites

Strange, changing ~ to false worked fine on my PrestaShop v1.7 RC3 test site. I'm using XAMPP too.

Share this post


Link to post
Share on other sites

After changing files I get :

Twig_Error_Runtime in classes.php line 4484: Invalid escaping strategy "name" (valid ones: html, js, url, css, html_attr) in "PrestaShopBundle:Admin/Module:catalog.html.twig".

Share this post


Link to post
Share on other sites

Did you try my simple, less secure solution above or PrestaShop's more complicated, but secure solution?

Share this post


Link to post
Share on other sites

I had the same issue twice, my solution was download the file https://curl.haxx.se/ca/cacert.pem and save into /app/cache/prod/. The problem exist because if the production cache is deleted then the file cacert.pem is deleted too.

 

I check in https://github.com/PrestaShop/PrestaShop/pull/6848/files and in my offline copy that file classes/Tools.php have the constant declaration:

const CACERT_LOCATION = 'https://curl.haxx.se/ca/cacert.pem';

and that file must exist in:

_PS_CACHE_DIR_.'cacert.pem'

as you can see in this global definition:

define('_PS_CACHE_CA_CERT_FILE_', _PS_CACHE_DIR_.'cacert.pem')

so, I chek if the file cacert.pem exist in production cache and it was deleted...

 

 

I hope this help.

  • Like 3

Share this post


Link to post
Share on other sites

So are you saying that this issue exists in PS v1.7.0.1?  If so, I would suggest you open a new forge ticket so they can fix the issue... again

Share this post


Link to post
Share on other sites

that solved my Problem, thanks :)

I had the same issue twice, my solution was download the file https://curl.haxx.se/ca/cacert.pem and save into /app/cache/prod/. The problem exist because if the production cache is deleted then the file cacert.pem is deleted too.

 

I check in https://github.com/PrestaShop/PrestaShop/pull/6848/files and in my offline copy that file classes/Tools.php have the constant declaration:

const CACERT_LOCATION = 'https://curl.haxx.se/ca/cacert.pem';

and that file must exist in:

_PS_CACHE_DIR_.'cacert.pem'

as you can see in this global definition:

define('_PS_CACHE_CA_CERT_FILE_', _PS_CACHE_DIR_.'cacert.pem')

so, I chek if the file cacert.pem exist in production cache and it was deleted...

 

 

I hope this help.

  • Like 1

Share this post


Link to post
Share on other sites

I would like to edit the link at the bottom of the footer (© 2016 - Ecommerce software by PrestaShop™).


As much as I like to give credit to PrestaShop, it doesn't look as professional as if I put my own company information in this space. I have edited it in previous versions but can't find the correct file or translation in the back office. Can anyone tell me the correct way to change it? Version 1.7.0.1 doesn't have cms block module. So please advice alternative way. Thank you.


Share this post


Link to post
Share on other sites

Go to Advanced Parameters > Performance and change "Never recompile templates" to "Force compile" and then refresh your website and it should disappear. Once you've finished modifying TPL files, you can change it back to "Never recompile templates" for maximum performance.

  • Like 1

Share this post


Link to post
Share on other sites

I'm new to Prestashop and have downloaded 1.7. When I try to get my add-ons, I get the message: Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache. Can anyone help in an easy to understand way?

Share this post


Link to post
Share on other sites

Im new with prestashop, and i dont know if this solution is good or not, but i solved doing this:

 

Take this file: public_html/vendor/composer/ca-bundle/res/cacert.pem

And copy to: public_html/app/cache/prod/cacert.pem

 

If some one see that this solution is wrong or dangerous say us 

 
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Im new with prestashop, and i dont know if this solution is good or not, but i solved doing this:

 

Take this file: public_html/vendor/composer/ca-bundle/res/cacert.pem

And copy to: public_html/app/cache/prod/cacert.pem

 

If some one see that this solution is wrong or dangerous say us 

 

I experienced this issue after upgrading to 1.7.0.4 (from 1.7.0.3) and this worked. Thank you!

  • Like 1

Share this post


Link to post
Share on other sites
Hi,
 
I try the method with replace "cacert.pem" file and add var on two file Tool.php and config.inc.php but it didn't work
 
ALcywI.png

 

Also the is a problem with this link :

http://www.mysite.com/adminXXXXX/index.php/module/manage?_token=XXXXX

This is a 500 error

 

It is really a pity that it does not work at once...

 

Do you have a solution for PrestaShop 1.7.0.4

 

Thank

Share this post


Link to post
Share on other sites
Same problem:

Can not get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and can not fallback on cache

 

Version: 1.7.0.3

 

Solution?

 

Thank you very much.

Share this post


Link to post
Share on other sites

I'm having the same issue as well. any solution for this?

 

I'm using 1.7.0.4.

 

It was working on the day I installed the prestashop (2 days ago) But stopped working today.

Am I missing something?

Share this post


Link to post
Share on other sites
Hi,
 
I think it comes from the configuration of your Apache server in php.ini
 
I am on Macos X with Xampp I have the same issue and in me Web Server OVH it's the same to
 
I tried bitnami-prestashop-1.7.0.4-1-osx-x86_64-installer.dmg and there it's OK the Module Link in backend work properly. 
 
I think it would come from the cache with extension=php_apc.dll and extension = intl.so but it's very difficult to add this extension on local Xampp server and it's impossible to me web server.

Thank 
Edited by Salisuka (see edit history)

Share this post


Link to post
Share on other sites

might be the settings of apache/php but I'm really puzzled to understand why it was working the first day right after I installed it. I haven't changed any settings though.

also I can not connect to addons marketpace from there (module selection page) as well.

  • Like 1

Share this post


Link to post
Share on other sites

ok. sorted.

I was using apache2.2 / php5.4. so I upgraded to apache2.4/php5.6 then it works perfectly now. must be some sort of compatibility issues.

  • Like 1

Share this post


Link to post
Share on other sites

Hello All

So, I have got the same message:

"Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache"

 

Any solution for that ? I tried all the comments mentionned above but ... nothig work for me !

:mellow: 

 

Thanks for your support

  • Like 1

Share this post


Link to post
Share on other sites

"Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache"

I'm also experiencing this problem on my localhost MAMP PRO server (PHP 5.6.27, Prestashop 1.7.0.4).

 

My online test e-shops work well, never had problems there. (using SSL and also non-SSL)

Share this post


Link to post
Share on other sites

Hello All

 

Solution is so easy... it is on server side

Actually, problem comes if CURL service is not activated in your server

It is related to php version, As I know starting from php 5.6.21 support CURL

Anyhow, solution is 100% server side... contact your hosting and ask how to activate CURL

 

Enjoy one again

;)

 

  • Like 1

Share this post


Link to post
Share on other sites

Edit @ Bassel

 

Have just asked our hosting to double check if the Curl is active or not and to activate it if not - will write back here what the out come is and hopefully shortly...

 

next edit some 20 min later

 

OK - we have CURL already fully installed and active - this did not resolve the issue

 

post as written below still un-solved  :(

 

Edit at 13.42 - used prestashop online chat - told to contact programmes and then chat was cut.

 

Also on the phone - its says 4 min wait - its now 11 min and ext 590 is now unavailable and and answer phone followed by termination of call

 

Super customer support from Prestashop eh!!

 

 

 

I have just spent 12 hours loading this nice new 1.70 PS which was freshly downloaded on the 1st Feb 2017

 

for our domain mdrdirect.co.uk

 

Having spent some time puting in various data - I moved to the modules section

 

and guess what ........   was greeted by this

 

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

As I can see this issue seems to be dating back a bit now having found this post after the event of loading 1.7

 

 

Is there a simple fix ?

 

Why has the prestashop team not resolved this

 

and the most important part of all - why has the prestashop team continued to allow this version to be downloaded from their site.

 

and finally should I delete it all and revert back to 1.6

 

 

Any help on this issue is most welcome

 

Many thanks

 

Ian

Edited by KGI (see edit history)

Share this post


Link to post
Share on other sites

Hi dear 

as I mentionned above this problem comes if CURL service is not activated in your server... refer to your hosting service and ask for CURL activation

Share this post


Link to post
Share on other sites

Hi dear 

as I mentionned above this problem comes if CURL service is not activated in your server... refer to your hosting service and ask for CURL activation

You are wrong, stop spreading invalid information.  The previous user already stated that Curl is activated

Share this post


Link to post
Share on other sites

Hi again

I dont spread invalid infos,

This instruction I got directly from Prestashop technical team in Paris.... I tried it and It works ... at least works in my case ... so if it didn't work for another case I am sorry for him.

Share this post


Link to post
Share on other sites

Hello All

 

Solution is so easy... it is on server side

Actually, problem comes if CURL service is not activated in your server

It is related to php version, As I know starting from php 5.6.21 support CURL

Anyhow, solution is 100% server side... contact your hosting and ask how to activate CURL

 

Enjoy one again

;)

 

Long story short: I sent this advice to one of my customers who had the same issue and IT SOLVED THE PROBLEM

 

As I read the posts above: maybe it's not working in all cases, but it's definitely something to consider and to check.

 

Thank you Bassel.

Edited by Andrej Stas (see edit history)

Share this post


Link to post
Share on other sites
Hello, one more detail that might help.

 

It is not enough just to have CURL installed you must have an updated version.

 

I have already had problems with this, and checking the logs I found the following entry that caused the problem: cURL error 35: error: 14077410: SSL routines: SSL23_GET_SERVER_HELLO: sslv3 alert handshake failure

 

This "handshake" error in my case was for using an outdated version of CURL (7.21.0)

 

I requested to upgrade to my service provider for (7.52.0) and everything worked normally.

 

Here is the list of CURL versions


 

To check which version you have installed

By command line: $ curl -V

Or PHP with the famous phpinfo ();

  • Like 1

Share this post


Link to post
Share on other sites

What to do? I cant configure the default module; heres the error message:

 

[PrestaShop] Fatal error in module file :/home4/reflect988/public_html/modules/blockreassurance/blockreassurance.php:
Interface 'PrestaShop\PrestaShop\Core\Module\WidgetInterface' not found

Edited by Ginnova (see edit history)

Share this post


Link to post
Share on other sites

That error message occurs when you try to use a PrestaShop v1.7 module in PrestaShop v1.6. You should uninstall the blockreassurance module and restore the blockreinsurance module from the original PrestaShop v1.6 archive.

Share this post


Link to post
Share on other sites

I solved the problem when i changed my PHP configuration, CURL must be active too. (my configuration is an OVH Server)

 

I worked with PHP 5.6 Legacy, i changed by PHP 5.6 Stable, with CURL 7.38.0n and everything is working now :)

  • Like 3

Share this post


Link to post
Share on other sites

I have the same sort of issue. I cannot access the modules and services - which renders me helpless. :(

 

Is there a list of the exact server/PHP settings required to get PrestaShop 1.7 running?

Share this post


Link to post
Share on other sites

I had the same issue twice, my solution was download the file https://curl.haxx.se/ca/cacert.pem and save into /app/cache/prod/. The problem exist because if the production cache is deleted then the file cacert.pem is deleted too.

 

I check in https://github.com/PrestaShop/PrestaShop/pull/6848/files and in my offline copy that file classes/Tools.php have the constant declaration:

const CACERT_LOCATION = 'https://curl.haxx.se/ca/cacert.pem';

and that file must exist in:

_PS_CACHE_DIR_.'cacert.pem'

as you can see in this global definition:

define('_PS_CACHE_CA_CERT_FILE_', _PS_CACHE_DIR_.'cacert.pem')

so, I chek if the file cacert.pem exist in production cache and it was deleted...

 

 

I hope this help.

Buenas

 

como se hace esto que pones aqui, no se como modificar estos parametros.

Share this post


Link to post
Share on other sites

I solved the problem when i changed my PHP configuration, CURL must be active too. (my configuration is an OVH Server)

 

I worked with PHP 5.6 Legacy, i changed by PHP 5.6 Stable, with CURL 7.38.0n and everything is working now :)

Oui ça marche très bien.

passer en PhP 5.6 stable corrige le bug.

 

Merci!

  • Like 1

Share this post


Link to post
Share on other sites

I have also run into this problem:

 

Modules & Services > Modules > Selection - Gives the following error:

 

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache
 
Modules & Services > Modules > Installed Modules - (with php debugging enabled) - gives me two errors + stack traces:
 
ConnectException in CurlFactory.php line 126: cURL error 28: Resolving timed out after 5515 milliseconds
ConnectException in RequestException.php line 49: cURL error 28: Resolving timed out after 5515 milliseconds
 
In Both errors are curl was requesting:
 
I have tried curling this URL from the command line and it returns without a timeout.
 
I have tried solutions already mentioned as follows:
1. Copying https://curl.haxx.se/ca/cacert.pem im /app/cache/dev and /app/cahce/prod which was already present so copied over the top just to be sure
2. Deleting app/cache and having it recreate (checked cacert.pem was present) - Permissions on these files were correct
3. Restarting apache / server
4. Disabling none prestashop modules and overrides
5. set verify_ssl: false in app/config/config.yml
 
None of the above have any effect. The site was running fine until this started happening. I don't have anything specific that I was doing that seem to have caused it. I did install the gmerchent module shortly before this error occurred but I cant say it is related (I tried removing this modules folder and Disabling none Prestashop modules just in case) My dev version on my local machine still works fine.
 
Setup:
Prestashop: 1.7.1.1
Apache: 2.4.18
PHP 5.6.30-10+deb.sury.org~xenial+2
curl 7.47.0 - enabled
 
Any ideas or solutions would be greatly appreciated as I am running out of options bar trying a full reinstall. I really don't want to have to do that.
Edited by hygap (see edit history)

Share this post


Link to post
Share on other sites

I solved the problem when i changed my PHP configuration, CURL must be active too. (my configuration is an OVH Server)

 

I worked with PHP 5.6 Legacy, i changed by PHP 5.6 Stable, with CURL 7.38.0n and everything is working now :)

thanks a lot, for this solution, it works,

 

Ornot

  • Like 1

Share this post


Link to post
Share on other sites

For me no solution mentionned are working, on order to open the module page I use a small trick, it's not professionnal but I have no choice.

 

http://ristime.blogspot.com/2017/05/probleme-prestashop-17-page-module.html  it's in French

 

basically, just need to replace one word by another in the url so we can reach the page of the installed module

 

I replace the word "catalog" by the word "manage" to reach directly the page

Share this post


Link to post
Share on other sites

For me no solution mentionned are working, on order to open the module page I use a small trick, it's not professionnal but I have no choice.

 

http://ristime.blogspot.com/2017/05/probleme-prestashop-17-page-module.html  it's in French

 

basically, just need to replace one word by another in the url so we can reach the page of the installed module

 

I replace the word "catalog" by the word "manage" to reach directly the page

I tried this but the url is already "manage" and not catalog.

Did anyone get this resolved in a way that will not be affected by upgrades?

thanks,

Breda

Share this post


Link to post
Share on other sites

I'm using 1.7.1, the php is 5.6 and the Curl is enabled up to 7.53.1.

And I'm getting this error, can anyone recommend anything?

thanks,

Breda

Share this post


Link to post
Share on other sites

Hi, from 2 months I've the same problem in the modules manager:

 

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache.

 

I've tried both of the proposed solution (first download "cacert.pem" file and paste into my ftp - second verify and change the line code of "app/config/config.yml") but they don't work.

 

Please could somebody give me any tips about to solve finally this problem?

 

Thanks in advance, best regards

 

Luca

Share this post


Link to post
Share on other sites

Upgrading to PrestaShop v1.7.2.0 RC1 fixed this error message for me. You can try installing that in a separate test site to see if it fixes the issue.

Share this post


Link to post
Share on other sites

i fixed it by deleted the folder /app/cache and after actualize my prestashop , a new folder is created automaticly by Prestashop and it works.

i hope this help  :)

Edited by PR1989 (see edit history)

Share this post


Link to post
Share on other sites
On 07/01/2017 at 5:54 PM, tali656 said:

Im new with prestashop, and i dont know if this solution is good or not, but i solved doing this:

 

Take this file: public_html/vendor/composer/ca-bundle/res/cacert.pem

And copy to: public_html/app/cache/prod/cacert.pem

 

If some one see that this solution is wrong or dangerous say us 

 

This worked for me! Thanks!

Share this post


Link to post
Share on other sites

I found the solution and it worked for me,

Scan your Home directory with virus scanner in Cpanel or ask your web-hosting provider to do this for you.

you will find an infected file in the home directory

public_html/admin/autoupgrade/latest/install/langs/fr/flag.jpg: SiteLock-BIN-TROJAN

Clean this file and issue will be fix.

 

Note: Must Scan Home Directory in order to find the right infected file.

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More