Jump to content
Robert Schmitt

Ssl // Image Not Showing As Secure?

Recommended Posts

Hi Robert!

 

Which version of PS you use? And you get the same results with all browsers?

 

Regards

MacRoy

Share this post


Link to post
Share on other sites

Below are the warning messages you are receiving. Hard to say if this is a theme or module issue, but something in your store is trying to load fonts from google using http.

Mixed Content: The page at 'https://vectorart.at/en/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Open+Sans:400,800,300,700'. This request has been blocked; the content must be served over HTTPS.
Mixed Content: The page at 'https://vectorart.at/en/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Lobster'. This request has been blocked; the content must be served over HTTPS.
Mixed Content: The page at 'https://vectorart.at/en/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Dancing+Script'. This request has been blocked; the content must be served over HTTPS.

There is also this warning which is trying to load something from flickr.com using http.

Mixed Content: The page at 'https://vectorart.at/en/' was loaded over HTTPS, but requested an insecure script 'http://www.flickr.com/badge_code_v2.gne?count=6&display=random&size=t&layout=x&source=user&user=7392841@N04'. This request has been blocked; the content must be served over HTTPS.

Share this post


Link to post
Share on other sites

We are fixing our theme, but it seems some part of standard theme is also affected of this problem

Share this post


Link to post
Share on other sites

We are fixing our theme, but it seems some part of standard theme is also affected of this problem

that could be true, however you have not provided your version of prestashop, or the version of a particular module that you might have a problem with.  if you are using an older version of the theme, then perhaps you should consider an upgrade, or be more specific about your issue

Share this post


Link to post
Share on other sites

PS verison 1.5.6.1 with many changes

 

We have solved issue with images of theme, now we have problem with links, 

 

 

if we put this solution https://github.com/PrestaShop/PrestaShop-1.5/commit/0452979ce77b36ece8b8745bb3383d104ccedfaa

could we have some problems ?

what exactly is the issue that you have and that you believe this commit would resolve?  btw, you are using an older version of 1.5 (released in 2013), I believe the latest version is 1.5.6.3

 

You also have not stated if you are using a custom theme or the default theme, and was that the original default theme, or had you upgraded from a previous version.

Share this post


Link to post
Share on other sites

The issue is that, only user account page and order page are https

but all others site pages are http

if i add s to http, for example in home, links in menu are right (with https) but when i click it go to http version

Share this post


Link to post
Share on other sites

If you only enable SSL, by default that only enables HTTPS on secures pages (like checkout and account pages). 

 

I don't know if PS v1.5.6.1 has the option to force HTTPs on ALL pages, you need to review your preferences page in the back office and see if that option is available.

Share this post


Link to post
Share on other sites

Yesterday you said in your post it was 1.5.6.1.  Either way, if you don't have that option then you will likely need to make core changes to your store to force this.  A store that old however, you really should consider an upgrade

Share this post


Link to post
Share on other sites
When your SSL certificate fails to encrypt all the elements of the page (Like Images) then you receive an "unsecured content" message. To resolve this error, you have to find those elements (In your case images) of the page that are not encrypted and make following modifications -

 

1. If images are hosted on Your Server

 

    Whenever an image link is created within a page using the absolute URL then resulting image link will not be encrypted by SSL. For example - Following image link cannot be encrypted by SSL certificate -

 



<img src="http://www.yourstore.com/assets/photo1.jpg">

 

    To correct this issue, simply remove your store's domain from the image tag and create a relative link -

 

    <img src="/assets/photo1.jpg">


<img src="/assets/photo1.jpg">

 

2. If images are hosted on External Server

   

    In case, your images are hosted on external server (Like Flickr or Amazon) then you will need to modify the image link to use the secure "https" protocol. Note that, external server should support "https" protocol in order to secure images. In this case, image link will look like this -

 



<img src="https://www.externalserver.com/assets/photo1.jpg">

Share this post


Link to post
Share on other sites

I am running prestashop 1.7.x and using the default classic theme. Images are not showing up only on https pages like the contact us page and the login page, and registration page. If I turn on ssl on whole site, then my images on products page are all not found as well. If I turn off ssl, then all is fine. I want to enable it for secure pages and to view the images. How can I properly troubleshoot this? I feel like I enabled the wrong setting in the BO, but not sure where...

Share this post


Link to post
Share on other sites

I am running prestashop 1.7.x and using the default classic theme. Images are not showing up only on https pages like the contact us page and the login page, and registration page. If I turn on ssl on whole site, then my images on products page are all not found as well. If I turn off ssl, then all is fine. I want to enable it for secure pages and to view the images. How can I properly troubleshoot this? I feel like I enabled the wrong setting in the BO, but not sure where...

 

 

The issue that you have mentioned seems to be coming because of the .htaccess file in your store. This issue can be fixed by regenerating the .htaccess file.

 

Please follow the instructions below to regenerate the .htaccess file.

 

- Go to CONFIGURE (Shop Parameters) -> Traffic & SEO -> SEO & URLs

 

- Disable 'Friendly URL' and save the configurations.

 

- Enable 'Friendly URL' and save the configurations and it will regenerate the .htaccess file.

The issue that you have mentioned seems to be coming because of the .htaccess file in your store. This issue can be fixed by regenerating the .htaccess file.
 
Please follow the instructions below to regenerate the .htaccess file.
 
- Go to CONFIGURE (Shop Parameters) -> Traffic & SEO -> SEO & URLs
 
- Disable 'Friendly URL' and save the configurations.
 
- Enable 'Friendly URL' and save the configurations and it will regenerate the .htaccess file.

Share this post


Link to post
Share on other sites
On 28-4-2017 at 3:33 PM, Knowband Plugins said:

 

 

The issue that you have mentioned seems to be coming because of the .htaccess file in your store. This issue can be fixed by regenerating the .htaccess file.

 

Please follow the instructions below to regenerate the .htaccess file.

 

- Go to CONFIGURE (Shop Parameters) -> Traffic & SEO -> SEO & URLs

 

- Disable 'Friendly URL' and save the configurations.

 

- Enable 'Friendly URL' and save the configurations and it will regenerate the .htaccess file.

The issue that you have mentioned seems to be coming because of the .htaccess file in your store. This issue can be fixed by regenerating the .htaccess file.
 
Please follow the instructions below to regenerate the .htaccess file.
 
- Go to CONFIGURE (Shop Parameters) -> Traffic & SEO -> SEO & URLs
 
- Disable 'Friendly URL' and save the configurations.
 
- Enable 'Friendly URL' and save the configurations and it will regenerate the .htaccess file.

Hi,

 

Unfortunately this didn't work at my 1.7.3.4 testshop.  My ssl is showing a warningsign. I think it has to do with the images. Do you, or anyone else, what could be the problem? I have this problem with the standard theme and other themes. I tried the sollution above.

 

Thank you!

Share this post


Link to post
Share on other sites

i would suggest starting by looking at all the media files (images, css, javascript etc...) in the browser (view source or the browsers network tab, press F12).  This way you can atleast identify which media resources are not secure, and then use that information to determine what needs to be changed.

Share this post


Link to post
Share on other sites
6 hours ago, Peter Pastoor said:

Unfortunately this didn't work at my 1.7.3.4 testshop.  My ssl is showing a warningsign.

Is it the pure shop like on the first day or did you insert text and / or pictures into modules etc.? Maybe you inserted a pic-source with http:// (on the german forum an user inserted two blind gifs ...). It should be easy to recognize this, but not without a link to your shop ...

Share this post


Link to post
Share on other sites

And now i have a

500 Internal Server Error

 

when i go to Modules......it works very fine...1.7.3.4......

 

First off all i need to fix that. I will answer your questions later. Thank you for your help for now :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More