Jump to content
Stig K

Error 500 - Internal Server Error on all pages except for Admin front page

Recommended Posts

Hi,

 

I have yesterday installed Prestashop 1.5.0.17 to a brand new site, that is running on the same server farm (IIS 7.5, PHP 5.3) as 3 other PrestaShops (versions between 1.3 and 1.4) ..

 

I am expiriencing a really strange behavior of the site.. The installation went just perfect, no issues registered at all .. but when I access the front office I get a HTTP 500 Internal Server Error .. When I go to the backoffice, I get the login page just fine, and I am able to login and get main admin site displayed just fine .. now the mysteria gets even more weird, since if I click a link (Any link - have tried them all) I once again get HTTP 500 Internal Server Error.

 

I have on the main page of backoffice the following 2 items in RED:

  • cross.png URL Rewriting
  • cross.png Browser cache & compression

and these in YELLOW :

  • error.png Smarty optimization
  • error.png Combine, Compress & Cache

But I am not able to figure out if that is causing the issue, since I cannot find any documentation on how to fix these, so I am stock :-S

 

BTW : I have allready tried to reinstall the site 3 times from scratch, and I have tried changing the file permissions to 775 with FileZilla!

 

 

Can anyone help in this case? :-)

 

/Stig :-)

Edited by Stig K (see edit history)

Share this post


Link to post
Share on other sites

I have same problem but only in the admin area and only for SEO & URL section, any solution?

Share this post


Link to post
Share on other sites

Same problem her: I can see everything in the back office expect for the modules section. I get a blank page or internal system error 500. Does anyone have any idea how to solve this?

Share this post


Link to post
Share on other sites

Same problem than lieslot : I can see everything in the back office expect for the modules section. I get a blank page or internal system error 500.

Share this post


Link to post
Share on other sites

This is a bug, you can try to To disable smarty cache (advanced parameters->>performance)

Share this post


Link to post
Share on other sites

Hello There,

I am using default English theme, my site was working fine, I have got message that new version available of Prestashop. So i Clicked on update but after updating getting error on admin page(back Office)

{Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.}

So please tell me solution as soon as possible.

 

Thanks :-(

Somit

Share this post


Link to post
Share on other sites

if you've got internal server error = turn on error reporting - then instead of this message you will see detailed information what and where doesnt work.

 

open config/defines.inc.php

 
find this line define('_PS_MODE_DEV_', false);
change to look like this: define('_PS_MODE_DEV_', true);

Share this post


Link to post
Share on other sites

i think you are not getting my point. i have updated prestashop in back office after that i am getting this error in back office.

not able to access back office and front office.

Share this post


Link to post
Share on other sites

If you activate debug-modus, you will get the errors and can debug. Please proceed according Vekia's instructions.

Share this post


Link to post
Share on other sites

i think you are not getting my point. i have updated prestashop in back office after that i am getting this error in back office.

not able to access back office and front office.

this is why i suggested to turn on error reporting.

without debug information, it's impossible to help in cases like that.

Share this post


Link to post
Share on other sites

i think you are not getting my point. i have updated prestashop in back office after that i am getting this error in back office.

not able to access back office and front office.

 

For more information about this error, Please read the Error 500 blog post in my Signature. That should also point you in the right direction.

 

Once you get the error, (after Error Reporting is turned on) please copy the error in this thread and we will help you out. 

Share this post


Link to post
Share on other sites

Hello Representative,

 

Kindly check attached image. Comapre option not working in my site, i have installed default theme Prestashop 1.5 English version. 

So please suggest me solution. while features are same but not able to compare products.

post-736821-0-78460100-1390855202_thumb.jpg

Share this post


Link to post
Share on other sites

Hello Representative,

 

Kindly check attached image. Comapre option not working in my site, i have installed default theme Prestashop 1.5 English version. 

So please suggest me solution. while features are same but not able to compare products.

 

Hi, the comparison feature will not compare the descriptions. However, it will compare the features that you have in your products. You have not yet added any features to your products. You can add features in the Back Office/Catalog/Features 

 

You need to add both Features and Feature values. 

 

Example: A feature would be "Screen size" and Feature values can be "4.3 inches" or "5 inches" etc.. Once you do that, you can add the features within each product in the Edit Product section of the catalog. 

 

That will be better for using the Product Comparison.  Thank you!

Share this post


Link to post
Share on other sites

Maybe it will be useful information for some of you:

 

I had problems with HTTP Error 500... and spend many hours reading forum topics and trying many solutions... turning on error reporting / disabling some modules / reuploding files / cheking server configuration and many more...

 

Finaly I found solution in some blog, away from PS community :) Its:

1. Turn On and turn Off the SEO friendly URLs. This will generate the a .htaccess file on your root.
2. Download the .htaccess file. Comment the line “SetEnv HTTP_MOD_REWRITE On” by putting # before the line and reuplod.
3. If the version of PHP running on your server is 5.4 (5.5 / 5.6), change it to 5.2.

 

This should solve your problem ;)

  • Like 1

Share this post


Link to post
Share on other sites

I ran the One-Click upgrade with the option to change to the default theme on (ypgrading from 1.6.0.11 to 1.6.0.14). Although there was no default theme version, only my "custom bootstrap" theme. After upgraded, no theme was set and I got 500 server error. I discovered the problem after I changed PS_MODE_DEV as suggested by vekia on jan/21/2014. I decided to restore my backups and ran one-click upgrade again , this time with the option turned off. Hope it helps someone in the future.

 

 

if you've got internal server error = turn on error reporting - then instead of this message you will see detailed information what and where doesnt work.

 

open config/defines.inc.php

 
find this line define('_PS_MODE_DEV_', false);
change to look like this: define('_PS_MODE_DEV_', true);

 

Share this post


Link to post
Share on other sites

I am also facing the same issue "Server Error 500" while changing default theme by adding new downloaded theme as zip folder.first time i got a new theme without any css or js while loading front end.Currently a server error shows in each page while calling front end url.please anybody helps to solve my issues.

 

thanks in advance

Share this post


Link to post
Share on other sites

Hi,

 

I'm using Ps 1.4.9 i can access back office but on front page i'm getting error 500 after i edited the config file now i can see the error can someone help what can be the problem see below error:

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/username/public_html/classes/MySQL.php on line 34

Warning: Cannot modify header information - headers already sent by (output started at /home/username/public_html/classes/MySQL.php:34) in /home/username/public_html/classes/FrontController.php on line 370

Warning: Cannot modify header information - headers already sent by (output started at /home/username/public_html/classes/MySQL.php:34) in /home/username/public_html/classes/FrontController.php on line 371

 

the front page doesnt show any thing.

 

Gabriel

Share this post


Link to post
Share on other sites
On 1/21/2014 at 3:43 AM, vekia said:

if you've got internal server error = turn on error reporting - then instead of this message you will see detailed information what and where doesnt work.

 

open config/defines.inc.php

 
find this line define('_PS_MODE_DEV_', false);
change to look like this: define('_PS_MODE_DEV_', true);

The funny thing on my problem is that after change the false to true, it does not show the error but gives the error 500 message. Also, the only problem is in the module page. All others work very good.

What do you suggest?

Share this post


Link to post
Share on other sites

I had same troubles with Error 500, and I solved them by removing the /var/cache directory. 

After that, my site was working again. 

Share this post


Link to post
Share on other sites
5 hours ago, jemm971 said:

I had same troubles with Error 500, and I solved them by removing the /var/cache directory. 

After that, my site was working again. 

I do not find that var directory in Prestashop 1.5.6.0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More