Jump to content

Recommended Posts

I installed Prestashop 1.7 on the following folder 

https://qiladah.com/presta17/index.php

and I cant access my admin panel; it says page not found 

these information were sent to me the moment I installed my prestashop 

URL : https://qiladah.com/presta17
Admin URL : https://qiladah.com/presta17/admin123

 

How do I make it work ? 

 

 

 

 

 

Share this post


Link to post
Share on other sites

The software renamed the admin folder after you delete the install folder that the installer tells you to.

Just go into cpanel and hit file manager and look for a folder that starts with the word adminandsomerandomcrap

that will be your way to backoffice

so domain/folder/admin+string it makes

Share this post


Link to post
Share on other sites

so your structure looks like this?

public_html/presta17/admin123

 

If so then the cause is the A in admin must be capital so rename the folder to Admin123. If ya used softalicious this is the case. if ya manual install you  just need to name is something different then admin.

 

 

Edited by jstillings1 (see edit history)

Share this post


Link to post
Share on other sites

yes you are right. I built up my store on opencart as I am planning now to re build it again on prestashop using other folder. 

qiladah.com is the opencart 

qiladah.com/presta17 is the prestashop. 

now, can  I have theme both until I have my prestashop store ready ?

 

Share this post


Link to post
Share on other sites

So your root domain is showing an Opencart that is colored so badly it looks to be missing. it is really there. Your Presta17 folder is giving an error because of open cart and its friendly URL redirect system saying Opencart does not have a page called presta17. same thing with your admin page.

If your on a cpanel just go park a domain name pointed at the folder presta17 and use that domain to access presta

You can put up an open cart and a presta on same server just most people do it like this

open cart is public_html/opencart/

presta is public_html/presta17/

 

Then they park a domain name to that open cart and another to the second.

 

Since your using root as the server you will have to set it up like that.

Domain => root will only allow whatever software is in root to control your URL mapper

Share this post


Link to post
Share on other sites

This is pretty neat!

Your 302 for parking the subdomain was successful.

http://prntscr.com/l421m6

So your site would be http://qiladah.qiladah.com

and your backoffice will be http://qiladah.qiladah.com/admin1231992

Now the thing is your http server is getting a 302 on every resource.

http://prntscr.com/l424j5

 

The actual error message is even odder

http://prntscr.com/l4251j

 

It appears you did the subdomain incorrectly causing the 302.

if your on cpanel undo what you did and try this

https://documentation.cpanel.net/display/74Docs/Subdomains

In the box with the house on left type public_html/presta17/

 

Now delete all the stuff in presta17 and install it again by going to

http://qiladah.qiladah.com

That will set up prestashop with the proper URL mapping.

Once you park a subdomain you only use that as the address never the folder you dumped it in on the main.

 

That should get ya set up.

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

i do not understand what's going on. I created a new subdomain and install presta as following:

A new installation of PrestaShop 1.7 1.7.4.3 has been completed. The details of the installation are shown below:
Path : /home/qiladahc/public_html/test/test
URL : http://test.qiladah.com/test
Admin URL : http://test.qiladah.com/test/admin123

 

it gives me 500 internal server error when I open the admin link 

 

 

Share this post


Link to post
Share on other sites

That is awesome news!

You might think that a  500 error is a bad thing but I assure you the subdomain/install was done the right way now. You are now caught up to everyone else who uses a cpanel server.

The issue is now because of Cpanel and WHM and PHP settings.

On that server the only fix is to wait for Cpanel to push a  fix. It is a complicated technical answer as to why, which I will spare you.

I will link you the topics on Cpanel

https://forums.cpanel.net/search/22470757/?q=php+fpm&o=date

https://forums.cpanel.net/threads/allow_url_fopen-does-not-change.631395/#post-2601473

 

Just hang out and grab a coffee as CPanel is realizing their Easy Apache 4 push and  failed PHP-FPM deployment and force of allow_url_fopen was a really bad idea which broke about everything but wordpress sites.

 

 

Share this post


Link to post
Share on other sites

I turned on but it did not work too. 

meanwhile I tried to delete the htaccess file from the admin folder and it worked!

I do not know how far is this will take me but at least I can access my admin panel now.

if I am not mistaken; I understand that I have deleted the server access file which was preventing my admin panel to show up

 

Share this post


Link to post
Share on other sites

Prestashop has a ton of .htaccess files in it under numerous folders. The 500 Error is solvable the 403 that will follow is not  unless Cpanel pushed a fix that i am unaware of. But I admire you for sticking at it!

You can catch some of the fun i had on youtube if you get board and want to see me trouble shoot that 500 and 403  all night long:)

jeremiah stillings is the thing to search. or you can catch some fun on the https://github.com/PrestaShop/PrestaShop/issues/10768  lots of fun videos there!

Edited by jstillings1 (see edit history)

Share this post


Link to post
Share on other sites
  • 3 months later...
  • 5 months later...

Hi, I have successfully installed version 1.7.2.5 on my backup server using the guidance given in this link: https://hostadvice.com/how-to/how-to-install-prestashop-on-ubuntu-18-04-server/. My ubuntu is 18-04 server LTS and I followed the guide exactly as given without getting any errors. I deleted the folder install and renamed the folder admin to Admin123. I can access the shop, using the servers static IP that is 82.135.199.207. However, when trying to access the back-office in order to continue the setup of the shop, I am getting an error "HTTP ERROR 500". Any advises how to overcome this problem would be very much appreciated. Thank you!

Share this post


Link to post
Share on other sites

I bet if you check the admin folder is not named Admin123. It appends a huge string of characters sometime during the install after you delete the install folder.

If it was just admin when you renamed it, then Prestashop probably renamed it after you did.

 

Share this post


Link to post
Share on other sites

@Vidar Bjerkeland If you got an HTTP error 500, I would suggest that you enable the debugging mode to find the actual error message. There are 2 ways to enable debugging mode:

The first method to enable debugging mode (if you are able to access the back office / admin page)

1) Log into the back office - > Go to Advanced Parameter -> Debug mode

2) Then enable the debug mode -> Yes

3) Save it

The second method to enable debugging mode (if you are not able to access the back office / admin page)

1) Go to your root prestashop installation directory and edit this PS config file : /public_html/config/defines.inc.php

2) Using editor with a line number, at the line 29 you will see the following code:

/* Debug only */
if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', false);
}

change the false to true like below:

/* Debug only */
if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', true);
}

3) Save it.

After enabling the DEBUG Then, go back to the page that trigger the blank page or internal error 500. There must be some error messages that will appear and from there you can share the error message for us to help.

Another important thing is, if your shop is not ready for live production, then do not enable the cache option at the back end because when u try to make some changes, it might break something like having blank page, cache files that conflicts with another module, etc. I think by default it is enabled.

it is not recommend to enable cache setting if the shop is in development status or not ready for live production. Sometimes blank page problem can be problem with the server configuration like file permissions but the common problem in prestashop is due to the the PS cache that needs to be cleared or disabled.

Let's say that you are not able to disable the cache option at the backoffice because of the blank page, then you have to manually disable it through mysql database. To disable the cache manually:

1) Go to your SQL database management like phpmyadmin, find the table that says something like PS_CONFIGURATION or *_CONFIGURATION

2) Find a field called PS_SMARTY_CACHE and put the value as 0 and PS_SMARTY_CLEAR_CACHE put the value as everytime

3) Save it and try reload the blank page.

Edited by arafatx
Make changes to the setting path. (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...
On 10/1/2018 at 12:28 AM, qiladah said:

I installed Prestashop 1.7 on the following folder 

https://qiladah.com/presta17/index.php

and I cant access my admin panel; it says page not found 

these information were sent to me the moment I installed my prestashop 

URL : https://qiladah.com/presta17
Admin URL : https://qiladah.com/presta17/admin123

 

How do I make it work ? 

 

 

 

 

 

I had the same issue with prestashop 1.6 version, and solved with downgrading php version to 5.6. You could try that

Share this post


Link to post
Share on other sites
  • 1 year later...
On 8/15/2019 at 9:18 PM, arafatx said:

@Vidar Bjerkeland If you got an HTTP error 500, I would suggest that you enable the debugging mode to find the actual error message. There are 2 ways to enable debugging mode:

The first method to enable debugging mode (if you are able to access the back office / admin page)

1) Log into the back office - > Go to Advanced Parameter -> Debug mode

2) Then enable the debug mode -> Yes

3) Save it

The second method to enable debugging mode (if you are not able to access the back office / admin page)

1) Go to your root prestashop installation directory and edit this PS config file : /public_html/config/defines.inc.php

2) Using editor with a line number, at the line 29 you will see the following code:


/* Debug only */
if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', false);
}

change the false to true like below:


/* Debug only */
if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', true);
}

3) Save it.

After enabling the DEBUG Then, go back to the page that trigger the blank page or internal error 500. There must be some error messages that will appear and from there you can share the error message for us to help.

Another important thing is, if your shop is not ready for live production, then do not enable the cache option at the back end because when u try to make some changes, it might break something like having blank page, cache files that conflicts with another module, etc. I think by default it is enabled.

it is not recommend to enable cache setting if the shop is in development status or not ready for live production. Sometimes blank page problem can be problem with the server configuration like file permissions but the common problem in prestashop is due to the the PS cache that needs to be cleared or disabled.

Let's say that you are not able to disable the cache option at the backoffice because of the blank page, then you have to manually disable it through mysql database. To disable the cache manually:

1) Go to your SQL database management like phpmyadmin, find the table that says something like PS_CONFIGURATION or *_CONFIGURATION

2) Find a field called PS_SMARTY_CACHE and put the value as 0 and PS_SMARTY_CLEAR_CACHE put the value as everytime

3) Save it and try reload the blank page.

Thank you very much @arafatx, I too was stuck like others but followed your steps and now able to access my site's backoffice normally.

One question: My site is currently in "WIP", should I ever turn the cache on when I go live or leave it off?

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi.  I hit this issue and nothing was working.  Deleting the install folder did not trigger the rename of the admin folder. 

I ended up relocating everything in the cache directory and tried to access the page.  Nothing but the admin folder then renamed.  Put the new name at the end of the URL and presto it worked.

Let me note, I have NO idea if this did the trick.  I tried everything I read here to no avail with multiple browser cache clearing.  So maybe it is related, maybe it isnt, but worth a shot if you arent having any luck.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More