Jump to content

Wechsel der Hauptdomain nicht Möglich. HILFE!


Recommended Posts

Hallo Community,

 

Ich hoffe ein erfahrener Prestashop-Freund findet diesen Thread und kann mir helfen.

 

Mein Wissen mit Shops ist leider noch sehr begrenzt.

 

Ich habe vor einiger Zeit einen Prestashop aufgesetzt. dieser ist auch schon fertig und ich hatte für die Bearbeitung zeitweise eine alte nicht mehr benutzte Sub Domain verwendet. Nach fertigstellen wollte ich die Domain mit der eigentlichen Hauptdomain wechseln. aber es will einfach nicht funzen. normalerweise ginge das ja wie folgt. Domain bzw. Subdomain als Hauptdomain einstellen. im Backend unter Seo & Urls die neue Domain eintragen, speichern und aktualisieren und rein theoretisch sollte das ganze dann schon fertig sein, richtig?

 

wenn ich das so getan habe und die Website aktualisiere ist die neue "Hauptdomain" sichtbar aber kann den Shop nicht aufbauen. stattdessen wird mir angezeigt das der Pfad nicht beendet werden kann.

 

Nun habe Ich bereits jemanden drauf schauen lassen der mehr Ahnung hat. aber auch er kann den Fehler hier nicht finden. Hier war dann erstmals der Moment wo auch die Website sich mal aufgebaut hat jedoch komplett ohne Inhalte :(

 

nach ergebnisloser Suche des Fehlers, hatten wir irgendwann aufgegeben und hatten die Domain erstmal wieder getauscht aber dann funktionierte plötzlich nicht mal mehr diese. erst nach einiger Wartezeit ging dann der Shop wieder.

 

Nun bekomme Ich zudem auch diverse Fehlermeldungen wenn Ich auf die Kundendaten schaue von eingehenden Bestellungen. Wobei diese Fehler nicht die Funktion dabei beinträchtigen.

 

Kennt jemand diese beschriebene Problem und hat einen Ratschlag wie ich das lösen könnte?

 

Habe schon überlegt einen Datenbank Backup zu machen udn Prestashop neu aufzusetzen. Fraglich ist natürlich ob der Fehler in der Datenbank selbst liegen könnte. Dann bringt mir das neu aufsetzen auch nicht viel.

 

Freue mich über jede Antwort.

 

Liebe Grüße

Patrick

Share this post


Link to post
Share on other sites

1. Umleitungen auf die Unterverzeichnisse der Domain sind korrekt gesetzt? (einfach mal eine html-Seite ind Verzeichnis und aus dem Browser aufrufen)

2. Wie verhält es sich mit den DNS-Settings serverseitig? (s.o.)

3. Sind in der .htaccess irgendwelche Settings, die auf die alte Subdomain pointen? (evtl. htacess mal umbenennen)

4. Die Sache ist beim alten Provider geblieben? (wenn nicht, kann es helfen, abzuwarten, bis die DNS-Routings passen, bis zu 24h)

Share this post


Link to post
Share on other sites

Es gibt hier in der Abteilung Benutzerleitfäden auch eine Anleitung zum Domainwechsel, so ist meines Wissens auch eine Änderung von Einträgen direkt in der Datenbank erforderlich. 

 

Ggf. schreibe genau, was du gemacht hast und was passiert, wenn du die Seite aufrufst (bzw. gib uns einen Link), bei Fehlermeldungen brauchen wir den genauen Text. Ggf. kann es helfen, die .htaccess umzubenennen, um falsche Einträge darin auszuschließen.

Share this post


Link to post
Share on other sites

Hallo,

 

Vielen dank vorab für euren raschen und informativen Antworten.

 

Bevor Ich versuche die offenen Fragen zu beantworten, wollte Ich schauen das Ich die gegeben Ratschläge einmal teste.

 

Ich habe die HTACCESS einmal umbenannt. -> die eigentliche Hauptdomain unter Seo & Urls´s eingetragen. -> vorsichtshalber auch die alte Subdomain komplett auf einen Shopfremden Ordner umgeswitcht. Cache gelert.. Der Umleitungsfehler ist leider geblieben hierzu habe ich ein Screenshot gemacht.

 

von der neu generierten HTACCESS habe Ich ebenfalls 3 Screenshots gemacht.

 

In der HTACCESS steht die richtige Domain nach der Umstellung drin.

 

 

Vielen dank im voraus für mögliche Ideen.

 

Liebe Grüße

Patrick

 

post-1334649-0-89950200-1497787984_thumb.png

post-1334649-0-15557900-1497787992_thumb.png

post-1334649-0-15250300-1497787997_thumb.png

post-1334649-0-48818000-1497788002_thumb.png

Share this post


Link to post
Share on other sites

Jetzt solltest du doch auch im Backend sehen, was da bei SEO&URL so eingestellt ist....

 

Dann vielleicht auch mal alle Fremdmodule und Overrides im Bereich Leistung deaktivieren, um zu sehen, ob da irgendwas nicht so ganz korrekt eingestellt ist.

Share this post


Link to post
Share on other sites

Hallo Claudio,

 

Habe es gerade einmal mit dem Deaktivieren der Fremdmodule und Overrides probiert aber Problem bleibt weiterhin bestehen.. im DNS auch mal eben geschaut. dort ist soweit keine auffällige Veränderung wie mir scheint.

Sitemap ist offenbar auch mit dem Domainwechsel weg.

 

Liebe Grüße

Patrick

Share this post


Link to post
Share on other sites

Wenn dei Umleitung weiter besteht, dann muss aber irgendwo in den Settings des Shops selbst oder eben auf dem Server eine Umleitung sitzen. Wenn ich den fliesendings da eingebe, lande ich auf einer Seite freebuy...

 

Oft sind es nur kleine Settings, an die kein Mensch denkt, die einem aber dann zu schaffen machen. Ich kann das aus leidvollen durchgeackerten Nächten sagen, wo dann am nächsten tag ein anderer 5 Minuten rumgeklickt hat und es lief...

Share this post


Link to post
Share on other sites

ja die Freebuyshop ist die vorrübergehende subdomain. da die seite ja noch weiterhin erreichbar sein muss (schon allein wegen der Schnittstelle)

damit diese erreichbar bleibt schalte ich nach dem Probieren wieder auf diese seite um.

 

das ist aber auch sehr verflixxt mit diesen einstellungen :)

Share this post


Link to post
Share on other sites

unter URL Einstellungen für benutzerfreundliche URL fiel mir eben auf das darunter folgendes Problem beschrieben ist:

 

 

Eine URL-Umleitung (mod_rewrite) ist auf Ihrem Server nicht aktiviert, oder es ist nicht möglich, Ihre Serverkonfiguration zu überprüfen. Für die Suchmaschinenoptimierung muss mod_rewrite aktiviert sein.

 

Könnte das der Grund sein? wenn dem so wäre, wie aktiviert man das dann?

Share this post


Link to post
Share on other sites

Zunächst muss mal geprüft werden, ob das Modul auf deinem Apache installiert und eingeschaltet ist.

 

Dazu erstellst du eine php-Datei z.B. info.php mit folgendem Inhalt:

<!doctype html>
<html>
<head>
<meta charset="utf-8">
<title>Server-Informationen</title>
</head>

<body>
<?PHP
phpinfo ();
?>
</body>
</html>

Die lädtst du dann auf den Server und rufst sie im Browser auf.

 

Da such mal nach "mod_rewrite"

 

Wenn er was findet, könnte das so aussehen: $_SERVER['HTTP_MOD_REWRITE'] On

Allerdings läuft der Shop ja im anderen Verzeichnis auch, und wenn es ein- und der derselbe Server ist, dann glaube ich eher nicht, dass es daran liegt.

Share this post


Link to post
Share on other sites

ja die Freebuyshop ist die vorrübergehende subdomain

Was verstehst du unter einer "Subdomain"? www.freebuyshop.de ist jedenfalls keine Subdomain im üblichen Sprachgebrauch (shop.freebuyshop.de wäre eine). Solche Differenzen können zu fatalen Fehlern führen.

 

Das mit dem nicht erkannten mod_rewrite ist normal, ist bei mir auch so. Es ist ja auch offensichtlich, daß Umleitungen funktionieren, sonst hättest du das Problem ja nicht! Um helfen zu können, müßtest du irgendwann noch mal die Einstellungen für die neue Domain aktivieren, dann kann man schauen, ob einem was auffällt und / oder genau angeben, welche Änderungen du denn jetzt genau vorgenommen hast, ansonsten ist alles pures im Nebel stochern.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Die genaue Fehlermeldung wäre hier sehr hilfreich, und ggf. ein Auszug aus dem Error-Log des Servers.

 

Wir klonen und kopieren Shops fast täglich. Das läuft zwar automatisiert, aber die notwendigen Schritte sind wie folgt:

 

A ) Datenbank:

 

1. ps_configuration

 

PS_SHOP_DOMAIN

PS_SHOP_DOMAIN_SSL

 

2. ps_shop_url   (was viele nicht wissen, dass es diese Tabelle gibt)

 

Ohne Multi-Shop hat diese Tabelle nur einen Eintrag, und darin auch wieder die Felder domain und domain_ssl.
Eigentlich ein Ärgernis, dass das an zwei Stellen redundant verpackt ist.

 

B ) .htaccess neu schreiben

 

Wenn es damit nicht geht, dann besteht m.M.n. ein Problem ausserhalb von PrestaShop.

Edited by Scully (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More