Jump to content
gelöschter user

Seite wird wegen Suchformular als unsicher gemeldet

Recommended Posts

Hallo zusammen

 

Es geht um diese Seite:

 

https://www.einradshop.ch/einrad-shop

 

 

Sie wird als unsicher gemeldet, weil das Suchfeld (oben rechts) anscheinend über eine unsichere Verbindung umgeleitet wird

 

Mixed Content: The page at 'https://www.einradshop.ch/einrad-shop/de/einrad-kaufen-schweiz' was loaded over a secure connection, but contains a form which targets an insecure endpoint 'http://www.einradshop.ch/einrad-shop/de/suche'. This endpoint should be made available over a secure connection.

 

Ich möchte das ändern, damit sich die Besucher sicher fühlen auf meiner Seite. Es ist mir aber total unklar WO ich das ändern kann. Ist ja nicht eine einfach html- seite. 

 

Könnt Ihr mir also bitte einen Tip geben wo ich den Link auf https einstellen kann ?

 

Besten Dank und Gruss

 

Stefan

Share this post


Link to post
Share on other sites

Hallo Einrad, ich bin noch nicht ein spezialist. Brobier mal im Backofice Voreinstellung. dort ist am Anfang ein schalter "SSL auf allen Seiten anwenden" stell den mal auf on. Ich denke das sollte es sein.

Share this post


Link to post
Share on other sites

Hallo Jubara. Das ist schon so eingestellt und alle Seiten sind auf SSL. Nur eben nicht dieses Suchformular, das zwar in die SSL- Seite eingebettet ist, aber anscheinend die Daten unverschlüsselt überträgt

Share this post


Link to post
Share on other sites

Ja wie gesagt, bin noch nicht der spezi. Bei mir hat dies geholfen. Hoffe für Dich, dass man Dir helfen kann.

Share this post


Link to post
Share on other sites

Das sieht mir so aus, als wäre das einfach ein Problem mit dem Template. Da ist einfach HardCoded http drinnen.

post-1091593-0-03013900-1481091408_thumb.png

Am besten lädst du dir dein Template runter, und durchsuchst den Ordner z.B. mit notepadd++ und ersetzt jegliches HTTP mit HTTPS

 

Zumindest wäre das eine Idee

 

Denn du hast noch mehr http links in deinem Shop.

Aber meine o.g. Möglichkeit, ist nicht das Ultimative, denn so könntest du nich tmehr auf http umschalten ohne das die links weiter https zeigen.

Edited by Lausli (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Das ist verzwickter als ich dachte. Ich nehme an es ist im Ordner "Themes" zu finden. Da gibt es nur Dateien mit Endung tpl oder php. Und die sind voll von irgendwelchen Variablen. Es existiert aber keine Seite mit html, wo ich diese http / https - Links finde.

 

Bin grad etwas ratlos. Ich meine mein 1.4.9 Shop funzt wirklich gut, hat einen guten Workflow und ich hab keine Lust auf 1.6 umzusteigen. Vielleicht mal ein Update auf 1.7.

 

Wäre es evt. eine gute Idee Template neu einzuspielen oder besser  nicht ? (never change a running system)

Share this post


Link to post
Share on other sites

Warum machst du nicht einfach, was Lausli dir rät (im Ordner des Themes sollte reichen)? Sicherheitshalber solltest du vorher die Originaldateien sichern (aber das soll man sowieso von Zeit zu Zeit).

Share this post


Link to post
Share on other sites

Da ich nicht weiss wie man das thema exportiert schaute ich in einer Sicherung nach, die ich gestern machte. Ich nehme an der Ordner "Theme" ist für die Templates gedacht. Ich wurde darin auf jeden Fall nicht fündig, wie vorhin beschrieben wimmelt es von dateien, daher weiss ich nicht wo ich die Suche ansetzen soll.

 

post-302476-0-04164300-1481146268_thumb.pngpost-302476-0-21083000-1481146312_thumb.png

Edited by einrad (see edit history)

Share this post


Link to post
Share on other sites

Sei mir nicht böse, aber es ist sinnlos, mit einem relativ komplexen Shopsystem zu arbeiten oder gar Änderungen durchführen zu wollen, ohne die Grundlagen überhaupt verstanden zu haben. Denn auch das "Innenleben" von 1.4.9 scheint dir ja fremd zu sein, sonst würdest du solche Fragen überhaupt nicht stellen.

 

Deshalb rate ich dir dringend, dich erst einmal mit Prestashop gründlich vertraut zu machen. Wenn dir dazu die fachlichen Kenntnisse fehlen oder du das auch gar nicht möchtest , wirst du dir wohl jemanden suchen müssen, der deinen Shop in technischer Hinsicht betreut. Sonst wird dir ein Upgrade wohl kaum gelingen.

Share this post


Link to post
Share on other sites

Ich seh den Sinn nicht ganz hinter Deiner Antwort. Ein Forum dient ja genau denen, die sich  schwertun und Hilfe brauchen. Wüsste ich alles hätte ich den Beitrag nicht geschrieben. Immerhin betreibe ich den Shop schon ein paar Jahre, nur so ganz Nebenbei bemerkt. Wenn es so ist dass man nichts fragen darf, dann lass ich das mal so stehen und logg mich aus dem Forum aus. Auf Nimmerwiedersehen

Share this post


Link to post
Share on other sites

Nur für den Fall, dass Du oder jemand anderes das noch liest:

 

Was wir hier versucht haben zu erklären ist die Tatsache, dass man Updates einspielen sollte. Du musst nicht auf 1.6.1.x umsteigen aber Sicherheitsupdates einspielen.

Du benutzt jetzt eine ältere Version. Diese ist angreifbar und unsicher. Es geht hier um deine Kundendaten und den Datenschutz. Auch um deinen Server, der gekapert werden kann. Theoretisch.

 

Da du Probleme hast an sich einfache Umsetzungen durchzuführen wurde geraten sich mehr damit zu befassen. Das hat den Grund, dass ein Shop eben einen gewissen administrativen Aufwand mit sich bringt den man betreiben sollte um einen sicheren Betrieb zu gewährleisten.

 

Dein Linux Mint System aktualisierst du ja auch mit täglichen Sicherheitsupdates. Aus guten Grund.

Am Ende wollen wir halt nur helfen. Es wäre fahrlässig von uns Dich nicht darauf hinzuweisen und dir nur zu erklären, wie du Änderungen vornimmst. SSL / Http und https gehen ja zwangsläufig in einen Sicherheitsbereich.

 

Viel Glück

Share this post


Link to post
Share on other sites

Das Problem ist ja bereits, daß er offenbar nicht versteht (oder nicht richtig liest), wie man mit Notepad+ Strings in einem kompletten Ordner ersetzt, das ist schließlich eine absolute Grundlage weit unterhalb den üblichen Anforderungen, die ein System wie Prestashop stellt.

Share this post


Link to post
Share on other sites

Naja in Linux(Mint) gibt es per Editor diese Funktion nicht default mäßig im gedit oder geany etc.

 

Aber es gäbe wie mit notepad++ oder notepaddqq die das nachrüsten.

 

Vielleicht mach ich mal einen Leitfaden für sowas. Grundvoraussetzungen, Tools etc.

 

Aber ich befürchte das das nichts am Kern der Sache löst.

 

Naja hoffen wir es :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More