Jump to content
PIXnetDesigns

Probleme mit Benutzeranpassung (Textfeld)

Recommended Posts

Hallo,
 
ich habe mal wieder ein Problem, für welches ich keine Lösung finde.
 
Ich habe einen Artikel angelegt und in den Benutzeranpassungen ein Textfeld hinzugefügt.
Soweit Sogut.
 
Das erste Problem tritt bereits bei der Bestellung auf. Ich gehe in den Artikel, wähle meine Einstellungen wie Größe und Schriftart, gebe den Text in das vorgesehene Textfeld ein, Speichere den Text. Bis hier hin klappt es ganz gut. Wenn ich den Artikel nun in den Warenkorb legen möchte, leert er das Textfeld und sagt, dass Pflichtfelder gefüllt werden müssen.
 
Wenn man den Artikel Direkt mit PayPal über den entsprechenden Button zahlt, dann funktioniert die Bestellung und er legt den Artikel auch in den Warenkorb. Nun ist aber das Problem, dass der hinterlegte Text nicht angezeigt wird. Weder in der Bestellung noch sonst irgendwo.
 
Ist das ein Allgemein bekannter Bug oder was läuft hier falsch?
 
Ich nutze Prestashop 1.6.1.4 mit diesem Theme: http://addons.presta...age-planet.html
 
 
 
 
Dazu hätte ich auch noch gern gewusst, ob es eine Möglichkeit gibt, dieses textfeld mit bei den Varianten aufzuführen? Das wäre etwas benutzerfreundlicher.

post-1095429-0-26228300-1470228829_thumb.png

post-1095429-0-75029400-1470228829_thumb.png

Share this post


Link to post
Share on other sites

Der Artikel ist deaktiviert.

 

Ich würde mal auf ein Problem mit dem Theme tippen.

Share this post


Link to post
Share on other sites

 

Dazu hätte ich auch noch gern gewusst, ob es eine Möglichkeit gibt, dieses textfeld mit bei den Varianten aufzuführen? Das wäre etwas benutzerfreundlicher.

 

Es gibt ein Modul, daß das Textfeld nach oben zieht:

http://addons.prestashop.com/de/17365-move-customization-fields-to-the-top.html

 

Die Probleme könnten durch dein Template hervorgerufen werden, wobei ich mich frage ob du dieses Template überhaupt rechtssicher hinbekommst? (In dem Zusammenhang vielleicht auch mal dein Impressum rechtssicher machen <_< gerade die offensichtlichen Impressum-Mängel sind leichte Beute für die Abmahner)

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Der Artikel ist deaktiviert.

 

Ich würde mal auf ein Problem mit dem Theme tippen.

 

Ja ich habe ihn erst mal deaktiviert, da er nicht funktioniert hatte aber bereits Bestellungen über den angesprochenen paypal-direkt-button eingeflogen sind. Kann ihn als Anschauung aber gern noch mal aktivieren.

 

 

Es gibt ein Modul, daß das Textfeld nach oben zieht:

http://addons.prestashop.com/de/17365-move-customization-fields-to-the-top.html

 

Die Probleme könnten durch dein Template hervorgerufen werden, wobei ich mich frage ob du dieses Template überhaupt rechtssicher hinbekommst? (In dem Zusammenhang vielleicht auch mal dein Impressum rechtssicher machen <_< gerade die offensichtlichen Impressum-Mängel sind leichte Beute für die Abmahner)

 

Grüsse

Whiley

 

Das wäre extrem Schade, da das Theme recht teuer war. Aber das ist ein guter Hinweis. Ich werd es mal mit dem Originalen Theme testen.

 

Und danke für den Hinweis mit dem Impressum. Ich hatte es mit der hilfe von erecht 24 erstellt, da mein Kunde nicht bei kommt mir eins von seinem Anwalt oder so zu liefern. :/

Share this post


Link to post
Share on other sites

Und danke für den Hinweis mit dem Impressum. Ich hatte es mit der hilfe von erecht 24 erstellt, da mein Kunde nicht bei kommt mir eins von seinem Anwalt oder so zu liefern. :/

Ähm, du bist nicht der Shopbetreiber, sondern hast den Shop als Dienstleister für einen Kunden erstellt?

 

Dann solltest du dich wenigstens mit den absoluten Grundlagen auskennen. Das Impressum hat immer noch Mängel (und das ist ja wirklich kein Hexenwerk), den Unterschied zwischen Umsatzsteuernummer (die nicht angegeben werden muß und aus Datenschutzgründen auch nicht angegeben werden sollte) und USt.Id-Nr. (die angegeben werden muß, wenn es eine gibt, was nicht obligatorisch ist) solltest du kennen und daß "Deutschland" Berufsbezeichnungen verleiht, ist mir auch neu. Und was ist mit Mehrwertsteuer und Versandkosten?

 

Wir dürfen hier ja keine Rechtsberatung leisten, aber ich würde den Shop sofort offline nehmen.

Share this post


Link to post
Share on other sites

Kann ich nur bekräftigen, aber auch aus anderen Gründen! Denn da der Shop

  • weder MwSt. noch Versandkostenlink beim Produkt aufweist,
  • außerdem den in Deutschland nicht rechtsicheren Checkout PrestaShops einfach übernimmt,
  • weder AGB-Bestätigung noch Widerrufsbelehrung dem Kunden zumutet,
  • den rechtlich problematischen Express-Checkour Paypal aktiviert hat
  • und ... und ... und ...,

wäre es für jeden eine wunderbare Gelegenheit, bei Problemen den für den Internetauftritt verantwortlichen Webdesigner auf Schadenersatz zu verklagen. Denn das wäre problemlos für jeden Kunden möglich!

Sei mir nicht böse, aber allein das dilettantische Layout ist schon eine Zumutung! Ich nehme mal an, du übst noch und verlangst doch hoffentlich kein Geld dafür, oder? ;)

 

Das würde auch den Fehler bei Aufruf deiner eigenen Website erklären:

 

Fatal error: Uncaught exception 'UnexpectedValueException' with message 'The current host header value does not match the configured trusted hosts pattern! Check the pattern defined in $GLOBALS['TYPO3_CONF_VARS']['SYS']['trustedHostsPattern'] and adapt it, if you want to allow the current host header 'www.pixnet-designs.de' for your installation.' in /var/www/vhosts/pixnet-designs.de/httpdocs/t3src/typo3_src-6.2.6/typo3/sysext/core/Classes/Utility/GeneralUtility.php:3413 Stack trace: #0 /var/www/vhosts/pixnet-designs.de/httpdocs/t3src/typo3_src-6.2.6/typo3/sysext/core/Classes/Utility/GeneralUtility.php(3469): TYPO3\CMS\Core\Utility\GeneralUtility::getIndpEnv('HTTP_HOST') #1 /var/www/vhosts/pixnet-designs.de/httpdocs/t3src/typo3_src-6.2.6/typo3/sysext/core/Classes/Utility/GeneralUtility.php(3478): TYPO3\CMS\Core\Utility\GeneralUtility::getIndpEnv('TYPO3_REQUEST_H...') #2 /var/www/vhosts/pixnet-designs.de/httpdocs/t3src/typo3_src-6.2.6/typo3/sysext/core/Classes/Utility/GeneralUtility.php(3483): TYPO3\CMS\Core\Utility\Genera in /var/www/vhosts/pixnet-designs.de/httpdocs/t3src/typo3_src-6.2.6/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 3413

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More