Jump to content

[SOLVED] friendly URL and images not showing


mdgt
 Share

Recommended Posts

Prestashop 1.5.2, fresh install.

 

Not having friendly url activated gives me the following URL to images:

http://www.xxxxx.no/img/c/6-category_default.jpg

Having friendly url activated gives me the following:

http://www.xxxxx.no/...ential-oils.jpg

 

This results in images with a ? showing everywhere except for the logo.

 

 

As you see it is missing the /img/. How do I correct this issue in a quick way?

 

 

 

 

Best regards

//Anders

Edited by mdgt (see edit history)

Share this post


Link to post
Share on other sites

Under the preferences -> images have you got "Move Images" section ?

pref025-imageMove.png?version=1&modificationDate=1344444532000

PrestaShop has two image storage systems: the legacy one, which is efficient and has proven its worth over many versions of PrestaShop, and an improved one, which offers even better performance. You can keep relying on the old one, but you might want to use the new one, in which case you will need to trigger a one-time moving process of all the images.

The process is really simple: just click on the "Move images" button, and PrestaShop will take care of everything. Once the process is completed, do not forget to change the "Use the legacy image filesystem" option, and set it to "No".

Share this post


Link to post
Share on other sites

okay, now it's all clear for me, i hope so ;-)

 

 

i've noticed that you use non-default template, so - can you please paste the here the list of images defined under the preferences -> images ?

Share this post


Link to post
Share on other sites

hey

 

i've noticed that you've got:

  1. large
  2. large_default

 

when you regenerating thumbnails, you have to regenerate large_default

(you don't have to regenerate all images - only images for your theme)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

I deleted the htaccess in root and then created a new one by going to homepage root via webbrowser.

This created a htaccess and the images appear again.

 

I can now use URL rewriting.

Share this post


Link to post
Share on other sites

I deleted the htaccess in root and then created a new one by going to homepage root via webbrowser.

This created a htaccess and the images appear again.

 

I can now use URL rewriting.

 

Happy to hear that, so, the problem was with htaccess file

 

@Frenkie please follow mdgt suggestions and let us know

Share this post


Link to post
Share on other sites

  • 2 weeks later...

The friendly URL option did not work on products but worked on categories on my site (1.5.4.1) If you have this problem then this worked for me.

Ignore the 'mod_rewrite is not working on your server' error when you switch-on friendly URLs. (Most commercial servers are running Apache :)

Look at the Schema of URLs section at the bottom of the URLs & SEO page. My 'Route to products' box had this in it:

{category:/}{id}-{rewrite}{-:ean91}

Below it had the number 13 in red. I inserted this number into the box and all friendly URLs work.

{category:/}{id}-{rewrite}{-:ean13}

Share this post


Link to post
Share on other sites

  • 2 weeks later...

I have a similiar problem when enabling friendly URL on Prestashop 1.5.4.1: category images are not showing, products and everything else are fine.

 

I have re-generated images and.htaccess, nothing.

 

I'm not using default theme and i'm also using Clean Url module to get rid of number prefixes so i've noticed that missing image link still has the category number prefix (6) :

 

http://www.myshop/c/6-category_themename/imagename.jpg

 

Disabling friendly url is fixing category image not showing.

 

 

Should i change something here?

 

post-538413-0-06018100-1372343607_thumb.png

Edited by yanc (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Can anyone please check the post http://www.prestashop.com/forums/topic/261070-product-images-arent-getting-displayd-with-friendly-url-enabled/ and suggest what needs to be done?

 

Our system is already has use the legacy image filesystem as no. Also we are using all custom images.

 

Will moving images to new file system help? mod-rewrite is also enabled on our server and URLs are also getting created properly.

 

Images are showing properly in admin panel.

 

Regards,

Abhijeet

Share this post


Link to post
Share on other sites

  • 3 months later...

I found the same when I just tried to switch on the freindly urls in a new website in the latest version of prestashop and the images disapeared from the thumbnails and product images.

 

I did the same as a previous contributor suggested and deleted the .htaccess file let it regenerate and then swicth the freindly urls back on and it worked.

Share this post


Link to post
Share on other sites

  • 4 years later...
  • 2 weeks later...
On 4/13/2018 at 5:45 PM, InnocentPuff said:

Has the same issue. Solve by enabling " webservice " option in Advance Parameter > Webservices. (PrestaShop 1.7)

I have enabling this, but it does not work for me. please, tell me more. Thanks

Share this post


Link to post
Share on other sites

  • 2 years later...
  • 1 year later...

Hi for those that have not yet found a solution, one possible cause is that the product has not link_rewrite value.

Go to the table ps_product_lang -> link_rewrite, it MUST have information, otherwise there is no information to build the image URL when URL friendly is active

Hope it helps!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More