Jump to content

Recommended Posts

Posted (edited)

Hallo

Ich arbeite mit Prestashop 1.7.1.0 und habe das ein Thema und mehrere Module von verschiedenen Firmen installiert.

Dabei tritt folgender Fehler auf: 

Bei Kaufabschluss bei einem noch nicht registrierten Kunden erscheint "ServerFehler 500". Kehre ich mit der Pfeiltaste zurück dann kann der Kauf vollständig abgeschlossen werden.

Kann mir jemand helfen das Problem zu lösen?

Danke, Gruß

Edited by Comshop (see edit history)

Share this post


Link to post
Share on other sites

Ja, die Serverlogs, denn irgendwo wird ja dann hingeroutet, wo eben dann der Fehler auftritt.

Hier hilft ein aktiviertes Error-Reporting und die entsprechenden Errorlogs des Servers. Beides findet man in den entsprechenden Suchen schnell und kann dann weitere Forschung betreiben.

Share this post


Link to post
Share on other sites

Danke für deine rasche Antwort.

Ich habe bereits den Debugger in PS und die error pages in cPanel aktiviert.

Da ich kein Profi bin kann ich mit den ersichtlichen Informationen nicht viel anfangen.

Gibt es Profis die gegen Bezahlung solche und ähnliche Probleme beheben? Z.Bp: WebmasterTools zeigt folgende Fehler: "offers", "review", "aggregateRating"

Share this post


Link to post
Share on other sites

.dann poste doch die infos aus den erstgenannten logs. Dazu am besten den Fehler reproduzieren 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Comshop said:

Z.Bp: WebmasterTools zeigt folgende Fehler: "offers", "review", "aggregateRating"

Das bezieht sich auf fehlende Rich text snippets im Theme. "review" und "aggregateRating" sind optional, "offers" allerdings nicht.

Der 500er deutet eher auf eineInkompatibilität hin. Ich vermute mal, der Shop läuft unter PHP 7.1 oder 7.2. Dann musst du entweder die Änderungen einspielen (kann aber auch an einem Modul liegen), die es seit 1.7.1 gegeben hat (viele!) oder upgraden. Aber bloß nicht auf 1.7.6.0, sonst kommst du vom Regen in die Traufe.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Ich arbeite mit PS und habe das Thema "wt_newdeal" und mehrere Module von verschiedenen Firmen auf der Seite (https://comshop.com.pt "Second Hand Shop") installiert.

Prestashop 1.7.1.0
PHP: 5.6.40

 

 

Folgende Probleme, die ich nach Wichtigkeit geordnet habe, sollten behoben werden.

1.) "ServerFehler 500" tritt bei Kaufabschluss bei einem noch nicht registrierten Kunden auf.
Kehre ich mit der Pfeiltaste zurück dann kann der Kauf vollständig abgeschlossen werden.
Passiert nur wenn die Hauptsprache Portugiesisch aktiviert ist, bei Englisch und Spanisch funktioniert alles einwandfrei. (Siehe Anlage 1-5)

2.) WebmasterTools zeigt folgende Fehler: "offers", "review", "aggregateRating" (Siehe Anlage 6)

3.) Social Login (Facebook, Google, PayPal) von Knowband funktioniert nicht mehr,

4.) Aktualisieren auf die best mögliche Version.

Können sie mir helfen diese Probleme zu beseitigen und mit welchen Kosten muß ich rechnen?

Anlage 1.jpg

Site Comshop Error Handling.txt

Anlage 2.jpg

Anlage 3.jpg

Anlage 4.jpg

Anlage 5.jpg

Anlage 6.jpg

Share this post


Link to post
Share on other sites

Es scheint sich ja um einen älteren Shop zu handeln, da ist die erste Frage, ist der Fehler neu und seit wann tritt er auf bzw. was ist zu diesem Zeitpunkt passiert, hast du etwas verändert / aktualisiert oder vielleicht dein Provider (z. B. die PHP-Version)?

Der Fehler tritt nach dem Klick auf den Kaufen-Button auf? Wird die Bestellung übertragen und nur die Bestätigungsseite nicht angezeigt? Passiert das bei allen Zahlungsarten?

Share this post


Link to post
Share on other sites

Den Shop gibt es seit 2010 der immer wieder bis auf die heutige Vers. 1.7.1.0 aktualisiert wurde. 

Dieser Fehler wurde bereits im Mai diesen Jahres festgestellt. Zwischenzeitlich habe ich das Thema "WT" und einige neue Module installiert. Dann habe ich den Shop auf SSL umgestellt. Leider wurde auch der Providor von einem anderen übernommen. Der vorherige hat fast immer alle Probleme gelöst, hingegen kümmert sich der aktuelle Provider um nichts.

Die Bestellung wird durch "500 Server Error" abgebrochen.

Share this post


Link to post
Share on other sites
34 minutes ago, Comshop said:

Die Bestellung wird durch "500 Server Error" abgebrochen.

Dann sollte sich im Server-Error Log eine entsprechende Meldung finden. Wenn Sie diese hier posten können wir weiterhelfen. Falls keine Meldung zu finden ist oder kein Zugriff auf die Logs besteht kann auch der Debugmodus im Presta-Backend (temporär) aktiviert werden, dann erscheint die Fehlermeldung direkt beim Abbruch.

Share this post


Link to post
Share on other sites

Ich denke, ein bißchen mußt du schon selbst recherchieren oder dir einen bezahlten Dienstleister suchen. Die Server-Logs haben nichts mit Prestashop zu tun, ob du überhaupt Zugriff hast, hängt von deinem Provider ab.

Meine Fragen hast du nicht wirklich beantwortet. Ist das jetzt ein Fehler der immer auftritt oder nur ab und zu (im letzteren Fall könnte es einfach ein TimeOut durch eine vorübergehende Überlastung des Servers sein, das passiert bei allen Onlineshops mal)?

Share this post


Link to post
Share on other sites

Vielen Dank für deine Hilfe.

Vielleicht hast du meine Frage an die Comunity vom 27.07.2019 1:03 PM übersehen:

"Da ich kein Profi bin kann ich mit den ersichtlichen Informationen nicht viel anfangen.Gibt es Profis die gegen Bezahlung solche und ähnliche Probleme beheben?" 

Share this post


Link to post
Share on other sites
1 hour ago, Comshop said:

"Da ich kein Profi bin kann ich mit den ersichtlichen Informationen nicht viel anfangen.Gibt es Profis die gegen Bezahlung solche und ähnliche Probleme beheben?" 

Klar gibt es die und viele sind auch hier im Forum aktiv. Und hier im Forum gibt es ein extra Unterforum für Jobangebote wo du deine Anfrage platzieren kannt.

Wo und ob du die Error Logs findets hängt wie Rictools schon sagte von deinem Hosting.Provider ab. Falls du das spontan nicht findest kannt du noch meinen Tipp mit dem Debug Modus ausprobieren.

Share this post


Link to post
Share on other sites
vor 9 Stunden schrieb Comshop:

Vielleicht hast du meine Frage an die Comunity vom 27.07.2019 1:03 PM übersehen:

"Da ich kein Profi bin kann ich mit den ersichtlichen Informationen nicht viel anfangen.Gibt es Profis die gegen Bezahlung solche und ähnliche Probleme beheben?" 

Du mußt dich halt entscheiden, ob du Hilfe hier im Forum suchst (dann mußt du aber auch Rückfragen beantworten, sonst kann man dir nicht helfen) oder einen Profi engagierst (aber auch der wird sich ohne klare Fehlerbeschreibung schwer tun).

Share this post


Link to post
Share on other sites

Ich habe bereits mein Anliegen im Jobcenter gepostet, in dem ich einen in dieser Materie erfahrenen Profi suche der dann auch alle technischen Zugangsdaten erhalten wird.

Danke Dir

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More