Jump to content
Presta_cool

Mise à jour 1.6.1.4 vers 1.6.1.8 erreur "index.php?controller=404"

Recommended Posts

Bonjour à tous,

 

Je me disait, non, ne fais pas la mise à jour.

Tout marche correctement pour le moment....

 

Après mise à jour 1 Click upgrade ma boutique présente un sérieux problème.

 

La page d'accueil s'affiche correctement, à part les images de mes produits.

Si je clique sur un lien quelconque, le message suivant apparait au sommet d'une page vide :

index.php?controller=404

 

Pouvez vous me mettre sur la bonne voie ?

 

Pat

Share this post


Link to post
Share on other sites

hello

je viens de faire la mise a jour ........ coté BO tout semble ok

mais coté front office ..... j'ai une magnifique page blanche ............ bon heureusement c'est sur ma boutique de test, mais ça quand même ...

Share this post


Link to post
Share on other sites

bonnnnnnn, ça se complique

j'ai voulu aller voir dans les modules et j'obtiens ça :

 

PrestaShop] Fatal error in module file :/srv/www/clients/client54/web325/web/DevTEST/modules/statsdata/statsdata.php:
syntax error, unexpected '['

Share this post


Link to post
Share on other sites

Salut,

 

Effectivement PHP < 5.3 ne gère pas un certain format. Si le problème vient de la ligne 108, tu peux aussi remplacer cette ligne dans /modules/statsdata/statsdata.php :

$this->context->controller->registerJavascript('modules-plugindetect', 'modules/'.$this->name.'/js/plugindetect.js', ['position' => 'bottom', 'priority' => 150]);

par ça :

$this->context->controller->registerJavascript('modules-plugindetect', 'modules/'.$this->name.'/js/plugindetect.js', array('position' => 'bottom', 'priority' => 150));

Ca résoudra temporairement ton problème sans devoir mettre à jour PHP sur ton serveur.

  • Like 1

Share this post


Link to post
Share on other sites

bon, oubliez ce que j'ai écrit ..... je cherchais dans le répertoire du théme ...... scouzi

Share this post


Link to post
Share on other sites

un seul mot .... génial !!

ça marche nickel, j'ai tout retrouvé !!!

 

reste a passer php en 5.4

Share this post


Link to post
Share on other sites

bonjour,

 

moi aussi je suis dans la même panade !!

après mise à jour vers 1.6.1.8

 

le message suivant s'affiche ; index.php?controller=404

 

HELP 

 

merci  :rolleyes: 

Share this post


Link to post
Share on other sites

Alors après avoir fouillé dans le forum dans les autres langues :

 

1. Se mettre en maintenance (si ce n'est pas déjà fait.

2. Vider le cache du site

3. Aller dans Préférences > SEO & URL et juste cliquer sur Enregistrer.

 

Pour moi ça a marché

  • Like 1

Share this post


Link to post
Share on other sites

merci SL-DESIGN pour la solution ! j'ai eu meme probleme a la migration vers 1.6.1.11 du coup retour en 1.6.1.9 mais le probleme persistait !!

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More