Jump to content
thokawa75

Lieferzeit: Artikel nicht mehr verfügbar...

Recommended Posts

Hallo zusammen,

habe ein Problem mit einem Artikel.

Dort steht nachdem ich ihn angelegt habe - "Lieferzeit: Artikel nicht mehr verfügbar"

Stimmt aber nicht!

Bei "Mengen" habe ich eine Zahl eingegeben und in der Haupteinstellung unter Versand steht auch die Lieferzeit drin.

Das ist auch der einzige Artikel wo das so steht...

Allerdings habe ich auch eine neue Kategorie in der Navigation angelegt und darin eben den Artikel angelegt... Kann das damit zusammenhängen und muss ich irgendwo anders noch was einstellen wo ich jetzt einfach nicht drauf komm?

Danke euch schon mal

Share this post


Link to post
Share on other sites

Welche PS-Version? Lagerverwaltung eingeschaltet? Produkt als Variante angelegt? ....

 

Poste mal deine .URL

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo,

meine Version ist 1.6.0.9

 

Lagerverwaltung ist an und auch als Variante angelegt.
Beim Produkt selber steht dann im FO der Preis usw, unterhalt ein grünes Kästchen mit "auf Lager" und darunter dann eben "Lieferzeit: Artikel nicht mehr verfügbar"
Auch ohne Variante war das so... Ist allerdings auch nur in der neu angelegten Kategorie so.
Andere Produkte die ich hinzugefügt habe in den alten Kategorien passt alles...

den Shop findest du unter http://www.Dekoversand-Walter.de

 

ach, die neue Kategorie lautet übrigens "Sichtschutz"

Edited by thokawa75 (see edit history)

Share this post


Link to post
Share on other sites

Sieht für mich nach einem Rechtssicherheit Modul oder erweitertem Shopmodul aus. Du haste eine

<p id="availability_statut">
<span id="availability_value">auf Lager</span>

für den ersten Teil und dann

<span class="delivery-info">
<span class="delivery-label"> Lieferzeit: </span>
<span class="delivery-value"> Artikel nicht mehr verfügbar </span>

für den zweiten Teil. Recht eindeutig.

Share this post


Link to post
Share on other sites

das problem ist nur, dass es NUR beim allerersten Artikel der Fall ist, den ich in der neuen Kategorie hinzugefügt habe...
bei den anderen artikel habe ich alles genau so gemacht und da passt die lieferzeit angabe...
 

Share this post


Link to post
Share on other sites

Aktuell kann ich den Fehler nicht nachvollziehen, da die Anzeige überall stimmt.

 

Unschön ist allerdings, dass EU-legal bei Artikeln, die nicht mehr lieferbar sind, überhaupt eine Lieferzeitangabe anzeigt. Da du ja auch an anderer Stelle kleine Anpassungen vorgenommen hast, solltest du vielleicht in einem solchen Fall die Anzeige komplett unterbinden. Dazu wäre nur eine zusätzliche if-Abfrage nötig in der /modules/eu_legal/views/templates/hook/displayProductDeliveryTime.tpl, und zwar direkt nach der ersten Code-Zeile {if $is_object}:

{if ($product.quantity <= 0 && $product.allow_oosp)}
Die müsste dann am Dateiende mit einem zusätzlichen {/if} geschlossen werden.

 

Übrigens interessante Arbeiten, die du da anbietest. Du bekommst vielleicht demnächst eine Bestellung. :)

Share this post


Link to post
Share on other sites

danke, werde dies dann mal versuchen, wenn ein wenig Zeit vorhanden ist ;-)
Und ebenfalls danke, dass Dir meine Arbeiten gefallen - das meiste produzier ich selber und bin da auch gut beschäftigt... deswegen bleibt leider auch das ein oder andere im onlineshop liegen - hätte noch einige produkte zum reinstellen, müsste noch produktfotos machen usw. ;-)
o.k. dann mal schauen - würd mich natürlich über eine bestellung freuen ;-)

bis dann und danke nochmal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More