Jump to content

Keeps redirecting to HTTPS even if the SSL option is disable


giwrgos88
 Share

Recommended Posts

Hello, I have downloaded a live project of prestashop on my local environment. The live version is using SSL and because i don't want to create self-signed SSL Certificate I want to disable the SSL on my local environment. So what I did I changed the value of PS_SSL_ENABLED from myphpadmin from 1 to 0 but the site keeps redirecting me to https instead of the http. I checked the site urls but they are fine same as my  htaccess. Does anyone have any idea what it keeps redirecting me to https? I'm using mac with chrome

Share this post


Link to post
Share on other sites

Disabling it from phpmyadmin is not enough. When you disable SSL from admin dashboard it has other related functions which should be executed. So reverse that SSL change you did from phpmyadmin and disable SSL from admin dashboard. Also check your .htaccess file if there is any 301 redirection for https.

Share this post


Link to post
Share on other sites

Disabling it from phpmyadmin is not enough. When you disable SSL from admin dashboard it has other related functions which should be executed. So reverse that SSL change you did from phpmyadmin and disable SSL from admin dashboard. Also check your .htaccess file if there is any 301 redirection for https.

As a said the htaccess looks fine. I changed it from the backoffice but still redirects me to https

Share this post


Link to post
Share on other sites

 if you have ever tried the run the copied store before changing the setting, the info may has been saved by browser.

It seems that browser also cache or save the data in cookies. I have had similar issue with my own store before.

Please also try to clear your browser cache and cookie to see it it helps

 

Share this post


Link to post
Share on other sites

 if you have ever tried the run the copied store before changing the setting, the info may has been saved by browser.

It seems that browser also cache or save the data in cookies. I have had similar issue with my own store before.

Please also try to clear your browser cache and cookie to see it it helps

I cleaned the cache and also tried different browsers + incognito 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More