Jump to content
  • 0
ralph.poland

Email Configuration Error - Gmail Smtp Server

Question

Hello Guys,

 

I can`t configure my email in prestashop cloud version. 

 

Erro shows when trying to send checking email : 

 

Error: Please check your configuration
The SMTP connection failed to start [smtp.gmail.com :25]: fsockopen returned Error Number 0 and Error String 'php_network_getaddresses: getaddrinfo failed: Name or service not known'

 

SMTP server : smtp.gmail.com

smtp username: myemail@gmail.com

password : xxxxxxx

 

+

 

I tryied all  combinations of encryption (encryption none, SSL, TLS )  and port ( 465 , 587 )

 

I  chose "  Set my own SMTP parameters (for advanced users ONLY) "

 

In my gmail account IMAP protocole is enabled

 

In customer position email is correct 

 

In my google accout 2part verification is turned off

 

I tryied everything i found in the internet and still not workin

 

Did anyone had similar problem ??

Edited by ralph.poland

Share this post


Link to post
Share on other sites

27 answers to this question

Recommended Posts

  • 0

According to your error above >> smtp.gmail.com :25 

 

I assume that port number is changing and not 25 every time?

 

Because if it is  smtp.gmail.com :25 that is part of the problem.

 

I just took a look at Google and yeah, the IMAP port is only for receiving mail, just like a POP port, sorry about that. I decided to give it a try on my machine and it worked using the SSL setting,

 

Outgoing Mail (SMTP) Server - SSL: smtp.gmail.com
Use Authentication: Yes
Port for SSL: 465

 

So are you see the error with smtp.gmail.com :465 or smtp.gmail.com :25 ?

Share this post


Link to post
Share on other sites
  • 0

I trydied at the firts time 


 


SMTP server : smtp.gmail.com


smtp username: myemail@gmail.com


password : xxxxxxx


encryption ssl


port 465 


 


 


i did the same for tls / 587


 


 


and  many other combinanation  , port 25, port 933 that u told me to check... 


 


and still nothing....i`m lost ;/


Edited by ralph.poland

Share this post


Link to post
Share on other sites
  • 0

Error information also changes an every time i change port and enryption. 

 

ssl/465

Error: Please check your configuration

 

tls / 587

 

Error: Please check your configuration

 

smpt connection failed , 

 

 

i must say that is 1 firts time when i use PS and my It skill are on very basic level 

Edited by ralph.poland

Share this post


Link to post
Share on other sites
  • 0

If you are sure you are using the correct login Gmail name and password, for example can you send and receive using a regular email client like Outlook or Windows Mail? 

Share this post


Link to post
Share on other sites
  • 0

MS OUTLOOk WORKS FINE

 

SMTP server : smtp.gmail.com

smtp username: myemail@gmail.com

password : xxxxxxx

encryption ssl

port 465 

 

 

Could this be couse of the domain that i use right now. I didn`t addin  PS setting SSl certificate to this domain. But I checked the default PS domani which already has SSL with the same setting and didn`t work out. Any more ideas??  

Share this post


Link to post
Share on other sites
  • 0

No, the SSL is provided by gmail. 

 

I guess you'll need to contact Cloud support. See if they support gmail. 

 

Like I said, I tried it with my setup and it worked. So at least we know it is possible. If you like I could move this thread over to the cloud forum ... it might get a better response in that forum.

Share this post


Link to post
Share on other sites
  • 0

Would be great IF you could. I read that the other people had some similar problem with gmail but on their instaled version of PS and they changed something in code and after this it worked. But there were post talking about some older version PS and i rather cant change anything in cloud version

Edited by ralph.poland

Share this post


Link to post
Share on other sites
  • 0

I'd strongly recommend to see to paragraph 5.5 of the cloud's terms of use. I guess you will find the answer there why third party mail accounts won't work properly.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Independent from §5.5 and what others claim I got my problem with Gmail solved!!!

 

For all who are in the same (desparate) situation I was here is how it worked finally on my side:

All Gmail addresses I had before I set up PS Cloud did not work, but after creating a new Emailaddress with Gmail it worked!

 

The settings I use are:

Google: enable smtp and imap AND enable "allow less safe apps"

 

PS Backend -> Advanced Parameters -> Email:

Mail domain name: leave this box empty

smtp server: smtp.gmail.com

smtp username: your individual username (= your full gmail-address like XYZ@gmail.com)

smtp password: your individual password (= your Gmail login password)

encryption: SSL enabled

Port: 465

 

So my recommendation for all with gmail problems is to create a new email address in Gmail, then setting the email-function of PS according the data above. Here on my side it works now like a charme.

 

Good luck,

Martin

Edited by mag29
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Tahnks Mag29 , I`ll check it.  I was trying use the other email providers but It didnt work as well. Even sent questin to PS support but they havent answer yet. Hope that crating new email will help. 

 

Have you tryied to send test email from shop administrative panel ??

Share this post


Link to post
Share on other sites
  • 0

Ralph,

yes, have sent the test mail from the BackOffice, all works incl. order confirmation email incl invoice, newsletter registration confirmation email and account creation email confirmation.

 

Create a new account and try again. Let me know if this works.

Good luck,

Martin

Share this post


Link to post
Share on other sites
  • 0

New Gmail accout working for me as well. Thanks mag29

I dont get it, I have same pop/imap sett in both gmail accounts. and one is working the other ( old one ) don`t

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Ralph, good to hear that the new account works on your side, too! I have absolutely no clue why the old account does not work, while the new one with the 100% same settings does: it is the same on my side, but as the issue is now fixed for me I do not care about strange things with Google-software. ;-)

I just think it is important for others to know the (strange) solution to this gmail-problem, so we got a solution that works on my side and you have positively tested it on your side, I recommend to go our way for all who have issues with gmail.

 

Cheers

Marti 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

You don't really have to create a new account, you just can go to "https://www.google.com/settings/security/lesssecureapps"

Log in with your gmail account, and allow unsafe apps to login

 

Update: i did the test with a account which doesn't send trough Prestashop cloud, after going to the URL it worked perfectly.

 

Kind regards,

Jaimy

Edited by Crezzur
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Jaimy,

no, this did not work with the old account for me, I (and others) had def. to create a new account. Feels like you are somehow "burnt" on google side with your old account if you have unsuccessfully tried the smtp because you did not enable the less safe apps option (sounds that you tested with an account that was not "burnt").

My recommendation (new account) is for all who have no success even after enabeling the less safe apps option.

Best regards

Martin

Share this post


Link to post
Share on other sites
  • 0

,

 

did you also disable the 2 steps check from google ?

yes, I invested tremendous time, I followed and tried all google recommendations and forum advices without success, just the new account-way made it for me. This way it worked instantly without any problem, using the same settings as with my failed trials with the old account, so there were no wrong settings on my side.

Edited by mag29

Share this post


Link to post
Share on other sites
  • 0

The same was in my case. Every option checked like 2 step veryf., allowiing to login from unsafe apps,  plus many, many more other option that i`ve seen in the other PS user on forum and finally started working when i use mag29 advice an created new account. 

Share this post


Link to post
Share on other sites
  • 0
Google translator used.

It was desperate, no solution and thanks to this post is solved.

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello 

I found the solution and now the system send email at once.

I create a new google account  and i put the new email  Tls and port 587 

and it works. !!!!!

 

i dont know why but it works.

Thanks

Giannis

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi guys, 

i've solved this problem that i've been around for a while. 

 

I have an old account with Gmail and for it worked using as username only the name withouth @gmail.com

 

tls 587 ;)

 

hope this will help lot of you! :)

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

Thanks you for your sharing. I found that i need to create google passwd for apps access to my gmail. It work now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More