Jump to content

Recommended Posts

Greetings,

I have problem on accessing my back office :

 

HTTP 500 Internal Server Error
 The website cannot display this page

Most lilely causes
 The website is under maintenance
 The website has a Programming Error

 

I have turn on debugging on and it told me : MySQL server has gone away
 

But I can access my front office, the problem is I can't access the login page of my backoffice.

If MySQL server has gone away, it should be I may not access my front office. Are this come from time out on communicating with MySQL server ?

Can you help on what should I do about this ?

 

Thanks in advanced.

 

Regards,

Ronald

Share this post


Link to post
Share on other sites

Hi Ronald.

 

Have you checked your server logs?

 

What type of hosting are you on/

 

Regards.

Robin.

The CartExpert Team.

Share this post


Link to post
Share on other sites

Maybe it will be useful information for some of you:

 

I had problems with HTTP Error 500... and spend many hours reading forum topics and trying many solutions... turning on error reporting / disabling some modules / reuploding files / cheking server configuration and many more...

 

Finaly I found solution in some blog, away from PS community :) Its:

1. Turn Off and turn On the SEO friendly URLs. This will generate the a .htaccess file on your root.
2. Download the .htaccess file. Comment the line “SetEnv HTTP_MOD_REWRITE On” by putting # before the line and reuplod.
3. If the version of PHP running on your server is 5.4 (5.5 / 5.6), change it to 5.2.

 

This should solve your problem ;)

Share this post


Link to post
Share on other sites

Best solution:

 

Delete ".htaccess" file and you are good to go.

  • Like 1
  • Confused 1

Share this post


Link to post
Share on other sites

Hi,

 

I am havin same issue, and going nuts. First, I thought was a blue host ( hosting and domain ) service going on. But , sincerely dont know what else to do. It is showing same mistake 

 

HTTP 500 Internal Server Error
 The website cannot display this page

Most lilely causes
 The website is under maintenance
 The website has a Programming Error

 

And also cant access my front or back office. I have spent hours trying to do something and I used the cloud based option. 

 

Can anyone help me with this?

Share this post


Link to post
Share on other sites

I am also facing the same issue "Server Error 500". I am using Prestashop Cloud.

 

I am very new to this.

 

Please anybody suggest to overcome this error

Share this post


Link to post
Share on other sites

"Server Error 500" means a fatal error. It can happen in a thousand reasons. Any details?

Share this post


Link to post
Share on other sites

Hi tiku,

 

Thanks for the 

 

I am totally new to prestashop cloud and i am not technical guy. I dont have any knowledge Technology .

 

before 3 days back it is worked very fine, suddenly from since yesterday morning it has stopped working.

 

And unable to login to Back office to Manage my store.

 

I am able to see my store details after login to my account page but unable to manage my store

 

Back office login link: http://www.evafashions.in/backoffice/index.php?controller=AdminLogin?email=evafashionsin%40gmail.com (Not working)

 

 

website URL: http://www.evafashions.in/ (it is also working)

 

At least please suggest me some fixes then will try from end,.. pleaseeeeeeeee..

Share this post


Link to post
Share on other sites
Guest locen
Hi,

I receive this error both in the back office that frontoffice by side but not always, are the pages that sometimes crashano ..

The problem is that I contacted my hosting but they said so:

 

With regard to its communication to inform you that in order to examine the case would have to perform a verification code of your site to search for the error that causes the behavior observed. Code debugging is entirely borne by the customer.

I suggest you visit the official website of Prestashop or plugin / theme / module that involves the failure to identify what causes it and the procedure to be able to solve.

 

Someone who can help me?

Share this post


Link to post
Share on other sites

Hi all,

The cause of Internal Server Error 500 can be too low values for activity and request timeout in FastCGI setting on IIS.

 

When using IIS you can activate Failed Request Tracing Rules for your website and define a rule for only this error to analyze the exact reason. Start IIS Manager, open server-sites-your site and click Failed Request Tracing in the actions pane. Activate it and check if the path for logfiles is ok. Now click Failed Request Tracing Rules and add a rule. Select All Content (*), next select Status Code and enter 500 (400-500 is also possible), do not select Time taken and Event severity, next select only WWW Server and Area RequestNotifications (other areas can be added later if necessary). Save the rule and try to get the 500 error.

 

If the 500 error occurs it is logged and you can view the log with your browser. You find it in the path defined in Failed Request Tracing for your site. In the Request Summary you will see the module causing the error.

 

In case FastCgiModule is the reason you can change the setting in IIS. Select the server (not your site) and there you have FastCGI setting. You can see that you can select  that this module shall generate a 500 error. Select the PHP version of your site and increase activity and request timeout. You can calculate it from the logfile or test with some values.

 

Good luck

Edited by CodeRider (see edit history)

Share this post


Link to post
Share on other sites
Guest locen

Where i can change this?

Share this post


Link to post
Share on other sites

Hi locen

I wrote where to change it if you use IIS and have access to it. Otherwise you have to ask your hosting partner who should be able to identify the origin of the error. What is your webserver version, PHP version etc.?

Share this post


Link to post
Share on other sites
Guest locen

my hosting is REGISTER

 

these are my info 

 

Server information Linux #1 SMP Thu Jul 31 13:37:45 CEST 2014 x86_64

Server software version Apache

PHP version 5.4.4-14+deb7u2

Memory limit 140M

Max execution time 2880

Share this post


Link to post
Share on other sites
Guest locen
THESE ARE OTHER INFORMATIONS    DATABASE INFORMATION

MySQL version 5.5.34-enterprise-commercial-advanced-log

MySQL server hostingmysql320.register.it

MySQL name

MySQL user

Tables prefix ps_

MySQL engine InnoDB

 STORE INFORMATION

PrestaShop version 1.6.0.9

Shop URL http://www.martemodena.com/shop/

Current theme in use default-bootstrap

 MAIL CONFIGURATION

Mail method You are using the PHP mail() function.

 YOUR INFORMATION

Your web browser Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Edited by locen (see edit history)

Share this post


Link to post
Share on other sites

You have Apache on Linux. So you can't go that way. But the 500 can be result of a timeout anyway. So have a look in your configuration where it can happen.

Share this post


Link to post
Share on other sites
Guest locen

why i should not have linux? 

For prestashop i know that linux is basic

Share this post


Link to post
Share on other sites

Same issue.

When I am trying to install a fresh copy of prestashop 1.6.4 i got that error:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@... and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Could anyone help with this problem?

 

Thank you

Share this post


Link to post
Share on other sites

In one case Smarty setting caused the error.

Check if In Advanced Parameters-Performance 'Template Compilation' is set to 'Never recompile template files'

If not, set it to this value.

Edited by CodeRider (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
Guest locen

Thanks, what settings are better?

Share this post


Link to post
Share on other sites

I, too, have tried everything suggested.  I have no known reason for the Error 500; pressing F5 didn't do a thing.  My error message comes up when I try to get to my admin login page.  There are no signs of .htaccess files in my cpanel at all.  More disturbing is that the Zen-Cart icon appears on that page, even though I'm typing in my PS admin url.  I removed ZC before installing PS. Sooo... next?

 

Doing this on Win7, by the way.

Share this post


Link to post
Share on other sites

HTTP 500 Internal Server Error is non-specific error. It is caused by a fatal problem in the code and needs debugging to fix.

Share this post


Link to post
Share on other sites
Guest locen

but this problem, for me, is casual, not always. 

i have this problem for example if i click "show all" button if there are a lot of products..if there are few products no problems!

Share this post


Link to post
Share on other sites

@ a lot of products

I see timeout or memory limits at the server.

Share this post


Link to post
Share on other sites
Guest locen

@ a lot of products

I see timeout or memory limits at the server.

how can i change this?

Share this post


Link to post
Share on other sites

My logs weren't showing anything remarkable, and, in fact, I didn't have any logs dating from the installation of this shopping cart.  I contacted my host who was able to find the errors and correct them.  (My Cpanel wasn't coming up for me, either.)

Share this post


Link to post
Share on other sites

Error 500 happens me third time. And it make me mad.

  • First two times it happened when I cleaned the cash from the back office.
  • the last time it happened when just uploading category thumbnail image.  

And nothing helps me to get back my site, just restoring backup. Many hours of work gone. Why it happens in such silly actions?

Share this post


Link to post
Share on other sites

In Performance - Smarty set Template compilation:

 

1. Recompile templates if the files have been updated

2. Cache - YES

Share this post


Link to post
Share on other sites

I have the same issue. I would like to install a new site. I copied each file to the right folder, and after I got the 500 Internal Server Error.

I am not able to install the site.. 

 

I'm running an other PS on my server, I built it last year, so I don't know what is wrong now...

 

Any idea?

 

Thanks,

Barney

Edited by BarneyHU (see edit history)

Share this post


Link to post
Share on other sites

500 Internal Server Error is too common error. It is a fatal PHP error, but doesn't say what exactly is wrong. Debugging is needed.

Share this post


Link to post
Share on other sites

I reset clean url now getting this error message

 

Parse error: syntax error, unexpected ''supplier_rule'' (T_CONSTANT_ENCAPSED_STRING), expecting function (T_FUNCTION) in /home/vol3_5/byethost6.com/b6_19343639/mbawithfun.cu.cc/htdocs/override/classes/Dispatcher.php on line 7

Share this post


Link to post
Share on other sites

My WEb Address : http://mbawithfun.cu.cc

 

 

<?php
class Dispatcher extends DispatcherCore
{
        'supplier_rule' => array(
            'controller' =>    'supplier',
            'rule' =>        'supplier/{rewrite}/',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'supplier_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
        'manufacturer_rule' => array(
            'controller' =>    'manufacturer',
            'rule' =>        'manufacturer/{rewrite}/',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'manufacturer_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
        'cms_rule' => array(
            'controller' =>    'cms',
            'rule' =>        'info/{rewrite}',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'cms_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
        'cms_category_rule' => array(
            'controller' =>    'cms',
            'rule' =>        'info/{rewrite}/',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'cms_category_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
        'module' => array(
            'controller' =>    null,
            'rule' =>        'module/{module}{/:controller}',
            'keywords' => array(
                'module' =>            array('regexp' => '[_a-zA-Z0-9_-]+', 'param' => 'module'),
                'controller' =>        array('regexp' => '[_a-zA-Z0-9_-]+', 'param' => 'controller'),
            ),
            'params' => array(
                'fc' => 'module',
            ),
        ),
        'product_rule' => array(
            'controller' =>    'product',
            'rule' =>        '{category:/}{rewrite}.html',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'product_rewrite'),
                'ean13' =>            array('regexp' => '[0-9\pL]*'),
                'category' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'categories' =>        array('regexp' => '[/_a-zA-Z0-9-\pL]*'),
                'reference' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'manufacturer' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'supplier' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'price' =>            array('regexp' => '[0-9\.,]*'),
                'tags' =>            array('regexp' => '[a-zA-Z0-9-\pL]*'),
            ),
        ),
        'layered_rule' => array(
            'controller' =>    'category',
            'rule' =>        '{rewrite}/filter{selected_filters}',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                
                'selected_filters' =>        array('regexp' => '.*', 'param' => 'selected_filters'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'category_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
        'category_rule' => array(
            'controller' =>    'category',
            'rule' =>        '{categories:/}{rewrite}/',
            'keywords' => array(
                'id' =>                array('regexp' => '[0-9]+'),
                'categories' =>        array('regexp' => '[/_a-zA-Z0-9-\pL]*', 'param' => 'categories_rewrite'),
                'rewrite' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*', 'param' => 'category_rewrite'),
                'meta_keywords' =>    array('regexp' => '[_a-zA-Z0-9-\pL]*'),
                'meta_title' =>        array('regexp' => '[_a-zA-Z0-9-\pL]*'),
            ),
        ),
    );
    
}

Edited by singhharsh555 (see edit history)

Share this post


Link to post
Share on other sites

In one case Smarty setting caused the error.

Check if In Advanced Parameters-Performance 'Template Compilation' is set to 'Never recompile template files'

If not, set it to this value.

My problem is solved!
 
I had the option to "force compilation"
 
Activate the option of 'Never recompile template files' and the problem is solved.
 
thank you very much!

Share this post


Link to post
Share on other sites

has actualizado la version de prestashop ?

 

si es asi lo mas seguro que tienes problema con la plantilla anterior ...cambiala por una compatible con tu nueva version de prestashop ....

Share this post


Link to post
Share on other sites

Hello guys i solved it be the two steps, im working on version: 1.6.1.12

Step 1: Deactivate the SEO and Urls

Step 2: Set cache to off and turn it on again.

 

Hope it helps

Share this post


Link to post
Share on other sites

hello

it happened to me too.

I read on another topic that i have to make a small changes to classes/tool.php

so i FIRST renamed the original file into toolsORIGINAL.php

THEN i downloaded the file and i made my changes on my pc.

After that i uploaded the changed file with the changes.

 

After that, when i refreshed the page, it gave me the error 500.

 

BOTH, THE FRONTEND AND THE BACKEND.

 

So i cannot do anything. I still have access to my cpanel (godaddy)

 

After i see the situation, i deleted the changed file and i re-named the toolsORIGINAL.php into tools.php (it was literally untouched)

BUT THE INTERNAL SERVER ERROR 500 REMAINED and until now both the sides (back and front) are not accessible.

 

I will really appreciate any help.

 

Thank you.

 

V

Share this post


Link to post
Share on other sites

Hi guys,
I started using Prestashop just recently, and I frequently encounter error 415 when I go translating the products. Can someone help me?

 

Faithfully yours

PS. I attach the error letter to you:  Errore 415 (it-en): Unsupported media type

Share this post


Link to post
Share on other sites

I've solved the problem, after PS v.1.6.x update the:

 

Performance Advanced - > Performance - > DEBUG MODE:

Disable non PrestaShop modules was set on YES , i turned it NO and it works

 

The wall procedure, in my case, for update is:

- Manually Backup all Files

- Manually Backup DB MySql

- Autoupgrade

- Manually Clear Cache : 

cache/smarty/compile
cache/smarty/cache
img/tmp
delete all EXCEPT index.php
- Remove .htaccess
- Turn Off and Turn ON Friendly Url
- Check if my theme is correctly set on
 
Hope it helps
 
:)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More