Jump to content
dizain

zip code and state are not showing

Recommended Posts

Hello, 

 

I'm sorry I have been asking a lot of questions lately. 

 

I have a problem when trying to register an account in my shop. 

 

I only ship to USA. The problem is when you try to register then there is no option to enter state and zip code (See attachment: zipcode1)

 

However, after hitting continue then I get 3 errors messages. (see attachment: zip code2)

 

1. postcode is required.

2. The zip/postal code you've entered is invalid.

3. This country requires you to choose a state. 

 

and then I can see the options to enter the state and zip code. (see attachment: zipcode 3)

 

 

Please let me know how to fix this. 

 

Thank you. 

post-776167-0-98585900-1397261969_thumb.png

post-776167-0-96143800-1397261971_thumb.png

post-776167-0-70018600-1397261972_thumb.png

Share this post


Link to post
Share on other sites

I noticed if I select United States then it shows the states and zip code. However, is there a way to let United States selected by default. I ship only to USA. Thanks and please let me know how to fix this. 

Share this post


Link to post
Share on other sites

I noticed if I select United States then it shows the states and zip code. However, is there a way to let United States selected by default. I ship only to USA. Thanks and please let me know how to fix this. 

 

back office-->localization-->countries

 

disable all countries you do not do business in.

 

 

note:  if you edit country, here you can give options like require zip and has states. :)

  • Like 1

Share this post


Link to post
Share on other sites

Thank you so much however, I have done this and nothing change. I sent you a private message. Thank you so much for your time. 

Share this post


Link to post
Share on other sites

based on your first screen shot, it sounds like your custom theme is not programmed correctly.  the way PS works, is that it checks if the Country "has states" and "has zip codes" before those fields are displayed

 

So when a page loads that has address information, it is supposed to look at the selected country and then show states and zip codes based on the country config.  This seems to work if you change the country, but not if the country is defaulted already.

 

So disabling all the countries but US will likely not fix the issue.  You may need to edit your theme if it does not work properly.

Share this post


Link to post
Share on other sites

I have the same problem. There is no state drop down option for any country in the FO but it is, thank fully, in the BO. This problem effects all new account registrars. I have opened a test account in the BO due to the fact that I cannot create the account in the FO (Error: "This country requires you to choose a state"). But now, when I try to proceed with the check out (and the correct address and state as created in the BO) I get an error with no carriers available.

 

The website is www.adornbybedight.co.za

 

PLEASE CAN ANYONE ASSIST WITH THIS!

I was suppose to go live with my site 2 weeks ago and cannot do that until this problem has been solved.

  • Like 1

Share this post


Link to post
Share on other sites

The same...

It seems the bug is only with internet explorer....

Share this post


Link to post
Share on other sites

The same...

It seems the bug is only with internet explorer....

No, this problem also exists in Firefox.

In my country section i uncheck "Does it need Zip/postal code?", in registration form i don't seeing а ZIP/Postal code field, but the system returns an error "A Zip/Postal code is required"

 

 

 

 

p.s. Solution - Must to delete "NNNN" from "Zip/postal code format" field.

Edited by chipset (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

I managed to solve my problem. In my shop was not showing the postcode, country and state fields, so I edited the address layout of my country, adding these fields and everything was fixed.

Share this post


Link to post
Share on other sites

I had the same problem and I solved it changing in preferences/performance, disabling smart cache javascript code, I set "no" and works fine

  • Like 1

Share this post


Link to post
Share on other sites

i have the same problem

no zips code

did you read post #11?  Have you performed the same steps to confirm that the selected country is configured to have zip codes?

Share this post


Link to post
Share on other sites

I have we same problem, but only with Safari browser. All other browsers show fields correctly. Strange :)

Share this post


Link to post
Share on other sites

This is really a frustating issue, several posts about this and no solutions. On my mobile site zipcode is not visible but it is required. If customers make an order through the mobile site they get an error that zipcode is required, but there is no field to show it. When the site is viewed from a computer the field is visible and orders can be made. Is there any known cause for this and what is the solution?

  • Like 1

Share this post


Link to post
Share on other sites

Hello:

 

I have the same problem, i look in my country an the zip code an state are there, but no in registration page, i think is and old problem whit one page registration prestashop. Long time ago i'm looking for solution but nobody find it.

Why will?

Share this post


Link to post
Share on other sites

I managed to solve my problem. In my shop was not showing the postcode, country and state fields, so I edited the address layout of my country, adding these fields and everything was fixed.

Can you show a print screen of the solution that  you found... I have everything right configured but neither zip code neither the state appears ...

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More