Jump to content
zirael

smtp settings - zoho - email still does not work

Recommended Posts

Hi guys, I just created my own domain email on zoho.com, and i´m trying to configure it.. filling in the SMTP settings with the data from zoho just doesn´t work. 

 

this means: server:smtp.zoho.com

 

user and password are correct..

 

SSL and port 465.

 

After an attempt to send a verification email i just get the "check your settings" message without any specifications.

 

Did anyone solve this issue?

 

Thanks :)

Share this post


Link to post
Share on other sites

I was setting it just as it´s shown in that image.

Password is right, when it is wrong I get an error message about the failed authentication.

 

I was wondering - maybe any of the zoho settings? I have no clue where the problem is..

 

 

edit: i just created a test gmail account and it works..so it must be zoho problem....

 

Is there anyone with a zoho email account in use? 

Edited by zirael (see edit history)

Share this post


Link to post
Share on other sites

What PS version? im asking because old ps 1.5.4,.1.5.5) has got problems with SMTP due to the old SWIFT library usage.

let me know about you ps version please.

Share this post


Link to post
Share on other sites

Hi, i´m using 1.5.4.1. I will try to update to 1.5.6.1, and see what it will do. thanks.

Share this post


Link to post
Share on other sites

i am using prestashop 1.6 i have the same problem.mail sending failed.Error: Please check your configuration

what might be the fix?

Share this post


Link to post
Share on other sites

same here with 1.6. There are soooo many threads like this and no real solutions.
So Many topics with no replies, not solved.
This is not serious.. sorry.

Share this post


Link to post
Share on other sites

I had used Zoho earlier for all my business needs thereafter due to some issues and the tool not exactly meeting our organizational requirements, had to stop using Zoho. Thereafter, I started using Replicon cloud based time management software for our business time related needs.

 

Replicon has been so easy as well as pretty quick in getting implemented. Can also be accessed from any location, using web browser and very simple using because of its calendar view interface. An AWESOME tool with really robust support  :)

Share this post


Link to post
Share on other sites

I searched google and i found too many topics with this problem prestashop and zohomail, and not even a solution. This is very bad for both sides, there should be a solution...Really disappointed

Share this post


Link to post
Share on other sites

The problem is that PS doesn't save your SMTP password. When you click save it changes to PS login password. The solution is ensure that both passwords (SMTP and PS login) are the same. It worked for me with Google Apps configuration.  

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai eu le même problème que vous et j'ai bien galéré mon site sans les E-Mails était unitilisable.

 

J'ai eu des pistes grâce au Forum pour résoudre le problème cest pourquoi je partage avec vous...Je commence à maitriser cette version de PrestaShop 1.6.0.9 qui est assez stable selon mon expérience actuelle.

 

bien le sujet qui nous intéresse maintenant...

 

en ce qui me concerne

 

Nom de domaine des e-mails:  planet-work.com  (petite pub)

Serveur SMTP : smtp.planet-work.com

Utilisateur SMTP : votre adresse email complète (verifier bien en vous connectant à votre web-mail)

Mot de passe SMTP : Votre mot de passe que vous venez de vérifiez sur votre Web-Mail

Chiffrement : Aucun , mais cela dépend de votre hébergeur de mail, certains acceptent le chiffrage

Port : 587 c'est sur le numéro de port que j'ai essentiellement galéré car par défaut il est sur 25...

 

Dites moi si cela fonctionne pour vous!

 

A bientôt et merci à ceux qui font vivre le Forum qui est bien utile.

Edited by Joe Paris (see edit history)

Share this post


Link to post
Share on other sites

Hi.

 

I know this is an old post, but I was having the same problem, and I could solved it without complications:

 

1- Make sure your settings are all set. If you try a wrong password, the message will warn about authentication. Fix all and you must see something like "Please check your confs"

 

2- The trick is that the sender of test and all other mails is the store contact. Make sure the e-mail you are trying to set is the same of Menu->Preferences->Store Contacts - Contact Details->Shop email.

 

3- Enter the mails configuration again do make the test. You will note that "SMTP username" and "Send a test e-mail to" have the same value. You can change the test mail and click "send an e-mail test"

 

4- Enjoy the message "A test email has been sent to the email address you provided."

 

That's because the "from" can't be different of the account due to Zoho security settings. (https://forums.zoho.com/topic/smtp-not-working)

 

PS: thanks for the guys who pointed about Swift lib.

 

Eder

  • Like 1
  • Confused 1

Share this post


Link to post
Share on other sites

Thank you Eder!  

You made it so easy!!!  Thanks for the detailed, step-by-step help!

Christie

Share this post


Link to post
Share on other sites

Guys any solution it still does not work i am using prestashop 1.6.1.11 everything seems fine it just displays 

Error: Please check your configuration
Connection could not be established with host smtp.zoho.com [Connection timed out #110]
Send a test email
 

Share this post


Link to post
Share on other sites
18 hours ago, mridul.mahajan.in said:

Guys any solution it still does not work i am using prestashop 1.6.1.11 everything seems fine it just displays 

Error: Please check your configuration
Connection could not be established with host smtp.zoho.com [Connection timed out #110]
Send a test email
 

this error typically means that there is a firewall restrciting your access to this SMTP server port.  You should contact your hosting provider support for assistance

Share this post


Link to post
Share on other sites
On 25/5/2018 at 8:25 PM, mridul.mahajan.in said:

Guys any solution it still does not work i am using prestashop 1.6.1.11 everything seems fine it just displays 

Error: Please check your configuration
Connection could not be established with host smtp.zoho.com [Connection timed out #110]
Send a test email
 

Only solution to prestashop problems, is to stop using prestashop. The earlier you do that, the better for you.

Share this post


Link to post
Share on other sites
12 hours ago, gerstavros said:

Only solution to prestashop problems, is to stop using prestashop. The earlier you do that, the better for you.

this error has nothing to do with using Prestashop.  His hosting provider has a firewall preventing access to the SMTP server

Share this post


Link to post
Share on other sites
20 hours ago, bellini13 said:

this error has nothing to do with using Prestashop.  His hosting provider has a firewall preventing access to the SMTP server

all other platforms work fine, only prestashop has problem working with zoho servers. this, and lots of other problems of prestashop, forced me to stop using it. never regretted it.

Share this post


Link to post
Share on other sites
50 minutes ago, gerstavros said:

all other platforms work fine, only prestashop has problem working with zoho servers. this, and lots of other problems of prestashop, forced me to stop using it. never regretted it.

thats great for you, however your feedback is pointless and helpless here.  if you moved on from Prestashop, then move on...  otherwise stay on topic, this issue has nothing to do with Prestashop

Share this post


Link to post
Share on other sites

Problem was my hosting provider i use digital ocean and as bellini said Digital Ocean by default blocks all smtp traffic from their server so you have to specifically ask them after your account is atleast 3 months older to unblock it.

 

It was having nothing to do with PS :)

Edited by mridul.mahajan.in (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More