Jump to content

SOLVED -- Upgrading to 1.5.6.0 error


Recommended Posts

I am trying to upgrade to 1.5.6.0.

 

Before the release, the 1-click upgrade module worked.  When the upgrade for 1.5.6.0 came out a few minutes ago, the 1-click upgrade module says:

The 1-click upgrade module is up-to-date (your current version is v1.1.8)   X

 

I can't find manual upgrade instructions and don't want to overwrite my files without knowing better.

 

Thanks

 

Edited by freakydragon (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

the upgrade module does not work here. I upgraded the 1-click tot version 1.2 and deleted/uninstalled/reset and so on, but it will not work.

 

If I choose "Upgrade PrestaShop now !" there is a slight pause and then the page returns exactly the same.

 

How do I do a manual upgrade from 1.5.5 to 1.6 ?

Edited by petert (see edit history)

Share this post


Link to post
Share on other sites

I had to uninstall 1-click upgrade module v1.1.8. Then manually delete /Modules/autoupgrade

 

Download the new 1-click upgrade module v1.2.0

 

Install.

 

Then it all went well.

Tried that too a couple of times, will not work either. Strange thing is that sometimes the 1-click thingy will come up with version # 1.18 and sometimes with 1.2.....

When I delete the directory from modules then the module is still present in the overview of modules.

Share this post


Link to post
Share on other sites

Download the module directly from the prestashop, and manually install it. 

that's what I did after trying to upgrade the 1-click module through the backend.

 

That didn't give me results, so I uninstalled and deleted the module from the backend. I checked if the modules/autoupgrade directory was gone, it was. Then I ftp'ed the autoupgrade module from a freshly downloaded and unpacked at my local machine official archive. Then from the backend I installed and configured the module.

 

Still not working.

Share this post


Link to post
Share on other sites

Try uninstalling 1-click.

 

Delete everything in prestashop\admin??\autoupgrade

 

Reinstall 1-click v1.2.0

That didn't give me results, so I uninstalled and deleted the module from the backend. I checked if the modules/autoupgrade directory was gone, it was. Then I ftp'ed the autoupgrade module from a freshly downloaded and unpacked at my local machine official archive. Then from the backend I installed and configured the module.

Share this post


Link to post
Share on other sites

Are you sure you deleted prestashop\admin??\autoupgrade  ??

 

That is very different from deleting modules/autoupgrade

 

Two different locations.

aha, you are right! Sorry for being such an ass.

Removed the directory in admin.

 

I will try now.

 

Nope, nothing changed. Still no response.

Share this post


Link to post
Share on other sites

uninstall the 1-click upgrade module and delete it.

 

download the 1 click upgrade module from here and unzip  it.

 

Now go to your modules folder in prestashop and remove any folder named as autoupgrade and paste the unzipped autoupgrade module there.

 

go to modules in the backoffice you will find the new version of the 1-click upgrade just install it and enjoy.

 

if this is not getting succeeded then just go to admin auto upgrade and delete the files

 

take another backup of your files and try to upgrade.  

Share this post


Link to post
Share on other sites

uninstall the 1-click upgrade module and delete it.

 

download the 1 click upgrade module from here and unzip  it.

 

Now go to your modules folder in prestashop and remove any folder named as autoupgrade and paste the unzipped autoupgrade module there.

 

go to modules in the backoffice you will find the new version of the 1-click upgrade just install it and enjoy.

 

if this is not getting succeeded then just go to admin auto upgrade and delete the files

 

take another backup of your files and try to upgrade.  

I have done everything you asked, still no progress.

I made screenshots of every step, you can see the images here: http://arduinomarkt.nl/export/

 

I am about to do a manual upgrade, this 'automatic upgrading' takes a lot of time :(

Edited by petert (see edit history)

Share this post


Link to post
Share on other sites

have you unzipped the prestashop 1.5.6.0 downloaded file and kept it in autoupgrade folder inside admin folder ? It seems there is no problem with your module but problem in up-gradation file. No need to delete or uninstall the module again.

Edited by J.Sahu (see edit history)

Share this post


Link to post
Share on other sites

have you unzipped the prestashop 1.5.6.0 downloaded file and kept it in autoupgrade folder inside admin folder ? It seems there is no problem with your module but problem in up-gradation file. No need to delete or uninstall the module again.

No I have not unzipped the 1.5.6 download and did not keep it in autoupgrade folder. Should I try that?

Share this post


Link to post
Share on other sites

Still the same problem. Not being able to upgrade. All the rights are set correctly, the admin user that is doing the upgrade had id #1 in the database.

 

All the help from J. Sahu did not lead to an upgraded store.

 

What else can it be?

Share this post


Link to post
Share on other sites

  • 2 weeks later...

have the same problem!

have tried to uninstall/install 1-click upgrade module by hands

all сonditions for upgrading are green checkmarks

have tried to copy 1.5.6.0 version to /admin/autoupgrade/latest/prestashop/

When push Upgrade button nothings happens or it can show "The new version check has been completed successfully" BUT really nothing happens

Also "compare versions" allays stuck on "loading". It can't show what different between versions.

 

My presta 1.5.4.1 

Edited by kotkotan (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

have the same problem!

have tried to uninstall/install 1-click upgrade module by hands

all сonditions for upgrading are green checkmarks

have tried to copy 1.5.6.0 version to /admin/autoupgrade/latest/prestashop/

When push Upgrade button nothings happens or it can show "The new version check has been completed successfully" BUT really nothing happens

Also "compare versions" allays stuck on "loading". It can't show what different between versions.

 

My presta 1.5.4.1 

 

no, you can not have the same problem as there is no problem. 

Share this post


Link to post
Share on other sites

what do you mean?

that was sarcasm.

 

I ended up installing the latest version of Presta and somehow I managed to get my database in the new install. Lost all my pictures, nut at least I have a working store again.

Share this post


Link to post
Share on other sites

that was sarcasm.

 

I ended up installing the latest version of Presta and somehow I managed to get my database in the new install. Lost all my pictures, nut at least I have a working store again.

i've changing template for four month, can't create new shop. and i don't know why it can't upgrade  :( 

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More