Jump to content
netkomer

Error message "http 500"

Recommended Posts

Hi all,

 

I have installed prestashop version 1.5.2.0 and I have just updated paypal modulo to version 3.4.4

 

The problem is that now paypal is not working properly, I always get error message "http 500" when trying to buy via paypal.

 

How can I get previous version of paypal module so that to install it again?

 

Best regards,

 

Juan

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for your response but I cannot find modules/paypal/views/templates/front/express_checkout/paypal.tpl

 

May be paypal module version 3.4.4 uses a different directory structure.

 

Regards,

Share this post


Link to post
Share on other sites

Same problem. I tried the "paypal.tpl" solution and the "CURLOPT_VERBOSE, true" but they don't work or it is not possible to apply in 3.4.4 Paypal version...

 

:(

Share this post


Link to post
Share on other sites

It's a very big problem between Prestashop 1.5 and Paypal 3.4.4.

 

There is no solution at this moment, one would be continue using Prestashop 1.5 but with an older version of Paypal module. Does anybody know how we can do this?

 

Yesterday I called Prestashop and sent a email to support@prestashop.com and Paypal too, I'm waiting for their news,

 

saludos desde Madrid.

Share this post


Link to post
Share on other sites

It's a very big problem between Prestashop 1.5 and Paypal 3.4.4.

 

There is no solution at this moment, one would be continue using Prestashop 1.5 but with an older version of Paypal module. Does anybody know how we can do this?

 

Yesterday I called Prestashop and sent a email to support@prestashop.com and Paypal too, I'm waiting for their news,

 

saludos desde Madrid.

 

hi jorge8086, I feel so frustrated to find a way to fix it. If you get the solution and solve the issue, please post it here and let me know too, thanks.

Share this post


Link to post
Share on other sites

of course getinjoy, don't worry about it. :)

i hope the solution will be found asap, anyway i'm still trying to understand how prestashop launches an updated module like this one.. mamma mia! :(

 

 

Share this post


Link to post
Share on other sites

Dear friends, I've got the solution for this, found at the spanish forum (so if you apply it and it works you have to give a cheer to Spain!):

 

For the problem with Prestashop 1.5.2 and Paypal module 3.4.4:

 

- Go to "../modules/paypal/express_checkout" and edit "process.php"

- Go to124 line (or look for the instruction) and replace "if ($cart_currency != $currency_module)" with "if ($cart_currency !== $currency_module)"

- Save and upload the file.

- It's done, it will work!!

 

Best regards from Spain,

 

Jorge.

Share this post


Link to post
Share on other sites

Dear friends, I've got the solution for this, found at the spanish forum (so if you apply it and it works you have to give a cheer to Spain!):

 

For the problem with Prestashop 1.5.2 and Paypal module 3.4.4:

 

- Go to "../modules/paypal/express_checkout" and edit "process.php"

- Go to124 line (or look for the instruction) and replace "if ($cart_currency != $currency_module)" with "if ($cart_currency !== $currency_module)"

- Save and upload the file.

- It's done, it will work!!

 

Best regards from Spain,

 

Jorge.

 

Doesn't do anything, still doesn't work. :(

 

I have Prestashop 1.5.3.1 and Paypal module 3.4.4.

Share this post


Link to post
Share on other sites

TIP:

 

You can't solve a 500 error without the underlying error message which is by default hidden as to protect people from knowing what your underlying server/site information is.

 

1. You need to know the error

for 1.5.3

modify config/defines.php.inc to

define('_PS_MODE_DEV_', true);

 

before 1.5.3

modify config/config.inc.php

@ini_set('display_errors', 'on');

 

2. reproduce the error

 

3. using google search use this term: prestashop (part of your error message)

Share this post


Link to post
Share on other sites

very good advice elpatron,

 

and yes, the solution above only works with 1.5.2 and 3.4.4, i also wish it works with 1.5.3 but it does not :(

 

next time i'll think a lot, a lot, a lot, before updating prestashop or any module..

 

regards.

Share this post


Link to post
Share on other sites

Seems that a large number of people are having issues with PayPal module. This issue definitely results from the last update to paypal module. A very fundamental flaw and definitely a show stopper for Prestashop when the most commonly used payment module is broken. Come on Prestashop sort it out !!!

 

Marty

http://NZstore.biz

Share this post


Link to post
Share on other sites

TIP:

 

You can't solve a 500 error without the underlying error message which is by default hidden as to protect people from knowing what your underlying server/site information is.

 

1. You need to know the error

for 1.5.3

modify config/defines.php.inc to

define('_PS_MODE_DEV_', true);

 

before 1.5.3

modify config/config.inc.php

@ini_set('display_errors', 'on');

 

2. reproduce the error

 

3. using google search use this term: prestashop (part of your error message)

 

did you do this?

 

 

Seems that a large number of people are having issues with PayPal module. This issue definitely results from the last update to paypal module. A very fundamental flaw and definitely a show stopper for Prestashop when the most commonly used payment module is broken. Come on Prestashop sort it out !!!

 

Marty

http://NZstore.biz

 

 

please don't double post your philosophy...this works for the majority of people, then a majority of others follow community members advice and help to get it fixed...by giving detail or following advice

Share this post


Link to post
Share on other sites

OK, how can I test without me buying a product from my own shop? I've set the test mode to "true" based on your advice, but can't test it myself...

 

it's my customers who are having issues..

Share this post


Link to post
Share on other sites

Dear friends, I've got the solution for this, found at the spanish forum (so if you apply it and it works you have to give a cheer to Spain!):

 

For the problem with Prestashop 1.5.2 and Paypal module 3.4.4:

 

- Go to "../modules/paypal/express_checkout" and edit "process.php"

- Go to124 line (or look for the instruction) and replace "if ($cart_currency != $currency_module)" with "if ($cart_currency !== $currency_module)"

- Save and upload the file.

- It's done, it will work!!

 

Best regards from Spain,

 

Jorge.

 

it's perfect with presta 1.5.017 and paypal 3.4.4

it works

 

many thanks

Share this post


Link to post
Share on other sites

I have been having this problem. I have resolved the inmediate 500 error by changing all the directory permissions to 755 and all the file permisions to 644.

 

Now I get all the way through paypal and then the process blows up because the sales amount and/or pre-tax amounts are not matching.

 

But the first hurdle was the file permissions! Make sure they are correct or you'll never get to the next bug...

Share this post


Link to post
Share on other sites

Dear friends, I've got the solution for this, found at the spanish forum (so if you apply it and it works you have to give a cheer to Spain!):

 

For the problem with Prestashop 1.5.2 and Paypal module 3.4.4:

 

- Go to "../modules/paypal/express_checkout" and edit "process.php"

- Go to124 line (or look for the instruction) and replace "if ($cart_currency != $currency_module)" with "if ($cart_currency !== $currency_module)"

- Save and upload the file.

- It's done, it will work!!

 

Best regards from Spain,

 

Jorge.

 

Does not fork for me too ! PS 1.5.3.1 and Paypal 3.4.4 and also not for PS 1.5.2. and Paypal-Module 3.4.1 (this line is there not available on 3.4.1)

Share this post


Link to post
Share on other sites

I have been having this problem. I have resolved the inmediate 500 error by changing all the directory permissions to 755 and all the file permisions to 644.

 

Now I get all the way through paypal and then the process blows up because the sales amount and/or pre-tax amounts are not matching.

 

But the first hurdle was the file permissions! Make sure they are correct or you'll never get to the next bug...

 

Not solving the "Error" page too :unsure::(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×