Jump to content
Guilherme Dutra

[RESOLVIDO] Não consigo entrar no back Office

Recommended Posts

Ola Pessoal, estou com o seguinte problema.

Tentei editar a lingua inglês e o back office foi para tela de login.

Agora não consigo mais entrar. Toda vez que tento ele continua na tela de login.

Solicitei uma nova senha mas mesmo assim não entrou.

Não sei o que fazer mais. Já procurei no forum mas não encontrei nada parecido.

Não da erro, só não sai da tela de login.

 

www.oykostore.com

 

O site continua funcionando.

 

Obrigado

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade Guilherme Dutra :)

 

Quando solicitar ajuda deverá referir sempre a versão de Prestashop que está a utilizar.

 

Se fica preso na tela de login é porque o site não deve estar a redireccionar bem.

 

Se tivesse procurado bem nos tópicos mais recentes do fórum, teria encontrado um tópico com a solução que vou passar a descrever, desta vez de uma forma mais detalhada....

 

No ficheiro settings.inc.php, que fica na pasta config deverá ter a seguinte linha correctamente configurada:

 

Versões anteriores a 1.5:

// se a loja estiver numa pasta
define('__PS_BASE_URI__', '/nome-da-pasta-da-loja/');

 

// se a loja estiver na raiz ou root
define('__PS_BASE_URI__', '/');

 

Versões posteriores a 1.5:

// se a loja estiver numa pasta
define('_PS_DIRECTORY_', '/nome-da-pasta-da-loja/');

 

//se a loja estiver na raiz ou root
define('_PS_DIRECTORY_', '/');

 

Percebe agora porque é importante referir sempre qual a versão que está a utilizar ;)

  • Like 2

Share this post


Link to post
Share on other sites

Obrigado, consegui resolver o problema. Estou usando o Prestashop 1.5.2

 

Bem vindo á nossa comunidade Guilherme Dutra :)

 

Quando solicitar ajuda deverá referir sempre a versão de Prestashop que está a utilizar.

 

Se fica preso na tela de login é porque o site não deve estar a redireccionar bem.

 

Se tivesse procurado bem nos tópicos mais recentes do fórum, teria encontrado um tópico com a solução que vou passar a descrever, desta vez de uma forma mais detalhada....

 

No ficheiro settings.inc.php, que fica na pasta config deverá ter a seguinte linha correctamente configurada:

 

Versões anteriores a 1.5:

// se a loja estiver numa pasta
define('__PS_BASE_URI__', '/nome-da-pasta-da-loja/');

 

// se a loja estiver na raiz ou root
define('__PS_BASE_URI__', '/');

 

Versões posteriores a 1.5:

// se a loja estiver numa pasta
define('_PS_DIRECTORY_', '/nome-da-pasta-da-loja/');

 

//se a loja estiver na raiz ou root
define('_PS_DIRECTORY_', '/');

 

Percebe agora porque é importante referir sempre qual a versão que está a utilizar ;)

  • Like 1

Share this post


Link to post
Share on other sites

Quando uma resposta ou tópico lhe for útil, por favor clique no botão "Like This", pois assim estará a incentivar o autor a colaborar mais com a nossa comunidade ;)

 

Edite o titulo do tópico e coloque [Resolvido] .

 

Obrigado

Share this post


Link to post
Share on other sites
Guest gizelle

Oi meu nome é Gizelle e nao consigo entrar no meu back office desde o dia 19/03/13,digito tudo certo e sempre dar

SENHA OU USUARIO INVALIDO se puderem mim ajudar email gizelleeliza1@hotmail.com

Share this post


Link to post
Share on other sites

 

Oi meu nome é Gizelle e nao consigo entrar no meu back office desde o dia 19/03/13,digito tudo certo e sempre dar

SENHA OU USUARIO INVALIDO se puderem mim ajudar email gizelleeliza1@hotmail.com

 

Se você tiver acesso aos FTP e ao banco de dados, pode abrir o arquivo /config/settings.inc.php

Identifique o item _COOKIE_KEY_

 

Depois acesso o phpMyAdmin e rode o comando:

UPDATE `ps_employee` SET `passwd` = md5('_COOKIE_KEY_senhanova') WHERE `email` = 'seu@email.com.br';

Não esqueça de verificar o prefixo das tabelas no banco e alterar o _COOKIE_KEY_ para o valor correto.

 

Boa sorte

  • Like 1

Share this post


Link to post
Share on other sites

Existe uma maneira mais fácil ainda de recuperar (se não se trata de uma senha realmente esquecida).

 

No banco de dados vc. além de abrir um conta como administrador, Prestashop tbm. abre uma conta como cliente. Se o login como cliente funciona, então simplesmente copiar na tabela ps_customers o md5 hash para a tabela ps_employee. Veja tutorial aqui: http://mypresta.eu/e...n-password.html

Share this post


Link to post
Share on other sites

Boa noite,

Estou a utilizar a versão 1.5.4 e estou exactamente com o mesmo problema... nao consigo aceder ao painel de controlo.. nem me aparece nada, nem erro nem nada, e password nova e nada e nada.

 

ja tentei ir ao settings.inc.php e nao encontro o ('_PS_DIRECTORY_','/'); ...

 

 

HELP"

Share this post


Link to post
Share on other sites

estou com o mesmo problema, aparece a pagina de login ai coloco os dados e nada acontece, a pagina recarrega e continua na mesma, estou usando a loja 1.5.6.2.

Share this post


Link to post
Share on other sites

Bem vindo á nossa comunidade Guilherme Dutra :)

 

Quando solicitar ajuda deverá referir sempre a versão de Prestashop que está a utilizar.

 

Se fica preso na tela de login é porque o site não deve estar a redireccionar bem.

 

Se tivesse procurado bem nos tópicos mais recentes do fórum, teria encontrado um tópico com a solução que vou passar a descrever, desta vez de uma forma mais detalhada....

 

No ficheiro settings.inc.php, que fica na pasta config deverá ter a seguinte linha correctamente configurada:

 

Versões anteriores a 1.5:

// se a loja estiver numa pasta
define('__PS_BASE_URI__', '/nome-da-pasta-da-loja/');
// se a loja estiver na raiz ou root
define('__PS_BASE_URI__', '/');
Versões posteriores a 1.5:

// se a loja estiver numa pasta
define('_PS_DIRECTORY_', '/nome-da-pasta-da-loja/');
//se a loja estiver na raiz ou root
define('_PS_DIRECTORY_', '/');
Percebe agora porque é importante referir sempre qual a versão que está a utilizar ;)

 

 

Você sabe me informar qual a linha no novo Pretashop 1.6?

Share this post


Link to post
Share on other sites

Estou com o mesmo problema na versão 1.6 e não achei as linhas informadas no settings.inc.php, procurei chamadas semelhantes em outros arquivos no mesmo diretório mas também não localizei nada relacionado =/.. @exadra37, você conseguiu resolver?

Share this post


Link to post
Share on other sites

Estou com o mesmo problema na versão 1.6 e não achei as linhas informadas no settings.inc.php, procurei chamadas semelhantes em outros arquivos no mesmo diretório mas também não localizei nada relacionado =/.. @exadra37, você conseguiu resolver?

 

Pessoal e @exadra37, fiz a limpeza dos cockies e não tenho mais a falha descrita, obrigado pela atenção.

Share this post


Link to post
Share on other sites

Mil desculpas por poluir o tópico, mas o problema voltou em todos os navegadores..

 

* Fiz a exclusão do cookies nos navegadores (Chrome, FireFox e IE);

* Diminui o tempo de expiração dos cookies no arquivo classes/cookie.php;

* Limpei o cache da rede;

* A exibição de erros já está habilitada no arquivo config/defines.inc.php;

* Não localizei as instruções sobre setar o diretório em que a loja está instalada;

 

Se alguém tiver a solução e puder compartilhar, ficarei muito grato.. estou procurando aqui tb e se achar antes eu posto aqui para quem precisar o/

 

vlw galera.

Share this post


Link to post
Share on other sites

Boa tarde, estou no mesmo ponto que @war1987 fiz todas configurações inclusive a do "define('__PS_BASE_URI__', $context->shop->getBaseURI());" para "define('__PS_BASE_URI__', '/loja/');" que está no ficheiro config.inc.php linha 107. e ainda não funciona em nenhum navegador.

 

Se alguém puder dar uma luz, porque esta complicado

http://www.supermixlife.com.br/loja/sistema/

versão 1.6.0.8 Obs, Não foi nenhum updade. Foi baixado e instalado nesta versão

 

Elias[]'s

Share this post


Link to post
Share on other sites

Galera, obrigado pela atenção.. @comuniq, espero que tenha consigo arrumar a sua loja, pois vi que já tem as categorias cadastradas e alguns produtos tb.. se houver algo em que eu possa ajudar é só chamar =)

 

Bom, como não achei em nenhum lugar a solução real para esta falha (todos se referem aos cookies), resolvi migrar o servidor da hospedagem que estava a aplicação.. a hospedagem é da Locaweb e como trabalho lá fica bem mais fácil fazer isso.. depois da migração eu não tive mais a mesma falha (pelo menos por enquanto), loguei no painel, saí, loguei de novo e nenhuma falha até agora.. ressalto que não precisei limpar nada nos meus navegadores e não precisei fazer nenhuma alteração no cod. da loja que está em um sub diretório.. se alguém não conseguir resolver a mesma falha que relatamos de forma alguma e tiver a opção de realizar a migração de servidor, é uma alternativa.

 

Abraço e obrigado mais uma vez.

  • Like 1

Share this post


Link to post
Share on other sites

Então ainda não consegui resolver o problema, estou batalhando em cima disso ainda! Sobre a loja ela funcionou normal por uns 3 ~ 4 meses após a instalação e agora parou, por isso já tem algum conteúdo. Se alguém tiver mais alguma solução/tentativa por favor avisar, logico que se conseguir arrumar postarei aqui

Share this post


Link to post
Share on other sites

@Comuniq - Pergunte ao seu provedor o que foi alterado no servidor. Uma loja nao para de funcionar de um dia para outro. Provavelmente ele fez um upgrade do php.

 

1) Leia os logs de erro do servidor.

 

2) Ative o modo debug, para ver os erros que está dando: http://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

3) Um link de sua loja seria útil para analisar o problema melhor. ?

 

4) Por final, qual a versao Prestashop que está usando ? Veja aqui a configuracao mínima do servidor: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/ Aconselhamos usar php 5.3.+ e o mod_security em OFF, pois php 5.3. nao mais sustenta este módulo ativado no servidor e pode trazer problemas.

Share this post


Link to post
Share on other sites
Bom galera, pelo menos eu ainda não desistir : )

 

O problema é o mesmo, faço o login(Conta Valida) e ainda fica na mesma pagina. Quando o login é valido manda para este link http://www.supermixlife.com.br/loja/sistema/index.php?controller=AdminLogin&token=160e64646dd57e6ad3de823005273b80&redirect=AdminDashboard

 

Coisas que tentei alem do post acima:

 

Off no mod_security do ..htaccess 

<IfModule mod_security.c>

SecFilterEngine Off

SecFilterScanPOST Off

</IfModule>

 

Pagar as pasta de chace dentro do root

cache/smarty/cache

cache/smarty/compile

 

Ativei no php.ini

allow_url_fopen = On

allow_url_include = On

 

Acompanhei os logs de erro e não ocorreu nenhum problema, alguém tem alguma ideia a mais do que posso fazer? versão 1.6.0.8 do prestashop

Share this post


Link to post
Share on other sites

Vc. mexeu no ficheiro .htaccess ? O seu servidor tem o módulo mod_rewrite instalado ? É um servidor linux, ngnix ou windows ? O seu problema vem de um redirecionamento erroneo.

No seu caso O URI correto deverá ser /loja/ e o URL www.supermixlife.com.br.

Verifique ambos no seu back-office na aba "Preferencias -> SEO e URL's"

 

Apagar cache na versao Prestasho 1.6. = Aba "parametros avancados -> desempenho, bem em cima na barra de navegacao verde: limpar cache".

  • Like 1

Share this post


Link to post
Share on other sites

@selectshop.at o problema é que não consigo acessar o backoffice! Eu faço o login e ele manda novamente para a tela de login

 

Segue um usuário temporário para você fazer um teste:

E-mail: eliasdypaula@gmail.com

Senha: 12345678

 

Sim eu adicionei ao .htaccess o trecho do mod_security

 

Meu servidor de hospedagem é linux é o problema esta apenas para acessar o back-office

Share this post


Link to post
Share on other sites

O seu problema sao vários. Vc. deveria fazer um upgrade da versao php no servidor. Converse com o seu provedor. Prestashop 1.6. necessita de ao menos a versao 5.3. se já nao esteja disponível 5.4.

A versao php 5.2. por usar o mod_security nao mais serve, mesmo vc. desabilitando com php.ini próprio.

 

Eu consegui acessar ao seu back-office. Limpei o cache aonde deveria ser limpado e perdi a sessao.

 

Me manda dados de login para o seu FTP e banco de dados, para eu dar uma olhada o que está acontecendo através de mensagem privada.

 

http://www.prestashop.com/forums/index.php?app=members&module=messaging&section=send&do=form&fromMemberID=741527

  • Like 1

Share this post


Link to post
Share on other sites

Quando eu desativo o JS no meu browser eu novamente consigo acessar ao back-office. Estou achando que o problema é algum módulo responsável pro JS do seu servidor. Se vc. fizer um upgrade da versao php no servidor, é bem capaz que o problema suma...

 

Mas mesmo assim me mande os dados acima solicitiados. Vou dar uma olhada na sua configuracao.

 

Também register_globals deveria estar desativado, que ainda continua ativo, de acordo com a informacao da configuracao no back-office.

 

A única maneira no momento de ficar logado é desligar JS no browser, mas o problema é que nao poderá acessar a todos os tabs de configuracao que necessitam JS. Mande os dados e eu dou uma olhada o que está acontecendo. Só que podera demorar dois dias, pois amanha e depois tenho umas visitas marcadas com clientes fora do meu escritório. No domingo teria tempo e cabeca para verificar o seu problema mais minunciosamente.

 

No seu servidor deve estar faltando o módulo tokenizer, o que faz com que vc. nao vai poder usar tokens (o que contribuí com a seguranca da loja). Desativei a funcao para o front-office. Converse com o seu provedor.

1) Faca um upgrade da versao php no seu servidor para php 5.3.(16) por ex.

2) register_globals e mod_security por nao mais serem sustentados a partir das versoes php 5.3+ devem estar desativados no servidor.

3) o módulo tokenizer deverá estar ativado, para que vc. possa usar a configuracao de seguranca do Prestashop como acima descrito.

4) o tempo de execucao em 60 também deveria ser aumentada para ao menos 300 se possível. (módulo max_execution_time.) Se tiver scriptes que demorem mais de 60 segundos para serem executados eles abortam e podem provocar furos no banco de dados.

 

PS: notei que os produtos da sua página principal nao estao catalogizados em nenhuma categoria. As suas categorias nao contém produtos. Quando adicionar um produto, tem de escolher uma categoria padrao para poder acessá-los.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

selectshop.at estou com o mesmo problema! nao consigo, já tentei desativar meu js, já limpei cache, já reinstalei a loja 3x.

 

A versão 1.6 não consigo instalar! ela trava em 12% e dá erro na hora q vai criar o banco de dados! chega a criar, pq acessando o mysql, vejo tabelas criadas por ele, porem nao trava e dá erro.

 

ai instalei a versão 1.5.6.2, instala legal, mas nao consigo entrar no backoffice, coloco login e senha da erro, já gerei senha nova, ja mudei senha no bancodedados direto, já mudei e-mail direto no db tb! e nada! ele simplismente nao dá erro nenhum, ele apenas da um "reload" na pagina! =/

 

as configurações do meu servidor (hostnet):

 

PHP Version 5.3.10-1ubuntu3.15 System

Linux web158 3.2.0-64-generic #97-Ubuntu SMP Wed Jun 4 22:04:21 UTC 2014 x86_64

Server API Apache 2.0 Handler mysql MySQL Support enabled     Client API version 5.5.40

 

memory_limit 96M

upload_max_filesize 2M

max_file_uploads 20

 

openssl

OpenSSL support enabled

 

gd

GD Support enabled

GD Version 2.0

 

curl

cURL support enabled

cURL Information 7.22.0

 

SimpleXML

Simplexml support enabled

Revision $Revision: 321634 $

 

soap

Soap Client enabled

Soap Server enabled

 

mcrypt

mcrypt support enabled

mcrypt_filter support enabled Version 2.5.8

 

 

 

pode me ajudar pq nao consigo acessar o backoffice?

 

o endereço é www.kilin.com.br/webstore/administracao

 

login provisorio: italomota@gmail.com

senha: 124578369 (primeiro 12, dps 45, dps 78, dps o 369)

 

tentei instalar o presta 1.6 no diretorio loja e no diretorio store pelo:

 

http://www.kilin.com.br/store/install/index.php

Edited by italomota (see edit history)

Share this post


Link to post
Share on other sites

Boas,

 

Pelo que descreve o seu alojamento não suporta totalmente prestashop 1.0.6.9, sendo assim o mais indicado será contactar a empresa  e verificar se podem corrigir o problema, mas o mais certo é ter de mudar de alojamento de forma a evitar problemas no futuro.

 

Cumps

Share this post


Link to post
Share on other sites

CarlosC, mas o prestashop 1.5.6.2 é instalado automaticamente pelo proprio host! o q não é compativel com a 1.6.0.9??

 

e pq nao consigo entrar no backoffice do 1.5.6.2??

Share this post


Link to post
Share on other sites

Vc. terá que pedir aucílio ao seu host, ou seja oo que fez a instalacao.

 

Vc. tem acesso ao FTP ? Se sim poderá ativar o modo debug para verificar prováveis erros que estejam dando. Ou entao analise os logs de erro do seu servidor mesmo.

 

Ativar modo debug: http://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

e leia os erros que vem no topo da página.

 

Coinfiguracao mínima do servidor: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

Pelos requisitos acima descritos nao vai poder correr PS 1.5. e nem PS 1.6. Limíte de memório muito baixo.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

troquei de servidor! coloquei em um dedicado agora, com 1gb de memoria e limite de upload de 64gb max file size de 2gb tb

 

podem ver as configs pelo site www.kilin.com.br/info.php

 

e msm assim nao consigo instalar a 1.6 =/ continua dando erro...

Share this post


Link to post
Share on other sites

No seu novo servidor nao servem max_execution_time e também nao max_input_time. Limite de memória com 128M é o mínimo mesmo que vc. pode usar. Vc. deverá ter de preferencia 256M como descrito no link que coloquei mais acima.

 

No entanto para instalar Prestashop estes valores passam (mas nao para o uso cotidiano da loja, que vai crescendo!).

 

Qual os erros que está dando ?

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Boa dia amigos.

Estou iniciando agora no prestashop, porem ja estou apanhando, forneci a senha que foi criada na instalação do presta shop. 1.6, para uma pessoa, instalar um tema

o tema foi instalado, agora eu gostaria de mudar esta senha, para que a pessoa não tenha mais acesso, ao painel do prestashop, mas não encontrei nenhu lugar para alterar senha.

 

Aguem poderia por favor  dar um help, minha versão do prestashop 1.6... 

do forma mais simples possivel, até mesmo porque não entendo nada, dessas linguagem que fico observando nos foruns.

 

desde de ja agradeço a atenção

Ps não sei se estou postando no lugar certo, caso esteja errado desculpe

Share this post


Link to post
Share on other sites

Vc. ofereceu a SUA senha, da SUA conta, ou abriu uma conta de empregado ?

 

Vc. altera as senhas diretamente na conta do empregado/superAdmin. Vai no tab: "administração -> empregados" escolha lá o empregado em questão e usa a opção "editar"configure. Na página seguinte poderá mudar a senha.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Bom dia! Sou novo por aqui e então peço desculpas se a minha dúvida não for nesse espaço.

 

Tem uma loja virtual que estava funcionando normalmente, mas de uma hora para outra parou de funcionar. o site estava daso erro 404 e pagina em branco. fiz um backup da pasta public-html e ele mudou agoa aparece os links do site mas sem as imagens e não estou conseguindo acessar meu painel admin. faço log e senha mas ele nao redireciona. alguem saberia me dizer o que esta acontecendo e o que pode ser feito?

 

desde já agradeço 


desculpe segue o link do site. www.freekoti.com.br

Share this post


Link to post
Share on other sites

Desative o ficheiro .htaccess da raíz da sua loja colocando outro nome neste (.htaccess.bak por ex.). Delete o cach do seu browser (tecla F5) e tente acessar a página admin. Se der certo, vc. entao deverá reiniciar o seu .htaccess novamente colocando um ficheiro vazio na raíz da loja com este nome e dando-lhe direitos de escrita. Após isto vá no seu back-office na aba "preferencias -> SEO & URL's" e salve lá o botao na parte aonde vc. define o domínio da loja.

Share this post


Link to post
Share on other sites

Boa tarde.

Instalei o aplicativo do prestashop e não consigo redefinir a senha.

Esta dando erro ao tentar enviar a senha por email no back office.

meu email pingodeagua2@gmail.com

Share this post


Link to post
Share on other sites

Qual o erro ? Deverá debugar este primeiramente (se possível). Está conseguindo acessar com a senha antiga ou está somente com o problema de redefinir a senha ? A senha vc. redefine no seu back-office na aba dos empregados. Se nao está conseguindo acessar com a senha antiga, entao deverá primeiramente debugar o erro que está lhe dando. Especifique qual é, para podermos ajudá-lo.

Share this post


Link to post
Share on other sites

Preciso de ajuda quanto a um problema na minha loja, desenvolvi a mesma na hostinger e após todos os testes a loja estava perfeita decidi muda-la de servidor para a HOSTGATOR, acontece que depois de upar via ftp e colocar o banco a página my-account não abre de jeito nenhum. Os clientes não conseguem fazer login nem nada do tipo. Já instalei a loja no localhost e funciona perfeitamente assim como estava funcionando na hostinger.

Como resolver meu problema?

Segue dados da loja
taliartesbaby.com.br
Prestashop 1.6.1.4
Hospedagem é a Hostgator

Share this post


Link to post
Share on other sites

OIi

 

Como faço para descobrir o meu mail e que me esqueci me  de qual e!?

Como posso fazer para descobrir ???????

Alguém me pode ajudar sff e urgente

 


OIi

 

Como faço para descobrir o meu mail e que me esqueci me  de qual e!?

Como posso fazer para descobrir ???????

Alguém me pode ajudar sff e urgente

 

rafaelaveiro_4@hotmail.com

Edited by Rafael Aveiro (see edit history)

Share this post


Link to post
Share on other sites

Oii 

Nao consigo aceder a minha conta porque me esqueci do meu mail alguém me pode ajudar como posso descobrir o meu mail pra entrar sff

rafaelaveiro_4@hotmail.com

se alguém souber me ajude e urgente

hoje eu amanha pode ser você 

Share this post


Link to post
Share on other sites

Se esqueceu o seu mail, entao acesse ao banco de dados com phpmyAdmin e leia lá na tabela ps_customer o primeiro cliente = admin.

Share this post


Link to post
Share on other sites
On 3/24/2013 at 7:00 PM, Daniel - PrestaBR said:

 

Se você tiver acesso aos FTP e ao banco de dados, pode abrir o arquivo /config/settings.inc.php

Identifique o item _COOKIE_KEY_

 

Depois acesso o phpMyAdmin e rode o comando:

 


UPDATE `ps_employee` SET `passwd` = md5('_COOKIE_KEY_senhanova') WHERE `email` = 'seu@email.com.br';
 

 

Não esqueça de verificar o prefixo das tabelas no banco e alterar o _COOKIE_KEY_ para o valor correto.

 

Boa sorte

Deu certo funcionou de primeira no PS 1.6.2, Muito obrigado, tudo de bom para você.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More