Jump to content
FEY2014

Alten 1.5 Shop übernommen der mit PHP 7 nicht funktioniert, Sourcen nur per ftp verfügbar, wie upgraden?

Recommended Posts

Hallo miteinander,

das scheint mir ein recht positives Forum zu sein. Lauter nette Leute und Forumseinträge. ich bin neu hier, sowohl in Sachen PrestaShop als auch als "Heilsbringer" einer Webseite aus 2014 mit PS 1.5.0 (aus config ausgelesen). Der erstellende "Webmaster" ist wie so oft nicht mehr verfügbar, Informationen liegen nicht vor,

Ich habe also nur Zugriff per ftp um die alte Version zu sichern. Und soll den nun mt der Fehlermeldung wieder zum lauen bringen.

Hierzu habe ich bereits im Forum und Web gesucht, aber diesen Sprung hat noch niemand gemacht. Und ich muss leider gestehen, dass ich in Sachen PrestaShop ein Neuling bin.

Hierfür benötige ich das Wissen und die Erfahrung der Community um überhaupt einen Ansatzpunkt zu finden.

Was ist zu tun, kann und muss ich erst eine alte 1.5 Installation lokal auf meinem Rechner installieren, den Webshop einlesen und schauen, dass er fuktioniert und danach ein Upgrade einspielen?

Hierzu finde ich keine Informationen und bitte um Eure Hilfe.

Danke schon mal.

Bernhard 

Share this post


Link to post
Share on other sites

Hallo Bernhard,

willkommen im Forum!

Wäre es nicht einfacher den 1.5er Shop erstmal unter php 7 lauffähig zu machen?

Anleitung hier

Grüsse
Whiley

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb FEY2014:

Ich habe also nur Zugriff per ftp um die alte Version zu sichern. Und soll den nun mt der Fehlermeldung wieder zum lauen bringen.

Hallo!

Ich verstehe nicht so recht, wie die Situation ist und was du eigentlich vorhast. Hast du nur Zugriff auf die Dateien oder auch auf die Datenbank? Gibt es überhaupt einen laufenden 1.5er-Shop?

Von was für einer Fehlermeldung sprichst du?

Share this post


Link to post
Share on other sites
3 hours ago, Whiley said:

Wäre es nicht einfacher den 1.5er Shop erstmal unter php 7 lauffähig zu machen?

Aber vorher sollte der Shop, wenn es denn tatsächlich eine Version 1.5.0 ist, unbedingt auf 1.5.6.3 upgedated werden. 

Dazu das Modul 1-Click-Upgrade installieren, falls noch nicht vorhanden. (ggf. PM an mich, ich schick dir dann einen Download-Link für die passende Version).

In der Modul-Konfiguration in der Sektion Jetzt aktualisieren rechts den Button

Mehr Optionen(Expertenmodus) anklicken

und anschließend im Dropdown-Feld Kanal die Option

Update im Rahmen der aktuellen Version (empfohlen)

auswählen. Dann auf Speichern klicken.

Zuvor solltest du aber in jedem Fall (ebenfalls mit dem genannten Modul möglich) eine Datensicherung machen. Man weiß ja nie!

EDIT: All das klappt natürlich nur, wenn der Provider wenigstens zeitweise die PHP-Version auf 5.6.2 heruntersetzt. Denn ohne Zugang zum Back Offcie müsste man den Shop via FTP auf 1.5.6.2 aktualisieren, und das würde auch Datenbankänderungen einschließen. Nichts für einen Anfänger!

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites
7 hours ago, Whiley said:

Wäre es nicht einfacher den 1.5er Shop erstmal unter php 7 lauffähig zu machen?

Anleitung hier

Grüsse
Whiley

Wow, das nenne ich einmal einen schnelle ud quailifierten Zuspruch. Ihr seid toll. Danke schon mal.

Kann ich den mit der Anleitung so machen oder muss ich doch erst auf 1.5.6.3 upgraden? Ein php Downgrade ist bei one.com anscheinend nicht vorgesehen. Die Datenbank kann ich nur per Webtools von one.com Verwalten.

Gruss

Bernhard

 

Share this post


Link to post
Share on other sites

Danke. Der PrestaShop ist 1.5.0 und die Anleitung ist anscheinend für 1.5.6. Zumindest verstehe ich die erstei Zeile so:
"Für diejenigen, die auf Ihren PrestaShop 1.5.6 nicht verzichten wollen und trotzdem auf PHP 7.2 umsteigen wollen oder müssen, hier die wesentlichen Anpassungen zum Download."

Soll ich dennoch so vorgehen oder ist da eine andere Vorgehensweise notwendig.

Share this post


Link to post
Share on other sites

Ich kannte Prestashop zu der Zeit noch nicht, aber zwischen 1.5.0 (wenn es wirklich diese Version ist, normalerweise sind erste Null-Versionen einer Hauptversion so fehlerbehaftet, daß sie kein Mensch verwendet) und 1.5.6 kann eine lange Zeit und viele Änderungen gelegen haben. Aber versuchen kannst du es natürlich.

Meine Fragen sind übrigens leider offen geblieben.

Share this post


Link to post
Share on other sites
vor 11 Stunden schrieb FEY2014:

Kann ich den mit der Anleitung so machen oder muss ich doch erst auf 1.5.6.3 upgraden?

Wie Wuschel schon geschrieben hat:

vor 16 Stunden schrieb Wuschel:

Aber vorher sollte der Shop, wenn es denn tatsächlich eine Version 1.5.0 ist, unbedingt auf 1.5.6.3 upgedated werden. 

Aber welche Version hat dein Shop wirklich, eine 1.5.0er Version gab es nie, die erste dieser Reihe war die 1.5.0.17 (September 2012) richtig stabil wurden die Versionen erst ab der 1.5.5.0  (August 2013) bis zur Version 1.5.3.6 (Juli 2015) von denen es ja noch viele online gibt! Das man die Shopversion aus der config auslesen kann wäre mir neu, vielleicht kannst du es aber auf Grund des Installationsdatums (FTP) eingrenzen.

Oder den Autor des von mir oben verlinkten Artikels ansprechen, ich unterstelle mal das der die genauen Unterschiede aus dem FF kennt (?😉).

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Ich versuche die Informationen zusammen zu tragen.
Die Dateien auf dem Server haben das Datum 31.5.2014.

Und ja, ich habe in einer der config Dateien wie oben gepostet einen Eintrag gefunden.

shop/config/settings.inc.php

define('_PS_CREATION_DATE_', '2014-05-31');
define('_PS_VERSION_', '1.5.6.0');

Share this post


Link to post
Share on other sites
19 hours ago, rictools said:

Hallo!

Ich verstehe nicht so recht, wie die Situation ist und was du eigentlich vorhast. Hast du nur Zugriff auf die Dateien oder auch auf die Datenbank? Gibt es überhaupt einen laufenden 1.5er-Shop?

Von was für einer Fehlermeldung sprichst du?

Sorry, hier die Antworten auf deine Fragen.

Ich bin darum gebeten worden, eine nicht (mehr) funktionierenden Webshop wieder auf die Beine zu helfen. Die Fehlermeldung scheint aus einem PHP Upgrade entstanden zu sein. Vorher ein älteres PHP, vermutlich 5.x. Die Meldung ist:
Current PHP version is not supported. Control panel requirements are: PHP version 5.6, 7.0 or 7.1.

Ich habe FTP Zugriff auf die Dateien und Zugriff auf die Datenbank per weboberfläche von one.com . Der Shop lief einmal, nun seit einiger Zeit nicht mehr.

PrestaShop kannte ich bisher nur vom Namen. 

Gruss
Bernhard

Share this post


Link to post
Share on other sites
1 hour ago, FEY2014 said:

shop/config/settings.inc.php

define('_PS_CREATION_DATE_', '2014-05-31');
define('_PS_VERSION_', '1.5.6.0');

Ok, wenn wir mal unterstellen, es ist vermutlich 1.5.6.0, dann wäre für mich die logische Reihenfolge:

  1. Du spielst den Inhalt von eleazars Patch-zip für 1.5.6 ein, aus dem Tutorial, auf das @Whiley oben verlinkt hat.
  2. Du solltest dann wieder Zugang zum Back Office haben, also wäre dann der nächste Schritt, das Update wie von mir oben beschrieben durchzuführen.
  3. Anschließend vermute ich mal, musst du die Patches ein zweites Mal einspielen. Aber da frag lieber noch mal bei eleazar in dem anderen Forum nach. 

Solltest du keine Zugangsdaten zum Back Office haben, dann melde dich nochmal. Da gibt es mehrere Tricks, um rein zu kommen.

Share this post


Link to post
Share on other sites

Servus, 

ich muss Abbitte leisten: nachdem ich nun versucht habe auf dem Server die Updates ZIP einzuspielen und mich dabei noch weiter und weiter durch die Skripte gegraben habe (und zum Glück auch die HTML Seiten), musste ich feststellen, das ich in der falschen Shop Installation unterwegs war. 

Die gute Nachricht (eher: bessere nachricht) ist, das es eine Umleitung auf einen PrestaShop 1.6.0.8 gibt. Oh man. Das hätte ich mal früher herausfinden sollen. Dennoch hat mich di eLektüre Eurer Hilfe und der verlinkten Patch Seiten erheblich im Verständnis weiter gebracht. 

Eigentlich wollte ich nun direkt loslegen und das 1.6 Upgrade ZIP einspielen. Doch das ist für die 1.6.1.x gedacht. Naja, die Erfahrung zeoit, das zwichen einer 1.6.0 und 1.6.1 zwar nur kleine Differenzen bestehen, aaber vermutlich wesentlich.

Deshalb die Frage, ob ich das 1.6.1.x ZIP verwenden kann.

Gruss

Bernhard

Edited by FEY2014 (see edit history)

Share this post


Link to post
Share on other sites

Frag am besten in @Whileys Forum nach. In  jedem Fall wirst du aber die 1.6er Version upgraden müssen. Dan wird es wohl auf den von mir vorgeschlagenen Weg hinauslaufen. Nur eventuell mit der anderen Zip-Datei.

Share this post


Link to post
Share on other sites
6 minutes ago, Wuschel said:

Frag am besten in @Whileys Forum nach. In  jedem Fall wirst du aber die 1.6er Version upgraden müssen. Dan wird es wohl auf den von mir vorgeschlagenen Weg hinauslaufen. Nur eventuell mit der anderen Zip-Datei.

Wo finde ich Whiley s Forum?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More