Jump to content
negus

SSL Zertifikat neu einbinden

Recommended Posts

Hallo Leute

Folgendes Problem, ich bin mit meiner Domain auf ein eigenen Server umgezogen. Jetzt habe ich ein neues Zertifikat bekommen. Jeder der die Seite besucht bekommt ein Hinweis das es unsicher ist weil das Zertifikat nicht stimmt.

Speichert Prestashop das Zertifikat irgendwo ab das ich es löschen muss bevor ich das neue aktiviere?

Oder wo dran kann das liegen. Wer es mal ausprobieren möchte hier die URL shop.zwergschmuck.de

 

Share this post


Link to post
Share on other sites

Mit Prestashop hat das nichts zu tun. Das Zertifikat ist nur für www.zwergschmuck.de gültig, jedoch nicht für die Subdomain shop.zwergschmuck.de. Wenn du sowohl die Haupt- als auch die Subdomain verwendest, brauchst du zwei Zertifikate oder eines, das auch für Subdomains gilt, ansonsten mußt du beim Provider einstellen, daß das Zertifikat für die shop-Subdomain gilt statt für die Hauptdomain.

Share this post


Link to post
Share on other sites

Das Zertifikat ist für die Haup und für die Subdomain habe ich ja bei der bestellung aussuchen können.

Single Domain Certificate
Sichert einen einzelnen vollständig qualifizierten Domainnamen, wie www.meinedomain.de oder subdomain.meinedomain.de

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb negus:

Single Domain Certificate
Sichert einen einzelnen vollständig qualifizierten Domainnamen, wie www.meinedomain.de oder subdomain.meinedomain.de

Das "oder" im oberen Satz ist das Problem!

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Ich habe gestern beim Zertifikataussteller nachgefragt, es ist für Haupt und Subdomain geeignet.

Somit sollte es laufen was es aber nicht macht. Jetzt bitte mal eure Tipps, an was es liegen kann das es nicht funktioniert.

ssl.PNG

Share this post


Link to post
Share on other sites

Dein Screenshot zeigt lediglich die Umleitungen nach https, hier wird nichts darüber ausgesagt ob ein Zertifikat eingebunden ist und ob das Zertifikat für die Subdomain ausgestellt wurde.

Wenn diese 2 Bedingungen erfüllt wären, würden die Fehlermeldungen im Browser nicht kommen!

Also entweder - falls technisch möglich - gültiges Zertifikat selbst erzeugen und einbinden oder Provider aktivieren.

(Bei Prestashop hast du ja die ssl-Unterstützung für alle Seiten aktiviert?)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More