Jump to content
DT0

Produkte erscheinen auf mobilen Geräten erst nach Aktualisierung im Warenkorb

Recommended Posts

Hallo zusammen,

wir haben einen Shop mit 1.7.4.3 erstellt. Auf dem Computer funktioniert alles wie gewohnt. Auf mobilen Geräten jedoch, werden Artikel erst nach Aktualisieren der Seite im Warenkorb gezeigt. Wenn man auf "in den Warenkorb" klickt passiert optisch nichts. Wenn man die Seite neu lädt, wird das Produkt im Warenkorb gezeigt.

Auf der Suche nach einer Lösung habe ich einen älteren Beitrag gelesen, in dem dieser Fehler auf die Verwendung einer SSL-Verschlüsselung zurück geführt wurde. Leider gab es keine Lösung dafür. 

Bevor wir die Verschlüsselung eingerichtet haben, hat alles funktioniert, diese Ursache ist also durchaus möglich. 

 

Hattet Ihr bereits ein ähnliches Problem und habt eine Lösung dafür? Da SSL-Verschlüsselungen in zwischen nicht nur üblich sondern auch vorgeschrieben sind, sollte das ganze eigentlich keine Probleme machen oder? 

 

Vielen Dank und liebe Grüße

Share this post


Link to post
Share on other sites
Posted (edited)

Wenn nichts dagegen spricht, würde ich zunächst auf die neueste Version aktualisieren.

In diesen Forumsbereich gehören übrigens keine Fragen.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

In diesem Fall schon, denn es handelt sich tatsächlich um ein Prestashop-Bug, der erst ab 1.7.5.0 behoben wurde und keineswegs immer nur im Mobilmodus auftrat. Daher war auch Deine Antwort goldrichtig,

Share this post


Link to post
Share on other sites

Danke für eure Antworten. Ich habe inzwischen auf 1.7.5.1 aktualisiert.

Nun funktioniert auf dem Handy immerhin das "Vorschaufenster". Der Warenkorb-Button macht aber immernoch die gleichen Probleme.

Ich habe schon verschiedenstes im Debug-Modus probiert um Konflikte auszuschließen, leider ohne Erfolg. Es scheint wirklich an Prestashop zu liegen.

Habt Ihr noch einen anderen Ansatz für eine Lösung?

 

Vielen Dank vorab!

 

 

 

Share this post


Link to post
Share on other sites
vor 27 Minuten schrieb DT0:

Der Warenkorb-Button macht aber immernoch die gleichen Probleme.

Da das PrestaShop-Team sich für diesen Fehler (Ajax-Cart wird nicht aktualisiert), über den sich schon so einige Leute beklagt haben, nicht verantwortlich fühlt, wirst Du da von dieser Seite keine Hilfe erwarten können. Laut Aussage der Entwickler liegt es an irgendeinem Fremdmodul, denn sie können wohl den Fehler nicht reproduzieren. Es kann sich auch um eine Modulmodifikation handeln, wie sie bei Fremdtemplates nicht unüblich ist. Ich kann ihn übrigens auch nicht nachstellen, da der Warenkorb zumindest beim Standardtemplate meiner Testversion problemlos aktualisiert wird.

Mein Rat: Wenn Du Deine Kunden nicht verärgern willst, dann solltest Du entweder in der Lage sein, Fehler im Core von 1.7 selbst zu beseitigen oder solange bei 1.6 bleiben, bis das Team die Bugs selbst in den Griff bekommt. Das kann aber leicht eine Hängepartie werden.

Share this post


Link to post
Share on other sites
vor 9 Stunden schrieb DT0:

Ich habe schon verschiedenstes im Debug-Modus probiert um Konflikte auszuschließen, leider ohne Erfolg.

Hast du testweise alle Fremdmodule und Overrides deaktiviert und auch Caches gelöscht, evtl. anderen Browser probiert?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More