Jump to content

Recommended Posts

Hallo zusammen,

 

nach update auf 1.6.1.23 sind die Module nicht mehr erreichbar, folgende Fehlermeldung bekomme ich

[PrestaShop] Fatal error in module file :/var/www/.../htdocs/modules/avalaratax/de.php:
syntax error, unexpected '$_MODULE' (T_VARIABLE)

 

hat jemand auch das Problem?

Share this post


Link to post
Share on other sites

Sollte keine Probleme machen, stell einfach mal zurück und sieh nach, obs geht.

Ansonsten kannst du das Modul einfach mal vom Pfad her umbenennen und schauen, was passiert? Sind noch Backups vom Ausgangszustand vorhanden?

Share this post


Link to post
Share on other sites

jetzt habe ich den hier

[PrestaShop] Fatal error in module CertissimXMLElement.class:
syntax error, unexpected 'class' (T_CLASS)

Share this post


Link to post
Share on other sites

ne war nur avaralatax, nach dem Cache leeren war alles wieder in Ordnung.

 

Mal eine andere Frage, welche 1.6 Version würdet ihr für ein Update empfehlen?

Share this post


Link to post
Share on other sites
  • 2 years later...
Posted (edited)

Hallo zusammen,

bräuchte Mal wieder eure Unterstützung. Nun habe ich von 1.6.1.23 auf 1.7.7 Update gemacht und habe ich ähnliches Problemchen, ich komme wieder nicht in die Module rein, Symphony spuckt folgende Fehlermeldung aus

 

EBUG10:12:23doctrineSELECT name FROM znbqn_module WHERE active = 1

INFO10:12:24requestMatched route "admin_orders_index".

DEBUG10:12:24securityRead existing security token from the session.

DEBUG10:12:24securityUser was reloaded from a user provider.

INFO10:12:24phpUser Deprecated: Creating Doctrine\ORM\Mapping\UnderscoreNamingStrategy without making it number aware is deprecated and will be removed in Doctrine ORM 3.0.

DEBUG10:12:24doctrineSELECT t0.id AS id_1, t0.employee AS employee_2, t0.shop AS shop_3, t0.controller AS controller_4, t0.action AS action_5, t0.filter AS filter_6, t0.filter_id AS filter_id_7 FROM znbqn_admin_filter t0 WHERE t0.employee = ? AND t0.shop = ? AND t0.filter_id = ? LIMIT 1

DEBUG10:12:24doctrineSELECT t0.id AS id_1, t0.employee AS employee_2, t0.shop AS shop_3, t0.controller AS controller_4, t0.action AS action_5, t0.filter AS filter_6, t0.filter_id AS filter_id_7 FROM znbqn_admin_filter t0 WHERE t0.employee = ? AND t0.shop = ? AND t0.filter_id = ? LIMIT 1

INFO10:12:24phpUser Deprecated: Implementing "Symfony\Component\HttpKernel\DataCollector\DataCollectorInterface" without the "reset()" method is deprecated since Symfony 3.4 and will be unsupported in 4.0 for class "Csa\Bundle\GuzzleBundle\DataCollector\GuzzleCollector".

CRITICAL10:12:24phpUncaught Warning: Declaration of Cart::getProducts($refresh = false, $id_product = false, $id_country = NULL) should be compatible with CartCore::getProducts($refresh = false, $id_product = false, $id_country = NULL, $fullInfos = true, bool $keepOrderPrices = false)

CRITICAL10:12:24requestUncaught PHP Exception Symfony\Component\Debug\Exception\ContextErrorException: "Warning: Declaration of Cart::getProducts($refresh = false, $id_product = false, $id_country = NULL) should be compatible with CartCore::getProducts($refresh = false, $id_product = false, $id_country = NULL, $fullInfos = true, bool $keepOrderPrices = false)" at /var/www/web26948268/html/override/classes/Cart.php line 1044

Edited by gfkk (see edit history)

Share this post


Link to post
Share on other sites
6 hours ago, gfkk said:

/html/override/classes/Cart.php

Da ist ein Override aktiv der nicht mit deiner Prestashop Version kompatibel ist. Am besten umbennen um ihn zu deaktivieren und alle anderen Overrides/Module auch checken.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More