Jump to content

Je n'arrive pas à installer prestashop chez 1&1;


Recommended Posts

Bonjour,

n'ayant pas réussi à installer ma boutique faite en locale sur mon serveur, j'ai tout supprimé et
essayé de l'installer directement en ligne chez 1&1;. Les fichiers ont bien tous été envoyé mais je n'arrive
pas à aller plus loin. En effet, l'installation ne se lance pas. J'ai à chaque fois une erreur 404.
Quelqu'un peut-il m'aider? Cela fait déjà plusieurs jours que je suis sur le problème.

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

Il est difficile de répondre comme cela, car normalement vous déposez les fichiers dans le répertoire www de 1and1 et vous tapez l'adresse de votre site dans votre navigateur et à ce moment il vous indique une erreur qui vient du fait que php5 n'est pas activé sur les hébergement 1and1. Alors vous modifiez le .htaccess pour y ajouter la ligne correspondant à votre hébergeur suivant le modèle proposé sur http://www.prestashop.com/forums/viewthread/446/ et en retournant sur l'url de votre site la procédure d'installation se lance et voila.

Bien entendu tout cela se passe ainsi si vous avez chargé tous les fichiers extraits de l'archive chargé sur Prestashop.

Share this post


Link to post
Share on other sites

Bonjour,

merci de cette réponse. Oui, j'avais bien vu ce sujet avant de demander conseil et j'avais bien modifié le fichier htaccess. J'ai toujours le même problème après plusieurs tentatives d'installation. J'ai à chaque fois le messages "Error 404 - Not found

Le fichier requis n'a pas été trouvé. Il peut s'agir d'une erreur technique. Veuillez réessayer ultérieurement. Si vous ne pouvez pas accéder au fichier après plusieurs tentatives, cela signifie qu'il a été supprimé. "

Pourtant les fichiers semblent bien tous téléchargés. Je ne comprends pas.

Share this post


Link to post
Share on other sites

Bonjour,

Une erreur 404 indique que le fichier n'est pas présent sur l'hébergemnt à l'endroit que vous cherchez à atteindre. Je ne peux pas en dire plus malheureusement.

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Bonjour,

je n'arrive pas également à installer la boutique prestashop sur mon serveur 1&1;.

J'ai déjà un site qui tourne sur mon serveur et je désire installer une boutique pour son développement avant de l'installer sur le serveur de mon client (dans quelques semaines...)

Aussi, j'ai créé un repertoire "prestashop" à la racine de mon serveur dans lequel j'ai déposé tous les fichiers prestashop.

J'ai bien ajouter la ligne

AddType x-mapp-php5 .php

comme expliqué sur le wiki dans mon htaccess qui se trouve à la racine de mon serveur.

Lorsque je me me pointe sur l'adresse www.monsite.fr/prestashop, rien ne se passe, j'ai une page blanche. Lorsque j'affiche le code source de la page, je constate qu'il n'y a effectivement aucun code.

J'ai alors pointé vers l'adresse www.monsite.fr/prestashop/install, j'ai cette ligne qui s'affiche :

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/27/d240760159/htdocs/prestashop/install/classes/ToolsInstall.php on line 4

Savez vous pourquoi et comment y remédier ?

Merci d'avance !

Share this post


Link to post
Share on other sites

Bonjour
Il semble que 1and1 active le php5 désormais car la version activée pour ma base de données est bien php5. Je n'ai donc pas modifié le ".htaccess". Mais je me retrouve dans la même situation avec le message d'erreur. Je suis donc également preneur d'informations pouvant aider à résoudre ce problème.
En vous remerciant.
Désolé de ne pouvoir faire avancer le post ;-)

Share this post


Link to post
Share on other sites
Merci. Je vais continuer à chercher dans cette direction.

Bonjour
Sauf erreur de ma part si le dossier "prestashop" qui contient les fichiers est déposé à la racine du site il faut donc que l'adresse soit :
http://www.monsite.com/prestashop/install/

Si le contenu du dossier est directement déposé à la racine sans être dans le dossier "prestashop", l'adresse doit être :
http://www.monsite.com/install/

C'est surement pour ça que s'affiche une erreur 404.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Je suis également chez 1&1;et j'ai exactement fait comme jloupf et j'ai le même message d'erreur :
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/41/d345709763/htdocs/prestashop/install/classes/ToolsInstall.php on line 4

Cela fait 1 semaine que je me "bagarre"
help me please !!! :-/

merci pour votre aide précieuse

  • Like 1

Share this post


Link to post
Share on other sites

salut,
J'ai installé un site chez 1&1;il y a peu et selon leurs dire il faut installer le site à la racine /
mais en fait je me suis rendu compte que la racine est /Numero client/
en fait ils crééent directement un sous domaine au cas ou tu voudrais toi même créer des sous domaines.
je ne sais pas si ça va t'aider mais pour moi ce truc là a été une bonne prise de tête et bien entendu personne au service assistance ne te le signale.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Pour 1 & 1 sur le .htaccess j'ai mis

AddType x-mapp-php5 .php .php3 .php4 .htm .html



Mon site est à la racine /

Et pensez bien à mettre le point devant le htaccess et aucune extension

.htaccess

Si vous n'arrivez pas à nommer correctement le fichier sous windows créez un htaccess.txt, envoyez le sur votre site et à l'aide de votre logiciel ftp renommez le .htaccess

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More