Jump to content
Zeryk

update from 1.6.1.12 to 13 or 14, how?

Recommended Posts

1Click module offers only upgrade to 1.7 version, which would crash down my site ( already tried ) . One of the windows in Dashboard says:  "update to 1.6.1.13" when I click on it , ti goes to PS website front page, where is also only 1.7 :-( and search box doesn't give any either.

 

So how to I update to 1.6.1.13 or 14? Anybody can help please?

 

Thanks

Share this post


Link to post
Share on other sites

That is weird. As far as I know, 1-click upgrade cannot upgrade from 1.6 > 1.7

 

Can you show a screen print form inside the 1-click upgrade module showing that it only has 1.7 available?

Share this post


Link to post
Share on other sites

You likely installed the wrong version of the upgrade module.  There are 2 different versions...

1) Upgrades you to the latest release of PS v1.6

2) Upgrades you to the latest release of PS v1.7

 

Follow instructions and make sure you know how to take complete backups of your store before proceeding.  Also make sure you know how to recover your store when things break.  Do not rely on the upgrade module to do that for you...

Share this post


Link to post
Share on other sites

1Click module offers only upgrade to 1.7 version, which would crash down my site ( already tried ) . One of the windows in Dashboard says:  "update to 1.6.1.13" when I click on it , ti goes to PS website front page, where is also only 1.7 :-( and search box doesn't give any either.

 

So how to I update to 1.6.1.13 or 14? Anybody can help please?

 

Thanks

Probably you have installed the 1-click module for PS 1.7. which is in testing. You should use the module version before and not the v3.

 

If you deleted the original version of the module than simply upload the module I've attached to your folder /modules on ftp. Before you upload it, rename the module you have there to autoupgradev3 for ex.

 

The module attached is for upgrade between 1.x to latest 1.6. The module you have now on you FTP is the version 3 which allows upgrade to PS.1.7.

 

BTW 1.6.1.14 is fast and stable. 1.6.1.13 has a bug on speed for product page, so use the latest 1.14.

autoupgrade.zip

Share this post


Link to post
Share on other sites

Probably you have installed the 1-click module for PS 1.7. which is in testing. You should use the module version before and not the v3.

 

If you deleted the original version of the module than simply upload the module I've attached to your folder /modules on ftp. Before you upload it, rename the module you have there to autoupgradev3 for ex.

 

The module attached is for upgrade between 1.x to latest 1.6. The module you have now on you FTP is the version 3 which allows upgrade to PS.1.7.

 

BTW 1.6.1.14 is fast and stable. 1.6.1.13 has a bug on speed for product page, so use the latest 1.14.

Thanks for trying to help, but unfortunatelly I cant make it work.

 

When I tried to upload your zip file via BO, it showed up that version 7 one as result of successful upload. That could be the problem even if I re-named the module. viz attachment.

I cant get rid off that 1click module in BO which offers 7 version and cant even find it via ftp to make a hard delete. 

 

if  I upload it unziped directly into block modules, doesnt show up anywher in BO modules. . :-(

post-768871-0-07768000-1497505736_thumb.png

post-768871-0-64055400-1497505746_thumb.png

Share this post


Link to post
Share on other sites

If it is not showing, than perhaps you are  using different PS-versions. In DB one version, in scriptings other version. ( The module I added is only for PS 1.6.... and should be shown up.) Did you also cleared your browser cache and the smarty cache. Are you using caching options like Varnish, APC, XCache or other ? Seems to be a caching problem or different PS-Versions in one version.

 

Make a rollback of your shop at the time it was 1.6. if you can. If you have already new customers and/or orders, so you will loose them.

Edit: from the screen (sorry, the one I have seen only afterwards) I can see that you are using the correct version of 1-click module. Which is 1.6.7 and suitable for PS 1.6.

 

You have there only the possibility to choose 1.7. for to upgrade ? If yes, this is strange and could be a problem of some external cache like varnish. You are using caching options on your server ? (APC, XCache, varnish )? APC, xCache you can disable on tab "advanced parameters -> performance". If you are using varnish, than your provider should flush the cache of the server.

 

BTW: max_execution_time set on your server to 60 seconds is not enough for to make an upgrade. It should be corrected to 300. Contact your provider.

 

Perhaps the problem is this value, if you already tried an upgrade before. It could cause different PS-versions in one version (told before and edited by stroking out).

Share this post


Link to post
Share on other sites

You likely installed the wrong version of the upgrade module.  There are 2 different versions...

1) Upgrades you to the latest release of PS v1.6

2) Upgrades you to the latest release of PS v1.7

 

Follow instructions and make sure you know how to take complete backups of your store before proceeding.  Also make sure you know how to recover your store when things break.  Do not rely on the upgrade module to do that for you...

 

Where can I download the latest upgrade module? Cant find it on PS site. thanks.

Share this post


Link to post
Share on other sites

Im looking at it again. My mistake!  1.7 is the number ( version ) of the !click module it self. I can see the upgrade to 1.14 ...I feel bit stupid now:-(

 

But anyway, I tryied to upgrade and it failed to download the file. viz. attachment.

post-768871-0-24724400-1497510831_thumb.png

Share this post


Link to post
Share on other sites

BTW: max_execution_time set on your server to 60 seconds is not enough for to make an upgrade. It should be corrected to 300. Contact your provider.

At same time, check the max_input_time of your server as well. It should be 300 and not lower, for to make a successful update.

Share this post


Link to post
Share on other sites

There is no download for PS 1.6 anymore. The latest module is version 3. https://addons.prestashop.com/en/data-migration-backup/5496-.html

 

Please check the caching and setting on your server as described before.

This is not correct information. 

 

The module for PS v1.6 still exists, when you click the download button for the module, it will present you with 4 options, choose the option for PS v1.6 (which is module version 1.6.7)

https://addons.prestashop.com/en/data-migration-backup/5496-.html

Share this post


Link to post
Share on other sites

Ah yes. You are right. Version 1.6.7. I've added as download link on post #4. And it is the one Zeryk is using. The problem is another = bad configuration of his server settings. The download of upgrade files stop (probably due to low max_execution and max_input_time on his server).

Share this post


Link to post
Share on other sites

i agree, very common issue especially on shared hosting plans where resources are restricted. 

Share this post


Link to post
Share on other sites

 

ฉันกำลังมองหามันอีกครั้ง ความผิดพลาดของฉัน! 1.7 คือหมายเลข (รุ่น) ของ! คลิกโมดูลด้วยตนเอง ฉันสามารถดูการอัพเกรดเป็น 1.14 ... ฉันรู้สึกบิตโง่ตอนนี้ :-(

วิธีแทงบอล maxbet

แต่อย่างไรก็ตามฉันพยายามที่จะอัพเกรดและไม่สามารถดาวน์โหลดไฟล์ได้ ได้แก่ ความผูกพัน

 

In English Forum, please only English entries. You can post your question into Thai Forum.

Share this post


Link to post
Share on other sites

thanks all for advice, I requested my provider increase time limit and activate OpenSSL library. Ive checked some threads about updating to 1.14 version and I read lots of "doesn't work" things after updating. Ive installed URL cleaner recently and rewrote friendly URLs according my needs and functionality ( no duplicates ) of my site. Im not sure if 1.14 is so big difference ( according what I read in spec.) to worth the risk.

There is a list of bugs which were fixed as I understand, but Im not aware of those bugs in my 1.1.6.12 version.

https://github.com/PrestaShop/PrestaShop/milestone/21?closed=1

 

appreciate any comment.

 

Thanks

Share this post


Link to post
Share on other sites

Stay with 1.6.1.12 or use 1.6.1.14 which is fast and some bugs were released. 1.6.1.1.13 has a speed problem on BO, which is released in 1.6.1.14.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More