Jump to content
paju89

After enabling SSL certificate backend works but front end doest. why?

Recommended Posts

Hello. Until enabling ssl certificate my shop was working like a charm. but after enabling ssl certificate backend still works with https link  but frontend doest work at all . Also it automaticly redirects url to which is not proper at all. like this  https//site.com  in this url is missing. what can i do? i changed hundred times SEO&URL settings nothing helps.

 

this is admin panel it works4533a595ebb64c75a3de66e0c0c06077.png

 

but this is front end where it doenst work

 

1b89a9e66ea34e739a68a5560c533df4.png

Share this post


Link to post
Share on other sites

in the back office, SEO & URL page, make sure you only put the domain name in the SSL domain field.

 

There are 2 fields

Shop domain

SSL domain

 

Both should have the same value, and only the domain name, like...

example.com

 

not....

https://example.com

Share this post


Link to post
Share on other sites

I share the solution that worked for me:

Preferences .> SEO & URLs > Disable Apache's MultiViews option : Set to NO.

Share this post


Link to post
Share on other sites
Posted (edited)

I got the similar issue, but I found the solution, thanks for bellini13's suggestion.

make sure "shop domain" & "ssl domain" in "Traffic & SEO" are the same domain. (in production environment, they should be the same)

however, in my test case, I setup http listen port 81, so, the setup will be:

Shop domain => presta.local:81

SSL domain => prestal.local

(Don't specify port 443 in SSL domain, however, you can specify HTTP port, this is very important)

 

Edited by verybox (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More