Jump to content

Prestashop 1.7.0.4 How to make Image slider full Width


Recommended Posts

Dear Prestashop Developer and Professionals

 

I would like to ask if there are anybody who could help please. Is there any possibilities to make Image slider full width on Prestashop version 1.7.0.4?

 

Thank you very much

post-1200646-0-94883500-1486924709_thumb.png

Share this post


Link to post
Share on other sites

Hi dilshod, you can do it without editing any code!. Go to your back office (Design/Modules position) You have to put your slider in 'displayNavFullWidth' Hook. It's an empty hook after the menu on the header section.

Once you done that, you simply remove the slider module from the displayHome hook.

 

And That´s it!

 

Hope this helps

  • Like 3

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hi guys,

 

When I put my slider in 'displayNavFullWidth' I see this slider on my product page too... I would like slider only on homepage. Can you help me? 

 

Maybe you have to check: Design - Position - and the Slider have to be in only in the hook: displayHome

 

Hope that can help you

Share this post


Link to post
Share on other sites
  • 2 months later...

Hi guys... I moved the slider to "displayNavFullWidth" and it worked fine but I have the same problem of tumcia11

 

Now the slider is shown on every page and I just want to be display in the home page.

 

How do I fix that?

 

Thanks.

Share this post


Link to post
Share on other sites
Hey guys,

 

I posted the topic above with my other account.

 

I fixed the slider problem. After you move it to displayNavFullWidth hook, you have to search the displayNavFullWidth hook in Design > Positions. The Slider module will appear into it. So you click on "edit". In the "exceptions" box you select all and leave just "index" option not selected and save it. That is it.

 

Regards.

Share this post


Link to post
Share on other sites
  • 1 month later...

hi guys 

i have tried all the ways for 1.7 presta but fails 

please see this attached file and let me know how to remove whitespace from it 

 

thanks attachicon.gifdemoerrorsliders.png

I think you can go to:

homeslider.css 

remove margin-bottom: 50px;

or change to 0px

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 1 month later...

ive tried that soapnz, but then the slider vanishes altogether.
If i try hooking it back to home then it reappears :/

It was working fine before I just upgraded

 

edit: just switched back to default theme and its now working again. Has the hook name changed slightly?

Edited by MerseyRay (see edit history)

Share this post


Link to post
Share on other sites
  • 2 years later...
On 2/17/2017 at 5:59 PM, jprush76 said:

Hi dilshod, you can do it without editing any code!. Go to your back office (Design/Modules position) You have to put your slider in 'displayNavFullWidth' Hook. It's an empty hook after the menu on the header section.

Once you done that, you simply remove the slider module from the displayHome hook.

 

And That´s it!

 

Hope this helps

really ez solution . tnx a lot.
just one little thing. what is the best size for banner? not showing full size image on slider . (check attached file please) . what can i do?

aaaaaaaaa.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More