Jump to content
Arteinfo

Dopo aggiornamento modulo PayPal a v. 3.11 caricamento ecommerce molto rallentato

Recommended Posts

Dopo l'aggiornamento del modulo PayPal alla versione 3.11 i tempi di caricamento del sito sono diventati molto lunghi.
Ho provato anche a reimpostare il modulo, ma nulla il caricamento del sito anche da backend è molto rallentato, e spesso il server risponde con un TimeOut. Solo disattivando il modulo il problema non si presenta. 

Edited by Arteinfo (see edit history)

Share this post


Link to post
Share on other sites

Ciao,

ho anch'io lo stesso problema da qualche giorno, è tutto rallentatissimo e spesso ricevo questo messaggio:

 

(timeout)
Si è verificato un errore del server durante il caricamento delle tabelle: alcune tabelle non hanno potuto essere caricate.
Prova ancora ricaricando questa pagina.
Se incontri di nuovo questo problema, controlla i logs del tuo server o contatta il tuo fornitore di hosting per avere assistenza.

 

 

Ora che me lo hai fatto notare, ho aggiornata il modulo paypal 3-4 giorni fa.

 

Io sono abbastanza inesperto di Prestashop, sai dirmi come provare a risolvere questo problema?

 

Devo modificare circa 200 prodotti e con questa lentezza è impossibile lavorare!

 

Grazie,

 

Luca

Share this post


Link to post
Share on other sites

Io sono abbastanza inesperto di Prestashop, sai dirmi come provare a risolvere questo problema?

 

Per il momento ho disattivato il modulo e via FTP rinominato la cartella paypal in paypal_old in "modules" e ricaricata la versione v3.10.10 recuperata da un backup via FTP.

Se vuoi vedere se il problema è il modulo oltre a disattivarlo e vedere se il sito è più veloce, puoi modificate la voce: define('_PS_DEBUG_PROFILING_', false); in define('_PS_DEBUG_PROFILING_', true); nel file: / config / defines.inc.php. Caricando la pagina di darà così un report dei tempi di caricamento.

 

Per esempio: http://prntscr.com/cs3rti si vede chiaramente che è PayPal

 

 

 

Edited by Arteinfo (see edit history)

Share this post


Link to post
Share on other sites

Tornado alla versione 3.10.10 il caricamento trorna normale-
L'unico messaggio di errore ricevuto con la versione 3.11 rilevato nei log di Apache:

AH01071: Got error 'PHP message: PHP Warning: include_once(/var/www/vhosts/vegforce.com/httpdocsinit.php): failed to open stream: 
No such file or directory in /var/www/vhosts/vegforce.com/httpdocs/modules/paypal/express_checkout/ajax.php on line 28\nPHP message: 
PHP Warning: include_once(): Failed opening '/var/www/vhosts/vegforce.com/httpdocsinit.php' for inclusion 
(include_path='/var/www/vhosts/vegforce.com/httpdocs/tools/htmlpurifier/standalone:.:/opt/plesk/php/5.6/share/pear') 
in /var/www/vhosts/vegforce.com/httpdocs/modules/paypal/express_checkout/ajax.php on line 28\n',

Share this post


Link to post
Share on other sites

Ti ringrazio per la risposta,

 

proverò a mettere in pratica i tuoi consigli (sperando di essere in grado di farlo),

 

buona serata,

 

Luca

Share this post


Link to post
Share on other sites

Buongiorno a tutti,

ci sono appena passato anche io e dopo ore di smanettamento ho capito che era PayPal ultima versione (3.11) a causare i rallentamenti !!!

 

Ho "ricaricato" i files del modulo PayPal da un backup del giorno precedente l'installazione (versione 3.10.10) e tutto è tornato nella norma a parte il fatto che al momento della conferma ordine NON riporta il codice ordine ma scrive "#-3"

 

Qualcuno sa dirmi dove poter scaricare la versione 3.10 per provare a "re-installarla" sopra i miei files ?

 

NO COMMENT circa il comportamento di questo modulo (siamo anche clienti PayPal PRO e quindi ALTRI bugs!)

 

Saluti!

post-789242-0-65724200-1476154332_thumb.png

Share this post


Link to post
Share on other sites

Semplice, modifica al file la stringa giusta:

 

da

include_once _PS_ROOT_DIR_.'init.php';

 

a

include_once _PS_ROOT_DIR_.'/init.php';

 

manca infatti "/"

 

Saluti

Share this post


Link to post
Share on other sites

Salve a tutti il mio e commerce dopo l'aggiornamento di PayPal il mio ecommerce si è bloccato avete modo voi di ridarmi per link lo zip della versone precedente?

per favore aiutatemi che ho e commerce bloccato 

Share this post


Link to post
Share on other sites

Semplice, modifica al file la stringa giusta:

 

da

include_once _PS_ROOT_DIR_.'init.php';

 

a

include_once _PS_ROOT_DIR_.'/init.php';

 

manca infatti "/"

 

Saluti

 

Io avevo notato il problema ed ho fatto la modifica MA senza risultato (ossia il sito continuava ad essere lento)....

 

Ora ricontrollo :wacko: 

Share this post


Link to post
Share on other sites

Buongiorno,

io avevo un bug nella versione 3.10.10, venerdì ho fatto l'aggiornamento alla v.3.11 e sembrava tutto corretto e funzionante. Finché ieri non ci siamo accorti che la nuova versione paypal va ad appesantire il sitoweb fino a rallentarlo di 10-20 secondi. Ho ripristinato la v.3.10.10 ma ovviamente è quella che mi dava problemi.

 

Se alcuni clienti inserivano indirizzo di consegna diverso da quello di fatturazione generava errori nelle chiamate API e il totale veniva fuori sbagliato in riferimento alle tasse. 

 

Ora, qualcuno è in grado di aiutarmi? Perché questi problemi paypal da giungo 2016 ad oggi stanno iniziando ad essere troppi.

 

Grazie mille a tutti gli utenti del forum,

Ambra Della Pepa.

Share this post


Link to post
Share on other sites

Io avevo notato il problema ed ho fatto la modifica MA senza risultato (ossia il sito continuava ad essere lento)....

 

Ora ricontrollo :wacko:

 

No ricontrollato ed anche con la modifica del "/" non funziona...ossia sito lento...

 

Naturalmente ho svuotato le varie cache...

 

Ora provo a re-installare la vecchia versione...

Share this post


Link to post
Share on other sites

Semplice, modifica al file la stringa giusta:

 

da

include_once _PS_ROOT_DIR_.'init.php';

 

a

include_once _PS_ROOT_DIR_.'/init.php';

 

manca infatti "/"

 

Saluti

 

Grandioso !! Grazie !

  • Like 1

Share this post


Link to post
Share on other sites

per chi deve fare il downgrade

 

cancellare le 2 tabelle create

'._DB_PREFIX_.'paypal_braintree`

'._DB_PREFIX_.'paypal_plus_pui`

 

modificare in '._DB_PREFIX_.'configuration`

 

Configuration::updateValue('PAYPAL_VERSION', '3.11.0');

in

Configuration::updateValue('PAYPAL_VERSION', '3.10.10');

  • Like 1

Share this post


Link to post
Share on other sites

Ciao Giampiero. Io ho già fatto il downgrade. Ho proprio disinstallato, eliminato e reinstallato il modulo 3.10.10 ma il modulo ha dei bug. Non so se vi è mai capitato ma, se un cliente acquista ed ha l'indirizzo di fatturazione diverso da quello di consegna, il totale su paypal viene sbagliato. I prezzi dei prodotti risultano iva esclusa (perché nell'indirizzo di fatturazione c'è la p.iva) ma, la spedizione ha le tasse. E l'ordine si scarica a backoffice con il totale con tasse. Cioè tutto sbagliato. "Fortuna" l'errore è solo questo. Questa versione 3.11 aveva risolto il problema ma ha rallentato il sito, e ora mi ritrovo con lo stesso problema di prima.

Tu pensi si possa risolvere?

 

Grazie, Ambra.

Edited by ambra_creative (see edit history)

Share this post


Link to post
Share on other sites

A te ora funziona ?!? Io ho fatto la stessa modifica ma nulla...

Meglio non è come prima ma sono passato da 30 secondi per aprire una pagina a 3-4

Share this post


Link to post
Share on other sites

 

Hi Ambra,.
we noticed a performance problem with the module, we are now in the process of submitting a new version of corrective.
This version will soon be available throughout the evening.

 

Cordialement, 
Rubens - 202 ecommerce

 

 

Ma non fanno i controlli prima di rilasciare le versioni nuove ?

  • Like 1

Share this post


Link to post
Share on other sites

Ma non fanno i controlli prima di rilasciare le versioni nuove ?

a quanto pare non li stanno facendo molto bene da giugno....quest'aggiornamento dei protocolli di sicurezza ha reso tutto molto instabile...

Share this post


Link to post
Share on other sites

Buondì a tutti, sembra che abbiano rilasciato una nuova versione di paypal v.3.11.1 voi avete già provato questa nuova versione?

 

Grazie,

Ambra

Share this post


Link to post
Share on other sites

Ya hay una nueva versión de módulo que corrige el error  (3.1.1) está en Prestashop Addons y funciona bien. La pagina vuelve a cargar correctamente (poe lo menos la mía lo podéis comprobar en www.skinthinks.com con el nuevo módulo funcionando

Share this post


Link to post
Share on other sites

ok perfect skin thinks i'm trying to check if the same update v.3.11.1 on one of my website works properly. It seems to work. 

 

ok, perfetto stiamo facendo dei check con la nuova versione rilasciata su uno dei nostri siti e sembra sia tutto funzionante, ovviamente l'errore riguardava verifiche TLS: 

  • Fixed TLS timeout verification.

 

Thank you so much for your reply,

Have a nice day.

Ambra

Share this post


Link to post
Share on other sites

Salve a tutti,

ho installato la versione 3.11.1 poco fa in quanto da ieri segnalava un errore di TLS verificator. Con la nuova versione non c'è più l'errore ma in fase di apertura della finestra paypal, dopo la fase di attesa di caricamento, compare il seguente messaggio :

 

"Si è verificato un errore di sistema. Riprova più tardi." e alla chiusura della finestra il seguente errore :

"Don't see the secure PayPal browser? We'll help you re-launch the window to complete your purchase."

 

Di cosa si tratta?

Share this post


Link to post
Share on other sites

Mi sa che per il momento resto sulla 3.11 fixata

Noi con questa nuova versione non stiamo avendo problemi, probabilmente il cambio delle chiavi API è dovuto dal fatto che doveva cambiarle visto l'aggiornamento di PayPal e al protocollo di sicurezza nuovo.

Share this post


Link to post
Share on other sites

Aggiornato anche io a 3.11.1 e sembra tutto ok. Meno male, son due giorni che mi restituiva errore 500 ogni altra pagina! :(

 

Adesso mi rimane solo da capire perché mi da errore 500 ogni tanto cliccando su pagamento paypal.. ma è presente già dalle versioni precedenti <_<

Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Falso positivo.. l'errore 500 rimane anche con l'ultima versione; adesso ho fatto il "fix" di Giampiero che ringrazio e vediamo se è la soluzione definitiva.

 

Edit: niente, errore ancora presente...

L'errore che trovo nei log è

 

PHP Warning:  include_once(): Failed opening 'htdocs/shopinit.php' for inclusion (include_path='.:/usr/local/PEAR:/usr/local/lib/php') in htdocs/shop/modules/paypal/express_checkout/ajax.php on line 28
 

praticamente richiama shopinit.php che non è in quella posizione. Il fix dell'aggiunta del / non sembra cambiare la cosa..

Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Falso positivo.. l'errore 500 rimane anche con l'ultima versione; adesso ho fatto il "fix" di Giampiero che ringrazio e vediamo se è la soluzione definitiva.

 

Edit: niente, errore ancora presente...

L'errore che trovo nei log è

 

PHP Warning:  include_once(): Failed opening 'htdocs/shopinit.php' for inclusion (include_path='.:/usr/local/PEAR:/usr/local/lib/php') in htdocs/shop/modules/paypal/express_checkout/ajax.php on line 28

 

praticamente richiama shopinit.php che non è in quella posizione. Il fix dell'aggiunta del / non sembra cambiare la cosa..

 

Scusa domanda banale hai provato a disinstallare, cancellare e reinstallare la versione pulita del modulo?

Share this post


Link to post
Share on other sites

Appena fatto.. cancellato e pulito tutto.. cerco modulo paypal... clicco installa e tac 500 internal server error :angry:

Share this post


Link to post
Share on other sites

Mettendo la / l'errore sopra non si presenta più, ma ad ogni transazione appare 500 internal server error..

Lasciando il modulo così come mamma l'ha fatto, da errore 500 una volta su 3.

 

Ma negli errori php l'unico errore presente è quel warning.. quindi non so più dove cercare.

Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Ed eccomi qua... anche io dopo aver aggiornato il modulo PayPal

v3.11.1  su Prestashop 1.6.1.7 mi sono trovato con i pagamenti Paypal bloccati e un errore non specificato.

​Di seguito invio anche testo della mail di errore :
 

Errore dal tuo modulo PayPalAPI   Un cliente ha avuto un problema con il modulo PayPalAPI, vedi il rapporto:   PayPal response:
->

 

Dopo l'iniziale panico ho provveduto a disinstallare e reinstallare la stessa versione. Di conseguenza ho dovuto reimpostare anche il modulo.
Oltre questo ho dovuto eseguire anche una pulizia della cache del sistema.

​Fatto questo il sistema ha ripreso a funzionare e i tempi di caricamento sono tornati decenti.


 

Share this post


Link to post
Share on other sites

L'errore probabilmente era dovuto al down di ieri dei server americani (attacco hacker) 

ora dovrebbe nuovamente funzionare

Share this post


Link to post
Share on other sites

Provato... al terzo tentativo errore 500 :mellow:

Quello che non capisco è perché nei log non c'è traccia che possa aiutarmi...

 

Edit: la pagina che da errore è modules/paypal/express_checkout/payment.php

 

così sono andato sul file payment.php e ho aggiunto

 

ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);
error_reporting(E_ALL | E_STRICT);

 

giusto per essere sicuri.. poi c'è la modalità debug attiva.. la cache è off.. ma niente, l'unica cosa che visualizza è

 

Server Error 500 : Internal Server Error Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Ciao Tia©

anche io ho il tuo stesso errore. Ho contattato i tecnici Paypal e mi hanno risposto cosi:

 

Gentile xxxxx,

grazie per aver contattato PayPal.

Come potrai verificare dall'URL presente nella pagina dove si presenta l'errore, questo si presenta sul tuo server, prima che i server di PayPal vengano chiamati in causa. Quindi, mi dispiace contraddirti ma il problema é dipendente da voi. Lo puoi inoltre notare dal fatto che l'errore cita "postmaster@xxxxxxxxx.it" come server administrator. Gli errori "500" dipendenti da PayPal citano invece "postmaster@paypal.com".
Questo errore é generato dal tuo webserver (Apache, IIS, Tomcat). E' relativo, di solito, ad una configurazione che dello stesso webserver o da un problema momentaneo di non disponibilitá del servizio web oppure ad un errore di sintassi nello script.
Questo errore, lato server, puó essere generato da diverse cause. Per poter correttamente prendere visione della ragione specifica che ha causato il problema, ti consiglio di analizzare il tuo "error log". Il percorso ed il nome dello stesso file puó variare a seconda del Sistema Operativo e del webserver utilizzato.
All'interno del file in questione, dovrá essere cercato un errore del seguente tipo: "500 - Internal Server Error".

Di solito, le ragioni piú comuni sono:

- Permessi delle cartelle remote del server
- Configurazione errata dell' .htaccess
- Timeout del server

Per ottenere un errore piú dettagliato al fine di capire al meglio come risolvere il problema:

- Apri il file config/defines.inc.php
- Modifica la line "define('_PS_MODE_DEV_', false);" in "define('_PS_MODE_DEV_', true);"

Ti consiglio di contattare il tuo amministratore di sistema ed esporre a lui il problema.

Colgo l'occasione per ricordarti che PayPal, per policy, non fornisce supporto all'integrazione su carrelli sviluppati da terzi. Qualora avessi problemi relativi al carrello, ti invitiamo quindi a contattare il supporto tecnico della piattaforma che utilizzi, nel tuo caso Prestashop.

Per eventuali chiarimenti, non esitare a contattarci.

Grazie,
xxxxxxx
PayPal - MTS Team

Share this post


Link to post
Share on other sites

Niente di utile purtroppo :)

Sappiamo che non è paypal il problema, ma qualcosa in prestashop o sua configurazione.

Share this post


Link to post
Share on other sites

Ragazzi ho incredibilmente risolto cosi:

 

1) Disattivato la cache di prestashop

2) Disinstallato e Cancellato il modulo Paypal

3) Reinstallato l'ultimo Modulo Paypal (3.11.11)

4) Tramite Filezilla ho cambiato solamente i permessi della cartella Paypal (inclusi file e sottocartelle) in 755.

5) Disattivato pagamento express

6) Riattivato la cache di prestashop.

 

Adesso funziona che è una meraviglia.

 

In 5 giorni di lavoro avevo gia cambiato i permessi  svariate volte ma senza esito positivo. Oggi ho provato (con questo procedimento) a ripulire tutto e fare un installazione pulita cambiando solo i permessi delle cartelle ed ha funzionato!!!

 

Spero possa essere d'aiuto!

Edited by miki9250@yahoo.it (see edit history)

Share this post


Link to post
Share on other sites

Io ho trovato questo errore spulciano ulteriori log

 

Connection reset by peer: mod_fcgid: read data from fastcgi server error

 

:unsure:

Share this post


Link to post
Share on other sites

Abbiamo riscontrato anche noi lo stesso problema sui nostri e-shop è consigliabile effettuare un downgrade alla versione precedente.

E' uscita una pacth version v3.11.1

Share this post


Link to post
Share on other sites

La versione 3.11.1 è ok installata ieri. Da alcuni test sembra più veloce della 3.11 con la modifica

Share this post


Link to post
Share on other sites

Ciao ragazzi,

ma solo io per la lingua inglese non riesco a raggiungere il logo perché la path è sbagliata? 

 

Potreste aiutarmi a ricordare che file modificare per far raggiungere la path immagine corretta?

 

Grazie,

Ambra.

Share this post


Link to post
Share on other sites

Attenzione, il problema del / mancante permane anche con la 3.11.1 non lo hanno risolto!

 

Dovete editarlo ancora a mano

Share this post


Link to post
Share on other sites

Attenzione, il problema del / mancante permane anche con la 3.11.1 non lo hanno risolto!

 

Dovete editarlo ancora a mano

 

Sei sicuro ?

Share this post


Link to post
Share on other sites

C'è un modo per recuperare qualche versione precedente? io continuo ad avere problemi con un errore 500 random.. ormai ci ho perso mesi di lavoro e non so più cosa controllare. :(

 

Edit: oggi ho trovato un ulteriore dettaglio.. ogni volta che appare Server error 500 la data di modifica del file .htaccess cambia.. cosa potrebbe essere? i permessi di scrittura ci sono, cosa combina il modulo con l'htaccess?

Edited by Tia© (see edit history)

Share this post


Link to post
Share on other sites

Dopo mesi di imprecazioni ho finalmente risolto il problema... ho rimosso il modulo fastcgi dal webserver tornando al classico apache.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More