Jump to content
Eva Martin

[**help**] Produit Affiché Hors Stock Meme Si Stock Desactivé !

Recommended Posts

Bonjour a tous !

j'ai besoin d'un coup de main assez urgent ici www.directpoissons.com ...

Depuis quelques jours, pour une raison que j'ignore, tous les produits de la boutiques ont un message d'alerte incensé :

Quantité choisit supérieur au stock !

Bon, je sais il y a des fautes d'orthographe mais on s'en fiche : cette alerte ne devrait jamais s'afficher ! Je m'explique :

- 1 : la gestion des stocks est désactivée, et la commande des produits hors stocks est possible

- 2 : même si je réactive temporairement l'option "gestion des stocks", le message reste alors que le stock est plus que fourni ...

 

Le client peut tout de même passer sa commande, m'enfin bon on va dire que ça n'invite pas vraiment à l'achat, donc ...

 

Help please !!,

Share this post


Link to post
Share on other sites

Il est sur le thème et je pense qu'il devrait être facile de le réparer ... et je ne peux pas retirer également des produits du panier (bloc en haut à droite).

 

It is about the theme and I think it should be easy to fix it ... and I can't also remove products from the cart (right top block).

Share this post


Link to post
Share on other sites

Bonjour a tous !

j'ai besoin d'un coup de main assez urgent ici www.directpoissons.com ...

Depuis quelques jours, pour une raison que j'ignore, tous les produits de la boutiques ont un message d'alerte incensé :

Quantité choisit supérieur au stock !

Bon, je sais il y a des fautes d'orthographe mais on s'en fiche : cette alerte ne devrait jamais s'afficher ! Je m'explique :

- 1 : la gestion des stocks est désactivée, et la commande des produits hors stocks est possible

- 2 : même si je réactive temporairement l'option "gestion des stocks", le message reste alors que le stock est plus que fourni ...

 

Le client peut tout de même passer sa commande, m'enfin bon on va dire que ça n'invite pas vraiment à l'achat, donc ...

 

Help please !!,

Bonjour

 

100% des utilisateurs du forum ont ou eu besoin au moins une fois d'une aide. Une aide est toujours urgente, sinon ce ne serait pas utile de demander de l'aide.

Help ne vous amènera pas plus de réponses en plus Help ce n'est pas un mot français

 

Merci de parcourir et de lire les règles du forum.

Share this post


Link to post
Share on other sites

Merci pour cette réponse rapide ...

J'ai envoyé un message au développeur, mais j'aimerai vraiment pouvoir masquer ce truc rapidement t je dois avouer que je ne trouve pas bien comment m'y prendre ...

Si je pouvais au moins "traduire" ce message d'erreur par une phrase temporaire ce serait déjà bien, mais impossible de trouver l'expression en question parmis les traductions (j'ai tenté les modules installés de mon thème + du thème défaut + coeur, et les trad° front office de mon thème + défaut sans succès)

 

Merci d'avoir soulevé le bug du panier :)

Share this post


Link to post
Share on other sites

Désolée Oron ! 

C'est la panique qui à parlé à la place de mon Bescherelle que j'aime pourtant bien fort ... Je ne le ferai plus, promis :)

Share this post


Link to post
Share on other sites

Il est sur le thème et je pense qu'il devrait être facile de le réparer ... et je ne peux pas retirer également des produits du panier (bloc en haut à droite).

@tuk66 ça veut dire quoi ? Google Traduction n'a pas sa place dans le forum ....

Share this post


Link to post
Share on other sites

Sinon une idée pour simplement masquer ce message via les CSS customisées ? J'ai tentés quelques bidouilles mais je n'y connais pas grand chose ...

Share this post


Link to post
Share on other sites

Ahahah ! elle est bien bonne celle là : le message disparait ... si j'augmente la quantité de produits que je souhaite commander ! si je reviens ensuite a "1" il ne réapparait toujours pas, par contre bien sur si j'actualise la page hop ! le revoilà ... 

Share this post


Link to post
Share on other sites

Salut Eva
Tu veux juste masquer le message?
C'est curieux ce message plein de fautes. Tu devrais le retrouver dans les traductions (sauf si il est rentré en dur dans le tpl.
Si tu désactive le cache pour les feuilles de style, je te dirais quoi faire pour masquer le message ;)

Edited by Michel Faure (see edit history)

Share this post


Link to post
Share on other sites

Salut Michel !

Oui en effet je souhaiterai, si ce n'est corriger le "bug", au moins masquer ce message car les clients ont l'impression qu'ils ne peuvent pas commander... 

j'ai "inspecté" la page et trouvé la classe de l'objet, qui est 

".quantityAvailableAlert.alert-danger"

 

J'ai tenté de rentrer ça et de lui mettre "display:none" dans le custom CSS, mais rien ne se passe. j'ai tenté de mettre un # au lieu du petit point devant, toujours rien. J'ai mis des "!important" pour voir ... encore rien.

 

Désespoir, désespoir.

Share this post


Link to post
Share on other sites

désactives le cache pour les feuilles de style juste un instant

Depuis chez moi le diplay:none fonctionne.
Mais comme il y a le cache je ne peux pas te dire où ça se trouve.
Si non tu vas dans le global.css et tu met tout en bas:

.alert-danger{

display: none !important

}

 

Ça devrait fonctionner en attendant une meilleure soluce

Edited by Michel Faure (see edit history)

Share this post


Link to post
Share on other sites

Ahah !

En effet, si je désactive le cache smarty pour les CSS le message n'apparait plus ! Par contre si je le remets ça réapparait ... J'ai beau vider le cache du site, de mon navigateur etc, il revient tout l temps ... comment je peux remettre ça au carré ? En tous cas le fait que toi tu ne voies pas le message est super rassurant, ça veut dire que la plupart des visiteurs ne le voient pas non plus (enfin j'espère !)

Share this post


Link to post
Share on other sites

Non tu ne m'a pas compris.
Je le vois :(
Je disais juste qu'avec la modif du css j'arrivais à le cacher.
As tu essayé de mettre le petit bout de css dans le global css?

Share this post


Link to post
Share on other sites

Ah OK ! ben oui pour moi aussi un petit display:none dans le css et il n'apparait plus ! sauf qu'impossible de le faire marcher en BO.

 

Dans montheme/css je n'ai pas de "global.css", en revanche j'ai un truc qui s'apelle "style.css". J'ai ouvert ça et collé 

#quantityAvailableAlert.alert-danger { 
	display:none !important;
}

... Pour moi, le message s'affiche toujours. En revanche, si je décoche le cache pour les css, il ne s'affiche plus.

En ce moment meme ce cache est désactivé : vois-tu le message ?

Share this post


Link to post
Share on other sites

Ben en fait pour le moment le cache css est simplement désactivé ... Mais je suppose que l'idéal serait de le "nettoyer" et de le réactiver, sauf que j'ai beau nettoyer et renettoyer le cache en haut de la page "performances", a chaque fois que je réactive cette option des caches CSS pouf ! le message fait son Come Back :/

A moins qu'il ne soit pas grave de laisser les caches css désactivés ?

Share this post


Link to post
Share on other sites

Non ça n'est pas très grave si tu ne laisses que celui là mais ça n'est pas la solution.
je pense que si tu ne mettais que 

 

.alert-danger{

display: none !important;

}

 

ça suffirait. (ça permettrait de laisser les alertes sur quantité fonctionnelles)

​Pour le cache, essayes de le vider en l’effaçant via ftp. 

Edited by Michel Faure (see edit history)

Share this post


Link to post
Share on other sites

Alors, j'ai vidé le cache manuellement puis réactivé le cache CSS dans "preformances" : rien de neuf.

En revanche j'ai fait un test juste pour voir :

sans aucun custom CSS mais simplement avec le cache css désactivé : pouf ! plus de message ! Ca fait pareil chez toi ?

Si ce n'est pas trop grave, je vais laisser ça en l'état je crois ...

Share this post


Link to post
Share on other sites

le display: none !important, doit être dans css/autoload/11-bootstrap.min.css a la ligne 3775

 

ça devrait fonctionner avec le cache activé

 

tu ne fais qu'ajouter display: none !important après la ligne 3775

Edited by Michel Faure (see edit history)

Share this post


Link to post
Share on other sites

Bravo d'avoir trouvé la bonne ligne, ça faisait un moment que je la cherchais :)

Bon, par contre, le message apparait tjs quand je réactive le cache des css. Je crois que c'est un bug du coté du cache, j'ai l'impression, parce que de toutes façons rien que dans les "preferences/custon CSS" ca aurait déjà du marcher depuis longtemps.

Share this post


Link to post
Share on other sites

oui, du coup je vais marquer le sujet résolu.

Merci infiniment pour l'idée du cache CSS, tu m'as sauvé :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More