Jump to content

Recommended Posts

Boa noite pessoal,

 

Já vasculhei e achei alguns tópicos referente a configuração do envio de e-mail pela loja prestashop, porém nenhuma das dicas resolveu o meu problema.

 

quando faço um novo pedido, não recebo o e-mail da loja informando que foi criado um novo pedido, apenas recebo um e-mail do pague seguro com os dados para fazer o pagamento.

 

Tento testar o envio do e-mail e cada hora é um erro diferente. 

 

 

qualquer ajuda será muito bem vinda.  estou trabalhando em localhost utilizando o WAMP.

post-895373-0-08532300-1420238942_thumb.jpg

Share this post


Link to post
Share on other sites

Boas,

 

Deve fazer o teste num outro local porque o modulo pagseguro não ira funcionar devidamente em localhost.

Share this post


Link to post
Share on other sites

Pelo localhost nao ter acesso ao net, vc. nao poederá usar. É um servico terceirizado que necessiat a conexao externa através de uma IP ligada ao internet.

Share this post


Link to post
Share on other sites

quer dizer que enquanto eu estiver no localhost , todos os pedidos de testes que eu fizer não irei receber um e-mail da loja informando o número do pedido e tal ?

só falta essa etapa para poder subir a loja pra a minha hospedagem.

 

Obrigado.

Share this post


Link to post
Share on other sites

Nao se estes necessitam de conexao externa que é o caso do módulo pagseguro nativo. Este módulo funciona com um API e esta necessita ter conexao a internet para aceitar pedidos e devolver o código de "recebido/aceito". Teste o módulo com ligacao externa diretamente em um servidor com conexao ao net.

 

Outra coisa: nao aconselhamos rodar Prestashop em servidores Windows. Os problemas sao enormes. Eu mesma (nao leiga, mas expert em servidores) acabei desistindo. Vc. vai ter que adaptar funcoes do servidor ao menos duas vezes ao mes ou entao cada vez que for fazer uma alteracao no back-office ou ativaer/desativa funcoes/módulos.

 

Procure uma hospedagem Linux boa com estes requisitios mínimos: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

 

Windows somente serve para Exchange e Windows mesmo, outra software (seja lá qualquer que for) vai dar problemas.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

A querstão nem chega a ser o pagseguro.

 

Quando um novo usuário faz cadastro na loja não recebe e-mail. Nenhuma notificação é gerada por e-mail. 

Então, isso se dá pelo fato de esta com a loja em localhost ?

 

blz, vou subir a loja e fazer o teste em ambiente produtivo. vou ver se resolve assim. 

Share this post


Link to post
Share on other sites

Pode até ser, pois também nao tem conexao externa para enviar mails ao net. Suba a loja ao servido e teste lá, e por favor nao use servidor windows. Vc. vai se arrepender... Ou entao ter trabalho toda hora assim que alguma coisa foi alterada/adicionado no back-office.

 

Servidores Windows somente rodam 100% com aplicacoes Windows.

Share this post


Link to post
Share on other sites

obrigado pela dica, já contratei uma hospedagem linux, já tinham me falado que o windows dá trabalho rs.

 

obrigado novamente.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More