Jump to content
killeer

Smartblog is not showing the content of the blogs

Recommended Posts

Hi

 

Can anyone help with the Smartblog module?

 

all was working ok but for some unknown reason none of the blogs are showing any content other than the blog image.

 

post-380599-0-67131500-1414351459_thumb.jpg 

Share this post


Link to post
Share on other sites

I have getting the same problem. I was installed the smartblog module but it was not shown in the front end side. I was searching for Contentbox module, but its not available.

Share this post


Link to post
Share on other sites

I have getting the same problem. I was installed the smartblog module but it was not shown in the front end side. I was searching for Contentbox module, but its not available.

 

what is your ps version ?

Share this post


Link to post
Share on other sites

Hi there, I'm using Smartblog too and also have problems.

 

When adding a new post, it's not showing up on the frontpage for clients that are not logged in.

 

But when I go to the blogpost url, www.mydomain.nl/smartblog.html, clients that are not logged in can see all the posts.

 

Only when I log in as a customer, the blogpost appears on the frontpage.

 

I also don't have a Contentbox Module. But looks like my problem has to do with logged in vs. not logged in clients.

 

How can I fix this?

PS: 1.6.0.9

Theme: EDA

Share this post


Link to post
Share on other sites

Hi,

 

Anyone with the same problem? I haven't contentbox module installed but smartblog doesn't show content of the blog.

Share this post


Link to post
Share on other sites

I had this same problem but solved it by NOT using an underscore in the Link Rewrite field.

 

e.g. instead of share_the_love_for_prestashop_1_6

 

try share-the-love-for-prestashop-1-6

 

It solved it for me.

  • Like 4

Share this post


Link to post
Share on other sites

I am having an issue as well. Its not showing anywhere on the front office. i even uninstalled and reinstalled loosing all our posts and still cnt get it up and going. 

Share this post


Link to post
Share on other sites

Hello, I too was having this problem with Smartblog and upon investigating on the module code for a bit found that it had to do with the friendly URL; when you click a post to see its contents it takes you to a URL that probably shows its id and its name (e.g. 4-this-post-is-an-example); my solution was to open SmartBlogPost.php file inside /modules/smartblog/classes and then write a regular expression to extract the id that was wrongly being passed to the getPost function.

 

I'll leave the steps for you to try (in case you're still having this issue):

  1. Open SmartBlogPost.php in /modules/smartblog/classes
  2. Add a new line between lines 64 and 65 with this code:
    preg_match('/^[\d]+/', $id_post, $id_post);
    $id_post = $id_post[0];
  3. Those lines must be inserted right before line 65 (which starts with $sql = 'SELECT.........)
  4. Save the file
  5. This solution is working with friendly url's so while one probable solution would be to change the setting for friendly url or link rewrite on the module, i could not find any of those options; maybe the module developer will get this fixed in a future release, for now this seems to do the trick.

 

Best of luck!,

Edited by memovillalobos (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Hi guys,

 

I would love to use Smartblog as it looks awesome but despite following all the advice above (including editing the php file which was heartshopping for a very amateur coder like me) the blog still does not display content. Here are the links - to the blog posts page (where they show) and click any actual post and they do not. 

 

http://www.hairmywords.com/smartblog.html

 

Any help would be appreciated - if I can't solve this soon will have to use a paid module whereas this really should do fine!

 

Thanks

 

Joshua

 

 

Share this post


Link to post
Share on other sites

PS. I just noticed that despite rewriting the friendly link with - it still insersts a _ and a number which is probably blocking the work suggested above. Any suggestions?

Share this post


Link to post
Share on other sites

Hello, I too was having this problem with Smartblog and upon investigating on the module code for a bit found that it had to do with the friendly URL; when you click a post to see its contents it takes you to a URL that probably shows its id and its name (e.g. 4-this-post-is-an-example); my solution was to open SmartBlogPost.php file inside /modules/smartblog/classes and then write a regular expression to extract the id that was wrongly being passed to the getPost function.

 

I'll leave the steps for you to try (in case you're still having this issue):

  1. Open SmartBlogPost.php in /modules/smartblog/classes
  2. Add a new line between lines 64 and 65 with this code:
    preg_match('/^[\d]+/', $id_post, $id_post);
    $id_post = $id_post[0];
  3. Those lines must be inserted right before line 65 (which starts with $sql = 'SELECT.........)
  4. Save the file
  5. This solution is working with friendly url's so while one probable solution would be to change the setting for friendly url or link rewrite on the module, i could not find any of those options; maybe the module developer will get this fixed in a future release, for now this seems to do the trick.

 

Best of luck!,

Good, 

Share this post


Link to post
Share on other sites

Hello, 

 

The solution suggested by Nixnix is not working on 1.6.0.14 any ideas why?

 

Best Regards

Share this post


Link to post
Share on other sites

Hello, 

 

I have a problem

 

When i try to go to" mydomain/smartblog.html" for listing all blogs posted, it redirects me directly to my home page website ?

 

Can you help me with this please ?

Share this post


Link to post
Share on other sites

The solution that worked for me was the one posted by Nixnix. Thanks so much for the help!


  • Sad 1

Share this post


Link to post
Share on other sites

I am using transformer theme ad its blog module, for some reason, all the content I had in it disappeared in the front office. The page is blank, content is still on the dashboard and no 404 is displayed when going to that address. Can someone help? 

Share this post


Link to post
Share on other sites

I found that if you delete whole blog categories you will have problem with new posts on Home page. You need to have at least one blog category even if you don’t want to use it. The best way is to leave „uncategories” category. In my case that helped.

Share this post


Link to post
Share on other sites
On 26.10.2014 at 9:43 PM, killeer said:

hi

 

solved this, i deleted contentbox module and the smartblog is working fing


It helps for me. PS 1.6.1.17, SB 2.0.1

Share this post


Link to post
Share on other sites
On 12/8/2015 at 4:01 PM, Nixnix said:

Here is the solution to this error: https://github.com/smartdatasoft/smartblog/issues/20

 

The variable 'content' is very generic and the Smartblog developer should change it. But until then, this works.

 

thanks, it worked perfectly, the file to edit are the following:

/modules/smartblog/controllers/front/details.php

and 

/themes/themeXXX/modules/smartblog/views/templates/front/posts.tpl

 

Ciao,

Davide

Share this post


Link to post
Share on other sites

NOTE: If Nixnix's solution is not work, check the file /controllers/front/category.php. 

The "gods" developers changed the order of the attributes of the "getAllPosts" function, so if the file is still called that function with the order: LANG, LIMIT START, LIMIT is wrong.

If we open the file SmartBlogPost.php and we will see the function, now we see it like this: public static function getAllPost ($limit_start, $limit, $id_lang = null)

Edited by Jose FG (see edit history)

Share this post


Link to post
Share on other sites
On 12/3/2014 at 11:48 AM, jellygnite said:

I had this same problem but solved it by NOT using an underscore in the Link Rewrite field.

 

e.g. instead of share_the_love_for_prestashop_1_6

 

try share-the-love-for-prestashop-1-6

 

It solved it for me.

Thank you,

This worked for me. 

Prestashop Ver1.6.1.24

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More