Jump to content
  • 0
anonymous_itop

Error Smarty

Question

I have error log with smarty, undefined index at line 157,69,70,71,72,109,110 in file smarty_internal_templatebase.php. And site can not display pattern same CSS error. How can i fix it ? Thanks. 

Notice: Undefined index: grid_size_lg in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 69 
Notice: Undefined index: grid_size_md in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 70 
Notice: Undefined index: grid_size_sm in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 71 
Notice: Undefined index: grid_size_ms in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 72 
Notice: Undefined index: ajax_popup in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 109 
Notice: Undefined index: productlist_view in public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 110
Edited by anonymous_itop

Share this post


Link to post
Share on other sites

57 answers to this question

Recommended Posts

  • 0

PrestaShop doesn't have $hazmat_fees, $poison_fees or $refrigerated_fees variables, so you must have installed a third-party module that creates these variables. Find that module and contact the developer of the module for support.

Share this post


Link to post
Share on other sites
  • 0

I have same kind of issue in my prestashop store. I have Prestashop 1.6..0.4 when i click the category so can't show a black page with this error "

This page isn’t working

www.apparelprime.com is currently unable to handle this request.

HTTP ERROR 500

"

Please help me. any solution?

 

category.png

Share this post


Link to post
Share on other sites
  • 0

Edit config/defines.inc.php and change the value of _PS_MODE_DEV_ from false to true. You should then get an error message instead of a 500 error that should help you debug the problem.

Share this post


Link to post
Share on other sites
  • 0

ContextErrorException en 4f4a0120120279100d12a6e9be1d212162eda7e3.file.login.tpl.php línea 36 :
Aviso: índice indefinido: tpl_dir
en 4f4a0120120279100d12a6e9be1d212162eda7e3.file.login.tpl.php línea 36
en ErrorHandler -> handleError ('8', 'Índice no definido: tpl_dir', 

a content_5a3309d23148a3_66186756 ( objeto ( Smarty_Custom_Template )) en la línea 188 de smarty_internal_templatebase.php
en Smarty_Internal_TemplateBase -> fetch ( objeto ( Smarty_Custom_Template ), nulo , nulo , nulo , falso , verdadero , falso ) en SmartyCustom.php línea 317
en Smarty_Custom_Template -> fetch () en Module.php línea 2241

en TrackingFront -> displayLogin () en stats.php línea 35

Me da este error al intentar acceder a la url de afiliados a traves del modulo TrackingFront

Alguna sugerencia?

Share this post


Link to post
Share on other sites
  • 0

From the error message, it appears the problem is on line 33 (in PrestaShop v1.6.1.17) of modules/trackingfront/views/template/front/login.tpl:

{include file="$tpl_dir./errors.tpl"}

On your website, $tpl_dir is not defined, which is weird, since it should be defined on line 444 (in PrestaShop v1.6.1.17) of classes/FrontController.php:

            'tpl_dir'             => _PS_THEME_DIR_,

Are you trying to use the PrestaShop v1.6 tracking module in PrestaShop v1.7? That would explain this error, since the module does not support PrestaShop v1.7.

 

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, rocky said:

Del mensaje de error, parece que el problema está en la línea 33 (en PrestaShop v1.6.1.17) de modules / trackingfront / views / template / front / login.tpl:

{include file = "$ tpl_dir./errors.tpl"}

En su sitio web, $ tpl_dir no está definido, lo cual es extraño, ya que debe definirse en la línea 444 (en PrestaShop v1.6.1.17) de clases / FrontController.php:

            'tpl_dir' => _PS_THEME_DIR_,

¿Está tratando de usar el módulo de seguimiento PrestaShop v1.6 en PrestaShop v1.7? Eso explicaría este error, ya que el módulo no es compatible con PrestaShop v1.7.

 

ok, Thanks! I have Prestashop v1.7.

Share this post


Link to post
Share on other sites
  • 0

Then you'll need to delete the trackingfront module, since it's not compatible. There is no version of that module that works in PrestaShop v1.7 at the moment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×