Jump to content
  • 0
Oda

Prestashop 1.4.5.1: Problem on config SMTP

Question

Hi,

 

I have a new store using a clear Prestashop 1.4.5.1, and need config SMTP (phpmail not enabled). On old store 1.2.5, config of autentication work well. In Prestashop 1.4.5.1 show (on try send test-mail):

The SMTP connection failed to start [mail.gamestorebrasil.com:26]: fsockopen returned Error Number 110 and Error String 'Connection timed out'

 

The config is autenticated, but whitout SSL. Connect on por 26.

 

Anyone have any experience with this?

 

Thanks a lot any help.

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Hi,

 

Same problem here. I've tried SMTP, phpmail, web based mail, etc...

I can't get it working

 

Even my hosting provider looked at it but no solution yet.

 

Help

thanks a lot!

Share this post


Link to post
Share on other sites
  • 0

Hey, I have the same issue!

I'v been driving my host mad about this! - Looks like I'm not the only one experiencing issues with smtp!!

 

"Error: please check your configuration

The SMTP connection failed to start [ssl://smtp.gmail.com:465]: fsockopen returned Error Number 110 and Error String 'Connection timed out'"

 

Hope we find a solution ASAP!!!

 

Mike - creator of http://dovjudaica.com

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

I am having the very same problem with sending and receiving email, as well as retrieving passwords. Did anyone get anywhere with this? The store cannot work if customers are not reciving emails, any workaround???

 

The SMTP connection failed to start [smtp.1and1.es:587]: fsockopen returned

Error Number 110 and Error String 'Connection timed out'

 

I am on SMTP with SSL open, but I tried almost all the alternative options (port 25, 587, php mail, etc...), I am with 1and1

 

Thanks

 

apprentice

Share this post


Link to post
Share on other sites
  • 0

I'm experiencing the same issue with all emails from the store. Using the PHP mail() function is not an option for me.

 

This is the error in my 1.4.6.2 installation:

 

"Error: por favor, compruebe su configuración The SMTP connection failed to start [ssl://smtp.gmail.com:465]: fsockopen returned Error Number 110 and Error String 'Connection timed out'"

 

Needless to say my backoffice is in Spanish

Share this post


Link to post
Share on other sites
  • 0

Make sure you are configuring correctly smtp has some strict rules you must follow.

 

Mail domain name: pop.yourmail.com

SMTP server: smtp.yourmail.com

SMTP user: johndoe@yourmail.com

SMTP password: your password you use to access your mail

 

I use php mail but took a look and it worked just fine using the example above.

Hope this helps.

Share this post


Link to post
Share on other sites
  • 0

The SMTP parameters solution (instead of PHP mail) that worked for me is as follows (source:http://www.hostknox.com/tutorials/prestashop/smtp-parameters)

Mail domain: yourdomain.com

SMTP server: yourdomain.com

SMTP User : yoruemail@yourdomain.com

SMTP password: your password

Kρυπτογραφηση: TLS

Port: 465

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

my version is 1.4.6.2 i have the same problem i try my own server email and gmail is not working.... anyone can help ?

Share this post


Link to post
Share on other sites
  • 0

I encountered this problem aswell. Until 4pm all was working well. I was doing some changes on item stock, was still getting transactional mails. Then I was testing payment transactional mail (and others) and it suddenly stopped working. So I went to test e-mail sending and got this report 

Edited by Katus

Share this post


Link to post
Share on other sites
  • 0

Hello

My site worked perfectly in version 1.5.6.2, but one day, the error

Error: please check you configuration [...] Connection failed to start [..] fsockopen error 110 [...]

 appeared.

 

I did not change anything.

Perhaps my host changed its PHP version, but I am not aware of that.

 

If you have any hint/walkthrough/workaround/solution I would be very glad to know about it.

 

(of course I checked with other mail clients, everything works fine)

 

Regards

Edited by Jorlanne

Share this post


Link to post
Share on other sites
  • 0

Hello, Jorlanne

 

Sry, but we can‘t find a solution. So we using a gmail account.

Configuration is prety simple – you will find many examples on web (ports, ssl, etc.)

One important thing – to make work smtp via gmail, go to gmail settings and „Allowing less secure apps to access your account“!!! - enabled.

Good luck, have fun

Share this post


Link to post
Share on other sites
  • 0

Hello,

and thank you for your answer.

May be I was not clear; I already successfully used (an tried) many external mail accounts (gmail, laposte.net, turbosmtp). I know how to configure the mail (I have done it for a mailing program I developped)

 

The error poped up recently (2 or 3 weeks) and I cannot find a solution. I think it is not in the configuration itself. 

 

My current assumption is that the site hoster (hostpapa) updated/upgraded some COTS (PHP, javascript, or other) which is no more fully compatible with  the prestashop version I use: 1.5.6.2.

 

But I cannot find the list of the COTS compatible with this version of prestashop to compare with the version provided by the site hoster.

 

I continue my search and I do not want to upgrade the prestashop version without knowing what the problem is.

 

Best regards

Edited by Jorlanne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More