Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

 
Photo

Register Globals?


  • Please log in to reply
5 replies to this topic
ristretto6

    PrestaShop Apprentice

  • Members
  • PipPip
  • 27 posts

Posted 23 May 2008 - 11:26 PM

Hi, there.  I'm pretty new to PHP and MySQL, but the first thing I'm met with when trying to install PrestaShop is it's telling me that my Register Globals are on when they should be off.  I've tried researching this but don't understand how or where to change this in my PHP settings.  Can someone please let me know where I can turn this off?

Thanks!!

KaanK

    PrestaShop Newbie

  • Members
  • Pip
  • 21 posts

Posted 25 May 2008 - 10:55 PM

You must be talking about this i guess ?


[li]PHP register global option is off (recommended)[/li]
[li][/li]

I am the one with you. trying to fix this up.

But cant find how to.

its me again on the stage help me guyss :D

ristretto6

    PrestaShop Apprentice

  • Members
  • PipPip
  • 27 posts

Posted 27 May 2008 - 03:25 AM

I asked my web host and got a really great answer:

***

In order to turn off register_globals, you should create and use files named php.ini. A php.ini file should contain the following lines:

register_globals = off
post_max_size = 20M
memory_limit = 80M
upload_max_filesize = 20M
max_execution_time = 120
expose_php = off
session.save_path = /tmp
mysqli.default_socket = /tmp/mysql5.sock


The first line turns off the "register_globals" setting, and the rest of the lines are needed for compatibility reasons.

Note that php.ini files do not work recursively, and you need to add the file in each directory where you want the PHP behavior changed.

***

I tried this and now my register globals are turned off and it lets me proceed to the next step.
Hope this helps anyone else having this problem!

smoker

    PrestaShop Newbie

  • Members
  • Pip
  • 6 posts

Posted 31 May 2008 - 01:18 PM

if using share hosting, just edit .htaccess file and add list line

php_flag register_globals off



sworld

    PrestaShop Apprentice

  • Members
  • PipPip
  • 58 posts

Posted 16 October 2013 - 03:38 PM

I am having php5.ini file with register_globals as off, but config info shows

 

Optional parameters: Please fix the following error(s)

  • register_globals


Nemo1

    PrestaShop Superstar

  • US Moderators
  • 6737 posts

Posted 17 October 2013 - 09:04 AM

It must be php.ini, are you sure that php5.ini is being grabbed by the server as configuration file?


nemopssignature.jpg
Looking for quality PrestaShop Web Hosting? Look no further than Arvixe,  an official PrestaShop Partner!

Blank Page? Enable error reporting: config/defines.inc.php set PS_MODE_DEV to true!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users