Jump to content
Alex Neacsu

Error message: An unexpected error occurred. [PrestaShop\PrestaShop\Core\Domain\Category\Exception\CannotAddCategoryException code 0]

Recommended Posts

Hi there, 

I'm getting this message on saving a new manually created category:   "An unexpected error occurred. [PrestaShop\PrestaShop\Core\Domain\Category\Exception\CannotAddCategoryException code 0]"

Do you have any idea what it is? And how to fix it?

 

Thanks in advance!

Alex

  • Like 1

Share this post


Link to post
Share on other sites
On 8/22/2019 at 5:27 PM, Alex Neacsu said:

Hi there, 

I'm getting this message on saving a new manually created category:   "An unexpected error occurred. [PrestaShop\PrestaShop\gimp freejobalert notepad++Core\Domain\Category\Exception\CannotAddCategoryException code 0]"

Do you have any idea what it is? And how to fix it?

 

Thanks in advance!

Alex

Facing the same issue here too. Help is appreciated.

Thanks in advance,
Regards,

Oliver

Edited by OliverSo (see edit history)

Share this post


Link to post
Share on other sites

The main difference is that String is immutable but both StringBuilder and StringBuffer are mutable. Also, StringBuilder is not synchronized like StringBuffer and that's why faster and should be used for temporary String manipulation.Sarkari Result adda

Share this post


Link to post
Share on other sites

I got the same error. I hope someone with more experience can tell us how to fix this. 

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem here, what I noticed is that this happened on secondary languages. When I enter categories in English I don't face any problem. Probably is an error with translation mod

Share this post


Link to post
Share on other sites

Hi there, 

I'm getting this message on saving a new manually created category:   "An unexpected error occurred. [PrestaShop\PrestaShop\gimp freejobalert notepad++Core\Domain\Category\Exception\CannotAddCategoryException code 0]"

Do you have any idea what it is? And how to fix it?

Hmm that is interesting especially with the secondary languages. Funny enough I was having a similar problem with this plus size clothing site. Kept getting an error is it this translation mod? I'm so confused. Lots of people seemed to be having that same issues really curious for answer.  Any advice or tips would be great thanks.

Share this post


Link to post
Share on other sites
1 minute ago, Judith45 said:

Hi there, 

I'm getting this message on saving a new manually created category:   "An unexpected error occurred. [PrestaShop\PrestaShop\gimp freejobalert notepad++Core\Domain\Category\Exception\CannotAddCategoryException code 0]"

Do you have any idea what it is? And how to fix it?

Hmm that is interesting especially with the secondary languages. Funny enough I was having a similar problem with this plus size clothing site. Kept getting an error is it this translation mod? I'm so confused. Lots of people seemed to be having that same issues really curious for answer.  Any advice or tips would be great thanks.

I'm trying to figure out a solution, usually on frameworks (Symfony) such an error comes from the database

Share this post


Link to post
Share on other sites

Dear all,

 

I don't know if actually by altering these settings fixed my problem, but finally now I can add both languages and alter them at any time. What I did:

Go to Traffic & SEO -> On SEO & URLs, go down and find the options Friendly urls and accented urls. At first friendly urls was on, but accented not. If you see on the ? icon, if you are using chars other than latin, then you have to enable it.

regards! 

Screenshot_1.jpg

Screenshot_2.jpg

Share this post


Link to post
Share on other sites

Problem can be caused by invalid date format in ps_category columns date_add and date_upd 

Share this post


Link to post
Share on other sites

Hi, 

 

I have several prestashop websites on the same types of servers and only this error code in version 1.7.6.1 as soon as I want to save a meta keyword. Only one language is used so that is not it can you help me too?

 

your solutions didn't work for me

Thanks

 

[PrestaShop\PrestaShop\Core\Domain\Category\Exception\CategoryException code 0]

Edited by Sh7 (see edit history)

Share this post


Link to post
Share on other sites

I have the same issue when I try to edit some pages. However, some pages can be saved, others not (even if I try to save the page without any changes).
[PrestaShop\PrestaShop\Core\Domain\CmsPage\Exception\CmsPageException code 0]
It did work fine with PS 1.7.6.0, but recently I did update to PS 1.7.6.1 and I think problem came with 1.7.6.1.
Any Idea??

Share this post


Link to post
Share on other sites

Provide screenshots of your ps_category table? It will be good if in screenshot we can see the category you try to edit.

image.png.dc98114656b26b7e3881dd1a20ce568f.png

Share this post


Link to post
Share on other sites
On 1/17/2020 at 11:24 PM, Sh7 said:

Hi, 

 

I have several prestashop websites on the same types of servers and only this error code in version 1.7.6.1 as soon as I want to save a meta keyword. Only one language is used so that is not it can you help me too?

 

your solutions didn't work for me

Thanks

 

[PrestaShop\PrestaShop\Core\Domain\Category\Exception\CategoryException code 0]

Hi, i have the same error with Prestashop 1.7.6.5 and keywords.
Have you resolve this bug?
Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More