Jump to content
DeliMallorca

Módulo Correos incompatible

Recommended Posts

Hola,

 

estoy intentando instalar el módulo de correos que me han pasado para la versión de Prestashop 1.7, pero me da el error de incompatibilidad con la versión:

"Se ha producido un error al instalar el módulo correos. The version of your module is not compliant with your PrestaShop version."

He hablado con correos unas cuantas veces y me han confirmado que la versión que me han enviado (v5.0.3) es la correcta para la versión 1.7 de prestashop. Después de unos cuantos intentos me han indicado que intente descargar el módulo desde la pantalla de búsqueda de prestashop, pero me da el mismo error.

Mi versión exacta es la 1.7.0.6.

 

¿Cómo se puede solucionar este error?

Saludos,


DeliMallorca

Share this post


Link to post
Share on other sites

Hola,

 

estoy intentando instalar el módulo de correos que me han pasado para la versión de Prestashop 1.7, pero me da el error de incompatibilidad con la versión:

"Se ha producido un error al instalar el módulo correos. The version of your module is not compliant with your PrestaShop version."

He hablado con correos unas cuantas veces y me han confirmado que la versión que me han enviado (v5.0.3) es la correcta para la versión 1.7 de prestashop. Después de unos cuantos intentos me han indicado que intente descargar el módulo desde la pantalla de búsqueda de prestashop, pero me da el mismo error.

Mi versión exacta es la 1.7.0.6.

 

¿Cómo se puede solucionar este error?

Saludos,


DeliMallorca

Share this post


Link to post
Share on other sites

Hola,

 

gracias por tu respuesta, pero el módulo que tendría que integrar sería el de Correos, que es con quien tengo el contrato, ¿no?

 

Gracias

Share this post


Link to post
Share on other sites

Abre el fichero /correos.php y comenta esta línea:

$this->ps_versions_compliancy = array('min' => '1.6.0.4', 'max' => _PS_VERSION_);

 

Share this post


Link to post
Share on other sites

Hola,

mil gracias por tu respuesta.

He hecho lo que me has dicho y sigue sin funcionar. Lo había buscado en los foros y lo había intentado, pero no había funcionado. 

Para comentar lo que he hecho es poner /* y */, ¿no?

/*$this->ps_versions_compliancy = array('min' => '1.6.0.4', 'max' => _PS_VERSION_);*/

Descomprimo el ZIP, entro en el archivo correos.php con el bloc de notas, modifico el código, guardo, cierro y vuelvo a comprimir en ZIP.

Lo siento, no soy informático 😖

Parace que tarda más en dar el error, pero da exactamente el mismo.

¿Qué puedo hacer más?

Muchas gracias

Share this post


Link to post
Share on other sites

He hecho lo mismo poniendo el ; fuera del comentario. También he borrado la frase completamente; y otra prueba dejando el ;

 

El resultado siempre es el mismo

Share this post


Link to post
Share on other sites

Editalo directamente por FTP en la carpeta /modules/correos.

Share this post


Link to post
Share on other sites

Hola,

 

muchas gracias por las respuestas. Finalmente cambiamos el código, pero sigue sin funcionar el módulo.

Desde correos nos indican que contacte con Prestashop, pero he intentado llamarles y no contestan.

 

¿Cómo podría arreglar esto? ¿Hay algún mail de contacto o teléfono de soporte técnico?

 

Muchas gracias

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, DeliMallorca said:

De todas formas, adjunto el archivo que me enviaron, por si podéis echarle un vistazo.

 

Muchas gracias

v5.0.3-correos.zip

¿Puedes mandar una foto del problema que te está ocurriendo últimamente? 
Yo acabo de instalar el archivo del módulo que has adjuntado y no tuve ningun problema en Prestashop v1.7.4.2 (claro igual esta estructura es algo distinta a la del 1.7.0.6)

Si quieres me das acceso a tu backoffice via mensaje privado y lo reviso a la brevedad, no creo que tarde mucho en solucionarlo :) 

Edited by PrestaMake

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More