Jump to content

Recommended Posts

Hallo zusammen,

ich benutze momentan Prestashop 1.7.5

Ich habe nun ein paar Artikel angelegt, welche Varianten besitzen. Nun habe ich das Problem, dass wenn ich die Variante auswähle, auf einmal eine anderer Artikel angezeigt wird und auch ein anderes Bild. Lege ich aber den zuvor ausgewählten Artikel in den Warenkorb, ist auch der originale artikel drin.

Es ist schwer zu erklären, daher gebe ich mal einen Link mit, wo man es selber testen kann.

https://king-customs.eu/oil-slick-front-heckscheiben-sticker/895-22123-sticker-volkswaggin-oil-slick-4-groessen.html#/78-grosse_aufkleber-30cm

dort einfach mal die Variante ausprobieren.

Ich hab die Varianten schon kontrolliert und die Bilder sind alle immer die selben, wo zum Artikel dazu gehören.

 

Gruss Mike

Share this post


Link to post
Share on other sites

Hast du da ein Modul/Override installiert was eine Umleitung verursacht? Du kannst diese (temporär) mal unter Performance deaktivieren und schauen ob das Problem immer noch auftritt.

Share this post


Link to post
Share on other sites

Also hab mal geschaut und habe kein Modul, wo eine Umleitung verursachen könnte.

Ich glaube, es ist mal wieder ein Fehler von Prestashop selber, weil nicht nur bei den Aufklebern, sondern auch bei der Bekleidung hab ich dieses Problem. Auf dem alten 1.6 hatte ich die Bekleidung auch schon drin und nie Probleme mit den Varianten.

Share this post


Link to post
Share on other sites
Posted (edited)

Er wechselt beim Auswählen einer anderen Variante vom Artikel mit der ID 895 zum Artikel mit der ID 885 (bei anderen Artikeln ähnlich, aber mal 2, mal 4 Nummern Veränderung), das sieht verdächtig nach Fehlern in der Datenbank aus.

Hattest du den Shop von 1.6 auf 1.7 direkt upgegradet?

Ich würde auf jeden Fall einmal die .htaccess umbenennen und über SEO & URLs neu generieren. Bedenke dabei auch gleich die Zusammenstellung der URL, die zweite Zahl (die Artikelnummer?) ist da wohl überflüssig bzw. im Hinblick auf Suchmaschinen schädlich (viele stören sich schon an der ID in der URL). Probier einmal, ob das Problem bei einem neu angelegten Artikel auch auftritt.

Und überarbeite den viel zu früh springenden und dabei den Artikelnamen zunächst überdeckenden Header. Und den Layer beim MouseOver der Navigationspunkte, der von diversen Blöcken überdeckt wird.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites
13 hours ago, rictools said:

Er wechselt beim Auswählen einer anderen Variante vom Artikel mit der ID 895 zum Artikel mit der ID 885 (bei anderen Artikeln ähnlich, aber mal 2, mal 4 Nummern Veränderung), das sieht verdächtig nach Fehlern in der Datenbank aus.

Hattest du den Shop von 1.6 auf 1.7 direkt upgegradet?

Ich würde auf jeden Fall einmal die .htaccess umbenennen und über SEO & URLs neu generieren. Bedenke dabei auch gleich die Zusammenstellung der URL, die zweite Zahl (die Artikelnummer?) ist da wohl überflüssig bzw. im Hinblick auf Suchmaschinen schädlich (viele stören sich schon an der ID in der URL). Probier einmal, ob das Problem bei einem neu angelegten Artikel auch auftritt.

Und überarbeite den viel zu früh springenden und dabei den Artikelnamen zunächst überdeckenden Header. Und den Layer beim MouseOver der Navigationspunkte, der von diversen Blöcken überdeckt wird.

Hallo,

also den Shop hab ich direkt auf 1.7 installiert. Mein alter war damals auf 1.6 und hatte eben nie Probleme.

Habe eben mal versucht, die ID zu ändern aber geht irgendwie nicht. Die zweite Zahl dahinter habe ich echt keine Ahnung, was die bedeutet oder woher sie kommt. Ich habe keine Artikelnummer hinterlegt, bei den einzelnen Produkten.

Auch wollte ich eben die URL verändern aber das lässt das Programm auch nicht zu.

Das mit dem Header ist auch so eine Sache. Ich habe dem, der das Templates gemacht schon angeschrieben aber bekomme keine Rückmeldung von Ihm, genauso auch wegen dem MouseOver.

 

Gruss Mike

Share this post


Link to post
Share on other sites

Die ID ändern kannst du nicht. Das Problem ist ja, daß beim Ändern der Variante die Anzeige zu einem anderen Artikel (mit der entsprechend anderen ID springt) und das liegt nach meiner Vermutung an einer falschen Zuordnung der Varianten (die ja auch ihre eigenen Varianten-IDs haben) in der Datenbank, dort kannst du das ggf. überprüfen.

Die zweite Zahl muß irgendwo herkommen, wie lautet denn in den URL-Einstellungen das Format für die Friendly URL?

Wurde das Template so geliefert? Es sieht wirklich absolut nicht nach einem professionellen Template aus, sondern nach einem total verbastelten ...

Hast du mal versucht, ob das Problem auch bei einem neu angelegten Artikel auftritt?

Share this post


Link to post
Share on other sites
On 5/18/2019 at 2:41 PM, MikeCustoms said:

Die zweite Zahl dahinter habe ich echt keine Ahnung, was die bedeutet oder woher sie kommt. Ich habe keine Artikelnummer hinterlegt, bei den einzelnen Produkten.

Poste mal deine Regel die unter SEO & URLs bei den Produkten hinterlegt ist. Hier müsstest du sehen was das für eine Zahl ist.

image.thumb.png.cb22052e0478c2d6d63be3f56e3380ac.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More