Jump to content
antobarto

[gelöst] Wieder mal: PS 1.7.5 Text "Shop-Einstellungen" im Footer ändern

Recommended Posts

Hallo,

die Frage wurde schon gestellt, ich wollte sie wegen Nichterfolg nochmal stellen, aber während des Schreibens konnte ich es selbst lösen. Ich veröffentliche sie trotzdem inkl. Tipp, falls das Problem auch noch bei anderen (noch immer) auftritt. 

Wie ändere ich die Überschrift "Shop-Einstellungen" zB in "Kontakt" im Footer?

Version: 1.7.5.0
Theme: Classic

Ich habe die Änderungen wie in einem anderen Thread vorgeschlagen in folgenen Dateien manuell vorgenommen:

/app/Resources/translations/de-DE/ModulesContactinfoShop.de-DE.xlf
/app/Resources/translations/de-DE/ShopThemeGlobal.de-DE.xlf

Dann im Backend unter Optimierung->International->Übersetzungen nachgeschaut, wo beim Modul ContactInfoShop der gewünschte Text "Kontakt"  korrekt eingetragen war. Lediglich das Frontend bleibt unbeeindruckt von meinem Bemühungen. Dort stand nach wie vor "Shop-Einstellungen".

Lösung:
Ich musste im Übersetzungstool "Reset" klicken. Erst danach war der gewünschte Text auch im Frontend sichtbar. 

Edited by antobarto (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Vielen Dank, hat wunderbar funktioniert!! Ich hatte davor alles versucht gehabt und war verzweifelt.

Share this post


Link to post
Share on other sites

Wie kann man da eigentlich die Schriftgröße anpassen? Links ist es 12px und rechts bei Shop-Einstellungen sind es 14px - sieht blöd aus

Share this post


Link to post
Share on other sites

Per CSS (Untersuchen-Funktion nach Rechtsklick in den meisten Browsern um zu schauen wo, ggf. CSS-Caching vorher deaktivieren).

Share this post


Link to post
Share on other sites

Guten Nachmittag :)

Darf ich mir erlauben mich hier an zu hängen?

On 4/24/2020 at 10:22 AM, rictools said:

Per CSS (Untersuchen-Funktion nach Rechtsklick in den meisten Browsern um zu schauen wo, ggf. CSS-Caching vorher deaktivieren).

Soweit bin ich, allerdings finde ich in meiner PS-Umgebung (auf localhost) mehrere theme.css Dateien. In leider keiner aber diese "class"oder sonstige Stil-Festlegungen welche vom "Inspektor" (unter Firefox) angezeigt werden?

Beim Rumtesten habe ich mehrere dieser theme.css in einzelnen Punkten verändert. Aber nie das gewünschte Resultat ereicht! :(

Vieen Dank für eine positive Antwort :)

Share this post


Link to post
Share on other sites

Du siehst doch in der Untersuchen-Funktion, in welcher Datei in welchem Ordner die Anweisungen zu finden sind. Es ist technisch unmöglich, daß sich mehrere gleichnamige Dateien im gleichen Ordner befinden.

Davon abgesehen ist es sowieso besser, diese in die custom.css zu schreiben.

Share this post


Link to post
Share on other sites
Posted (edited)

Vielen Dank für die schnelle Antwort :)

Es sind allerdings bei mir mehrere theme.css zu finden! :o in verschiednenen Ordnern!

Ok. Ich werde mir die custom.css suchen und dann alles andere so belassen wie es im Original ist.

Vielen Dank :)

PS. Originaldaten in custom.css kopieren, und zumindesst mal die Hintergrundfarbe ändern klappt! :)
Nochmals vielen Dank :)

Edited by Jean Gangolf (see edit history)

Share this post


Link to post
Share on other sites

Noch einmal, du siehst in der Untersuchen-Funktion (zumindest in Chrome) in welchem Ordner die Datei liegt (beim MouseOver), sorry, wir können hier nicht auch noch Sachen bis ins Detail erläutern, die mit Prestashop eigentlich nichts zu tun haben.

Share this post


Link to post
Share on other sites

Re...

Ich bitte um Verzeihung, aber:

1 minute ago, rictools said:

...(zumindest in Chrome) in welchem Ordner die Datei liegt (beim MouseOver)...

ist bei mir in FF leider nicht so. Gebe mich aber mit Antwort zufrieden und werde aufhören... ;)

Danke :)

Share this post


Link to post
Share on other sites

In meinem FireFox ist es genauso wie im Chrome. Keine Ahnung was du da aufgerufen hast, mach doch mal einen Screenshot.

Share this post


Link to post
Share on other sites

Guten Abend noch mal :)

Ich möchte Dich nicht weiter belästigen... ;)

In Zwischenzeit habe ich ja eine custom.css angelegt. Und die gibt es nun defintiv nur einmal! :) Nun, wenn ich drüber "hovere", wird auch diese angezeigt! :)

Somit ist zumindest dies Problem gelöst! :)

Vielen Dank noch mal :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More