Jump to content

Recommended Posts

Hallo,

bin noch recht neu und habe ein Problem:
Wenn jemand ein Produkt in den Warenkorb legt, passiert mal optisch nichts... erst, wenn man auf eine andere Seite im Menü klickt, wird der Warenkorb angefärbt und zeigt an, dass was darin ist... das ist aber nicht sehr intuitiv und führt dazu, dass man mehrmals das Produkt in den Warenkorb legt, weil man glaubt, dass es nciht geklappt hat... 

Wie kann ich das denn ändern?

Share this post


Link to post
Share on other sites
Posted (edited)

Da sind keine Produkte drin deshalb konnte ich nicht testen, außerdem sollte der Shop "in Wartung" gestellt werden bis es fertig ist,

wen du keine Grundkenntnisse hast und trotzdem einen shop betreiben möchtest ist Prestashop dafür zu Kompliziert,

dafür empfehle ich dir Shop von jimdo.com da ist alles oberflächlich übersichtlich und leicht verständlich gehalten brauch also keine programmier Kenntnisse.

https://www.youtube.com/watch?v=dMIlrgAA0Fc

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Du Kannst im Menüpunkt "KINDERSICHER" was in den warenkorb legen...

jimdo ist leider etwas teuer für meine zwecke

Share this post


Link to post
Share on other sites
Posted (edited)

ich weis jetzt was du meinst, das liegt wahrscheinlich an den Artikel Einstellungen,

ohne jemanden der sich damit auskennt wirst du sowieso nicht sehr weit kommen, google nach prestashop anleitungen, da gibt viele anleitungen und videos.

auch wie man einen Artikel anlegt.

 

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Ok, Danke, werd die Videos nacher schauen... bin soweit aber mit dem Grundgerüst eh recht weit. 

Kannst du mir auch verraten, welche Einstellung im Artikel das ist, jetzt wo du weißt, worum es geht? :)

Danke!

Share this post


Link to post
Share on other sites

Teste mal die Einstellungen im Modul Warenkorb! Normalerweise wird nach dem ein Produkt in den Warenkorb gelegt wurde ein Layer angezeigt.

Allgemein sieht dein Shop sehr unvollständig aus, ich würde erst einmal alles einrichten und konfigurieren.

Welche PHP-Version läuft denn?

Generell solltest du immer deine Shopversion angeben.

Share this post


Link to post
Share on other sites

In den Moduleinstellungen vom Warenkorb kann ich nur Ajax-Warenkorb aktivieren oder deaktivieren... beide Einstellungen haben diesbezüglich keine Änderung gebracht leider.
Kann es sein, dass dieser Layer ein Mod ist, der irgendwie deaktiviert ist? Weisst du vl, wie der heißen könnte?

Naja, eigentlich habe die Grundeinstellungen bereits getroffen... das optische und die Inhalte fehlen halt noch, sind aber das letzte... möchte erst sehen, ob ich mit dem Tool ans Ziel komme, dann Pflege ich alles ein und mache den Feinschliff.

Es läuft PHP 7.3.2, Shop 1.7.4.2

Share this post


Link to post
Share on other sites

Prestashop ist auch in der neuesten Version nicht für das erst im Dezember 2018 erschienene PHP 7.3 freigegeben, stelle auf 7.2 zurück. Außerdem würde ich auf die neueste Prestashop-Version aktualisieren, die Bugs werden nach und nach weniger ...

In deinem Shop fehlen viele Standardelemente wie Links im Header oder im Footer, da scheinen zahlreiche Module noch nicht aktiviert zu sein.

Share this post


Link to post
Share on other sites

Hm an der PHP Version kann es nicht liegen - habe gerade zum test noch einen shop installiert, da funktioniert alles. (gleich PHP version, gleiche prestashop version)

Ich muss wohl selbst im Zuge der Ein-/Umstellungen was verändert haben, was das Layover deaktiviert hat.
Ich werde Prestashop also einfach nochmal installieren.

Nein, die Standardelemente, die ja nach der Installation eh da wären, habe ich absichtlich deaktiviert.
Nur weil sie vorinstalliert sind, müssen sie ja nicht in das Konzept und den optischen Geschmack passen ;)

Aber danke für eure Hilfe!

Share this post


Link to post
Share on other sites

Trotzdem wird Prestashop mit PHP 7.3 nicht richtig laufen! Als deine Prestashop-Version herauskam, gab es PHP 7.3 wohl noch gar nicht ...

Hast du das Modul Warenkorb mal resettet? Danach Caches gelöscht?

Dass dein Shop so mit den nicht sichtbaren wichtigen Links nicht bleiben kann ist dir hoffentlich klar?

Nichts gegen ein puristisches Design, aber so sieht er aus wie ein Shop der noch nicht fertig ist oder ein Fakeshop ...

Generell, wer einen simplen Shop haben möchte, nimmt ein simples Shopsystem und nicht ein so komplexes wie Prestashop ...

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, habe die Linkliste nun eingefügt... komischerweise macht er aber einen Zeilenumbruch nach der 2. Kathegorie... kann mir nicht erklären warum...

Noch eine Frage: Das Modul Kundenanmeldungs-Link ist bei mir zwar installiert (habe es auch schon reseted), ich kann es aber keiner position zuordnen... auch nicht, wenn ich sage "Unsichtbare Hooks anzeigen"... ich bekomm neben meinen Warenkorb also den Anmeldebutton nichtmehr zurück :(

Und gleich noch eine Frage: wie kann ich den Shop selbst ansehen, wenn er im Wartungsmodus ist?

Und: wie kann ich denn die fortlaufende Rechnungs-/Lieferscheinnummer reseten?

DANKE! Ich komme gut voran :)

Edited by coffeefish (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Du hast wohl eingestellt, dass 2 Spalten im Footer angezeigt werden (sinnvoller wäre es, wenn die drei Kategorien nicht untereinander, sondern nebeneinander angezeigt würden).

Der Anmelde-Button ist da, entweder du hast die Einstellung zwischenzeitlich gefunden oder du hattest nicht alle Caches gelöscht.

Du kannst deine IP hinterlegen.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Ah okay, und wo kann ich das umstellen? Hab dazu im Template nichts gefunden leider...

Anmeldebutton, etc habe ich gelöst, ja.

 

Noch eine Sache: wie kann ich die Beispielbestellungen die bereits drin sind löschen? Bzw. die Rechnungs- und Lieferscheinnummern auf 0 reseten?

Share this post


Link to post
Share on other sites

Zumindest bei 1.6 ist die Spaltenanzahl des Footers gut versteckt im Modul Block Kategorien (blockcategories)!

Zum Löschen von Beispielbestellungen gibt es ein Modul, wie das mit Rechnungs- und Lieferscheinnummern ist weiß ich nicht aber wer will denn Nummern die mit 0 bzw. 1 beginnen ...

Share this post


Link to post
Share on other sites

hm hab jetzt alles möglich durchsucht, aber beide module (weder blockcategories) noch ein modul zum löschen der beispielinhalte gefunden :(
kannst du mir einen tipp geben? danke!

Share this post


Link to post
Share on other sites

Beim 1.7-Demoshop sind leider die Einstellungen der Kategorien deaktiviert, schau mal ins Modul Kategoriebaum.

Das Modul zum Löschen der Demodaten heißt Prestashop Cleaner.

Share this post


Link to post
Share on other sites

In dem Modul Kategoriebaum habe ich leider keine Lösung gefunden.
Hast du noch andere Ideen, wo die Einstellung liegen könnte?

Super danke, hab das Modul gefunden! :)

Share this post


Link to post
Share on other sites

jup, soweit kenn ich mich damit eh aus... also neue punkte erstellen etc klappt eh alles, nur eben nicht nebeneinander... und das wird dort witziger weise nichtmal erwähnt... :(

werd wohl presta neu istallieren müssen, dann sollts wieder klappen... obwohl ich eh schon so gut wie alles resetet habe...

Share this post


Link to post
Share on other sites

Nu mach mal langsam, wegen so etwas installiert man den Shop nicht neu, muss sich ja finden lassen. Hast du möglicherweise noch ein Kaufmodul für den Footer installiert? Alle Caches gelöscht?

Share this post


Link to post
Share on other sites

Hatte nur GoogleAnalytics im Hook "displayFooter" - hab ich jetzt aber auch mal rausgehaut... ändert nix.
Caches auch nochmal frisch geleert - keine Änderung.

Share this post


Link to post
Share on other sites

Vielleicht kann ja einer der 1.7-Nutzer sagen, wo man die Spaltenzahl des Footers einstellen kann. Evtl. läßt sich das auch per CSS konfigurieren, da dein Shop im Wartungsmodus ist, kann ich das aber nicht testen.

Share this post


Link to post
Share on other sites

Da ist in 1.7. keine Spaltenanzahl vorgegeben - wieviele Spalten da reinpassen hängt von den jeweiligen Inhalten ab und ist durch das genutzte CSS eingeschränkt und läßt sich dadrüber anpassen. Die Seite ist gerade im Wartungsmodus sonst hätte ich dir einen Vorschlag für passende Werte gemacht.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok ganz komisch: wollte gerade den Wartungsmodus deaktivieren, aber plötzlich wirft mich das Backend immer raus!
Zwar kann ich mich einloggen und ich sehe die Übersicht vom Backend, aber sobald ich einen Menüpunkt anklicke, komme ich wieder auf die Anmeldemaske... ich habe aber nichts umgestellt...?! Wie gibts das?

 

Edit: jetzt geht das Backend wieder... lag das vl daran, dass ich von einer andern IP aus gekommen bin...? seltsam!

Nagut, Wartungsmodus ist jedenfalls deaktiviert. Würde mich sehr über eure Hilfe freuen! Danke!

Edited by coffeefish (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

http://demo.prestashop.com/de/?view=front
So oder so Ähnlich würde ich mir das auch vorstellen eben... aber im Idealfall ohne den "Shop Einstellungen" (das hab ich eh schon ohne), aber dann align center... das hab ich leider noch nicht hinbekommen. Hätte ich aber für die Newsletteranmeldung auch center.


 

Edited by coffeefish (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More