Jump to content
stempelgarten

"Alias" bei Registrierung im Shop nicht abfragen

Recommended Posts

Posted (edited)

Hi zusammen

Felder in den Ländern hinzufügen oder Löschen, Verschieben etc. habe ich gelesen und gefunden. Doch wird bei der Registrierung als Kunde bei der Adresse der "Alias" verlangt, wenn man den Kunden als Admin erfasst. Dort wird er dann "Adress Kürzel" genannt. Wenn er es selber macht, ist es optional. Benötige ich aber gar nicht.

Wo kann ich den ausblenden? global.css oder authentication.css habe ich abgesucht. Das ist so das, was ich hier im Forum lese. Oder dann Add-Ons kaufen, die das können sollten. Aber ob diese dann für die V1.7 richtig funktionieren und das gewünschte Feld ausblenden können? Und wegen 1 Feld ein Add-On kaufen?

 

Edited by stempelgarten (see edit history)

Share this post


Link to post
Share on other sites

Unter /html/presta/classes die customer.php hat wohl zwei Einträge mit "Alias". Doch, wenn ich die ausklammere, kann der Shop nicht mehr immer aufgerufen werden. Im Adminbereich, wird dieses Feld dann aber wie erhofft, nicht mehr angezeigt.

Share this post


Link to post
Share on other sites
Posted (edited)

Wenn der Kunde seine Adresse angibt, wird der "Alias", also die Bezeichnung der Adresse (wichtig bei mehreren zur Unterscheidung) vorbelegt und muß nicht extra eingegeben werden, im Adminbereich muß man das selbst eintragen, bei mir ist das auch so und eine Vorbelegung würde mir etwas Tipparbeit sparen, kann man sicher programmieren. Dein Ansatz scheint mir aber nicht zielführend zu sein. Ein Ausblenden des Feldes würde dazu führen, daß du nicht mehr zwei Adressen (z. B. für Rechnung und Lieferung) eingeben kannst.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Ach so, da muss ich dann manuell schreiben, ob das eine private oder geschäftliche Adresse ist, z.B.

Es ist halt so, dass es merkwürdig ist, dass dann der Shop aus dem einen Browser nach so einer Modifikation noch erreichbar ist, ein anderer findet ihn nicht mehr. Oder wenn, dann mit Weiterleitungsfehler. Kann es sein, dass der Hoster da was mit der PHP-Version und/oder HTTPS, resp. SSL hat? Seit die da SSL zwingend wollen, haben die Kunden auf meinem alten Shop Probleme mit dem Zugriff darauf oder innerhalb des Shops, mit der Ausführung von Funktionen Probleme. Login oder Checkout z.B. Kommt immer auf den Browser und deren Version an.

Muss der PrestaShop gewisse Parameter beim Hoster haben? PHP-Version, Rechte, RAM, TimeOuts, etc.?

Share this post


Link to post
Share on other sites

Es bringt nichts, wenn du in einem Thread jetzt Dinge ansprichst, die mit dem Thema überhaupt nichts zu tun haben, mach lieber einen neuen Thread auf und gib klare Informationen, was nicht funktioniert. Die PHP-Version kann z. B. wichtig sein, manchmal wird die vom Hoster einseitig geändert. Bei TimeOuts kommt ein Error 500, wenn das bei der gleichen Situation mal passiert und mal nicht, ist das ein Hinweis auf zu wenig max_execution_time bzw. Überlastung des Servers (den man ja meist mit zahlreichen anderen Nutzern teilt).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More