Jump to content

[PS 1.7.5.0] JS and CSS not loading


Luna Ryuko
 Share

Recommended Posts

19 hours ago, Rhobur said:

most likely you're subdomain is not set correctly, check the ps_shop_url table for physical_uri and the .htaccess file for the same,

Seems like it's set up correctly.

image.png.bd387a7b86636fbb34583658261bc7fd.png

Anyway, the issue is with the paths to the CSS and JS files on frontend. There are no slashes in the URL at all for some reason.

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 8 months later...

Hello, did you solve it, i have a new hosting, and this problem, happened to me too.

same page i have loaded on other server and working ok.

On this server PHP Version 5.6 , 7.2, 7.3 and nothing works, i thik it is something from hosting.

Share this post


Link to post
Share on other sites

28 minutes ago, bbnicu said:

Hello, did you solve it, i have a new hosting, and this problem, happened to me too.

same page i have loaded on other server and working ok.

On this server PHP Version 5.6 , 7.2, 7.3 and nothing works, i thik it is something from hosting.

post url and community can review/provide feedback.

Share this post


Link to post
Share on other sites

  • 3 months later...

i cloned the source from git and had same problem with 1.7.7.0 develop branch.
you need to install php, javascript and css dependencies as they are not included in the git repo.

this is the related link to documentation: https://devdocs.prestashop.com/1.7/basics/installation/#download-dependencies

to install PHP dependencies, go into root folder of the project and run below commands in terminal(Composer required):

cd /path/to/prestashop
composer install
# or alternatively, since 1.7.8:
make composer

for Javascript and CSS(NodeJS required):

cd /path/to/prestashop
make assets

 

Share this post


Link to post
Share on other sites

  • 1 year later...

For those who have the same issue and already try this:

  • delete cache
  • check the table PREFIX_shop_url, the domain, domain_ssl and the physical_uri are correctly set.

  • regenerate the file .htaccess by renaming the old file to .htaccess_old

  • Disable friendly URL

  • Enable friendly URL

Try also to delete your navigator cookies (this was the fix for me on prestashop 1.7.7.5). But you can also check if you don't have (beta) page speed module enabled on the cPanel.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

I had the same problem and found a solution, that was trivial.
For me, the problem was that the hosting had ssl set by default, and I didn't know about it.  So I just turn on ssl on the website and the problem was solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More