Jump to content

[SOLVED] Admin's login redirect bug


Recommended Posts

I really found a bug!

The problem was in the two files, login.php and init.php. This two files are found in Admin folder and are responsible for validating the admin’s credentials. So, when those files send or get a cookie to/from the browser they get wrong with this two lines:

$cookie = new Cookie(‘psAdmin’, substr($_SERVER[‘SCRIPT_NAME’], strlen(PS_BASE_URI), -strlen($currentFileName[‘0’])));

$cookie = new Cookie(‘psAdmin’, substr($_SERVER[‘PHP_SELF’], strlen(PS_BASE_URI), -10));

Thoses lines are not sending a correct path to the browser. Maybe that’s because I use sites other than the main site as virtuals home pages. To fast correct the problem I put explicity the path by my self. So, the lines were just as:


$cookie = new Cookie(‘psAdmin’, “admin445” );

$cookie = new Cookie(‘psAdmin’, “admin445”);

After the change everything worked nice.

I hope this can help someone. About me, I’m gona sleep because I spent a lot of time to fix this and here in Brazil are 01:15AM and, as soon as I wakeup I’ll take a Cisco exame wink

Thank's to all!

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...
  • 4 months later...



I have something similar issue. Admin does not let me login and keep redirecting me to the login page without any error. I am using and it is installed on my local host with php 5.2.3


I have tried the above solution and also tried to reset the admin password with no luck.


Please help.



  • Like 1
Link to comment
Share on other sites

I am having a problem logging in to my back office. I have tried everything above and nothing works. Please help. I have using Prestashop_1.4.4.0. I am not getting an error message it just keep getting directed back the login page.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hi Molina,

You can check out the latest updates on this in the Forge here.


We're hoping to have this fixed for all of you soon.




I don't quite understand why this hasn't been fixed. This "bug" has been around for months and you direct people to an ISP site to fix it! At least put a note in the install script that warns people of the problem. It takes all of 60 seconds to "fix" it, but hours or days to diagnose it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...