Jump to content
cosma.ganassin@gmail

Avviso da Ebay di contenuto non sicuro (HTTP) nelle inserzioni

Recommended Posts

Ricevo da ebay il seguente messaggio di avviso di contenuto non sicuro:

Abbiamo trovato contenuto (HTTP) non sicuro nelle tue inserzioni. I browser mostrano un messaggio "Non sicuro" sulle pagine che contengono risorse HTTP. Per un'esperienza d'acquisto più sicura, devi aggiornare i tuoi contenuti. Vedi i dettagliUlteriori informazioni

I dettagli indicano la seguente evidenza:

Abbiamo trovato del contenuto HTTP nella sezione della descrizione dell'oggetto della tua inserzione.

 

Analizzando in contenuto HTML trasmesso, nella prima riga si vede quanto indicato :

<link rel="stylesheet" type="text/css" href="http://www.ciclimaggioni.it/modules/ebay/views/css/ebay.css"><p> </p>
<table class="ProductPrestashop" cellspacing="0" cellpadding="0" border="0"><tbody><tr><td class="leftProductPrestashop" colspan="3">
<h1><span class="bodyNameProductPrestashop">KTM - ULTRA FLITE 29 colore titangrey-blue Taglia 17"</span></h1>
<br><h2><span class="bodyPriceProductPrestashop">757,32 € instead of <del> 899,00 € </del> (promotion of 16%)</span></h2>
<p> </p>
<h3>Disponibilità :</h3>
<h3></h3><h4>KTM - ULTRA FLITE 29 colore&nbsp;titangrey-blue Taglia 17"</h4>
<p>La MTB stabile veloce e confortevole!</p>
<h3><span class="bodyDescriptionProductPrestashop"><p>Colour: titangrey-blue<br>Frame: Ultra 29" Alloyframe<br>Fork: RockShox XC30, 27,5-100-Coil-TK-QR9<br>Brakes: Shimano M396/M395, Rotor 180/180<br>Shifters: Shimano Deore M610-10<br>Rear derailleur: Shimano SLX M670 shadow<br>Cranckset: Shimano Deore M612 40-30-22<br>Wheels:&nbsp;KTM Line CC 29" Ryde/M3050<br>Tires: Continental X-King Sport 55-622<br>Weight: 13,6 kg</p></span></h3>
<blockquote>
<h4><strong><span class="bodyDescriptionProductPrestashop">Altre immagini potrebbero essere disponibili nel sito web ufficiale ciclimaggioni punto it</span></strong></h4>
</blockquote>
<p> </p>
</td>
</tr><tr class="footerProductPrestashop"><td>
<p>&nbsp;</p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
<p>&nbsp;&nbsp;&nbsp; <img src="https://www.ciclimaggioni.it/img/cms/wwwciclimaggioniit-1429829692.jpg" alt="" width="293" height="83"></p>
<p> </p>
</td>
<td> <br></td>
<td>
<h4> </h4>
<p> </p>
<h4><a href="http://feedback.ebay.fr/ws/eBayISAPI.dll?ViewFeedback2&amp;userid=%7BEBAY_IDENTIFIER%7D&amp;sspagename=VIP:feedback&amp;ftab=FeedbackAsSeller">Guarda le nostre valutazioni <img src="https://www.ciclimaggioni.it/img/cms/stats.png" alt="" width="22" height="22"></a><br><a href="http://my.ebay.fr/ws/eBayISAPI.dll?AcceptSavedSeller&amp;sellerid=%7BEBAY_IDENTIFIER%7D&amp;ssPageName=STRK:MEFS:ADDSTR">Aggiungi questo negozio ai preferiti <img src="https://www.ciclimaggioni.it/img/cms/favorite.png" alt="" width="22" height="22"></a></h4>
</td>
</tr></tbody></table><p> </p>

Ho provato a scaricare via FTP molti file del sito ma non ho trovato questo contenuto.

Qualcuno sa dirmi dove lo posso trovare al fine di correggere http in https?

Eventualmente ci sono altri modi per modificarlo?

Grazie

 

Share this post


Link to post
Share on other sites

Scusate, ma nessuno a questo problema usando il modulo ebay incluso in PS?

Ho visto che un suggerimento è di modificare l'URL nel template prodotti da http a https, ma come si fa? Nella pagina di SEO&URL delle impostazioni posso inserire solo l'indirizzo del Dominio SSL ma senza mettere http o https.

Bisogna passare ad un modulo ebay a pagamento?

Grazie

Share this post


Link to post
Share on other sites

L'ho già scritto. Anche se ci mettessi due ore, lo farei. Purtroppo però appena rifaccio una sincronizzazione dei prodotti per aggiornare le quantità, tutto ritorna come prima. Non posso rimodificare tutti i prodotti dopo ogni sincronizzazione!  Serve una modifica a monte, dove PS o il modulo ebay prende l'indirizzo URL

Share this post


Link to post
Share on other sites

visto che non puoi risincronizzare ogni volta, non puoi settare l'aggiornamento delle sole giacenze invece che tutto l'html ?

 

Share this post


Link to post
Share on other sites

Questa può essere un'idea. Grazie.

Il problema rimarrebbe solo sui nuovi prodotti inseriti, con un carico molto meno oneroso.

Se però si riuscisse a modificare l'impostazione a monte, sarebbe comunque meglio, non credi?

 

Share this post


Link to post
Share on other sites

credo, ma credo che faresti prima a comprare un modulo dallo shop e configuarrlo..sono 400 prodotti, tra l'altro avresti una descrizione ed una grafica decisamente migliore su ebay rispetto a quelle che hai ora.

Se hai bisogno di consigli fammi sapere. ciao.

Share this post


Link to post
Share on other sites

Ciao a tutti,

leggiamo ora questo topic, non sappiamo se e come siete riusciti ad avanzare con la risoluzione del problema, ma volevamo aggiornarvi sul fatto che il nostro modulo eBay2 ufficiale (l'unico realizzato in partnership con eBay), nell'ultima versione disponibile, ha risolto il problema legato ai contenuti in http non sicuri.

Restiamo a disposizione per ogni eventuale chiarimento,  Visto che il forum è un po' dispersivo, vi consigliamo di scriverci direttamente a quest'indirizzo, c'è un intero team supporto pronto a guidarvi e aiutarvi in caso di necessità.

Per qualsiasi info, non esitate! :)

Share this post


Link to post
Share on other sites

Buongiorno, scusate avere trovato soluzione al problema indicato. Mi ritrovo in situazione analoga e non

riesco a trovare dove modificare per poter far recepire al template http e non https per il puntamento 

al css

****/modules/ebay/views/css/ebay.css

nella gestione modelli (template del modulo)

 

Grazie

************

 

Good morning,
i have an issue with official module to sync data ,
in particular i don't try as is possible to change (from http to https) in manage template of product the reference to css file:
 
.../modules/ebay/views/css/ebay.css
 
Ebay lock the sync because is not https.
 
please could you help me to try where is possible to change this parameter ?
 
thank you in advance for your support.
 
kind regards
Danilo
 
 

 

Share this post


Link to post
Share on other sites

Ciao, per versione 1.15.6 la modifica è la seguente

nel file ebay.php

eseguire la seguente modifica alla linea 2261

Cita

    public function ajaxPreviewTemplate($content, $id_lang)
    {
        // work around for the tinyMCE bug deleting the css line
        $css_line = '<link rel="stylesheet" type="text/css" href="'.$this->__getModuleUrl().'views/css/ebay.css" />';
        $css_line = str_replace("http://", "https://", $css_line);
        $content  = $css_line.$content;

nel file EbaySynchronizer.php in classes

eseguire la modifica alla linea 1016

Cita

    private static function __getPictureLink($id_product, $id_image, $context_link, $size)
    {
        //Fix for payment modules validating orders out of context, $link will not  generate fatal error.
        $link   = is_object($context_link) ? $context_link : new Link();
        $prefix = (Tools::substr(_PS_VERSION_, 0, 3) == '1.3' ? Tools::getShopDomain(true).'/' : '');
        return str_replace('http://', 'https://', $prefix.$link->getImageLink('ebay', $id_product.'-'.$id_image, $size));
    }

infine, nel file EbayFormTemplateManagerTab.php in classes > tabs

modificare così alla linea 88

Cita

    public function postProcess()
    {
        $ebay_product_template = Tools::getValue('ebay_product_template');
        $ebay_product_template_title = Tools::getValue('ebay_product_template_title');
        if (empty($ebay_product_template_title)) {
            $ebay_product_template_title = '{TITLE}';
        }

        // work around for the tinyMCE bug deleting the css line
        $css_line = '<link rel="stylesheet" type="text/css" href="'.$this->_getModuleUrl().'views/css/ebay.css" />';
        $css_line = str_replace("http://", "https://", $css_line);
        $ebay_product_template = $css_line.TotFormat::formatDescription($ebay_product_template);

ovviamente è necessario risincronizzare per acricare il nuovo template

saluti

Share this post


Link to post
Share on other sites

Ciao a tutti, io ho il modulo Fastbay, ma ho lo stesso problema, o meglio, al momento non sincronizza nessun prodotto e mi da questo errore:
Le regole sulla sicurezza di eBay consentono solo risorse HTTPS nelle inserzioni, non HTTP. Aggiorna o rimuovi le risorse HTTP.
Come posso risolvere?

image.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More